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Глава 5 
Таблицы Семейств и Наследование 
В этой главе Вы изучите, как использовать элементы Таблиц Семейств и Наследования 
для эффективного многократного использования данных. Вы также научитесь 
использовать эти элементы для быстрого создания разновидностей существующих 
конструкций. 

Цели 
После завершения этой главы Вы сможете: 

• создавать и изменять таблицы семейств детали. 

• Создавать и изменять таблицы семейств узлов. 

• Управлять таблицами семейств. 

• Использовать элементы наследования 

Введение в Таблицы Семейств 

Определение 
Таблицы Семейств � набор деталей (или сборок, или элементов), которые совместно используют 
одинаковые элементы. Детали в таблицах семейств обычно имеют один или более различных 
размеров. 

Например, болты имеют различные размеры, но они все выглядят подобными и выполняют одну и ту 
же функцию. Таким образом, их можно представлять "семейством" деталей. На следующем рисунке, 
болт слева является "родовой (generic)" моделью, а остальные являются "вхождениями" родовой 
модели. Родовая модель � главный объект в таблице семейств. Каждая таблица семейства имеет 
один и только один родовой объект. Каждая таблица семейства имеет одно или более вхождений. 
Можно создавать таблицы семейств детали или таблицы семейств сборок. Таблица семейства не 
может содержать и детали, и сборки. 

 
Рисунок 1: Семейство Болтов 
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Использование Таблиц Семейств 
Таблицы семейств можно использовать для: 

• Создания и сохранения большого количества объектов просто и компактно. 

• Сохранение времени и усилий в процессе стандартизации деталей. 

• Создания разновидностей деталей без повторного создания и моделирования каждой из них в 
отдельности. 

• Создания небольших отличий в деталях без использования уравнений. 

• Создания списков деталей, которые могут быть распечатаны и включены в списки или 
различного рода спецификации. 

Структура Таблицы Семейства 
Таблицы Семейств отображаются как электронные таблицы, состоящие из колонок и строк. Строки 
отображают вхождения (деталей) и их соответствующие значения элемента. Колонки отображают 
названия элементов. 

 
Рисунок 2: Таблица Семейства для Болта 

Таблицы Семейств состоят из трех компонентов: 

1. Родового объекта, на котором основываются все члены семейства. 

2. Размеров и параметров, номеров элементов, имен пользовательских элементов и имен указанных 
компонентов сборок. 

3. Имен всех членов семейства (вхождения), созданных в таблице и соответствующих значений для 
каждого табличного объекта. 

Преимущества Использования Родовых Объектов и Вхождений 
Имеется несколько преимуществ при использовании таблиц семейств. Например, можно увеличить 
производительность путем: 

• сохранения нескольких подобных моделей в одном файле. 

• Сохранения различных положений одной и той же сборки. 

• Сохранения различных этапов обработки модели. 



  Pro/ENGINEER 2001 Углубленный курс 

- 141 - 

• Сохранения разновидностей модели на постоянной основе при использовании Pro/PROGRAM. 

Создание Таблиц Семейств Детали 

Для создания таблицы семейства детали, необходимо иметь модель родовой детали и определить ее 
разновидности. 

Создание Родовой Модели 
Первый шаг в создании таблицы семейства состоит в создании модели родовой детали со всеми ее 
возможными элементами. Следующий рисунок иллюстрирует родовой болт. 

 
Рисунок 3: Родовой Болт 

После моделирования родовой детали, необходимо определить те размеры, параметры и элементы, 
которые будут изменяться от одного вхождения к следующему. 

Создание Таблиц Семейств 
Затем, в таблицы семейств можно добавлять измененные объекты, щелкая по Family Tab в 
Менеджере меню. 

 
Рисунок 4: Диалоговое Окно New Family Table 

Выберите соответствующие пиктограммы для добавления объектов в таблицу семейства. 

Принципы Использования Таблиц Семейств 
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• Система перечисляет колонки в том порядке, в котором были добавлены объекты. Поэтому, 
добавляйте объекты в логическом порядке, группируя подобные объекты. 

• При изменении символов размеров посредством Modify > DimCosmetics, эти символы 
отображаются в заголовке столбца. 

• В случае присвоения имени элементу посредством Setup > Names, имя отображается в 
заголовке столбца. 

Создание Вхождений 
После добавления объекта к таблице, можно щелкнуть по FAMILY TAB для создания вхождения. 
Можно использовать любой из следующих методов: 

• вручную заполнить таблицу путем указания значений для вхождений. 

• Использовать Edit > Copy with Increments для создания различных вхождений путем 
размножения. 

• Считать ранее созданную таблицу. 

• Использовать электронную таблицу, типа Microsoft Excel, для создания вхождений. 

 
Рисунок 5: Таблица Семейства для Болта 

Подтверждение Действительности Вхождений 

В качестве заключительного шага следует использовать пиктограмму  [Проверка] для проверки 
того, что все вхождения достоверны и могут быть регенерированы до сохранения изменений в детали 
/ сборке. Pro/ENGINEER регенерирует каждое вхождение последовательно. 

Обратите внимание: 

Никогда не сохраняйте модель в PDM среде без регенерации или проверки вхождений. Просмотрите 
диалоговое окно FAMILY TREE, чтобы убедиться в корректности всей информации до сохранения. 
Если таблица семейства предъявляется в Pro/PDM или INTRALINK с орфографическими ошибками в 
обозначениях вхождений, это обычно требует вмешательства Администратора для решения 
проблемы. Никогда не переименовывайте вхождение в PRO-TABLE, если деталь была предъявлена 
(submitted). 



  Pro/ENGINEER 2001 Углубленный курс 

- 143 - 

 
Рисунок 6: Дерево Семейства 

Щелкните по пиктограмме  [Предварительный просмотр] в диалоговом окне для предварительного 
просмотра каждого вхождения. 

Создание Таблиц Семейств Сборок 
Для создания таблиц семейств сборок, необходимо иметь модель родовой сборки со всеми 
компонентами, необходимыми для всех вхождений, и, затем, добавить объекты, которые будут 
отличаться в одном вхождении от другого. 

К таблице семейства сборки можно добавлять следующее: 

• размеры уровня сборки, типа совмещения с отступом и выравнивания с отступом. 

• Элементы уровня сборки. 

• Параметры сборки. 

• Компоненты. 

Вызов Вхождений 
Различные вхождения можно вызывать, используя следующие три метода: 

• использовать Family Tab после первого подсвечивания вхождения и открыть его. 

• Вызвать родовую модель для получения списка таблицы семейства. 

• Вызвать непосредственно вхождение, если существует индексный файл вхождений. 

Изменение Таблицы Семейств 
После установки таблицы семейств, можно изменять любую родовую модель или вхождения. Каждый 
тип изменений воздействует на таблицу семейств по разному: 

• Изменение табличных размеров � размеры, перечисленные в таблице, являются 
переменными размерами. Изменение этих размеров обновляет таблицу. 
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Рисунок 7: Изменение Переменного Размера 

• Изменение не табличных размеров � размеры, которые отсутствуют в таблице, являются 
постоянными размерами. Любое изменение требует регенерации всех вхождений, вне 
зависимости от места изменения. 

 
Рисунок 8: Изменение Постоянного Размера. 
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• Добавление элемента к родовой модели � элемент, добавленный к родовой модели, 
появляется во всех вхождениях. 

 
Рисунок 9: Элемент, Добавленный к Родовой Модели 

• Добавление элемента ко вхождению � система добавляет колонку для элемента в таблице 
семейства и вводит Y для этого вхождения, N для родовой модели и * (аналогичной родовой 
модели) для всех других вхождений. 

 
Рисунок 10: Добавление Элемента ко Вхождению 

• Удаление элемента из родовой модели � система удаляет элемент из всех вхождений. Если 
в таблице семейства присутствует колонка, то она удаляется.. 
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Рисунок 11: Удаление Элементы из Родовой Модели 

• Удаление элемента из вхождения � система записывает N в колонке для этого элемента. 
Если колонка не существует, то она создается. При этом, для вхождения записывается N, для 
родовой модели Y и * для всех остальных вхождений. 

 
Рисунок 12: Удаление Элемента из Вхождения 
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• Переименование Вхождения в системе PDM � процедура переименования зависит от того, 
была ли модель проверена, сохранена и представлена (submitted): 

− Модель Pro/ENGINEER не проверена, не сохранена и не представлена: переименуйте 
вхождение в Pro/TABLE. Pro/PDM и Pro/Intralink не подозревают о существовании 
вхождения. 

− Модель Pro/ENGINEER проверена, но не сохранена и не представлена: переименуйте 
вхождение, используя функциональность Pro/ENGINEER. Не редактируйте 
непосредственно таблицу вхождений. 

− Модель Pro/ENGINEER проверена или сохранена и представлена: только 
переименуйте, используя Pro/PDM и Pro/Intralink. 

Опции Таблицы Семейства 
Pro/ENGINEER имеет несколько полезных инструментов для эффективного управления таблицами 
семейств. Используя File > Instance Operations, можно проверить каждый файл вхождения родовой 
модели, которая находится в сессии и удалить любое вхождение, которое отсутствует в родовой 
модели. Кроме того, можно использовать индексные файлы вхождения и файлы быстрых клавиш для 
увеличения эффективности таблиц семейств. 

Использование Индексных Файлов Вхождений 
Индексный файл вхождения содержит список всех вхождений, которые существуют для всех таблиц 
семейств в каталоге. Он относится к каталогу и имеет название "directory_name.idx". Если индексный 
файл вхождения существует, система перечисляет все вхождения при вызове модели. Для 
сокращения времени регенерации при вызове вхождений, можно создавать ускоряющие файлы 
(accelerator files). 

Использование Ускоряющих Файлов 
Ускоряющие файлы уменьшают время, требуемое системе для непосредственного вызова вхождения. 
Однако, они требуют большего дискового пространства, так как их размер почти соответствует 
размеру файла детали. Система присваивает ускоряющему файлу детали расширение .xpr, а 
ускоряющему файлу сборки расширение .xas. 

Используя опцию файла конфигурации "save_instance_accelerator", можно управлять созданием этих 
ускоряющих файлов. 

Введение в Элементы Наследования 

Определение 
Элемент наследования позволяет одностороннее ассоциативное слияние геометрии и данных 
элементов от одной детали к другой. Можно выбирать размеры и элементы в базовой модели для 
изменения значений размеров как во время создания элемента наследования, так и позже. 

Элементы наследования всегда создаются, ссылаясь на существующие детали. Элемент 
наследования начинается со всей своей геометрии и данных, идентичных той детали, от которой он 
их получил. Затем можно идентифицировать геометрию и данные элементов, которые могут 
изменяться в элементе наследования без изменения исходной детали. 

Использование Элементов Наследования 
Элемент наследования используется подобно элементам слияния. В одной детали можно 
использовать более одного элемента наследования. 

Он также может использоваться для создания разновидностей конструкции без использования 
таблицы семейства. 
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Возможности 
• Доступ к параметрам наследуемых моделей, их элементам и их применению, с 

использованием префикса «IID». 

• Вызов размеров в режиме Рисунка, Детали и Сборки. Размеры могут быть отображены в 
рисунке наследуемого объекта, который может иметь ограничения при использовании в 
рисунке деталей слияния (merged parts). 

• Многоуровневое вхождение элементов наследования. 

• Поддержка ссылочных массивов (RefPattern). 

• Особый Режим Разрешения конфликтов наследования. 

• Не геометрические элементы копируются дополнительно к трехмерным примечаниям 
(Геометрические допуска, Обработка поверхности и т.д.). 

• Отношения Родитель � потомок. 

Создание Элементов Наследования 
Ниже приведены несколько важных шагов в создании элементов наследования. 

1. Сначала открыть диалоговое окно Inheritance и меню LOCATE MDL. 

2. В меню LOCATE MDL открыть базовую модель. Изначально, все данные в базовой модели 
присутствуют в элементе наследования. Модель открывается в отдельном окне. Также, открывается 
меню LOCATION. 

3. Определите размещение элементов наследования как Default или External coordinate system 
(Внешняя система координат). 

4. Откройте диалоговое окно VARIED DIMENSIONS и выберите размеры базовой модели. Затем, 
можно изменять значения. 

 
Рисунок 13: Диалоговое Окно Varied Dimensions 

5. Используйте определение элемента Var Feats для открытия диалогового окна VARIED FEATURES. 
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Рисунок 14: Диалоговое Окно VARIED FEATURES 

6. Выберите объекты в качестве переменных. Позже их можно будет подавить перед созданием 
элементов наследования, или разрешить сделать это позже 

7. Элемент Наследования можно сделать зависимым или независимым от базовой модели. В первом 
случае зависимость создается между полученным объектом и базовой моделью. Изменения, 
сделанные в базовой модели, будут отражаться в полученном объекте. Независимый элемент 
наследования не обновляется при изменении базовой модели. 

8. Используйте Copy Notes для определения того, будут ли трехмерные примечания скопированы в 
элемент наследования. Трехмерные примечания могут быть скопированы в полученный объект, но 
они не могут быть изменены или стерты в полученном объекте. 

Лабораторный Практикум 

Цель 
В этом практикуме, Вы создадите и научитесь управлять семейством таблиц сборки и 
детали. Также, будет показана процедура создания элемента наследования и сравнения его 
с использованием деталей слияния (merge parts) и таблиц семейств. 

Метод 
В Упражнениях 1 и 2, Вы откроете родовое вхождение и определите семейство таблиц на основании 
родового объекта. Также, Вы измените таблицу семейства. 

В Упражнениях 3 и 4, Вы создадите элемент наследования с и без переменных размеров и элементов. 
Переменный размер будет добавлен позже. Вы также изучите, как создать полностью новую модель и 
добавить группу элементов к существующей геометрии, используя элементы наследования. 

Инструменты 
Таблица 1: Пиктограммы таблиц Семейства и Элементов Наследования 

ПИКТОГРАММА ОПИСАНИЕ 

   Проверить 

   Предварительный просмотр 

   Добавить объект 
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   Добавить ряд 

УПРАЖНЕНИЕ 1: Создание Таблиц Семейств Детали 
Задача 1. Вызвать родовую деталь шины и изучите таблицу семейства. 

1. Вызовите TIRE.PRT после установки соответствующего рабочего каталога. 

Обратите внимание: 

Существуют три вхождения родовой детали: с диаметрами обода 12_INCH, 13_INCH и 14_INCH. 
Добавление размера RIM_DIA в таблице семейства создает вхождения. 

2. Щелкните по Generic > Open. 

3. Щелкните по Family Tab. 

 
Рисунок 15: Таблица Семейства 

Задача 2. Создать все разновидности для размера обода 12_INCH путем изменения размера 
TIRE_WIDTH и параметра SIDEWALL_HEIGHT. Создать таблицу семейства для вхождения 12_INCH, 
имеющего "вложенное" вхождение. Добавить необходимые параметры к таблице вхождений. 

1. Выберите вхождение 12_INCH и щелкните по Open. 

2. Щелкните по Family Tab и по  [Добавляет объект]. 

3. Выберите выдавливание вращения, формирующее шину. Система должна теперь отображать 
размер шины. 
4. Выберите размер TIRE_WIDTH (6.00). Щелкните по Info > Switch Dimensions для просмотра 
символических имен размеров. 
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Рисунок 16: Размер Ширины Шины 

5. Щелкните по Parameter. Выберите параметр SIDEWALL_HEIGHT. Щелкните по Done Sel > Done / 
Return > ОК. 

6. Щелкните по  [добавляет строку]. Присвойте имя первому вхождению 12X4X1 и установите 
TIRE_WIDTH и SIDEWALL_HEIGHT в 4.0 и 1.0 соответственно. 

 
Рисунок 17: Добавление Первого Вхождения 

Задача 3. Так как таблица семейства является закономерной, создайте оставшиеся вхождения путем 
копирования нового вхождения. 

1. Выберите вхождение 12X4X1. Щелкните по Edit > Copy with Increments. 

2. Выполните приращение высоты стенки на 1 для первого направления. 
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Рисунок 18: Диалоговое Окно PATTERNIZE 

3. Выберите SIDEWALL_HEIGHT. Щелкните по > > . Введите [1.0] в качестве приращения и нажмите 
<ENTER> . 

4. Выберите 1 под QUANTITY. Введите [3] в качестве количества объектов массива в первом 
направлении. 

5. Выполните приращение шины на 2 для второго направления. Щелкните по пиктограмме + для 
направления. Выберите TIRE_WIDTH. Введите [2] в качестве приращения. 

6. Выберите QUANTITY. Введите [3] в качестве количества объектов массива во втором направлении. 

7. Щелкните по ОК для размножения вхождений. 

Задача 4. Система теперь автоматически добавляет вхождения к таблице. Можно редактировать 
таблицу для создания неоднородных вариаций или просто редактировать названия вхождений. 
Измените названия вхождений шины. 

1. Отредактируйте таблицу и введите соответствующие имена вхождений, как показано на следующем 
рисунке. 
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Рисунок 19: Таблица Семейства 12_INCH 

Обратите внимание: 

При каждом последующем создании массива, система добавляете новые вхождения к исходному 
размножаемому вхождению. Оригинал не дублируется. 

Задача 5. Использовать эту таблицу для создания вхождения на другой модели. Сохраните файл 
Pro/TABLE. 

1. Щелкните по File > Export Table > PRO/TABLE file. 

2. Введите [13_INCH_TIRE_IMPORT]. Щелкните по Save. 

3. Выберите вхождение 12X4X3. Щелкните по Open. 

4. Закройте 12X4X3. PRT и 12_INCH.PRT. 

Задача 6. Создать вхождения для шины 13_INCH. 

1. Щелкните по Window > Activate > Family Tab. Выберите вхождение 13_INCH. Щелкните по Open. 

2. Щелкните по Family Tab >  [Добавляет объекты]. 

3. Выберите выдавливание REVOLVED. Выберите размер TIRE_WIDTH. 

4. Щелкните по Parameter. Выберите параметр SIDEWALL_HEIGHT. Щелкните по Done Sel > 
Done/Return > ОК. 

Задача 7. Файл Pro/TABLE был отредактирован в NOTEPAD (или любом редакторе по умолчанию) 
для считывания вхождения 13_inch. Прочитайте информацию в таблице 13_inch_tire.ptd. 

1. Щелкните по File > Import Table. Выберите существующий 13_INCH_TIRE.PTD. Щелкните по File > 
Open. 
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Рисунок 20: Вхождения 13_Inch 

2. Щелкните по ОК. 

3. Вхождения 14_INCH шины уже были созданы. 

Задача 8. Проверить таблицу семейства, чтобы Pro/ENGINEER мог регенерировать все вхождения. 

1. Закройте текущее окно и активизируйте родовую деталь шины. 

2. Щелкните по Family Tab >  > Verify. Обратите внимание, что по мере регенерации системой 
всех вхождений одного за другим, стрелка помещается рядом с регенерируемым вхождением. 

3. Результаты проверки размещаются рядом с каждым вхождением в диалоговом окне FAMILY TREE, 
как показано на следующем рисунке. 

 
Рисунок 21: Диалоговое Окно Family Tree 

Обратите внимание: 
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Pro/ENGINEER также создает файл, называемый modelname.tst, который может быть просмотрен 
любым текстовым редактором. 

Выбор опции Verify только подтверждает успешную регенерацию модели. При этом не проверяется, 
чтобы модель удовлетворяла конструкторским критериям модели. 

4. Щелкните по Close > ОК для закрытия диалогового окна. 

5. Сохраните шину и закройте окно. 

УПРАЖНЕНИЕ 2: Создание Таблиц Семейств Сборки 

 
Рисунок 22: Разновидности Сборки Колеса 

Задача 1. Добавить компоненты сборки колеса в таблицу семейства и вызвать обод. 

1. Откройте WHEEL.ASM. 

2. Щелкните по Family Tab. Щелкните по  > Component. 

3. Выберите RIM.PRT, TIRE.PRT и SPINDLE_BUSHING.PRT в Дереве Модели. Щелкните по Done Sel 
> ОК. 

4. Различия в ободах основываются на таблице семейства вхождений собственно компонента обода. 
Откройте RIM.PRT. 

5. Изучите модель обода для определения, как она была построена. Щелкните по Utilities > Model 
Player. 
Задача 2. Создать таблицу семейства сборки путем ручного редактирования. Используйте 
инструменты, доступные в Pro/TABLE для повышения эффективности. 

1. Щелкните по . Введите [W_12X6-AR-4N] в качестве названия. 

2. Добавьте названия других вхождений. Введите их вручную. Редактируйте только некорректную 
часть имени, как показано в следующем рисунке. Используйте Copy и Paste для дублирования. 
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Рисунок 23: Таблица Семейства Колеса 

Задача 3. Ввести названия вхождения непосредственно в ячейки, чтобы вхождения сборки управляли 
вхождениями модели обода. 

1. Добавьте имена вхождения обода используя имена вхождения сборки. Подсветите четыре названия 
вхождения, как показано на следующем рисунке. 

 
Рисунок 24: Добавление Вхождений Обода 

2. Щелкните по Edit > Copy. Подсветите эти четыре ячейки под компонентом RIM. 

3. Щелкните по Edit > Paste. Удалите W_ в названиях в колонке RIM. 
4. Подсветите четыре названия вхождения обода. Щелкните по Edit > Copy > Edit Paste. 
Отредактируйте названия для отражения вхождений шины, как показано на следующем рисунке. 
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Рисунок 25: Добавление Названий Вхождения Шины 

Задача 4. Так как на колесе имеется посадочное место под ось (обозначенное "-SP" в имени 
вхождения), сборке требуется шпиндельная втулка. При наличии ушек, обозначенных "4N", втулка не 
нужна. Используйте Таблицу Семейства для удаления из сборки втулки, если используется ушко. 

1. Используйте опцию Yes/No для добавления или удаления втулки шпинделя. Отредактируйте 
таблицу, как показано на следующем рисунке. 

2. Щелкните по Verify в диалоговом окне FAMILY TABLE. 

 
Рисунок 26: Добавление Шпиндельной Втулки 

3. Щелкните по ОК и сохраните сборку. 

4. Закройте окно. 

Задача 5. Заменить колесо в сборке высшего уровня одним из вхождений. 

1. Откройте FT_FRT_SUSP.ASM. 

2. Щелкните Component > Adv Utils > Replace. Выберите одно из колес в сборке. 



Pro/ENGINEER 2001 Углубленный Курс    

- 158 - 

Обратите внимание: 
Используйте Query Sel для выбора всей сборки WHEEL.ASM, а не только шины. 
3. Используйте таблицы семейств для замены компонента. Щелкните по By Family Table Member. 
Щелкните по Browse. 
4. Выберите любое из созданных вхождений. Щелкните по ОК > Apply > Done. 

 
Рисунок 27: Вид Спереди Временно Приостановленной Сборки 

5. Повторите процесс для замены другого колеса. 

6. Сохраните сборку и сотрите ее из оперативной памяти. 

УПРАЖНЕНИЕ 3: Использование Элементов Наследования 
Задача 1. Вызвать ABSORBER_BAR.PRT и определить, где была создана ее система координат. 
Затем создайте элемент наследования без переменных размеров или элементов. 

1. Откройте IF_ABSORBER_BAR.PRT. 

2. Щелкните по Feature > Create > Data Sharing > Inheritance > Open. 

3. Выберите IF_ABSORBER_FASTENER.PRT. 

4. Щелкните по Default в меню LOCATION и выберите ОК. 

 
Рисунок 28: Добавленная Группа Элементов Наследования 
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Задача 2. Изменить значение размера отверстия в новой и в базовой модели. Добавьте переменный 
размер в новой детали. 
1. В активном окне (IF_ABSORBER_BAR.PRT) щелкните правой кнопкой мыши по Hole id 68 в Дереве 
Модели, как показано на следующем рисунке и выберите Modify. 

 
Рисунок 29: Выбор Отверстия ID 68 

2. Выберите размер 0.38 и измените его на 0.2. 

3. Подтвердить добавление этого размера к Таблице Inherited Vardim. Подтвердите Yes и Regenerate. 

4. Откройте IF_ABSORBER_FASTENER.PRT и выполните Regenerate. Ничего не изменяйте. 

5. Изменить скругление с 0.25 на 0.1. 

6. Перейдите в активное окно и выполните Regenerate. Скругление также изменится. 

УПРАЖНЕНИЕ 4: Элемент Наследования в Новых Моделях 
Задача 1. Создать новую деталь с именем HEX_BOLT и Элемент Наследования. Появится 
предупреждение об использовании двух различных систем измерения. 

1. Щелкните по File > New и введите [HEX_BOLT]. Используйте шаблон INLBS_PART_SOLID.PRT. 

2. Щелкните по Feature > Create > Data Sharing > Inheritance > Open. 

3. Дважды щелкните по IF_BOLT.PRT. 

4. Почтите предупреждение и щелкните по ОК. 

 
Рисунок 30: Предупреждение о Различных Системах Единиц 

5. Выберите Cancel в окне Open и в диалоговом окне Model. Щелкните по Yes. 

Задача 2. Открыть IF_BOLT.PRT и изменить его систему единиц на систему Pro/E по умолчанию. 
Затем, снова начните с Задачи 1. 
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1. Откройте IF_BOLT. 

2. Щелкните по Set Up > Units. 
3. В окне Units Manager выберите Inch lbm Second (система Pro/E по умолчанию) и Set. Затем 
выберите Interpret Existing Numbers > OK > Close. 

 
Рисунок 31: Изменение Системы Единиц 

4. Сохраните модель и удалите ее из сессии. 

5. Повторить шаги с 1 по 3, следуя описанию в Задаче 1. 

6. В меню LOCATION выберите Default. 
7. Дважды щелкните по Var Dims. Появляется диалоговое окно Varied Dimension. 

8. Выберите опции, как показано на следующем рисунке и измените значение 3 на 5. Выберите  и 
ОК. 
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Рисунок 32: Диалоговое Окно Varied Dimensions  

9. Дважды щелкните по Var Feats. Щелкните по Add и выберите отверстие. 

10. Выберите опции, как показано на нижнем рисунке. Щелкните по ОК. 

 
Рисунок 33: Диалоговое Окно Varied Features  

11. Просмотрите окончательный результат. Сохраните его и закройте окно. 

Резюме 

В этой главе Вы узнали что: 

• можно быстро создавать детали и сборки, используя Таблицы Семейств. 

• Таблицы Семейств неоценимы в случае подобных деталей и управляются одним файлом. 

• Таблицы Семейств уменьшают количество файлов, существующих в системе, позволяя таким 
образом, оптимально использовать системную память. 



Pro/ENGINEER 2001 Углубленный Курс    

- 162 - 

• Вхождения в Таблице Семейств ассоциативны. 

• Таблицы Семейств полезны при замене компонентов и использовании альтернативных 
проектов. 

• Можно создавать элементы наследования и детали, которые позволяют включать переменные 
размеры и элементы. 

• Элементы наследования часто используются вместо таблиц семейств, а также для 
копирования объектов из другой модели. 
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Глава 6 
Углубленные Инструментальные 
Средства и Массивы 
В этой главе Вы изучите различные способы создания геометрии в моделях на уровне 
сборок. Это поможет использовать все преимущества функциональных возможностей 
конструирования сверху-вниз, доступные в Pro/ENGINEER. 

Цели 
После завершения этой главы, Вы сможете: 

• создавать пересечения деталей и группировать объекты. 

• Зеркально отображать геометрию. 

• Создавать независимые элементы в компонентах и элементы уровня сборок. 

• Использовать уравнения для управления геометрией. 

• Создавать элементы уровня сборок. 

• Использовать художественные поверхности для определения твердотельной геометрии. 

• Создавать производные от сборок детали из моделей одиночных деталей. 

• Создавать размерные и ссылочные массивы. 

• Манипулировать существующими массивами. 

• Сохранять массивы от одного компонента к другому. 

Дополнительные Действия над Компонентами 

Создание Пересечений Детали 
Используя пересечение между двумя компонентами, можно определить новый компонент. Новая 
деталь зависит от деталей, из который создается пересечение; таким образом система всегда 
связывает его со сборкой. 

 
Рисунок 1: Часть Пересечения Двух Труб 
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Обрезка Деталей 
Используя опцию Intersect в меню MODIFY PART, можно обрезать существующую часть по объему, 
определенному пересечением с другой деталью. 

При создании элемента пересечения путем обрезки детали, эта деталь становится зависимой от 
сборки для элемента пересечения. 

Слияние и Отрезание Деталей 
Можно объединять существующий материал одной детали с другой деталью, копируя геометрию в 
модель или, путем поддержки постоянной ссылки. При копировании геометрии, модель не зависит от 
ссылочной детали. 

Используя технику "cutout (отрезание)", можно также удалять материал из одного компонента на 
основании пересечения с материалом другого. Можно копировать или ссылаться на геометрию, 
создавая условия зависимости или независимости. 

Следующий рисунок иллюстрирует методы слияния и отрезания. 

 
Рисунок 2: Использование Слияния и Отрезания 

Создание Зеркального Отображения Детали 
При создании компонента на уровне сборки, можно использовать Part > Mirror для создания 
зеркального отображения нового компонента по отношению к оригиналу. Зеркальную копию детали 
можно создавать, используя опции Reference или Copy. 



  Pro/ENGINEER 2001 Углубленный курс 

- 165 - 

 
Рисунок 3: Зеркальное Отображение Детали 

Создание Элементов Уровня Сборки 
В производственном процессе, некоторые элементы не добавляются к сборке, пока детали 
фактически не будут собраны. В качестве элементов модели, которые не существуют в детали в 
процессе ее создания (типа обрабатываемых отверстий и вырезов), можно создавать элементы 
уровня сборки (assembly-level features). 

Используя элементы сборки, можно выполнять следующее: 

• отверстия, вырезы и пазы в модели, обрабатываемые в процессе сборки, делая их видимыми 
только на уровне сборки. 

• Создавать опорные элементы и элементы поверхностей для привязки при сборке компонентов 
и создании элементов детали. 

• Определять операции обработки в сварных изделиях. 

• Создавать стыковочные отверстия/вырезы в подгоняемых деталях, делая эти элементы 
видимыми также и на уровне детали. 

• Создавать вырезы в сборке для просмотра некоторых невидимых компонентов. 

Использование Элементов Сборки для Определения Элементов Детали 
Иногда создание независимых элементов детали на уровне детали может быть более эффективным, 
чем создание их на уровне сборки. 

Уровень Видимости 

По умолчанию, Pro/ENGINEER показывает вычитаемый твердотельный элемент сборки (типа 
отверстия или выреза) только в сборке, но не в детали или каком либо узле. Определяя 
соответствующий уровень видимости (visibility level), можно рассматривать элементы уровня сборки 
собственно в деталях или узлах. 
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Определение Моделей для Пересечения 

При создании элемента уровня сборки, можно позволить системе выбрать модели, которые должен 
"вырезать" элемент, или можно самостоятельно указать модели. 

• При выборе Add Model и Auto Sel, элементы воздействуют (вырезают материал) из всех 
деталей вдоль траектории на эскизной плоскости на указанную глубину. 

• При выборе Add Model и Manual Sel, можно самостоятельно указать детали вдоль 
траектории, на которые должен воздействовать элемент. 

Для переопределения уровня видимости элемента сборки или изменения пересекаемых моделей, 
можно выбрать Feature > Intersect, или выбрать Redefine и Intsct Parts из диалогового окна. 

 
Рисунок 4: Вырез Сборки 

Примечание: 
Элементы уровня сборки автоматически создают вхождения таблицы семейства в компонентах, 
которые были выбраны для пересечения. 

Введение в Создание Массивов 

Используя размножение (patterning), можно создавать множество дубликатов, или вхождений, 
отдельных элементов, называемых ведущими (lead) элементами. Затем, можно управлять этими 
многочисленными элементами так, как если бы они являются отдельным элементом. Для управления 
размером и положением вхождений массива, можно использовать размеры или ссылаться на 
существующий массив. 

Массивы имеют множество преимуществ, которые позволяют: 

• увеличивать производительность путем быстрого и легкого воспроизведения элемента 
несколько раз. 

• Выполнять операции над всем массивом, в отличии от отдельных элементов. 

• Параметрически управлять массивом путем изменения его параметров. 

• Увеличивать эффективность работы путем изменения массива, в отличии от изменения 
множества отдельных элементов. 
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Типы Массивов 
В Pro/ENGINEER, можно создавать два типа массивов для определения местоположения вхождений: 

• Размерные массивы (Dimension patterns) � использует размеры для управления 
положением вхождений. 

• Ссылочные массивы (Reference patterns) � привязываются к существующему массиву. 

Создание Размерных Массивов 
Метод по умолчанию для создания размерного массива состоит в приращении управляющих 
размеров ведущего элемента. 

 
Рисунок 5: Массив, Управляемый Приращениями 

Создание Таблиц Массивов 
При помощи таблицы массива, можно управлять местоположением вхождений, создавая абсолютные 
размеры к той же привязке, что и для лидера. Размеры вводятся в табличном формате и каждый 
размер вхождения редактируется независимо. 

Используя эту технику, можно создавать более сложные конфигурации, типа неравного интервала или 
нерегулярных размеров, как показано в следующем примере. 

 
Рисунок 6: Примеры Таблиц Массива 

Использование Таблиц Массива 
Таблицы массива следует использовать, если: 

• Невозможно управлять массивом с использованием приращений размеров по причине их 
сложности или неравномерности. 

• Назначение конструкции требует размещать каждое вхождение от собственной привязки, в 
отличии от привязки к последнему вхождению при приращении. 
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• Различные модели могут использовать один массив. 

• Необходимо создать несколько конфигураций массива для различных вариантов модели. 

Создание Новых Табличных Массивов 
Для создания массива, управляемого таблицей: 

• выберите размножаемый элемент, используя опцию Dim Pattern. Выберите опцию массива и 
укажите таблицу в качестве метода управления массивом. 

• Выберите управляющие размеры для помещения в таблицу. 

• Введите имя таблицы. Система открывает редактор Pro/TABLE, который имеет колонку ID 
вхождения (IDX) и колонку для каждого выбранного размера. 

Создавайте вхождения, вводя требуемые размеры, по образцу в следующей таблице. Выйдите из 
редактора и щелкните по Done для создания массива. 

Таблица 1: Таблица Массива 

 

Переопределение Таблиц Массивов 
Для создания таблицы массива, можно использовать существующий массив, который был определен 
с приращением. При переопределении вхождения, используйте опцию To Table для преобразования 
существующего инкрементального массива. 

Для создания массива, показанного на следующем рисунке, конвертируйте инкрементальный массив в 
таблицу и, затем, удалите два вхождения. 

 
Рисунок 7: Преобразование Инкрементального Массива в Таблицу Массива 

Примечание: 
После преобразования массива к таблице, его нельзя вернуть назад к первоначальной форме. 

Редактирование Таблиц Массивов: Переменные и Постоянные Размеры 
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При изменении таблицы массива, важно понять разницу между переменными и постоянными 
размерами. 

• переменные размеры перечисляются в таблице массива и могут отличаться от одного 
вхождения к другому. 

• Все другие размеры размноженного элемента являются постоянными и все вхождения 
используют одни и те же значения. 

• Любые изменения, проводимые в переменных размерах, воздействуют только на изменяемое 
вхождение, после чего таблица обновляется. 

• При изменении постоянного размера изменяются все вхождения. 

 

Таблица 1: Таблица Массива 

 

 

 
Рисунок 8: Изменение Табличных Размеров 
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Рисунок 9: Изменение не Табличных Размеров 

Редактирование Элементов в Массиве 
Используя Modify > Patter Table, можно выбирать элемент в массиве и выполнять следующие 
изменения: 

• добавлять новую таблицу массива в элемент, удалять существующую таблицу массива и 
изменять вхождения. 

• Добавлять новую таблицу массива в элемент. 

• Удалять существующую таблицу массива. 

• Назначать новое имя существующей таблице массива. 

• Указывать, которая таблица массива используется при регенерации элемента. 

• Сохранять таблицу массива на жесткий диск, используя имя PATT_TABLE_NAME.PTB. 

• Считывать таблицу массива с жесткого диска. 

Создание Конструктивных Переменных В Массиве 
При добавлении нескольких таблиц массива к отдельному элементу, можно создавать различные 
модификации конструкции. Затем, можно переходить от одной модификации к другой, используя 
функциональные возможности переключения. 

 
Рисунок 10: Использование Таблицы Массива для Конструктивных Переменных 

Использование Массивов в Нескольких Моделях 
Таблицу массива можно сохранять в файл и, затем, использовать ее для управления другим 
массивом, считывая файл в другую модель. Эта методика обеспечивает одинаковую конфигурацию 
таблицы массива в различных моделях. Кроме того, при этом экономится время. 

 
Рисунок 11: Использование Таблицы Массива для Сохранения Связи Между Двумя Деталями 



  Pro/ENGINEER 2001 Углубленный курс 

- 171 - 

Массивы В Режиме Сборки 

Компоненты в режиме Сборки можно размножать подобно тому, как это делается при размножении 
элементов в режиме детали, используя размерные и ссылочные массивы. 

На следующем рисунке, первый болт ссылается на ведущее отверстие. Поэтому, можно привязать 
массив к нему. 

 
Рисунок 12: Размножение Компонентов в Сборке 

• Ссылочный массив можно использовать для сборки компонента с каждым вхождением или 
другим размноженным компонентом в сборке. Можно также привязывать размножаемые 
элементы, типа отверстий в детали. 

• Для размерных массивов можно использовать зависимости типа Mate Offset, Align Offset и 
внутренние опорные размеры. 

Лабораторный Практикум 

Цель 
В этом практикуме, Вы создадите массивы, а также создадите новые детали и элементы в 
контексте сборки. 

Метод 
В Упражнении 1, Вы создадите левую часть шарнира для карта путем зеркального отображения во 
временную сборку. Левый шарнир - зеркальное отображение существующего правого шарнира. 

В Упражнении 2, Вы завершите мастер-модель рулевого колеса путем создания художественной 
поверхности и замены существующей плоской поверхности на новую созданную поверхность. 

В Упражнении 3, Вы создадите рулевое колесо и детали аэродинамического покрытия из мастер-
модели рулевого колеса. 

В Упражнении 4, Вы создадите простой идентичный массив отверстий с приращением на тормозном 
диске. Затем, Вы конвертируете массив в таблицу для получения более гибкого контроля над 
размещением отверстий. 

В Упражнении 5, Вы соберете крепежные гайки с колесом, создавая радиальный массив. После 
сборки первой гайки, оставшиеся будут собраны с использованием существующего массива. 

УПРАЖНЕНИЕ 1: Зеркальное Отображение Шарнира 
Задача 1. Создать пустую сборку и собрать правый шарнир в качестве первого компонента. Создайте 
опорную плоскость в детали, относительно которой будет выполнено зеркальное отображение 
детали. 

1. Перейдите в соответствующий рабочий каталог. 

2. Создайте новую сборку с именем MIRROR_KNUCKLE. Снимите переключатель Use Default 
Template. Щелкните по ОК , затем Empty > OK. 

Примечание: 
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Не создавайте опорных элементов по умолчанию в этой сборке, так как потребуется только привязать 
эти два компонента друг к другу. 

3. Соберите RIGHT_KNUCKLE.PRT, как первый компонент. Система размещает его в ориентации по 
умолчанию. 

 
Рисунок 13:RIGHT_KNUCKLE.PRT 

4. Щелкните по Modify > Mod Part . Выберите деталь. 

5. Щелкните по View > Layers. Выберите слой DATUMS. 

6. Щелкните по пиктограмме Show. Перерисуйте экран. Щелкните по Close. 

7. Щелкните по пиктограмме Insert a Datum Plane. Щелкните по Offset. Выберите опорный элемент 
SIDE. 

8. Щелкните по Enter Value. Введите [-5]. 

9. Щелкайте по Done, пока не дойдете до меню ASSEMBLY. 

 
Рисунок 14: Новая Опорная Плоскость для Зеркального Отображения 

Задача 2. Создать новую деталь с левым шарниром. 

1. Щелкните по Component > Create > Part > Mirror. 
2. Введите [LEFT_KNUCKLE]. Выберите ОК. 

3. Щелкните по Copy в диалоговом окне. Выберите RIGHT_KNUCKLE.PRT. 

4. Выберите DTM5 в RIGHT_KNUCKLE.PRT. Щелкните по ОК. 

Примечание: 
Опорные элементы уровня сборки не используются, потому что при этом создается зависимость 
уровня сборки. Так как используется опорный элемент в исходной детали, теперь можно удалить 
файл сборки. 
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Рисунок 15: Зеркальная Деталь 

5. Сохраните LEFT_KNUCKLE.PRT. Щелкните по . Введите [LEFT_KNUCKLE] вместо имени 
сборки. 

6. Не сохраняйте сборку. Сотрите ее из сессии. 

УПРАЖНЕНИЕ 2: Замена Поверхности 
Задача 1. Создать поверхность протягивания для определения требуемого контура для рулевого 
колеса. 

1. Откройте ST_WHEEL_MAST_MODEL.PRT. 

2. Создайте элемент поверхности протягивания. Щелкните по Sketch Traj. Укажите FRONT в качестве 
эскизной плоскости траектории и ТОР в качестве верхней горизонтальной привязки. 

3. Нарисуйте дугу в качестве траектории, как показано на следующем рисунке. 

Примечание: 
Два следующих рисунка показывают фактическую твердотельную геометрию в целях ясности. 

 
Рисунок 16: Траектория для Поверхности Протягивания 

4. После завершения траектории, щелкните по Open Ends > Done. 

5. Нарисуйте поперечное сечение, показанное на следующем рисунке. 
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Рисунок 17: Сечение для Поверхности Протягивания 

6. Щелкните по пиктограмме Done Check и щелкните по ОК в диалоговом окне элемента для создания 
поверхности. Щелкните по Done/Return. Вызовите вид по умолчанию. 

 
Рисунок 18: Завершенная Поверхность 

Задача 2. Заменить существующую плоскую поверхность на новую художественную поверхность. 

1. Щелкните по Create > Tweak > Replace. 

2. Выберите плоскую верхнюю поверхность центра рулевого колеса. 

3. Выберите только что созданную новую поверхность. 

4. Щелкните по ОК для замены поверхности. 

5. Сохраните модель и закройте окно. 
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Рисунок 19: Замененная Поверхность 

УПРАЖНЕНИЕ 3: Создание Элементов Сборки 

 
Рисунок 20: Сборка SHELL.ASM со Сплайновым Вырезом 

Задача 1. Вызвать сборку оболочки и получить информацию по ней. 

1. Откройте SHELL.ASM 

2. Щелкните по Info > Bill of Materials. Выберите Top Level > OK > Screen. Модель состоит из трех 
компонентов. Щелкните по Close для закрытия Окна. 

3. Закрасьте сборку. 

4. Щелкните по Info > Feature. Выберите сплайновый вырез. Этот вырез был сделан в режиме 
Сборки, как элемент сборки. 

Задача 2. Обратите внимание, что элемент сборки пересекает внешний кожух. Измените пересечение 
элементов, чтобы включить внутренний кожух. 

1. Щелкните по Feature > Redefine. Выберите сплайновый вырез. 

2. Щелкните по Intsct Parts > Define. 

3. Щелкните по Sel By Menu. Выберите SHELL_INNER.PRT. 

4. Щелкните по Select и Done /Sel. Оставьте уровень видимости без изменения. Щелкните по ОК > ОК 
для завершения. 

5. Выполните перерисовку для просмотра результатов. Снова закрасьте сборку и проверьте, чтобы 
вырез проходил через обе оболочки. 
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Рисунок 21: Элемент Сборки 

Задача 3. Уровень видимости выреза сборки установлен в высший уровень. Проверьте это, 
осматривая детали индивидуально. 

1. Откройте SHELL_OUTER.PRT. Обратите внимание, что вырез не видим в режиме Сборки. 

2. Закройте окно SHELL_OUTER.PRT. Щелкните по Close в выпадающем меню Window. 

3. Щелкните по Activate в выпадающем меню для возврата в сборку. 

4. Находясь в режиме в Сборки, попробуйте добавить элемент к SHELL_OUTER.PRT. Щелкните по 
Modify > Mod Part. Выберите SHELL_OUTER.PRT. Система запросит подтверждения временного 
удаления элемента сборки. Щелкните по Confirm. 

5. Щелкните по Done в меню MODIFY PART. Элемент сборки возвращается. 

Задача 4. Сделать элемент сборки видимым на уровне Детали. 

1. Щелкните по Feature > Redefine. Выберите вырез. Щелкните по Intsct Parts > Define и дважды 
щелкните по Remove для удаления обеих моделей из списка пересекаемых компонентов. 

2. Выберите Part Level в выпадающем меню Level. 
3. Выберите SHELL_OUTER.PRT и SHELL_INNER.PRT. Щелкните по ОК > ОК для завершения 
элемента. 

4. Откройте, SHELL_INNER.PRT. Должен появиться элемент сборки. Откройте SHELL_OUTER.PRT. 
Появляется еще один элемент сборки. 

5. Закройте окна детали и повторно активируйте сборку. 

 
Рисунок 22: Пример Элемента Сборки 

6. [Необязательно] Создайте вырез сборки, как показано в предыдущем рисунке. 

7. Сохраните сборку и сотрите ее из оперативной памяти. 

УПРАЖНЕНИЕ 4: Создание Таблиц Массива 
Задача 1. Создать размерный массив ведущего отверстия, используя приращения для управления 
массивом. 

1. Перейдите в рабочий каталог PATTERNS_COPY. 

2. Откройте BRAKE_DISK_VENTED.PRT. 

3. Щелкните по Feature > Pattern; выберите элемент маленького отверстия. 
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4. Щелкните по Identical > Done. 

5. Выберите угловой размер 20.0. Введите [5]. Выберите радиус 2.000; введите [0.5]. 

 
Рисунок 23: Размеры Массива Отверстия 

6. Щелкните по Done ; введите [4] в качестве числа вхождений. 

7. Выберите угловой размер 20.0; введите [30]. 

8. Щелкните по Done ; введите [12] в качестве числа вхождений. 

Задача 2. Изменить массив отверстий на табличный и отредактировать таблицу для удаления 
дополнительных отверстий. 

 
Рисунок 24: Измененный Массив Отверстий 

1. Щелкните по Redefine; выберите одно из отверстий. 
2. Щелкните по кнопке Pattern в диалоговом окне отверстий. Выберите To Table. 
3. Укажите имя массива. Введите [holes1]. Система должна сообщить о создании таблицы массива 
HOLES1. 

4. Щелкните по Done /Return > . 

5. Щелкните по Done > Modify > Patter Table. 

6. Выберите таблицу массива HOLES1 из диалогового окна TABLES. Щелкните по Actions > Edit. 
7. Подсветите строки отверстий (idx =8-15, 24-31, 40-47) .Щелкните по Edit > Delete для удаления 
строк. 

Совет: 
Не следует перенумеровывать колонку idx для подсчета удаленных отверстий. Номера индексов 
вхождений должны быть уникальными, но они не обязательно будут последовательными. 
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8. Выйдите из редактор. Щелкните по ОК и Regenerate. 

Задача 3. Включить отверстия в твердотельную модель тормозного диска. В соответствии с 
назначением конструкции, он должен иметь тот же массив отверстий, что и вентилируемый диск. Для 
этого, сохраните таблицу массива на жесткий диск, чтобы система могла прочитать ее в другую 
деталь. 

1. Щелкните по Modify > Patter Table. Выберите таблицу массива HOLES1. 

2. Щелкните по Actions > Write . Система сохраняет информацию в таблице массива для 
конфигурации HOLES1 на жесткий диск (другая таблица массива с именем HOLES2 уже существует 
на жестком диске). Щелкните по ОК. 

3. Сохраните модель. 

Задача 4. Модификации конструкции требуют отверстий различной конфигурации. Добавьте другую 
таблицу массива к элементу отверстия, считывая ее в деталь вентилируемого диска с жесткого диска. 

1. Щелкните по Modify > Patter Table. Выберите HOLES1 в диалоговом окне TABLES. 

2. Считайте файл HOLES2.PTB. Щелкните по Actions > Read. Выберите HOLES2.PTB. Щелкните по 
Open. Система сообщит о создании таблицы массива HOLES2. 

3. Переключите массив на использование только что считанной таблицы. Выберите HOLES2. 
Щелкните по Actions > Activate. 

4. Щелкните по Ok > Regenerate для просмотра нового массива отверстий. 

Примечание: 
Можно использовать пиктограммы в диалоговом окне TABLES для выполнения действий типа 
Активизировать, Прочитать, Записать и т.д. 

 
Рисунок 25: Альтернативный Массив Отверстий 

Задача 5. Использовать таблицы массива для другой модели. Управляйте существующими 
отверстиями в твердотельной детали диска. 

1. Откройте BRAKE_DISK_SOLID.PRT. 

2. Щелкните по Feature > Pattern. Выберите отверстие. Щелкните Identical > Done. 
3. Щелкните по Table. Выберите угловой размер 20.0; затем выберите координату радиуса 2.000. 
Щелкните по Done. Система теперь перечисляет эти два размера в таблице. 

Примечание: 
Важно выбрать эти размеры в правильном порядке, потому что последовательность выбора 
определяет порядок колонок в таблице. Необходимо соблюдать порядок колонок в таблице массива, 
которая сохраняется на жестком диске. 

4. Щелкните по Read. Выберите HOLES1. Повторите эту процедуру для таблицы массива HOLES2. 
Сейчас в деталь считаны две таблицы массива. 

5. Щелкните по Switch. Выберите HOLES2. Щелкните по Done > Done. 
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6. Сохраните обе модели и сотрите их из оперативной памяти. 

УПРАЖНЕНИЕ 5: Копирование Компонентов в Режиме Сборки 
Задача 1. Собрать первую гайку с ведущим отверстием; затем создать ссылочный массив других гаек. 

1. Откройте файл сборки WHEEL.ASM. 

2. Щелкните по Component > Assemble. Выберите LUG_NUT.PRT. 

3. Выберите Mate из выпадающего меню CONSTRAINTS TYPE. Стыкуйте коническую поверхность на 
гайке с конической поверхностью внутри отверстия. Это полностью определяет размещение. 
Щелкните по ОК для завершения. 

 
Рисунок 26: Привязки для Сборки Гайки 

4. Щелкните по Pattern в Component menu . Выберите lug nut. 

5. Щелкните по Ref Pattern > Done. 

6. Сохраните модель и сотрите всю сборку из памяти. Используйте пиктограмму Select All, чтобы 
стереть все компоненты. 

Резюме 

В этой главе Вы узнали: 

• что необходимо устанавливать внешние привязки (external references) при слиянии деталей, 
создании элементов детали в режиме сборки, зеркальном отображении элементов уровня 
деталей и сборок. Используйте Design Manager для управления определением привязок. 

• Как вызвать различные уровни в сборку. Как создать художественную поверхность. 

• Что можно создать одиночную деталь из геометрии поверхности, представляющей 
окончательную сборку. Затем, использовать эту деталь для отдельных компонентов, 
обеспечивая, таким образом, точную стыковку. 

• Различия между типами массивов и назначение их использования. 
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• Как создать простой массив в двух направлениях. 

• Как создать таблицу массива. 

• Как экспортировать информацию о массиве и импортировать ее в другую модель для 
экономии времени. 

• Как размножать компоненты в режиме сборки. 
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Глава 7 
Локальные Группы и 
Пользовательские Элементы 
В этой главе Вы изучите, как использовать локальные группы для упорядочивания модели. 
Также изучите, как создавать и использовать библиотеки часто используемой геометрии, 
определяя пользовательские элементы (UDFs). 

Цели 
После завершения этой главы, Вы сможете: 

• создавать и управлять локальными группами. 

• Повторно использовать данные. 

• Работать с несколькими элементами так, как если бы они представляли один элемент. 

• Разрывать зависимости между элементами в группе. 

• Создавать и размещать пользовательские элементы (UDF). 

Введение в Локальные Группы 

Группа - набор элементов в пределах детали или набор компонентов в сборке, которые ведут себя как 
отдельный объект. Локальная Группа � группа, созданная в пределах модели. 

Локальная Группа: 

• является частью модели, в которой она была создана. 

• Не может быть перенесена в другую модель. 

• Отображается в Дереве Модели как одиночный элемент с подструктурой. 

 
Рисунок 1: Дерево Модели До и После Создания Локальной Группы 

Управление Группами 
В локальной группе можно выполнять различные действия типа подавления, стирания или 
переупорядочивания. При этом группа ведет себя как отдельный элемент. 
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Можно также: 

• создавать и отменять массив группы. 

• Разгруппировывать группу. 

• Разрывать зависимости, существующие между элементами. 

Размножение Элементов 
Сгруппированные элементы могут использовать те же массивы, что и другие стандартные элементы. 
При размножении, можно объединять все размеры всех элементов в группе. 

 
Рисунок 2: Размножение Группы 

В массивах локальных групп можно создавать некоторые конфигурации, которые невозможно 
создавать в ссылочных массивах, как показано на следующем рисунке. 

 
Рисунок 3: Ссылочный Массив 

Можно разбить массив группы "отменой массива" на индивидуальные группы с их собственными 
размерами, которые затем можно изменять или удалять индивидуально. 

 
Рисунок 4: Разбитые Группы 
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Разгруппировка 
Можно разбивать группу на индивидуальные элементы, чтобы можно было работать с каждым из них 
по отдельности. 

 
Рисунок 5: Разгруппировка Одной Группы 

Разрыв Зависимостей 
При создании группы, система создает зависимость между исходной группой и копией или массивом 
группы. 

При разбивке массива (unpattern) или разгруппировке группы, она продолжает сохранять зависимость 
на уровне элементов. Используя Modify > Make Indep, можно разорвать эту зависимость. 

 
Рисунок 6: Высота Одной Группы Сделана Независимой 

Пользовательские Элементы 

Определение 
UDF - группы элементов, привязок, и размеров, которые могут быть сохранены для последующего 
использования в моделях. UDF экономят время и силы путем создания библиотек общей геометрии. 
Следующий рисунок показывает UDF, которые могут использоваться многократно. 



Pro/ENGINEER 2001 Углубленный Курс    

- 184 - 

 
Рисунок 7: Геометрия Резьбовой Бобышки 

Создание UDF 
Для создания UDF, выполните геометрию модели, которую требуется сохранить и, затем, определите 
UDF в соответствии со следующими шагами: 

1. Начните с Определения и Указания Места Хранения 

На этой стадии, определите, требуется ли сохранять UDF, как Одиночный (Stand Alone) 
элемент или Зависимый (Subordinate) элемент. 

2. Сохраните Ссылочные Детали. 

При создании одиночного UDF, можно сохранять ссылочную деталь для последующего 
использования. Система создает копию текущей детали и назначает ей имя UDFname_GP.PRT. 

При сохранении UDF, как зависимого элемента, текущая модель автоматически становится 
ссылочной деталью. 

3. Присвойте имя группе 

Когда система сохраняет файл, она добавляет расширение файла .gph. UDF должен иметь 
корректное имя файла, уникальное и описательное. 

4. Выберите элементы. 

Используйте Query Sel или Дерево Модели для выбора элементов модели, включаемых в UDF. 

5. Создайте Запросы Внешних Привязок 

Такие пользовательские запросы помогают выбирать соответствующие привязки при размещении 
UDF в новой модели. 
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Рисунок 8: Внешние Ссылки для Резьбовой Бобышки 

6. Определите Переменные Размеры и Элементы 

При выборе элементов UDF, можно делать следующее: 

• Сделать некоторые или все управляющие размеры переменными. 

• Увеличить гибкость UDF, создавая переменные элементы. 

• Определить запросы и логические формулировки. 

• Создать предопределенные разновидности UDF. 

7. Завершите Определение 

• После определения всех элементов UDF, можно щелкнуть по ОК в диалоговом окне для 
автоматического сохранения UDF и ссылочных деталей на жестком диске. Система 
назначает UDF имя UDFname.gph. 

Размещение UDF 
При размещении UDF в новой модели, система создает в новой модели группу, содержащую 
элементы UDF. 

 
Рисунок 9: Новая Деталь Нуждается в Резьбовой Бобышке 

Файл UDF можно размещать, используя следующие шаги: 

1. Выберите управляющие опции для контроля геометрии. Для управления геометрией после 
размещения, можно определить ее как независимую или UDF-управляемую. 

2. Вызовите ссылочную деталь, чтобы помочь при размещении UDF, если необходимо. 
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3. Введите значения для любых созданных переменных размеров и выберите привязки для 
размещения. 

 
Рисунок 10: Выбор Привязок для Размещения UDF 

4. Укажите отображение постоянных размеров, как Normal, Read Only или Blank. 

 
Рисунок 11: Постоянные Размеры Скрыты 

5. Определите любые опциональные элементы. 

6. Закончите размещение. 

Создание UDF Уровня Сборки 
При создании пользовательских элементов уровня сборок, можно создавать группы компонентов и 
размещать их как отдельные объекты. 

Лабораторный Практикум 

Цель 
В этом практикуме, Вы создадите и научитесь управлять локальной группой. Также будут 
созданы и использованы компоненты общей библиотеки, известные как UDF. 
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Метод 
В Упражнении 1, Вы используете локальные группы для создания массива вентилируемых дисков для 
тормозов карта. Многочисленные элементы будут обрабатываться, как будто это один элемент и 
будет разорвана зависимость элементов в группе. 

В Упражнении 2, Вы сначала изучите процедуру создания UDF. Затем, Вы разместите UDF в 
различных моделях. 

В Упражнении 3, Вы создадите UDF из шлицевого окончания вала. 

В Упражнении 4, Вы разместите шлицевое окончание UDF на конце вала. 

В Упражнении 5, Вы добавите UDF к ступице. 

УПРАЖНЕНИЕ 1: Создание Локальных Групп 
Задача 1. Вызовите деталь и восстановите подавленную геометрию. 

1. В папке PATTERNS_COPY откройте BRAKE_DISK_VENTED.PRT. 

2. Щелкните по Feature > Resume > Last Set > Done > Done. 

3. Щелкните по Utilities > Model Player. 

 
Рисунок 12: Диалоговое Окно MODEL PLAYER 

4. Пройдите по этапам создание геометрии модели и определите, как была построена деталь. 

5. Обратите внимание, что геометрия лопатки состоит из четырех элементов: выдавливание, вырез и 
два элемента скругления. 

 
Рисунок 13: Геометрия Лопатки 

Задача 2. Создать локальную группу, содержащую четыре элемента. 

1. Щелкните по Feature > Group > Local Group. 

2. Назовите локальную группу [blade]. 
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3. Определить элементы для включения в группу. Выберите выдавливание лопатки, элемент выреза, 
и два элемента скругления в Дереве Модели. 

4. Щелкните по Done в меню SELECT FEAT. 

Задача 3. Скопировать группу радиально по диску. 

1. Щелкните по Group > Pattern. 

2. Выберите Группу BLADE в Дереве Модели. Отображаются все размеры для группы. 

3. Укажите управляющие размеры для массива. Выберите угол 30°, как показано на следующем 
рисунке. 

 
Рисунок 14: Размер Массива 

4. Введите [30], как приращение для этого размера. 

5. Щелкните по Done в меню EXIT. 

6. Введите [12], в качестве количества вхождений. 

7. Завершите массив. Щелкните по Done в меню EXIT. 

 
Рисунок 15: Законченный Массив Лопаток 

УПРАЖНЕНИЕ 2: Использование Опций Группы 
Задача 1. Открыть модель и создать массив группы. 

1. Откройте LOCAL_GROUP.PRT. 
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Рисунок 16: Исходная Модель 

2. Щелкните по Feature > Group > Local Group и введите [volcano]. 

3. Выберите выдавливание, уклон и отверстие в Дереве Модели. Щелкните по  > . Обратите 
внимание на ветвь группы в Дереве Модели. 

 
Рисунок 17: Ветвь Группы в Дереве Модели 

4. Находясь в меню GROUP, щелкните по Pattern и щелкните в пределах группы. 

5. Выберите размер для приращения в первом направлении, как показано на следующем рисунке. 

 
Рисунок 18: Размер для Приращения в Первом Направлении 
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6. Введите [3.0], щелкните по Done и введите [3]. 

7. Выберите размер для приращения во втором направлении, как показано на следующем рисунке 

 
Рисунок 19: Направление Приращения во Втором Направлении 

8. Введите [5.0], щелкните по Done и введите [2]. 

 
Рисунок 20: Созданный Массив 

Задача 2. Создать ссылочный массив группы. 

1. Выберите кромку и щелкните по  > Round Edges. 

 
Рисунок 21: Скругление Кромок 

2. Протяните радиус приблизительно 0.20. 

3. Выберите скругление и щелкните по  > Pattern. 

Задача 3. Исследовать опцию разбивки массива. 
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1. Выберите группу и щелкните по  > Modify 

 
2. Измените количество по вертикали на 1 и выполните регенерацию. 

3. Верните количество назад в 4. 

4. Измените угол уклона на 13.0 и выполните регенерацию. 

5. Измените угол уклона назад в 7.0. 

6. Измените размер, показанный ниже, на 3.0 и выполните регенерацию. 

 
Рисунок 22: Измененные Размеры 

7. Измените размер обратно на 5.0. 

8. Обратите внимание, что в процессе предыдущих изменений, компоненты группы обрабатывались, 
как вхождения массива. 

9. Щелкните по Feature > Group > Unpattern и выберите любую группу. Прочтите запрос. 

Задача 4. Используя изученные методы, выполните перестроение. (Подсказка: используйте Ungroup, 
Del Pattern и повторно создайте Массив Группы) 
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Рисунок 23: Восстановление Модели 

1. Щелкните по Feature > Group > Unpattern и выберите любую группу. 

2. Щелкните по  >  и прочтите сообщение. 

3. Измените размер выдавливания, как показано на следующем рисунке, затем выполните 
регенерацию. 

 
Рисунок 24: Изменение Размеров 

4. Обратите внимание, как положение компонентов группы может быть изменено индивидуально. 

5. Измените радиус скругления, как показано на следующем рисунке, затем выполните регенерацию. 
Обратите внимание, что изменение воздействует на все группы. 

 
Рисунок 25: Изменение Радиуса 

6. Щелкните по Feature > Delete и выберите отверстие, как показано на следующем рисунке. 
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Рисунок 26: Удаление Элемента Отверстия 

7. Щелкните по  > . Обратите внимание, что удаление элемента удалило всю группу. 

8. Удалите группу в верхнем левом углу, используя Дерево Модели. 

Задача 5. Исследовать опции UnGroup. 

1. Щелкните по Feature > Group > Ungroup. Выберите группы, как показано на следующем рисунке. 

Щелкните по  > . 

 
Рисунок 27: Выбор Групп для Разгруппировки 

2. Удалите отверстия из только что выбранных групп. Обратите внимание, что теперь можно удалять 
из групп индивидуальные элементы. 

3. Измените значение радиуса, как показано на следующем рисунке, затем выполните регенерацию. 

 
Рисунок 28: Изменение Значения Радиуса 

4. Обратите внимание, что значения размера все еще связаны после разбивки массива и 
разгруппировки. 
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Задача 6. Исследование опции Make Independent. 
1. Щелкните по Modify > Make Indep > Dimension. Выберите выдавливание (не уклон), как показано 
на следующем рисунке. 

 
Рисунок 29: Выбор Выдавливания 

2. Выберите высотный размер 2.0 и прочтите сообщение. 

3. Выберите следующие два выдавливания без отверстий и щелкните по  >  >  . 

4. Измените высоту этих, ранее выбранных выдавливаний на 3.0 и выполните регенерацию. 

 
Рисунок 30: Выдавливания с Измененной Высотой 

5. Обратите внимание, что теперь возможны независимые модификации элементов. 

6. Сохраните модель и закройте окно. 

УПРАЖНЕНИЕ 3: Создание UDF 
Задача 1. Создать UDF из шлицевого окончания вала. 

1. Откройте AXEL_END.PRT. Перейдите в соответствующий рабочий каталог. 

Совет: 
Для четкого отображения детали, выключите цвета в Utilities > Environment. 
2. Щелкните по Feature > UDF Library > Create. 

3. Введите [SPLINE_END] в качестве названия. 

4. Щелкните по Subordinate > Done. 

5. Выберите фаску, массив пазов и отверстия в Дереве Модели, как показано на следующем рисунке. 
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Рисунок 31: UDF Элементы, Подсвеченные в Дереве Модели 

6. Щелкните по Done > Done/Return. 

7. Создайте запрос для каждой ссылки, которая использовалась при создания элемента. Для первой 
кромки, введите [end edge]. 

8. Щелкните по Single > Done/Return и введите [main axis]. 

9. Введите [datum plane along axis] в качестве запроса для опорной плоскости. 

10. Для следующей ссылки, щелкните по Single > Done /Return. Введите [end surface]. 

 
Рисунок 32: Запросы для Привязок UDF  

11. Добавьте последний запрос. Введите [cylindrical surface]. 

12. Изучите запросы, используя опции Next и Previous. При необходимости исправить любой из 
запросов, щелкните по Type Prompt. После исправления запроса щелкните по Done/Return. 

Задача 2. Определите необязательные элементы для UDF, чтобы сделать их более гибкими для 
последующего использования. Сделайте переменной глубину шлицов и отверстий. 

1. Щелкните по Var Dims > Define. 

2. Сделайте размер глубины переменным. Выберите размер 1.25, определяющий длину вырезов. 
Щелкните по Done/Return > Done/Return. 

3. Определите запрос для этого размера. Введите [spline length]. 
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Рисунок 33: Переменный Размер 

4. Определить переменный элемент. Щелкните по Var Elements > Define. 

5. Определите элемент, по которому создаются переменные элементы. Выберите отверстие, затем 
снова выберите размер выреза 1.25. Выберите DEPTH. Щелкните по Done. 

6. Щелкните по ОК. Система создает файл SPLINE_END.GPH на жестком диске. 

7. Сохраните модель и закройте окно. 

УПРАЖНЕНИЕ 4: Размещение UDF 
Задача 1. Разместить UDF SPLINE_END на конце вала. 

1. Откройте AXEL.PRT. 

2. Щелкните по Generic > Open. 

3. Щелкните по Feature > Create > User Defined. Выберите файл. Щелкните по Open. Обратите 
внимание, что система автоматически регенерирует окончание модели вала. 

4. Щелкните по Independent > Done. 

5. Щелкните по Same Dims > Done. 

6. Введите [1.00] в качестве длины сплайна. 

7. В соответствии с назначением конструкции, нельзя легко изменять размер после размещения, но 
его необходимо видеть. Щелкните по Read Only, чтобы сделать все другие размеры только 
видимыми, но не изменяемыми. 

8. Укажите соответствующие привязки на валу, как показано на следующем рисунке. 
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Рисунок 34: Привязки Вала 

9. Измените направление стрелок, чтобы они указывали в том же направлении, что и стрелки, 
показанные в окне ссылочной детали. 

10. Так как глубина отверстия является переменным элементом, система запросит изменить ее. 
Щелкните по ОК > Done > Done, чтобы принять глубину по умолчанию и создать элементы. 

 
Рисунок 35: Завершенный UDF на Валу 

11. Попытайтесь изменить вырезы, формирующие шлицевое окончание. Обратите внимание, что все 
размеры подсвечиваются. Выберите размер ширины каждого выреза. Обратите внимание, что это 
размер только для чтения и его нельзя изменить. 

 
Рисунок 36: Размеры Только для Чтения 
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Задача 2. Добавить другой независимый UDF к другому концу вала, как показано на следующем 
рисунке. 

1. Используйте те же опции, что и для первого UDF (выберите нижнюю кромку). 

2. Также, убедитесь, что обе стрелки опорной плоскости указывают в требуемом направлении UDF на 
этом конце модели. 

 
Рисунок 37: Завершенный Вал 

3. Сохраните деталь и закройте окно. 

УПРАЖНЕНИЕ 5: Добавление UDF к Ступице 
Задача 1. Разместить UDF в ступице. 

1. Откройте R_HUB.PRT. 

2. Щелкните по Feature > Create > User Defined. Выберите UDF SPLINE_END. Щелкните по Open. 

3. Щелкните по UDF Driven > Done. 

4. Щелкните по Same Dims > Done. 

5. Введите [0.5] в качестве длины сплайна. 

6. Согласно назначению конструкции, нельзя отображать размеры в модели. Щелкните по Blank > 
Done для остальных размеров. 

7. Следуйте запросам и выберите соответствующие привязки в ступице, как показано на следующем 
рисунке. 
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Рисунок 38: Привязки UDF Ступицы 

8. Щелкните по Done для создания UDF. 

 
Рисунок 39: Завершенная Ступица 

9. Измените шлицевой вырез. Единственный размер, который отображается, является полной длиной, 
потому что остальные размеры скрыты. 

 
Рисунок 40: Скрытие Размеров 

Задача 2. Измените файл UDF и наблюдайте, как это воздействует на UDF- управляемое шлицевое 
окончание ступицы, но не влияет на независимое шлицевое окончание вала. 

1. Откройте AXLE_END.PRT. 

2. Измените ширину одного из вырезов с 0.2 на 0.1 и выполните регенерацию. 
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Рисунок 41: Изменение Ширины Выреза в AXLE_END.PRT 

3. Активизируйте окно R_HUB.PRT. 

4. Обновите SPLINE_END UDF, размещенный в ступице. Щелкните по Feature > Group > Update > 
Done/Return > Done. 

5. Регенерируйте модель, чтобы видеть изменения. 

 
Рисунок 42: Обновленная задняя Часть Ступицы 

Задача 3. Попытатсья сделать те же изменения в валу, которые были сделаны ранее в UDF. 

1. Откройте AXLE.PRT. Щелкните по Generic > Open. 

2. Щелкните по Feature > Generic. Обратите внимание, что опция Update недоступна, поскольку для 
UDF было выбрано Independent. Поэтому, он не связан с файлом SPLINE_END. 

3. Сохраните все файлы и сотрите все модели из памяти. Закройте окно AXEL_END. Щелкните по 
Erase > Not Displayed. 

Резюме 

В этой главе Вы узнали: 

• как создавать локальные группы. 

• Как управлять группами. 

• Как повторно использовать данные. 

• Как работать с несколькими элементами так, как будто они представляют один элемент. 

• Как разрывать зависимости между элементами в группе. 

• Как создавать пользовательские элементы (UDF). 

• Как размещать UDF в новой модели 
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Глава 8 
Углубленные Инструментальные 
Средства Сборки 
В этой главе Вы изучите различные способы управления сборками. Это будет выполнено 
путем изменения узлов и компонентов. 

Цели 
После завершения этой главы, Вы сможете: 

• изменять подсборки. 

• Переносить и добавлять компоненты. 

• Заменять компоненты. 

• Повторять размещение компонентов. 

• Создавать покомпонентные изображения сборок. 

Изменение Сборок 

После создания сборки, ею можно управлять, изменяя подсборки, перемещая или заменяя 
компоненты и создавая покомпонентные изображения деталей. 

Изменение Подсборок 
Поскольку Pro/ENGINEER собирает подсборку в текущую сборку в виде отдельного компонента, он 
применяет операции над компонентами ко всему узлу. 

Действия над компонентами следует выполнять в пределах узла, к которому они принадлежат. 
Однако, можно использовать опцию Mod SubAsm для переопределения, удаления, сборки и замены 
компонентов без вызова узла в его собственное окно. 

Реструктурирование Узлов 
Используя опцию Restructure, можно легко перемещать компоненты сборки с одного уровня на 
другой, например, из сборки высшего уровня в нижний узел. 
Можно также перемещать в новый узел, используя Component > Create > SubAssy. 
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Рисунок 1: Реструктурирование Сборки 

Обратите внимание: 

При реструктурировании компонента, система иногда требует повторного выбора его сборочных 
привязок для привязки геометрии на требуемом уровне сборки. Хотя при этом производится сборка на 
новом уровне или в узле, но при этом сохраняются оригинальные сборочные привязки, приводящие к 
внешним привязкам и возможным конфликтам размещения компонента. 

Перемещение Компонентов 
Используя различные методы, можно перемещать компоненты после их ограничения. Используемый 
метод зависит от типа проводимых изменений и степени, в которой требуется управлять компонентом 
после проведения изменений. 

• Переопределение (Redefining) или Перенаправление (Rerouting) Компонентов � может 
использоваться для сборки компонентов в различных положениях. 

• Использование зависимостей смещения (offset constraints) � для переноса компонента в 
другое положение можно использовать зависимость размещения Mate Offset и Align Offset. 

• Использование функциональности перемещения с упаковкой (package) � при упаковке 
можно переносить компонент в новое положение и автоматически добавлять смещения 
(offsets) при перемещении. 

• Использование скелетных сборок (assembly skeletons) � скелеты можно использовать для 
представления каркаса при перемещении сборки. 

• Временный перенос или поворот компонента � можно временно переносить и/или 
поворачивать компонент относительно осей системы координат сборки без изменения 
сборочных зависимостей компонента. 

• Использование Pro/PROGRAM � используя функциональность Pro/PROGRAM можно 
настраивать систему, чтобы она автоматически запрашивала значения размеров компонента. 

Замена Компонентов 
Используя Adv Utils > Replace, можно удалять один компонент из сборки и заменять его другим без 
удаления компонента и повторной сборки. 

Можно использовать следующие инструменты для замены компонентов в пределах сборки. 

• Член Семейства Таблицы 

• Взаимообмен Сборки 

• Компоновка 

• Вручную 

• Новая Копия 
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Обратите внимание: 

При замене компонента, система размещает новый компонент в том же порядке, в котором собрался 
первоначальный компонент. При удалении компонента и сборке нового, необходимо переупорядочить 
новый компонент, чтобы вернуть его в первоначальное место. 

Использование Функциональности Взаимозаменяемости Групп 
Создавая функциональность взаимозаменяемости (interchange) группы, можно устанавливать 
взаимозаменяемость между двумя или более независимо смоделированными деталями или 
сборками. 

Взаимозаменяемая сборка создается путем добавления всех моделей в один сборочный файл и, 
затем, устанавливаются эквивалентные привязки между моделями, назначая ссылочные ярлычки. 

 
Рисунок 2: Взаимообмен Сборки 

После создания функциональности взаимообмена, его можно использовать неоднократно в будущем. 
Можно легко переключаться между различными компонентами в группе взаимообмена сборки, 
которая содержит какой либо из членов группы. 

 
Рисунок 3: Использование Взаимообмена Сборки 

Использование Таблицы Семейств 
Используя таблицу семейства, можно делать различные вхождения в таблице семейства детали, 
автоматически взаимозаменяемыми, создавая их из одной и той же исходной детали, родового 
вхождения. Система автоматически размещает новый компонент таким же образом, что и старый 
компонент, так как каждое вхождение содержит одни и те же привязки. 
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Рисунок 4: Вхождения Шпильки 

Обратите внимание: 
При использовании любого из методов замены, если заменяемый компонент имеет собранные с ним 
дочерние компоненты, то можно заменить потерянные дочерние привязки путем переопределения 
или перенаправления их к новому компоненту. 

Замена Компонентов Вручную 
Используя Replace Component > Manual, можно использовать зависимости размещения или методы 
упаковки (packaging) для размещения нового компонента в обычной сборке. 

Повторение Размещения Компонента 
Существует возможность повторить зависимости размещения компонента для размещения 
дополнительных вхождений этого же компонента в сборке. Это уменьшает количество требуемых 
выборов, и можно не задавать повторно все привязки размещаемого компонента. Система также 
позволяет пропускать избыточные привязки, типа общей плоскости совмещения. 

 
Рисунок 5: Повторное Размещение Болта 

Создание Покомпонентных Изображений 
Используя View > Explode, можно создавать покомпонентное состояние по умолчанию для сборки. 
Такое состояние воздействует только на отображение сборки. Система не изменяет фактические 
расстояния между компонентами. 
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Рисунок 6: Покомпонентное Состояние Сборки 

Для изменения положения компонентов можно использовать Modify > Mod Expld для создания одного 
или нескольких покомпонентных состояний. В пределах каждого покомпонентного состояния можно 
перетащить компоненты в требуемое положение, используя диалоговое окно EXPLODE POSITION, как 
показано на следующем рисунке. Кроме того, между компонентами могут быть добавлены линии 
смещения. 

 
Рисунок 7: Настройка Положения Разнесения 

Лабораторный Практикум 

Цель 
В этом практикуме, Вы научитесь управлять компонентами в сборке. 
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Метод 
В Упражнении 1, Вы выполните реструктуризацию компонента в сборке, а не его удаление и 
повторную сборку. 

В Упражнении 2, Вы создадите взаимообмен компонентов в сборке, которые имеют в сборке одно и то 
же функциональное назначение, но физически различаются. 

В Упражнении 3, Вы продемонстрируете, как быстро собрать один и тот же компонент много раз, 
используя опцию Repeat. 
В Упражнении 4, Вы разнесете сборку и, затем, динамически перенесете ее компоненты. 

Инструменты 
Таблица 1: Пиктограммы Углубленных Инструментальных Средств Сборки 

ПИКТОГРАММА ОПИСАНИЕ 

   Зафиксировать в текущем положении 

   Собрать в положении по умолчанию 

   Изменить ориентацию зависимости 

    Предустановки 

    Удалить выбранную зависимость 

    Указать новую зависимость 

    Отобразить компонент в окне сборки 

    Отобразить компонент в отдельном окне 

УПРАЖНЕНИЕ 1: Реструктурирование Карбюратора 

 
Рисунок 8: Сборка Карбюратора 

Задача 1. Исследовать сборку высокого уровня. 

1. Перейдите в соответствующий рабочий каталог. 
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2. Откройте CARB_RESTRUCT.ASM. 

3. Просмотрите список всех компонентов. Щелкните по Info > BOM в меню, затем щелкните по ОК. 

4. Закройте окно по завершении. 

 
Рисунок 9: Спецификация 

Задача 2. Деталь клапан находится в узле вала, что делает физически невозможной сборку вала 
клапана с корпусом. Измените уровень, на котором размещен клапан. 

1. Щелкните по Restructure. 

2. Щелкните по Tree > Expand > All в Дереве Модели. 
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Рисунок 10: Перемещение Клапана 

2. Выберите VALVE.PRT в SHAFT.ASM. Компонент отмечается, как перемещенный. 

3. Выберите VALVE.ASM как назначение для компонента VALVE.PRT. Щелкните по Done. 

 
Рисунок 11: Клапан, Перемещенный в Сборку Клапана 

Задача 3. Перед сборкой клапана с валом может быть собрана ручка. Переместите ручку в сборку 
шахты. 

1. Щелкните по Restructure. Выберите HANDLE.PRT из Дерева Модели. 

2. Выберите SHAFT.ASM в качестве назначения. Дерево Модели должно соответствовать 
изображению на следующем рисунке. Щелкните по Done. 
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Рисунок 12: Перемещение Ручки 

3. Сохраните и сотрите сборку из памяти. 

Задача 4. Определите, имеет ли узел какие либо проблемы. 

1. Откройте SHAFT.ASM. Система отображает ручку в ее последнем известном положении. 

2. Щелкните по Component > Redefine > Confirm для перехода. Щелкните по Confirm, когда система 
сообщит, что все привязки сборки будут потеряны. 

3. Появляется диалоговое окно COMPONENT PLACEMENT. Ручка не имеет привязок к сборке. 
Замените отсутствующие привязки на поверхности ARM1. PRT. 
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Рисунок 13: Отсутствие Зависимостей 

4. Щелкните по пиктограмме Separate Window и пиктограмме Assembly Window в верхней части 
диалогового окна COMPONENT PLACEMENT. 

5. Для вставки зависимости, используйте Query Sel, выберите цилиндрическую поверхность 
ARM1.PRT, смежную с подсвеченной пурпурной поверхностью HANDLE.PRT. 

6. Для зависимости совмещения, выберите плоскую круглую поверхность ARM1.PRT, смежную с 
подсвеченной пурпурной поверхностью HANDLE.PRT. 
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Рисунок 14: Полностью Привязанный Компонент 

7. Щелкните по ОК для завершения размещения компонентов. 

8. Сохраните и сотрите сборку. 

УПРАЖНЕНИЕ 2: Замена Компонентов Сборки Тормоза Ступицы 
Задача 1. Попытаться заменить DISK_BRAKE_HOLLOW.PRT, удаляя его из сборки. 

1. Откройте BRAKE_HUB.ASM. 

2. Щелкните по Component > Delete. Выберите DISK_BRAKE_HOLLOW.PRT. Обратите внимание, что 
система подсвечивает фланцы тормоза, потому что они являются дочерними элементами диска. 

3. Щелкните по Quit > Quit Del/Sup. 

4. Закройте окно сборки. 

Задача 2. Заменить тормоз диска, используя взаимообмен сборки, чтобы можно было сохранить 
отношения родитель / потомок между компонентами. Создать новую сборку взаимообмена с именем 
DISKS.ASM. 

1. Щелкните по File > New. Щелкните по Assembly и Interchange в диалоговом окне NEW. Введите 
[DISKS]. Щелкните по ОК. 
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Рисунок 15: Выбор Подтипа 

2. Добавьте DISK_BRAKE_HOLLOW.PRT к группе взаимообмена. Щелкните по Component > Add. 
Выберите DISK_BRAKE_HOLLOW.PRT. Щелкните по Open. 

3. Добавьте DISK_BRAKE_SOLID.PRT к взаимообмену. Щелкните по Add > Functional Component > 
ОК. 

4. Дважды щелкните по DISK_BRAKE_SOLID PRT. 

5. Щелкните по View > Layers. Отобразите слой DATUMS. 

5. Соберите диск. Совместите (Align) Front с Front и ТОР с ТОР. Выровняйте со смещением (Align 
Offset) опорные элементы Side с Side со смещением 12.0. 

6. Щелкните по ОК > Done/Return. 

 
Рисунок 16: Сборка Взаимообмена Дисков 

Задача 3. Посредством сборки со взаимообменом настройте эквивалентные привязки компонентов. 
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1. Определите привязки, которые полый диск имеет в сборке тормоза ступицы. Щелкните по 
Reference Tag > Auto Tag. Выберите DISK_BRAKE_HOLLOW.PRT в графической области, но не 
диалоговом окне REFERENCE TAG. 

2. Дважды щелкните по BRAKE_HUB.ASM. Отображается диалоговое окно AUTO TAG CREATION. 

 
Рисунок 17: Диалоговое Окно Auto Tag Creation 

Задача 4. Использовать мышь для управления ориентацией модели в маленьком окне. Определите 
имена ярлычков. 

1. Введите [MATE_SURFACE] в качестве названия признака. Нажмите <ENTER> для подсвеченной 
поверхности. 

2. Введите [ALIGN_AXIS] в качестве названия оси. Должно отобразиться диалоговое окно, как 
показано на следующем рисунке. Щелкните по ОК. 

 
Рисунок 18: Определение Ярлычков 

Задача 5. Сделать диск взаимозаменяемым, назначая те же самые ярлычки. 

1. Назначьте ярлычок MAT_SURFACE задней части скрытой поверхности диска. Выберите 
MATE_SURFACE в области TAG NAME диалогового окна и DISK_BRAKE_SOLID в области 
COMPONENT. 
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2. Обратите внимание, что задняя поверхность полого диска подсвечена. Выберите эквивалентную 
поверхность на диске, как показано в следующем рисунке. 

 
Рисунок 19: Создание Ссылочных Ярлычков 

3. Выберите ALIGN_AXIS в области TAG NAME диалогового окна и DISK_BRAKE_SOLID в области 
COMPONENT. 

4. Выберите центральную ось в диске. Обратите внимание, что вхождение под ALL TAGS теперь 
отвечает Y, показывая, что определены все ссылочные ярлычки. 

5. Щелкните по ОК. Сохраните сборку и закройте окно. 

Задача 6. Автоматически замените полый диск сплошным диском. 

1. Вызовите BRAKE_HUB.ASM. 

2. Щелкните по Component > Adv Utils > Replace. Выберите DISK_BRAKE_HOLLOW.PRT. 

3. Сохраните по умолчанию By Interchange Assembly. 

4. Щелкните по + рядом с DISKS.ASM, чтобы распахнуть сборку взаимообмена; выберите 
DISK_BRAKE_SOLID.PRT. Щелкните по ОК. 

5. Щелкните по Apply > Done. 

 
Рисунок 20: Замененный Диск 

6. Сохраните сборку и закройте окно. 
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Задача 7. Замените компоненты сборки колеса, используя таблицу семейства определений, 
связанных с ней. 

1. Откройте WHEEL_GENERIC.ASM. Откройте родовое вхождение. 

 
Рисунок 21: WHEEL_GENERIC.ASM 

2. Замените родовое колесо одним из вхождений. Щелкните по Component > Adv Utils > Replace. 
Выберите RIM_GENERIC.PRT в Дереве Модели. 

3. Щелкните по Browse. Выберите вхождение 12X6-STYLE_C. Щелкните по ОК > Apply > Done. 

4. Заменить обод другим вхождением. Сохраните и сотрите всю сборку из памяти. 

 
Рисунок 22: Законченная Сборка 

УПРАЖНЕНИЕ 3: Повторение Компонентов 
Задача 1. Начать, собирая BOLT.PRT с отверстием в INTAKE.ASM. 

1. Откройте INTAKE.ASM. 

 
Рисунок 23: Завершенная Сборка Приемного Устройства 

2. Соберите BOLT.PRT с одним из отверстий в INTAKE.PRT. Используйте зависимости MATE и ALIGN. 
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Рисунок 24: Сборка Болта с Деталью Входного Устройства 

Задача 2. Разместите остальные болты в отверстиях. Болты не будут иметь зависимости один к 
другому. 

1. Щелкните по Component > Adv Utls > Repeat. Выберите BOLT.PRT. 

 
Рисунок 25: Диалоговое Окно Repeat 

2. Выберите Mate и Align в диалоговом окне. Щелкните по Add. 

3. Выберите подсвеченную синим поверхность, затем выберите ось A-12. 

4. Выберите переднюю поверхность блока, затем выберите ось A-1. 

5. Продолжайте размещать болты во всех отверстиях. Щелкните по Confirm. 

6. Сохраните сборку и сотрите ее из памяти. 
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УПРАЖНЕНИЕ 4: Создание Покомпонентных Видов Деталей и Динамическое 
Перемещение 

Задача 1. Открыть сборку и поэкспериментировать с динамическим перемещением. 

1. Откройте VALVE.ASM. 

 
Рисунок 26: Исходная Модель 

2. Выберите ARM и щелкните по  > Delete. 

3. Щелкните по Component > Assemble > Arm. 

4. Нажмите и удерживайте <CTRL> и <ALT> . Щелкните по  и переместите мышь. Обратите 
внимание, что компонент изменяет свой масштаб изображения на экране. 

5. Нажмите и удерживайте <CTRL> и <ALT> . Щелкните по  и переместите мышь. Обратите 
внимание, что компонент вращается. 

6. Нажмите и удерживайте <CTRL> и <ALT> . Щелкните по  и переместите мышь. Обратите 
внимание, что компонент при этом перемещается в плоскости экрана. 

Задача 2. Полностью ограничить компонент. 

1. Разместите компонент приблизительно, как показано на следующем рисунке. 
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Рисунок 27: Размещение Компонента 

2. Сохраните зависимость по умолчанию Automatic и выберите две поверхности, как показано на 
следующем рисунке. 

 

 
Рисунок 28: Выбор Поверхностей 

3. Снова, нажмите и удерживайте <CTRL> и <ALT> . Щелкните по  > . Затем, щелкните по 

 в процессе перемещения мыши. Обратите внимание, что компонент временно не связан. 

4. Щелкните по  [Определяет новую зависимость]. Сохраните зависимость по умолчанию 
Automatic. Выберите следующие две поверхности, как показано на следующем рисунке. 
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Рисунок 29: Выбор Поверхностей для Автоматического привязывания 

5. Обратите внимание, что система интерпретировала это как зависимость Mate (Совмещение). 

Проверьте степени свободы компонента с клавишами <CTRL> <ALT> и ,  и  . 

6. Разместите компонент. Щелкните по ОК. 

 
Рисунок 30: Размещение Компонента 

7. Обратите внимание, что рукоятка переориентировалась в положение по умолчанию. 
Переопределите рукоятку, выключив переключатель Allow Assumptions. Снова разместите рукоятку. 

8. Щелкните по  >  [Фиксация в текущем положении]. Обратите внимание, что рукоятка теперь 
полностью ограничена, и щелкните по ОК. 

Задача 3. Активизировать покомпонентное состояние по умолчанию. 

1. Щелкните по View > Explode. 

 
Рисунок 31: Бесполезный Покомпонентный Вид 
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2. Обратите внимание, что такое покомпонентное состояние, скорее всего, не будет полезным. 

3. Щелкните по View > Unexplode. 

Задача 4. Создайте пользовательское покомпонентное состояние. 

1. Щелкните по Explode State > Create. Введите [Explode_all]. 

2. Сохраните по умолчанию Motion Type перемещения. Установите Motion Reference (Привязку 
перемещения) в Plane Normal. 

3. Выберите поверхность, как показано на следующем рисунке. Выберите рукоятку. 

 
Рисунок 32: Выбор Поверхности 

4. Переместите, как показано на следующем рисунке. 

 
Рисунок 33: Перемещение 

5. Установить Motion Increment (Приращение Перемещения) в 10 и, выберите Крышку (Cover). 

6. Переместите, как показано на следующем рисунке. 

 
Рисунок 34: Перемещение После Установки Motion Increment 

7. Щелкните по Preferences > Move Many > Close. 
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8. Установите Motion Reference в Plane Normal. Выберите поверхность, показанную на следующем 
рисунке. 

 
Рисунок 35: Выбор Поверхности После Установки Motion Reference 

9. Выберите Arm, Cover и Shaft, затем, нажмите . 

10. Щелкните  в любом месте окна и переместите, как показано на следующем рисунке. 

 
Рисунок 36: Перемещение 

11. Установите Motion Reference в Plane Normal. Выберите поверхность, показанную на следующем 
рисунке. 

 
Рисунок 37: Выбор Поверхности После Установки Motion Reference 

12. Переместите VALVE_PLATE, как показано на следующем рисунке. 
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Рисунок 38: Перемещение Пластины Клапана 

13. Переместите Arm, используя EDGE/AXIS в качестве Motion Reference (Привязки Перемещения). 
Выберите кромку, как показано на следующем рисунке. 

 
Рисунок 39: Выбор Кромки 

Задача 5. Завершите покомпонентное состояние линиями смещения. 

1. Щелкните по ОК > Offset Lines > Create. 

2. Переключите  для отображения опорных осей и выберите две оси, как показано на следующем 
рисунке. 
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Рисунок 40: Выбор Двух Осей 

3. Повторите для других осей. 

 
Рисунок 41: Выбор Других Осей 

4. Используйте комбинацию опций Axis и Surface Norm для последней линии смещения. 

 
Рисунок 42: Использование Комбинации для Последней Линии Смещения 

5. Вернитесь в главное меню для завершения покомпонентного состояния. 

Задача 6. Создать другое покомпонентное состояние. 
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1. Щелкните по View > Unexplode. 

2. Создайте покомпонентное состояние с именем EXP_SUB_ASSY, как показано на следующем 
рисунке. 

 
Рисунок 43: Создание Нового Покомпонентного Состояния 

3. Используйте Explode State > Set Current для переключения между тремя покомпонентными 
состояниями. 

4. Используйте View > Explode и View > Unexplode для переключения между не разнесенным видом 
и последним используемым покомпонентным состоянием. 

5. Сохраните модель и сотрите ее из памяти. 

Резюме 

В этой главе, Вы узнали: 

• как реструктурировать компоненты сборки без их удаления. 

• Как создать и использовать взаимозаменяемые сборки (interchange assemblies) для замены 
компонентов в сборке. 

• Как заменить компоненты, используя вхождения таблицы семейства. 

• Как использовать функциональность повторения (repeat) для быстрого размещения 
компонентов в сборке без создания нежелательных связей. 
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Глава 9 
Упрощенные Представления и 
Псевдографика 
В этой главе Вы изучите, как использовать упрощенные представления для уменьшения 
времени вызова, перерисовки и регенерации больших сборок и деталей. 

Цели 
После завершения этой главы, Вы сможете: 

• создавать упрощенные представления деталей и сборок. 

• Создавать псевдографику (shrinkwraps) в режимах Детали и Сборки. 

• Создавать упрошенные представления с псевдографикой. 

Введение в Упрощенные Представления 

Определяя упрощенные представления (simplified reps) для модели, можно управлять тем, которые 
члены сборки система будет вызывать в сессию. 

Можно пропускать компоненты, использовать различные представления конкретных компонентов, и 
заменять на менее сложные версии компонентов. 

Упрощенные представления особенно полезны для: 

• повышения эффективности. 

• Настройки рабочего окружения. 

Обратите внимание: 
В отличие от функциональных возможностей подавления, упрощенные представители управляют 
дочерними объектами компонентов, которые заменяются или удаляются, а не требуют принятия 
самостоятельных действий. 
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Рисунок 1: Исключение Компонентов 

 
Рисунок 2: Замена Компонентов 

Работа с Мастер- Представлением 
Все упрощенные представления основываются на Мастер-Представлении (Master Rep) сборки. 
Мастер-представление всегда отражает всю сборку, включая все ее компоненты и детали. 

 
Рисунок 3: Мастер-Представление Сборки 
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Создание Упрощенных Представлений 

Упрощенные представления можно включать в сборку, используя различные методы, в зависимости 
от этапа проектирования. Можно: 

• использовать ранее определенные представления для автоматического создания. 

• Создавать пользовательские представления при открытии сборки или в процессе работы над 
моделью. 

• Создавать упрощенные представления в процессе использования Pro/FLYTHROUGH. 

Использование Предопределенных Представлений 
Вместо создания новых упрощенных представлений для модели, можно выбирать предопределенные 
представления. Pro/ENGINEER автоматически создает два типа упрощенных представлений для 
модели: 

• графическое представление. 

• Геометрическое представление. 

 
Рисунок 4: Графическое Представление, Отображенное в Каркасе 

Создание Пользовательских Представлений 
Вместо использования предопределенных упрощенных представлений, создаваемых системой, 
можно определять собственные пользовательские представления при открытии сборки или в 
процессе работы над моделью. 

После ввода имени, необходимо определить правило по умолчанию и, затем, определить действия 
для отображаемых компонентов. 

Определение Правила По Умолчанию 
Правило по умолчанию (default rule) для упрощенного представления определяет, как система должна 
классифицировать новые компоненты, добавляемые в сборку. Можно выбирать следующие опции в 
меню DEFAULT RULE: 

• Master (Мастер) 

• Geometry (Геометрия) 

• Graphics (Графика) 

• Exclude (Исключить) 

Обратите внимание: 
Нельзя переопределить правило по умолчанию для упрощенного представления. 

Определение Действия для Каждого Компонента 
После создания упрощенного представления и установки правила по умолчанию, следует определить 
одно из следующих действий для каждого компонента: 
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• Master � включает /отображает компонент в представлении. 

• Exclude � исключает компонент из представления. 

• Graphics � включает компонент в каркасном отображении. 

• Geom � включает только геометрию компонента. 

• Default � возвращает правило отображения по умолчанию для компонента. 

• Substitute � подставляет компонент с презентационной графикой. 

Выбор Компонентов 

Можно выбирать индивидуальные компоненты на экране или в Дереве Модели, или указать, что 
система применяет действие ко всем компонентам сборки. 

Для больших сборок с большим количеством компонентов, можно сэкономить время, используя 
несколько доступных инструментов выбора: 

• указать диапазон. 

• Использовать другое упрощенное представление. 

• Установить правило. 

При установке правила, можно указать, что система использует действие по умолчанию для всех 
компонентов, которые отвечают одному из следующих критериев: 

• Размещены в определенной зоне. 

 
Рисунок 5: Использование Зоны 

• Соответствуют указанному имени модели. 

• Имеют размер больше или меньше указанного, на основании ограничивающего компонент 
прямоугольника � куба наименьшего размера, содержащего деталь. 

• Расположен в пределах сферической области с указанным центром и радиусом. 

• Основывается на параметре модели (например, все объекты со стоимостью > 12.00). Для 
использования этой опции необходимо определить параметр и сохранить модель. 

Обратите внимание: 
Правила предназначены для выбора компонентов для исходного определения представления. 
Система сохраняет привязки замененных компонентов, чтобы иметь возможность работать со сборкой 
в будущем. Система не пересчитывает их при вызове упрощенного представления. 

Подстановка Компонентов 
При создании упрощенного представления, простые компоненты можно подставлять вместо сложных 
компонентов или узлов. Система сохраняет привязки замененного компонента, чтобы иметь 
возможность работать со сборкой в будущем. 

Для подстановки компонента, можно использовать любой из следующих методов, в зависимости от 
конкретных требований проекта и соображений управления данными: 
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• Interchange groups (Группы 
взаимозамены) 

• Family tables (Семейства таблиц) 

• Part simplified reps (Упрощенные 
представления деталей) 

• Envelopes (оболочки) 

• Assembly simplified reps (Упрощенные 
представления сборок) 

Группы Взаимозамены 

Группа взаимозамены - специальный тип сборки, который можно использовать для определения 
подстановки компонентов или создания функционального эквивалента заменяемых компонентов. В 
Pro/ENGINEER можно создавать два типа групп взаимозамены: 

• Группы функциональной взаимозамены � группы функциональных эквивалентов 
компонентов, которые можно легко заменить в сборке. Этот метод можно использовать для 
изменения конфигурации модели, в отличие от метода упрощения модели 

• Группы взаимозамены с упрощением � содержат упрощенные версии детали или сборки, 
которые можно использовать для замены компонентов в упрощенном представлении. 

 
Рисунок 6: Использование Группы Взаимозамены С Упрощением 

Таблицы Семейств 

Если для компонентов или узлов уже определены таблицы семейств, можно легко создавать 
вхождения в таблице семейств компонентов или узлов для уменьшения числа элементов или 
компонентов. Можно автоматически размещать подстановочные вхождения в сборке для замены 
полнофункционального вхождения. Или автоматического обновления простой детали. 

Упрощенные Представления Детали 

Упрощенные представления можно использовать в режиме Детали для замены компонента в 
упрощенном представлении сборки. 

 Для создания упрощенного представления детали и подстановки его в представление сборки, 
Мастер-представление должно быть в памяти. При вызове упрощенного представления детали или 
сборки, которое использует упрощенное представление детали, система автоматически вызывает 
Мастер-представление по умолчанию и регенерирует его. В результате, время вызова может быть 
увеличено. 

Совет: 
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Во избежание увеличения времени вызова, можно создать ускоряющий файл (accelerator file) (с 
форматом "repname.xpr"), который содержит информацию по модели, позволяющую сразу вызывать 
упрощенное представление в представлении сборки. Также, можно создавать графическое или 
геометрическое представление, как описано ранее в этом уроке. 

 
Рисунок 7: Использование Представлений Детали 

Упрощенное представление детали имеет следующие преимущества: 

• упрощенная деталь автоматически обновляется. 

• Экономится время регенерации и отображения. 

• При сохранении его с ускоряющим файлом можно также экономить время вызова и 
использование памяти. 

• Ускоряющий файл, в некоторой степени, легко обновлять. 

• Его можно использовать в любой сборке, которая использует полностью представленный 
компонент. 

Использование Оболочек 

Оболочка (envelope) - специальная деталь, которую можно создавать в контексте сборки специально 
для целей подстановки. 

Деталь оболочки содержит список всех компонентов, которые она заменяет, а также некоторую 
упрощенную геометрию для представления замененных деталей. 

Для создания геометрии оболочки создаются простые выдавливания, вырезы и пазы, для 
«огрубления» заменяемой геометрии. 

 
Рисунок 8: Использование Оболочки 

Использование техники создания оболочек для замены компонентов в упрощенном представлении 
имеет следующие преимущества: 
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• одна оболочка может заменить много компонентов. 

• Оболочка может пересекать границы подсборки для включения компонентов, не 
содержащихся в этой подсборке. 

• Система сохраняет геометрию оболочки в отдельном файле детали, чтобы можно было 
проводить изменения и назначать масс-инерционные характеристики в режиме Детали. 

• Оболочка «знает» свое местоположение, потому что оно определено в сборке. 

• Оболочки облегчают управление конструкторскими данными сборки. 

Обратите внимание: 
Оболочку можно использовать только в той сборке, в который она была создана. 

Упрощенные Представления Сборки 
При создании упрощенного представления узла в сборке, можно подставлять его в сборку высшего 
уровня для снижения объема выполняемых работ. 

Работа с Представлениями 
Упрощенные представления можно вызывать непосредственно при открытии сборки, используя опцию 
Open Rep в диалоговом окне OPEN. При вызове упрощенного представления с использованием этого 
метода, система регенерирует детали только в представлении и помещает их в память. 

Используя опцию Set Current, можно переключаться между определенными упрощенными 
представлениями при работе в сборке. 

Элемент Псевдографики 

Элемент псевдографики (Shrinkwrap): 

• позволяет распределять сложную конструкторскую информацию. 

• Защищает собственную информацию. 

• Обеспечивает точное представление конструкции для поставщиков и заказчиков. 

• Защищает конструкторскую информацию. 

Элемент псевдографики помогает точному представлению, включая: 

• представление в поверхностях. 

• Масс-инерционные характеристики 

• Резервирование пространства, требуемого для полного диапазона перемещений компонентов 

Элемент Shrinkwrap уменьшает размер данных на 70-90 %, позволяя: 

• сокращать время, необходимое для вызова визуализируемых наборов данных. 

• Снижать требования к аппаратному обеспечению, необходимому для работы с наборами 
данных. 

• Снижать время, необходимое для передачи данных в сети. 

Два Типа Псевдографики 

Существуют два типа элементов псевдографики: Экспортируемый Файл Псевдографики (Exported File 
Shrinkwraps) и Ассоциативная Псевдографика (Associative Shrinkwraps). 
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Экспортируемый Файл Псевдографики 
Экспортируемый файл псевдографики: 

• Вызывается посредством File > Export > Model. 

• Обеспечивает метод прямого предоставления данных в совместное пользование. 

• Управляет общим уровнем качества и созданием атрибутов. 

• Не ассоциативен. 

Существуют три метода экспорта файла псевдографики: 

• Помножество поверхностей (Surface Subset). 

• Слияние твердотельных моделей (Merge Solid). 

• Триангуляция твердотельных моделей (Faceted Solid) 

Их можно вызывать посредством диалогового окна, как показано на следующем рисунке: 

 
Рисунок 9: Диалоговое Окно CREATE SHRINKWRAP 
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Подмножество Поверхностей 

 
Рисунок 10: Псевдографика в Виде Подмножества Поверхностей 

Слияние Твердотельных Моделей 

 
Рисунок 11: Псевдографика со Слиянием Твердотельных Моделей 

Триангуляция Твердотельных Моделей 
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Рисунок 12: Элемент Псевдографики в Виде Триангуляции Твердотельных Моделей 

Ассоциативный Элемент Псевдографики 
Ассоциативный Элемент Псевдографики: 

• вызывается в меню Feature, Create, Data Sharing. 

• Способствует разделению данных и повторному использованию в других сборках. 

• Управляет уровнем качества и созданием атрибутов. 

• Внедряется в Деталь или Сборку. 

• Используется в Упрощенных Представлениях для повышения эффективности работы с 
крупными конструкциями. 

Опции Создания Псевдографики 
• Опции по умолчанию только для атрибутов 

 
Рисунок 13: Диалоговое Окно Shrinkwrap Attributes 
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• Диапазоны уровня качества от 1 до 10. 

• Высший уровень качества требует большего времени работы. 

• Автозаливка отверстий. 

• Включение лоскутных поверхностей (Quilts). 

• Игнорирование малых поверхностей. 

• Расширенное управление посредством диалогового окна SHRINKWRAP. 

 
Рисунок 14: Диалоговое Окно SHRINKWRAP 

• Подмножество компонентов. 

 
Рисунок 15: Диалоговое Окно SUBSET HANDLING 

• Дополнительные поверхности. 

• Включение опорных поверхностей. 

• Переключение зависимостей геометрии. 

• Опция воплощения (Externalize). 

• Конвертация из Локального во Внешнее. 

Лабораторный Практикум 

Цель 
В этом практикуме, Вы изучите элементы Упрощенного Представления и Псевдографики, 
которые являются ключевыми при работе с большими сборками. 
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Метод 
В Упражнении 1, Вы создадите Упрощенное Представление детали. 

В Упражнении 2, Вы создадите Псевдографику Сборки. 

В Упражнении 3, Вы создадите Упрощенное представление сборки. 

УПРАЖНЕНИЕ 1: Использование Упрощенных Представлений Детали 
Задача 1. Открыть головку блока цилиндров для создания ее упрощенной версии. 

1. Перейдите в каталог SIMP_REP. 

2. Откройте ENG_HEAD.PRT. 

3. Повращайте модель. Щелкните по средней кнопке мыши и нажмите <CTRL> . 

 
Рисунок 16: Деталь Головки Блока Цилиндров 

Задача 2. Создать упрощенную версию этой детали, показывая только основную форму и важные 
посадочные места. 

1. Щелкните по Simplfd Rep > Create. Введите [BASE_HEAD] в качестве названия и нажмите 
<ENTER> . 

2. Определите правило по умолчанию для этого упрощенного представления, чтобы исключить все 
элементы в этой модели за исключением указанных. Щелкните по Exclude Feat > Regenerate > Whole 
Model > Done. 

Совет: 
Если деталь регенерируется медленно, можно использовать Accelerate вместо Regenerate для 
ускорения вызова (эту опцию можно установить позже, выбирая Attributes в меню EDIT METHOD). 

3. Щелкните по Features > Include > From/To. 
4. В окне Дерева Модели, выберите первый элемент для включения в это представление. Выберите 
DTM1. 
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Рисунок 17: Выбор Элементов 

5. Выберите ROUND ID 65. Обратите внимание на то, что система теперь включает все элементы 
между DTM1 и скруглением. 

6. Щелкните по Done > Done/Return. Упрощенная деталь должна отображаться, как показано на 
следующем рисунке. 

 
Рисунок 18: Упрощенная Деталь 

Совет: 
Для просмотра представления только с включенными элементами, щелкните по Update Screen. Если 
элемент будет выбран по неосторожности, щелкните по Default и выберите элемент для установки 
его правила обратно в состояние по умолчанию. 
Задача 3. Создать второе упрощенное представление, которое покажет вырез в детали. 

1. Щелкните по Set Current > Master Rep > OK. 
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2. Щелкните по Create и введите [HEAD_CUTAWAY] в качестве имени. 
3. Щелкните по Include Feat > Accelerate (для более быстрого вызова) > Whole Model > Done. 
4. Щелкните по Work Region > Extrude > Solid > Done. 
5. Завершите определение рабочей области. Щелкните по Both Sides > Done. Укажите DTM1 в 
качестве эскизной плоскости. Щелкните по Okay, чтобы принять направление по умолчанию для 
просмотра. Щелкните по Тор и выберите DTM2. Выберите DTM2 и внешние вертикальные кромки в 
качестве привязок. 
6. Нарисуйте линию вдоль DTM2, которая выровнена по границам головки блока цилиндров, как 
показано на следующем рисунке. 

 
Рисунок 19: Эскиз Рабочей Области 

7. Щелкните по . Укажите направление удаления вверх. Щелкните по Okay, чтобы принять 
направление. 
8. Щелкните Thru All > Done > Done > OK > Done Return > Done Return. 
9. Повращайте модель и обратите внимание на вырезы. Представление должно отображаться, как 
показано на следующем рисунке. 

 
Рисунок 20: Законченный Вырез 
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10. Сохраните деталь и закройте окно. 

УПРАЖНЕНИЕ 2: Создание Псевдографики Сборки 
Задача 1. Открыть сборку двигателя и создать Псевдографику в режиме сборки. Игнорируйте 
некоторые невидимые компоненты. 

1. Откройте Мастер Представление CART_ENGINE.ASM Rep. 

2. Щелкните по Feature > Create > Data Sharing. 

3. Увеличьте Уровень Качества с 1 до 6. Щелкните по Done . 

 
Рисунок 21: Атрибуты Псевдографики 

4. Дважды щелкните по COMP SUBSET. Щелкните по Ignore. Выберите невидимые компоненты, 
ENG_MTR_SKEL, ENG_CONNECT_ROD, ENG_PISTON. Щелкните по Done. 

 
Рисунок 22: Дерево Модели 
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5. Дважды щелкните по SUBSET HANDLING. Щелкните по Select and Shrinkwrap > Done > OK. 
6. Сохраните модель. 

Задача 2. Создайте упрощенное представление, используя элемент псевдографики. 

1. Щелкните по Simplfd Rep > Create. 

2. Введите [SW_ENG_ASM]. Нажмите <ENTER> для принятия. 

3. Щелкните по Exclude Comp > Update Screen > Done > Done/Return. 

4. Сохраните модель и удалите ее из сессии. 

 
Рисунок 23: Псевдографика, Используемая для Упрощенного Представления 

УПРАЖНЕНИЕ 3: Создание Упрощенного Представления Сборки 
Задача 1. Открыть сборку двигателя, чтобы создать упрощенную версию. 

1. Откройте CART_ENGINE.ASM. 

2. Повращайте деталь для просмотра подробностей сборки. 

3. Выключите все опорные плоскости, оси, точки и систему координат. 

Совет: 
Если цвета были выключены ранее, их можно теперь вернуть назад. 

 
Рисунок 24: Мастер-Представление 
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Задача 2. Для улучшения эффективности работы этой сборки, создать ее упрощенную версию, чтобы 
показать только основные компоненты. 

1. Щелкните по Simplified Rep > Create. Введите [BASE_ENGINE] в качестве имени. 

2. Укажите правило по умолчанию для этого упрощенного представления, чтобы исключить все 
компоненты в этой сборке кроме явно указанных. Щелкните по Exclude Comp. 

Задача 3. Выбрать компоненты для включения в это упрощенное представление. 

1. Щелкните по Master Rep. Выберите ENG_BLOCK.PRT, ENG_HEAD.PRT, ENG_CLUTCH.ASM и 
ENG_SIDE_COVER.PRT. 

2. Просмотрите текущее представление. Щелкните по Update Screen. Обратите внимание, что 
маховик (ENG_FLYWHEEL.PRT) и вал визуально отсутствуют, как показано в следующем рисунке. 

 
Рисунок 25: Обновление Экрана 

3. Обратите внимание, что система позволяет удалять компоненты, которые имеют дочерние 
элементы без переадресовки отношений родитель / потомок. 

Задача 4. Базовое местоположение и размер маховика важны, но фактические размера и масс-
инерционные характеристики - нет. Поэтому, отобразите этот компонент только в каркасном виде. 

1. Щелкните по Graphics Rep. Щелкните по Select Mdl в меню SELECT MDL. Выберите 
ENG_FLYWHL.PRT из окна Дерева Модели. 

2. Щелкните по Update Screen и закрасьте изображение, если требуется. Обратите внимание, что 
система отображает в каркасе только маховик. 
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Рисунок 26: Добавление Графического Представления 

3. Щелкните по Done в меню EDIT REP. 

4. Удалите из памяти модели, которые больше не отображаются. 

Щелкните по File > Erase > Not Displayed. Обратите внимание на модели, перечисленные в 
диалоговом окне. Щелкните по ОК. 

Задача 5. Дерево Модели продолжает отображать мастер-сборку хотя BASE_ENGINE.ASM является 
активным представлением. Создайте другое упрощенное представление, используя представление 
детали BASE_ENGINE.ASM, созданное ранее. 

1. Щелкните по Create. Введите [SUB_HEAD]. Нажмите <ENTER> . 

2. Определите то же правило по умолчанию, что использовалось ранее. Щелкните по Exclude Comp. 

3. Начните создание нового представления, используя ранее определенное. Примите по умолчанию 
мастер-представление. Щелкните по By Rep > OK, чтобы принять BASE_ENGINE, которое является 
единственным представлением. 

Задача 6. Обратите внимание, что система установила все модели в Мастер-представление, которое 
было выбрано для представления BASE_ENGINE. Вспомните, что маховик является графическим 
представлением. Опция By Rep � является только инструментом выбора, который не устанавливает 
тип представления. Измените представление ENG_HEAD.PRT. 

1. Щелкните по Substitute. Выберите ENG_HEAD.PRT из Дерева Модели в качестве компонента для 
подстановки. 

2. Щелкните по By Simplified Rep > Browse для просмотра упрощенных представлений в этой модели 
(там должны присутствовать два ранее созданных в этом упражнении). Выберите BASE_HEAD. 
Дважды щелкните по ОК, чтобы заменить представление в сборке. 

3. Щелкните по Update Screen > Done, для завершения представления. 

Задача 7. Запросить систему на предмет моделей сборки двигателя, которые находятся в памяти, 
затем удалите их из памяти. 

1. Щелкните по Info > Pro/ENGINEER Objects. Обратите внимание на два перечисленных маховика, 
мастер-представление и графическое представление. Закройте окно. 

2. Щелкните по File > Erase > Not Displayed > OK. 

3. Снова щелкните по Info > Pro/ENGINEER Objects, чтобы увидеть результат. 

Задача 8. Создать другое представление с использованием сборки взаимообмена. Сборка была 
создана ранее. 
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1. Щелкните по Create. Введите [CONCEPT_ENG_BLOCK]. Укажите EXCLUDE COMP, как правило по 
умолчанию. 
2. Щелкните по By Rep. Выберите SUB_HEAD. Щелкните по ОК. Обратите внимание, что система 
исключила модель головки блока цилиндров, так как она была заменена. 

3. Используйте CONCEPT_BLOCK_BLOCK.ASM в качестве упрощенного взаимообмена для 
упрощения блока двигателя. Щелкните по Substitute > Select Mdl. Выберите ENG_BLOCK.PRT из 
Дерева Модели. 

4. Щелкните по By Interchange Assembly > Browse. 

5. Распахните CONCEPT_BLOCK_BLOCK.ASM в диалоговом окне SELECT MODEL. Выберите 
CONCEPT_BLK.PRT. Дважды щелкните по ОК. 

6. Щелкните по Update Screen. Представление должно отобразиться, как показано на следующем 
рисунке. 

7. Щелкните по Done для завершения представления. 

 
Рисунок 27: Подстановка 

Задача 9. Для последнего узла, муфты, создать деталь оболочки для уменьшения размеров детали. 

1. Перейдите в меню высокого уровня ASSEMBLY. Щелкните по Done/Return. 

2. Щелкните по Design Mgr > Envelope > Create. 

3. Укажите название геометрии оболочки. Введите [CLUTCH_ENV]. 

4. Определите сборку оболочки для подстановки. Выберите ENG_CLUTCH.ASM в Дереве Модели. 
Щелкните по Done. 

5. Создайте новый компонент для использования в качестве геометрии оболочки. Щелкните по Create. 

6. Щелкните по Part > Solid. Введите [CLUTCH_ENVELOPE]. 
7. Начните создавать выдавливание. Щелкните по Create First Feature > OK. Щелкните Solid > 
Protrusion > Revolve > Solid > Done > One Side > Done для создания сечения вращения. 
8. Укажите эскизную плоскость. Дважды щелкните по Sel By Menu. Дважды выберите 
ENG_CLUTCH.ASM. Щелкните по Datum > Name > ADTM3. 

9. Примите направление создания элемента. Щелкните по Okay. 

10. Укажите горизонтальную или вертикальную плоскость привязки. Щелкните по Bottom в качестве 
направления; затем дважды щелкните по Sel By Menu. Дважды выберите ENG_CLUTCH.ASM. 
Щелкните по Datum > Name > ADTM2. 

11. Нарисуйте форму, как показано на следующем рисунке, выравнивая эскиз по существующей 

муфте, используя показанные привязки. Щелкните по . 
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12. Для опции Revolve, щелкните 360 > Done > ОК > Done для завершения оболочки. 

13. Вернитесь в меню высокого уровня. 

 
Рисунок 28: Сечение Оболочки 

Задача 10. Используйте деталь оболочки в существующем упрощенном представлении 
BASIC_ENGINE. 

1. Измените одно из упрощенных представлений. Щелкните по Simplfd Rep > Redefine. Выберите 
BASE_ENGINE. Щелкните по ОК. 

2. Выполните подстановку детали. Щелкните по Substitute > By Envelope. Выберите CLUTCH_ENV. 

3. Просмотрите изменения в представлении. Щелкните по Update Screen. Обратите внимание, что 
сборка муфты была упрощена. 

4. Завершите переопределение представления. Щелкните по Done > Done/Return в меню SIMPLFD 
REP. Представление должно отобразиться, как показано на следующем рисунке. 

 
Рисунок 29: Подстановка Оболочки 

5. Сохраните и сотрите сборку из памяти. 

Резюме 

В этой главе, Вы узнали как: 

• создавать упрощенные представления, используя предопределенные или пользовательские 
представления. 

• Создавать упрощенные представления уровня детали или сборки. 

• Создавать элемент Псевдографики. 
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Глава 10  
Конструирование Сверху-Вниз и 
Компоновки 
В этой главе Вы изучите, как использовать параллельные методы проектирования для 
разработки моделей в среде конструирования сверху-вниз. 

Вы также изучите, как использовать Компоновки (Layouts), которые используются для 
передачи назначения конструкции сборки в нисходящей среде проектирования. Будет 
показано, как создавать компоновки и как использовать в них уравнения. 

Цели 
После завершения этой главы, Вы сможете: 

• определять назначение конструкции проекта. 

• Использовать двухмерные компоновки и инженерные записи для настроек и создания 
документации. 

• Определять структуру сборки. 

• Создавать новые детали и узлы в процессе работы со сборкой. 

• Копировать геометрию между компонентами в сборке. 

• Передавать назначение конструкции из данных высшего уровня в узлы. 

• Записывать преимущества построения компоновок или инженерных записей. 

• Связывать детали с компоновками. 

Введение в Метод Проектирования Сверху-Вниз 

Pro/ENGINEER предлагает несколько методов, которые можно использовать для успешного 
проектирования в нисходящей среде. Он имеет множество инструментов для исследования сборок и 
определения того, как они построены. 

Определение Намерения Проекта 
Используя Pro/ENGINEER, можно планировать конструкцию до создания каких либо моделей. Перед 
выполнением любой работы в Pro/ENGINEER, можно сохранить время и увеличить точность 
конструирования за счет: 

• эскизирования предварительной геометрии. 

• Определения информации по критическим размерам и монтажу. 

• Создания зависимостей между параметрами модели. 

• Указания того, как компоненты будут собираться. 
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Затем, можно использовать функциональные возможности компоновки для управления проектом на 
всех этапах процесса разработки. 

Определение Структур Сборки 
Следующие методы определяют структуру сборки до создания или сборки всех компонентов: 

Создание Новых Узлов 
Для создания новых узлов, можно использовать диалоговое окно CREATION OPTIONS для 
копирования существующих сборок, размещения трех опорных плоскостей по умолчанию 
непосредственно в сборке без ручного добавления зависимостей размещения, или определения 
только существования узла в структуре сборки. 

 
Рисунок 1: Создание Сборки 

Обратите внимание: 
При выборе Leave Component Unplaced и Copy From Existing или Empty в диалоговом окне 
CREATION OPTIONS, система отображает компонент в Дереве Модели, но не в фактическом окне 
сборки � даже, если компонент содержит геометрию. 
Копирование, Существующей Геометрии 

Можно определять новый узел путем копирования существующей сборки. Начало сборки файлов 
особенно полезно, если необходимо использовать узел немедленно; однако, нельзя копировать 
сборку, если она содержит какие либо компоненты. 

Определение Опорных Плоскостей По Умолчанию 

Можно создавать новый узел путем размещения трех опорных плоскостей по умолчанию 
непосредственно в сборке. Этот метод экономит время, потому что узел не начинается в отдельном 
окне сборки, и нет необходимости вручную добавлять сборочные зависимости. 

Определение Пустых Узлов 

Можно определять существование узла в структуре сборки, то есть в Спецификации (BOM) и Дереве 
Модели, создавая сборку, которая не содержит никакой геометрии. 

Создание Деталей без Геометрии 
Используя методы, описанные выше, для создания новых узлов, можно также создавать новые 
детали без геометрии, определяя их существование в структуре сборки. 
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• Копирование существующих деталей � при копировании начатой детали или другой 
существующей детали можно использовать сборочные зависимости или оставлять ее 
непривязанной. 

• Размещение опорных элементов по умолчанию � без создания фактической геометрии 
детали можно разместить три опорные плоскости непосредственно в сборке. 

• Пустой � система перечисляет пустые детали в Дереве Модели без отображения каких либо 
элементов в Графическом окне. Пустые детали можно размещать в положении по умолчанию 
или оставлять непривязанными. Это позволит обозначить присутствие детали в спецификации 
сборки. 

В процессе или после разработки модели изделия, можно создавать элементы в детали, используя 
Modify > Mod Part. Используя опцию Copy From Existing, можно копировать начальную информацию 
детали для получения соответствующего положения и зависимостей; однако, может потребоваться 
переопределить размещение детали. 

Размещение Компонентов в Положении По умолчанию 
Можно включить компонент как член сборки без фактического размещения его в окне сборки. Это 
позволит перечислить компонент в качестве члена сборки, даже если этот компонент не готов для 
сборки (например, не имеет геометрии). Если на этом этапе еще невозможно определить 
зависимости, можно быстро собрать компонент в положении по умолчанию для просмотра его в 
сборке и Спецификации. Положение по умолчанию для компонента � положение, в котором его 
нулевая точка соответствует нулевой точке сборки. 

Упаковка Компонентов 
Используя функциональные возможности Упаковки, можно размещать компонент в окне сборки без 
определения точных зависимостей размещения. 

Определение Уравнений Объекта в Pro/INTRALINK 
Можно использовать Pro/INTRALINK для настройки структуры сборки или виртуальны сборок в 
рабочем пространстве. 

Использование Скелетов Сборки 
Скелеты (skeletons) можно использовать для создания трехмерных компоновок сборки, симуляции 
движения, планирования пространства и визуализации конструкции сборки без разработки 
компонентов. Далее, скелет можно использовать как центральную привязку, которая может 
изменяться для обновления компонентов, путем прохождения информации вниз через структуру 
сборки. Для передачи назначения конструкции из скелетов в компоненты сборки, можно использовать 
любой из следующих методов: 

• конструировать элементы в детали с внешними привязками к скелету. 

• конструировать элементы в детали без внешних привязок к скелету, но с использованием 
скелета в качестве направляющей. 

• Иметь скелеты узлов, привязанные к скелетам верхнего уровня. 

• Использовать зависимости скелета для управления деталями, или использовать уравнения в 
компоновках для управления скелетом и компонентами. 

Концепция Блоков 
Вместо создания полностью разработанных компонентов и узлов для размещения их в сборке, можно 
создавать простые детали, которые их представляют. Позже, можно использовать эти блоки в сборке, 
для оценки временно занимаемого пространства, до момента завершения окончательных моделей. 
Используя различные методы, можно позже заменять компоненты в конструкции. 
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Копирование Привязочной Геометрии Между Моделями 
При изменении деталей или узлов в режиме Сборки, можно использовать элемент Copy Geom для 
копирования привязочной геометрии из одной модели в другую. Использование этого элемента при 
нисходящем проектировании позволяет выполнять следующее: 

• контролировать изменения путем переопределения зависимостей для элементов копирования 
геометрии. 

• Копировать скелетные данные в детали для создания элементов в режиме Детали, или в 
подсборки или их скелеты для моделирования в окне подсборки. 

• Создавать карты распределения деталей (map parts). 

• Консолидировать внешние привязки в отдельный элемент. 

• Копировать привязки в подсборки, которые могут иметь внешние привязки. 

Компоновки Pro/ENGINEER 

Компоновка (layout) - централизованное местоположение, в котором можно разрабатывать, 
передавать и управлять назначением конструкции в разрабатываемых моделях. Информация, 
которую можно включать в компоновку, подобна той информации, которую обычно записывают в 
записной книжке инженера: 

• двухмерная непараметрическая эскизная геометрия. 

• Конструкторские заметки. 

• Глобальные опорные плоскости, оси, точки и системы координат для автоматической сборки. 

• Глобальные размеры и параметры. 

• Табличные данные. 

• Глобальные уравнения. 

Преимущества Использования Технической Записной книжки 
Использование технической записной книжки или компоновки имеет следующие преимущества: 

• при консолидации критических параметров можно вызывать и контролировать различные 
модели из централизованного места. 

• Можно управлять любым количеством геометрических рисунков и моделей. 

• Компоновка обеспечивает корректную стыковку и размеры конструируемых компонентов. 

• Pro/ENGINEER автоматически вызывает техническую записную книжку в память рабочей 
станции при вызове любой детали или сборки, в которой эта записная книжка была заявлена. 

• Можно легко определять, которая из других деталей или сборок будет использовать 
глобальные опорные элементы и параметры, находящиеся в записной книжке, при помощи 
функциональности Where Used в меню Relations. 

Использование Компоновки в Процессе Проектирования 
Pro/ENGINEER позволяет воплощать назначение конструкции и управлять им в процессе 
проектирования. 

Важно добавлять в компоновку столько информации, сколько требуется для легкого понимания. Если 
записная книжка становится слишком сложной, можно создать другую записную книжку и объявить 
вместо одной другую, при необходимости. 
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Создание Технической Записной Книжки 
Для создания технической записной книжки, начните с инициализации компоновки. Создание записной 
книжки подобно созданию рабочего чертежа. Устанавливается размер листа, к которому можно 
добавлять дополнительные листы, при необходимости. 

Можно создавать несколько записных книжек для одного проекта; каждая записная книжка может 
состоять из нескольких листов. Можно иметь одну записную книжку, отображающую весь проект, в то 
время как другие будут содержать входящие узлы конструкции. 

Эскиз Проекта 
Для эскизирования конструкции, можно создавать геометрию, используя те же инструменты 
двухмерного рисования, которые доступны для рабочих чертежей. Геометрия может быть как простой, 
так и сложной. Pro/ENGINEER не используют геометрию компоновки для создания деталей. 

 
Рисунок 2: Пример Нарисованной Геометрии 

Аннотирование Компонентов Выносками 
При аннотировании проекта, можно использовать выноски для идентификации компонентов и 
последующего обозначения их в нижнем левом углу компоновки. Можно также добавлять текстовые 
примечания для отображения информации типа наименования проекта, материала, стоимости и т.д. 

 
Рисунок 3: Добавление Выносок и Примечаний в Компоновку 

Управление Конструкцией при Помощи Глобальной Информации 
Мощность компоновки Pro/ENGINEER увеличивается с использованием параметров. Включая 
глобальные размера и параметры в компоновку, можно управлять ключевыми элементами проекта. 
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Рисунок 4: Добавление Параметрических Размеров 

Для увеличения возможностей компоновки и передачи назначения конструкции, можно делать 
следующее: 

• использовать уравнения для установления взаимосвязи между параметрами. 

• Использовать наборы параметров для автоматического изменения значений параметров. 

• Добавлять глобальные опорные плоскости, оси, точки и системы координат для 
автоматизации сборки. 

Установление Взаимосвязи Параметров с Отношениями 
При добавлении уравнений, можно фактически повысить уровень назначения конструкции, 
контролируемый компоновкой. Можно настраивать глобальные уравнения таким образом, чтобы один 
глобальный размер получал свое значение из уравнения с другим глобальным значением. Можно 
создавать эти отношения между параметрами, даже если компоненты, которыми они будут управлять, 
еще не существуют. 

Организация Компоновок 
При добавлении параметров и уравнений в компоновку, можно использовать таблицы для их 
организации. 

 
Рисунок 5: Добавление Параметрических Таблиц 

Автоматическое Изменение Значений Параметров 
В режиме Компоновки можно использовать наборы параметров для автоматического изменения 
значений параметров. 
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Рисунок 6: Вхождение Болта 

Автоматическая Сборка 
При добавлении глобальных опорных плоскостей, осей, точек и систем координат в записную книжку, 
можно настраивать компоновку на автоматическую сборку. При добавлении опорных элементов 
необходимо определить все поверхности и оси, которые необходимы при сборке одного компонента с 
другим, используя только команду Align. Система, затем ссылается на опорные элементы при сборке 
детали. 

 
Рисунок 7: Добавление Глобальных Опорных Плоскостей и Осей 

Обратите внимание: 
Компоновка ограничивает доступ пользователя к своему проекту. После создания компоновки для 
управления геометрией модели, ее нельзя изменять на уровне детали или сборки � компоновка 
контролирует параметры, размеры и элементы. Только пользователи, имеющие доступ к компоновке, 
могут проводить изменения в этих ключевых параметрах. 

Связывание Деталей с Компоновками 

При использовании технической записной книжки для конструирования детали, для конструктора 
важно понять назначение и принципы использования компоновки и глобальной информации, 
используемой в ней. При добавлении в компоновке глобальных размеров, она должна 
сигнализировать конструктору, что это критический размер, который должен использоваться при 
проектировании детали. 
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Использование Глобальных Размеров 
Если требуется, чтобы деталь ссылалась на глобальный размер, необходимо объявить деталь в 
компоновке. При объявлении детали в компоновке, между ними создается прямая связь - то есть 
деталь может обращаться теперь к компоновке за некоторыми значениями. 

Обратите внимание: 
Pro/ENGINEER автоматически вызывает компоновку в оперативную память при вызове детали, 
которая была в ней объявлена. 

Запись Уравнений Сборки 
Уравнения - математические формулы, включающие символические размеры и параметры, которые 
можно использовать для передачи назначения конструкции. Они позволяют воспользоваться 
преимуществами параметрической природы Pro/ENGINEER. 

При использовании размеров в уравнениях, они используются в символической форме. 
Символические размеры на уровне сборок имеют в конце дополнительный суффикс, называемый 
символом кодирования (coding symbol). Все размеры с одинаковым символом кодирования (то есть, 
d0:8, d12:8, d25:8) принадлежат одной и той же детали. 

Обратите внимание: 
Если сборка находится в оперативной памяти - нельзя изменять зависимые переменные уравнения, 
даже на уровне деталей. Если сборка не находится в оперативной памяти, ее можно изменять на 
уровне деталей. После вызова сборки, система сбрасывает значения детали в те, которые диктуются 
уравнениями. 

На следующем рисунке показан пример уравнения сборки. В соответствии с этим уравнением 
диаметр отверстия (d2:0) всегда больше диаметра вала (d0:2) на 0.005. 

 
Рисунок 8: Уравнение Сборки 

Воплощение Назначения Конструкции 

Модель можно проектировать различными способами. Используя любой из следующих методов, 
можно передавать и сохранять назначение проекта, но каждый приводит к различным результатам. 

• проведение изменений вручную � без использования уравнений или компоновок � 
необходимость контролирования назначения проекта и соответствия посадочных мест при 
проведении изменений размеров в модели. 

• Использование сборочных уравнений � автоматизирует изменения в модели для 
обеспечения соответствующей стыковки и функционирования. 
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• Уравнения детали в режиме сборки � необходимо иметь управляемую деталь в 
оперативной памяти потому, что управляемая деталь контролирует размеры зависимой 
детали. 

• Уравнения детали и сборки в технической записной книжке � можно проводить все 
изменения в основной компоновке потому, что все детали и сборки связаны с компоновкой. 

Лабораторный Практикум 

Цель 
В этом практикуме, Вы создадите и разработаете компоновки в процессе конструирования 
без моделирования детали или сборки. 

Методы 
В Упражнении 1, Вы используете компоновку для проведения изменений по всей сборке. Изменения 
имеют отличительную особенность, их очень трудно провести вручную. 

В Упражнении 2, Вы разработаете компоновку для управления компонентами в сборке двигателе для 
создания параметров и отношений без сборок и компонентов. Вы также научитесь управлять 
существующими компонентами в сборке. 

УПРАЖНЕНИЕ 1: Использование Компоновок 
Задача 1. Открыть сборку карта. 
1. перейдите в каталог NOTEBOOK. Щелкните по File > Working Directory и выберите NOTEBOOK. 
Щелкните по ОК. 
Обратите внимание: 
Для повышения производительности сборку карта следует вызывать в каркасном представлении. 

2. Щелкните по File > Open. Выберите GO_CART.ASM, затем щелкните по Open. 

Задача 2. Попытаться непосредственно изменить ширину рамы. 

1. Щелкните по Modify. Затем дважды щелкните по Sel By Menu. В меню NAV ASM 1, выберите 
FRAME.PRT. 

2. Выберите элемент, который управляет шириной рамы. Щелкните по Name, затем выберите 
MAIN_FRAME. 

3. Все размеры, управляющие размером рамы, теперь отображаются, как показано на следующем 
рисунке. 

 
Рисунок 9: Размер Ширины Рамы 



Pro/ENGINEER 2001 Углубленный Курс    

- 254 - 

4. Выберите размер 20.0, управляющий шириной рамы. Система сообщает, что этот размер 
управляется в FRAME уравнением d11=frame_width в области сообщения. 

Задача 3. Компоновка аннотирует и управляет этим проектом. Вызовите компоновку, где находится 
параметр FRAME_WIDTH и измените его. 

1. Откройте GO-CART.LAY. Щелкните по File > Open. Выберите GO-CART.LAY, затем щелкните по 
Open. Первый лист - просто обложка, показывающая завершенный карт. 

2. Щелкните по Sheets > Next. В начальном варианте карта, ЛИСТ 2 организовывал сборку и 
определял основные компоненты и их размещение, в то время как ЛИСТ 3 определял размеры, 
управляющие габаритами карта. 

3. ЛИСТ 4. Поскольку проект развивался, в компоновку были добавлены детали, определяющие 
рабочую зону водителя (сидение и рычаги управления). 

4. Рассмотрите оставшиеся листы. Обратите внимание, что по мере развития проекта, компоновка 
также развивалась. 

5. Перейдите к ЛИСТУ 3. Щелкните по Set Current, введите [3]; затем щелкните по Done/Return. 

Задача 4. Изменить ширину рамы. 

1. Щелкните по Modify и выберите размер FRAME_WIDTH из таблицы в компоновке. Измените его 
значение на 40 и регенерируйте компоновку. Обратите внимание на появление нескольких ошибок в 
окне сообщений. Они возникли потому, что рама слишком широка. 

Обратите внимание: 
Этот тип раннего обнаружения ошибки - другое важное преимущество компоновки. Без него ошибка не 
была бы обнаружена до регенерации сборка, после чего система сразу переходит в среду 
Разрешения конфликтов. 

 
Рисунок 10: Изменение FRAME_WIDTH на 40 Приводит к Ошибкам 

2. Для исправления проблемы, сделайте значение FRAME_WIDTH более приемлемым. Измените 
значение на 30 и выполните регенерацию. Область сообщения указывает на отсутствие ошибок. 

Обратите внимание: 



  Pro/ENGINEER 2001 Углубленный курс 

- 255 - 

Если в области сообщений не появилось сообщения NO ERRORS, не продолжайте. Это указывает на 
то, что проблема все еще сохраняется и сборка не будет регенерироваться успешно. 

Задача 5. Перейти в окно сборки и вызвать карт для просмотра изменений. 

1. Перейдите в окно сборки карта. Щелкните по Window > GO_CART.ASM 

2. Щелкните по Regenerate > Automatic. Обратите внимание, что система полностью обновляет 
сборку, включая раму и все другие затронутые компоненты, выполняя следующие изменения: 

• увеличивает ширину рамы детали. 

• Заменяет передние и задние вилки более короткими деталями. 

• Заменяет верхнюю тягу подвески более короткими деталями. 

• Заменяет соединительную тягу подвески более короткими деталями. 

• Заменяет рулевой каркас более длинной стойкой. 

• Заменяет главную ось более длинной осью. 

• Заменяет полуоси более короткими деталями. 

• Изменяет левое и правое переднее крыло, соответствующими для новой рамы. 

3. Щелкните по File > Erase Current. Щелкните по пиктограмме Select All > ОК, чтобы стереть модель 
из памяти. 

4. Щелкните по File > Erase > Current > Yes для удаления компоновки из оперативной памяти. 

5. Щелкните по File > Erase > Not Displayed > OK, чтобы стереть родовые компоненты сборки. 

 
Рисунок 11: Измененная Сборка Карта 

УПРАЖНЕНИЕ 2: Разработка Компоновок 
Задача 1. Начать создание компоновки с именем ENGINE. 

1. Щелкните по File > New. Выберите LAYOUT; введите [ENGINE]. Щелкните по ОК. 

2. Для определения размера листа рисунка, выберите SIZE и A, затем щелкните по ОК. На экране 
отображается граница рисунка. 

Задача 2. Импортировать IGES файл в компоновку для начала процесса разработки. 
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1. Импортируйте PARTIAL_SECTION.IGS. Щелкните по File > Import > Append to Model. 
2. Выберите PARTIAL_SECTION.IGS, затем щелкните по ОК. Сечение представляет деталь сборки 
поршня. 

 
Рисунок 12: Импортированный IGES Файл 

Задача 3. Создать двухмерный эскиз в компоновке для представления поршня. 

1. Создайте перекрестье из двух конструктивных линий для использования их в качестве 
направляющих. Щелкните по Sketch > Construction > Crossed Pair > Vertex. 

2. Выберите верхнюю вершину импортированной геометрии и введите [0] в качестве угла. 

3. Нарисуйте вертикальную линию, представляющую левую часть поршня. Щелкните по Line > Vert 
Line, затем сделайте эскиз линии, как показано на следующем рисунке. 

 
Рисунок 13: Эскиз Поршня 

4. Нарисуйте горизонтальную линию, представляющую верхнюю часть поршня. Щелкните по Horiz 
Line > Vertex. Выберите верхнюю вершину вертикальной линии. Щелкните по Pick Pnt и удлините 
линию приблизительно до вертикальной конструктивной линии. 

5. Нарисуйте другую горизонтальную линию, представляющую основание поршня. 

6. Зеркально отобразите вертикальную линию относительно вертикальной конструктивной линии. 
Щелкните по Return для выхода из эскиза, затем щелкните по Tools > Mirror. Выберите вертикальную 
линию и щелкните по Done Sel. Выберите вертикальную конструктивную линию. 
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Рисунок 14: Зеркальное Отображение Вертикальная Линия 

7. Обрежьте линии, чтобы они сформировали прямоугольник. Щелкните по Trim > Corner. Выберите 
вертикальную линию зеркала и верхнюю горизонтальную линию. 

8. Повторить ту же процедуру для нижней горизонтальной линии. 

9. Щелкните по Done/Return для выхода из меню TOOLS. 

Задача 4. Убедиться, что из себя представляет геометрия путем аннотирования рисунка. 

1. Создайте выноски, присоединенные к сечению. Щелкните по Create > Balloon > Leader > Make 
Note. Выберите маленький радиус (как объект, к которому система должна присоединить 
примечание). Щелкните по Done Sel > Done. 

2. В области DISPLAY, выберите, где должна отображаться выноска. 

3. Введите [CRANK_SHAFT] в качестве название компонента. 

4. Создайте другую выноску для представления поршня. Щелкните по Make Note. Выберите правую 
вертикальную линию. Щелкните по Done Sel > Done. Выберите местоположение для выноски, введите 
[PISTON] и щелкните по Done/Return. 

 
Рисунок 15: Добавление Выносок 
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5. Если необходимо, переместите выноски. Щелкните по Move. Выберите выноску. Щелкните один раз 
для размещения выноски. 
6. При необходимости, переместите примечание, которое содержит названия. Щелкните по Move 
Many. Выберите обе созданные текстовые строки. Щелкните по Done Sel, затем переместите 
примечания. 
Задача 5. Продолжайте аннотировать компоновку двигателя, добавляя размеры к сечению. 

1. Добавьте размер для диаметра поршня с именем PISTON_DIA. Щелкните по Create > Dimension. 
Выберите верхнюю горизонтальную линию, представляющую поршень. Щелкните по средней кнопке 
мыши для размещения размера. 

2. Введите [PISTON_DIA] в качестве названия и значение [3.00]. 

3. Создайте другой размер для длины шатуна. Введите [ROD_LENGTH] в качестве названия 
параметра и значение [5.00]. 

4. Создайте диаметр для перемещения, представляемый конструктивной окружностью. Дважды 
щелкните по окружности, используя левую кнопку мыши; затем разместите размер. Введите [STROKE] 
в качестве названия и значение [4.00]. Щелкните по Done/Return. 

5. При необходимо, переместите размеры. Разместите диаметральный размер вертикально на экране. 

 
Рисунок 16: Добавление Размеров 

6. Преобразуйте диаметральный размер в линейный. Щелкните по Modify > Dim Params > Diam Dim 
Type. Выберите диаметр STROKE. Размер теперь отображается как линейный. Щелкните по  
Done/Return для возврата в меню MODIFY DRAW. 
7. Удалите символ диаметра из текстовой строки. Щелкните по Text > Text Line. Выберите размер 
STROKE. Используйте клавиши со стрелками и клавишу BACKSPACE для удаления части текстовой 
строки, в которой находится {0:∅ }. Дважды щелкните по Done/Return. 
8. При необходимости, переместите значение размера. 

Задача 6. Организовать компоновку и сделать ее более легкой в использовании, сведя в таблицу 
созданные параметры; затем выбрать параметр непосредственно из таблицы для изменения его 
значения. 

1. Создайте таблицу и разместите ее справа от рисунка. Выберите меню верхнего уровня в 
менеджере меню. Щелкните по Table > Create. Выберите точку для определения вершины таблицы. 
См. следующий рисунок. 
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Рисунок 17: Добавление Таблицы 

2. Определите ширину колонок в 15 знаков. Выберите вторую 5 слева, которая отображается на 
экране. Снова выберите вторую 5 слева, чтобы определить ширину второй колонки. Щелкните по 
средней кнопке мыши для завершения определения колонки. 

3. Определите шесть рядов, для использования двух текстовых строк. Выберите 3, которые 
отображаются на экране. Определите шесть рядов для таблицы; затем нажмите среднюю кнопку 
мыши для завершения. 
4. Измените выравнивание в ячейках. Щелкните по Mod Rows/Cols > Justify > Center > Middle. 
Выберите ячейку в каждой колонке. 
5. Объедините ячейки вверху таблицы для создания одной ячейки. Щелкните по Modify Table > 
Merge. Выберите эти две ячейки в верхней части таблицы. 

6. Определите заголовок таблицы. Щелкните по Enter Text. Выберите верхнюю ячейку. Введите 
[PARAMETERS] в качестве названия; затем нажмите <ENTER> в пустой строке для добавления имени 
в ячейке. 

7. Повторите процесс для левой колонки. Введите названия, как показано на следующем рисунке. 

 
Рисунок 18: Ввод Текста 

8. Добавьте значения параметра в правую ячейку. Щелкните по Enter Text. Выберите ячейку около 
записи STROKE. Введите [&stroke] в ячейку. Обратите внимание, что система автоматически 
добавляет параметр в таблицу. 

9. Введите значения параметра для ROD_LENGTH и PISTON_DIA, используя тот же метод. Не 
забудьте добавить символ &. 

Обратите внимание: 
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Не добавляйте значения для CYLINDERS и DISPLACEMENT на этом этапе. 

Задача 7. Добавить параметры в компоновку для определения значений в записях цилиндра и 
смещения в таблице. 

1. Щелкните по Done/Return > Relation > Add Param > Integer. Введите [CYLINDERS], в качестве 
названия и значение [2]. 

2. Отобразите существующие параметры. Щелкните по Show Rel. Обратите внимание, что 
INFORMATION WINDOW содержит параметр CYLINDER, а также другие размерные параметры. 
Щелкните по Close. 

3. Добавьте параметр с именем DISPLACEMENT, записывая отношение для определения его 
значения. Щелкните по Add в MENU MANAGER и введите следующее отношение: 
/* calculate the displacement of the engine

displacement = pi * (( piston_dia/2 )^2 ) *

stroke * cylinders

4. Добавьте новые параметры в таблицу, используя символ &. 

5. Подтвердите, что параметры имеют корректные значения. 

 
Рисунок 19: Добавленные Параметры 

Обратите внимание: 
Имейте в виду, что компоновка не имеет никаких моделей, декларированных в ней. 

6. Измените значение хода (stroke) на шесть. Щелкните по Modify. Выберите значение 4.00 в записи 
STROKE. Введите [6.00]. Регенерируйте компоновку и обратите внимание на изменения в значении 
смещения. 

Задача 8. Использовать компоновку для управления существующей сборкой. 

1. Щелкните по File > Open для вызова ENGINE_LAYOUT.ASM. 

2. Измените длину одного из шатунов. Щелкните по Modify > Mod Part. Выберите одну из записей 
CONNECTING_ROD_LO_PRT в Дереве Модели. Выберите базовое выдавливание и измените его 
длину с 5 на 10. 

3. Вызовите сборку. Щелкните по Regenerate > Automatic. Обратите внимание на то, что шатун 
проткнул верхнюю часть поршня. 

4. Измените компонент шатуна, используя компоновку. Откройте CONNECTING_ROD_LO.PRT. 

5. Отобразите уравнения модели. Щелкните по Relations > Show Rel. Обратите внимание, что для 
этой модели отсутствуют уравнения. Закройте Информационное Окно и щелкните по Done . 
6. Задекларируйте деталь в компоновке двигателя. Щелкните по Declare > Declare Lay. Выберите 
компоновку ENGINE в меню. 
7. Снова отобразите уравнения модели. Щелкните по Declare > Declare Lay. Обратите внимание на 
то, что параметры компоновки теперь связаны с деталью. Закройте Информационное Окно. 
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8. Добавьте в компоновке уравнение, управляющее длиной шатуна. Выберите базовое выдавливание 
шатуна. Обратите внимание на то, что система отображает параметрические размеры. Щелкните по 
Add. Введите следующие уравнения: 
/* Length of rod controlled by layout

d83 = ROD_LENGTH

 
Рисунок 20: Размер Штанги 

9. Регенерируйте деталь. Обратите внимание, что штанга возвращается назад к 5.00-дюймовой 
длине, так как компоновка теперь управляет ею. 

10. Закройте окно. 

Задача 9. Поршень не будет обновлять свое местоположение в сборке потому, что он был собран с 
компонентом, называемым скелетной деталью, вместо шатуна. Измените компоновку так, чтобы она 
управляла и штангой, и скелетом и чтобы сборка обновлялась корректно. 

1. Откройте LAYOUT_SKELETON.PRT. Система вызывает модель, состоящую из опорных кривых, 
осей и плоскостей. Видимыми являются только кривые; другие элементы находятся на слое и скрыты. 

2. Объявите модель в компоновке. Щелкните по Setup > Declare > Declare Lay. Выберите компоновку 
ENGINE. 

3. Добавьте уравнение к компоненту для управления тактом, представленным окружностью. Щелкните 
по Relations. Выберите окружность и нижнюю кривую для отображения размеров. Щелкните по Add. 
Введите следующее уравнение в две строки: 
/*drive the engine stroke from layout engine

d3 = STROKE

4. Добавьте другие уравнения для управления длиной кривой, представляющей шатун. Введите 
следующий две строки: 
/*drive connecting rod length from layout engine
d22 = ROD_LENGTH 
5. Сохраните модель и закройте окно. 

Задача 10. Управлять диаметром поршня из компоновки. 

1. Откройте PISTON_LO.PRT. 

2. Объявите поршень в компоновке. Щелкните по Declare > Declare Lay. Выберите компоновку 
ENGINE. 

3. Добавьте уравнение для управления диаметром поршня из компоновки. Щелкните по Relations. 
Выберите базовое выдавливание поршня. Щелкните по Add и введите следующее: 
/*Piston diameter is driven by layout engine

d2 = PISTON_DIA
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Рисунок 21: Управление Диаметром Поршня из Компоновки 

4. Сохраните поршень и закройте окно. 

Задача 11. Были объявлены компоненты в компоновку и записаны уравнения с использованием 
параметров компоновки. Управляйте сборкой из компоновки. 

1. Активизируйте окно компоновки. Щелкните по Window > ENGINE.LAY:1. 

2. Щелкните по Modify. Измените значения STROKE с 6.00 на 7.00, PISTON DIA с 3.00 на 4.00 и ROD 
LENGTH с 5.00 на 10.00. 

3. Регенерируйте и сохраните компоновку. 

4. Активизируйте компоновку сборки двигателя. Щелкните по Window > ENGINE_LAYOUT.ASM. 

5. Регенерируйте сборку. Щелкните по Regenerate > Automatic. Обратите внимание, что вся сборка 
обновляется корректно. 

 
Рисунок 22: Изменение Сборки 

6. Сохраните сборку и сотрите ее из оперативной памяти. Щелкните по File > Save. Нажмите 
<ENTER> . Щелкните по File > Erase > Current. Щелкните по пиктограмме Select All > ОК. 
7. Активизируйте компоновку двигателя. Сохраните и сотрите ее из памяти. 

Резюме 

В этой главе Вы узнали что: 
• компоновки полезны при аннотировании процесса проектирования. 
• Компоновки могут быть созданы на любом этапе в процессе проектирования. 
• Компоновки могут использоваться для централизованного управления проектированием. 
• Модели могут быть изменены путем изменения компоновки, в отличии от открытия всей 

модели и проведения простого изменения. 



  Pro/ENGINEER 2001 Углубленный курс 

- 263 - 

Глава 11 
Конструирование с Использованием 
Скелетов 
В этой главе Вы изучите, как использовать скелетные модели для разработки изделий в 
среде проектирования сверху-вниз. 

Цели 
После завершения этой главы, Вы научитесь: 

• описывать назначение скелетов. 

• Создавать скелеты. 

• Связывать компоненты сборки со скелетами. 

• Использовать геометрию скелетов для моделирования. 

• Управлять скелетом модели. 

• Использовать различные свойства скелетов. 

Что Такое � Скелетная Деталь? 

Скелетная деталь - специальная модель детали, которая создается в контексте сборки для 
разработки критериев конструкции без необходимости создавать компоненты и собирать их вместе. 
Скелетная деталь � это трехмерная компоновка сборки, которую можно использовать в качестве 
структуры для построения сборки. 

Использование Скелетных Деталей 
Скелетные детали можно использовать для трех главных целей: 

1. Граница раздела 
Скелеты могут быть созданы и использоваться в качестве границы раздела (Interfaces) конструкции 
между компонентами. 
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Рисунок 1: Граница Раздела Пластмассового Контейнера 

 
Рисунок 2: Граница Раздела Сборки Двигателя 

2. Пространственная Увязка 
Скелеты можно использовать для создания требований к занимаемому узлами пространству, которые 
позволят установить границу раздела между мастер-сборкой и узлами в модели. 

 
Рисунок 3: Требования к Размещению Узлов 
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3. Определение Перемещений Сборки 
Определяется ход сборки, который позволяет разрабатывать сложные взаимосвязанные 
перемещение перед добавлением компонентов. 

 
Рисунок 4: Скелет для Перемещения Поршня 

Создание Скелета 
Скелетную деталь можно создавать в сборке. Можно полностью контролировать ее уровень и 
местоположение. 

Примечания: 
Можно создавать только один скелет для каждой сборки, но скелеты могут существовать в каждом 
узле, который принадлежит сборке высшего уровня. [Можно иметь несколько скелетов в каждой 
сборке с опцией конфигурации "multiple_skeletons_allowed", установленной в «yes»]. 

При создании скелета после сборки компонентов, система автоматически переопределяет 
размещение скелета в качестве первого компонента, используя зависимость "совмещение нулевых 
точек". 

Для упрощения использования скелетов в модели, можно добавлять слои и изменять названия 
элементов. 

Связь Компонентов Сборки со Скелетами 
Сборка компонентов в скелетную деталь путем установки отношений между компонентами сборки и 
скелетными моделями имеет следующие преимущества: 

• Сокращение иерархии родитель/потомок � скелет становится мастер-родителем для 
большинства компонентов в сборке. 
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Рисунок 5: Пример Отношений Родитель / Потомок 

• Ограничение возможностей выбора зависимостей � опция Reference Control позволяет 
собирать модели только со скелетом, а не друг с другом. 

• Управление положением компонентов � компоненты собираются со скелетом. Система 
автоматически обновляет положение компонентов при изменении пространственной увязки 
скелета. 

• Централизованное управление перемещением � при изменении компонентов скелета 
можно контролировать перемещение связанных компонентов. 

Использование Скелетной Геометрии для Моделирования 
При создании или добавлении деталей в сборку, скелетную геометрию можно привязывать, копируя 
ее. 

Также имеется опция создания элементов геометрии. Такой метод имеет следующие преимущества 
перед копированием скелетных элементов вручную: 

• в отдельном элементе можно выбирать различные формы геометрии, типа осей, кривых и 
поверхностей. 

• Система автоматически связывает элементы геометрии с одноименными слоями, если 
выбранные элементы связаны со слоями в скелете. 

• Геометрия автоматически обновляется, если сборка, содержащая элементы геометрии, 
находится в оперативной памяти. 

Управление Скелетной Моделью 
Можно управлять скелетной моделью и изменять ее различными способами. Используя Modify > Mod 
Skel, можно изменять размеры сборки, а также добавлять и определять геометрию. 

Другие Свойства Скелетов 
Для эффективного использования скелетных моделей в процессе проектирования, имейте в виду 
следующее: 

• Удаление скелетов � скелетную модель можно удалять из сборки, но ее удаление не удаляет 
скелетную деталь с диска. 

• Обработка скелетов в Спецификации � при создании Спецификации (ВОМ) в рабочем 
чертеже с использованием Pro/REPORT, Pro/ENGINEER автоматически не фильтрует 
скелетные модели на экране. 

• Исключение скелетов из упрощенного представления � скелетные модели можно легко 
исключать из упрощенного представления в сборке. В Дереве Модели скелетные модели 
обозначаются уникальной пиктограммой для их дифференциации от других моделей деталей 

• Трэкинг - Pro/PDM и Pro/INTRALINK не управляют ссылками между скелетами и 
компонентами, только отношениями между сборкой и компонентами. 
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Лабораторный Практикум 

Цель 
В этом практикуме, Вы создадите скелетную деталь, которая может использоваться для 
эмуляции перемещения в сборке. 

Метод 
В Упражнении 1, Вы построите скелет, представляющий перемещение одноцилиндрового двигателя 
карта. 

В Упражнении 2, Вы установите отношения родитель / потомок между компонентами и скелетной 
моделью, соберите коленчатый вал, копируя скелетную геометрию и, затем, измените коленчатый вал 
на уровне детали. 

В Упражнении 3, Вы выполните модификации в скелетной сборке, изменяя параметры в связанной 
компоновке, и проверите отношения родитель / потомок. 

Инструменты 
Таблица 1: Пиктограммы для Скелетов 

ПИКТОГРАММА ОПИСАНИЕ 

   Вставляет опорную кривую 

   Вставляет опорную ось 

    Вставляет опорную плоскость 

    Вставляет опорные точки 

УПРАЖНЕНИЕ 1: Построение Скелета Двигателя 
Задача 1. Перейти в каталог скелета и создать сборку. Использовать файл стандартной детали для 
создания скелетной модели в качестве первой детали. 

1. Измените рабочий каталог на требуемый для работы. 

2. Создайте SKEL_ENGINE.ASM. Щелкните по File > New в меню. Выберите ASSEMBLY. Введите 
[SKEL_ENGINE]. Щелкните по ОК. 
3. Щелкните по Component > Create > Skeleton Model > ОК. Щелкните по Copy From Existing > 
Browse. Выберите START_PART.PRT. Щелкните по Open > ОК. 
Обратите внимание: 
В Дереве Модели система располагает скелетную деталь, как первый компонент сборки. При этом к 
скелетной детали автоматически добавляются начальные опорные элементы. Обратите внимание на 
пиктограмму скелета в Дереве Модели. 

4. Сохраните сборку, затем закройте окно. 

Задача 2. Создайте связь для кривошипа и поршня. Определите кривую для представления такта 
работы двигателя. 

1. Щелкните по File > Open. Выберите In Session в выпадающем списке LOOK IN. Выберите 
SKEL_ENGINE_SKEL.PRT. 

2. Щелкните по  > Done. Выберите опорный элемент FRONT в качестве эскизной плоскости. 

3. Щелкните по ОК и выберите опорный элемент ТОР в качестве ориентирующей плоскости в 
направлении взгляда. 
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4. Нарисуйте окружность с диаметром 4.00. 

5. Вернитесь к виду по умолчанию по завершении. 

 
Рисунок 6: Эскиз для Окружности 

6. Щелкните по  > Two Planes. Выберите опорные элементы в качестве привязок для создания оси 
A1. 

Задача 3. Создать эскизную опорную кривую для представления соединения шатуна коленчатого 
вала. 

1. Создайте эскизную плоскость для кривой. 

2. Щелкните по  > Offset. Выберите опорную плоскость FRONT от которой будет создаваться 
отступ. 

3. Щелкните по Enter Value, введите [1.75] и щелкните по Done. 

 
Рисунок 7: Новая Эскизная Плоскость 

4. Создайте кривую для представления связи. Щелкните по  > Done. 

5. Выберите DTM1 в качестве эскизной плоскости. Щелкните по Okay. Выберите опорный элемент 
Side для ориентации ТОР. 

6. Выберите опорный элемент F1{SIDE} в диалоговом окне REFERENCE. Щелкните по Delete. 
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7. Выберите левую часть опорного круга и опорной оси в качестве привязки для эскиза. Сделайте 
эскиз кривой, состоящей из двух линейных сегментов, как показано на следующем рисунке. 

 
Рисунок 8: Эскиз для Шатуна и Кривошипа 

8. Добавьте угловой размер 30.00, представляющий вращение кривошипа. Добавьте размер 5.00, 
представляющий длину шатуна. 

9. Удалите зависимость касательности, если произойдет конфликт. 

10. Щелкните по  > ОК. 

11. Щелкните по View > Default в меню. Модель должна отображаться, как показано на следующем 
рисунке. 

 
Рисунок 9: Шатун Номер Один 

Задача 4. Для помощи в процессе сборки и создания компонентов, добавьте опорную ось, 
представляющую соединение шатуна и поршня. 

1. Создайте опорную точку через вершины кривых. 

Щелкните по  > On Vertex. Выберите две вершины, как показано на следующем рисунке. 
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Рисунок 10: Создание Опорной Оси 

2. Создайте опорную ось через две точки. Щелкните по пиктограмме Create an axis; затем щелкните 
по Pnt Nrm Pln. Выберите DTM1 и PNT0. Повторите процесс для PNT1. 

 
Рисунок 11: Завершенный Скелет 

Совет: 
Устанавливая опцию файла конфигурации repeat_datum_create в yes, можно уменьшить количество 
выборов в меню, необходимых для создания нескольких опорных элементов. 

Задача 5. Подтвердите, что скелет перемещается соответствующим образом, изменяя угол в опорной 
кривой. Автоматизируйте изменение, используя уравнение. Уравнение должно увеличивать угол на 
30° при каждой регенерации детали. 

1. Проверьте перемещение скелета. Щелкните по Modify. Выберите опорную кривую. Измените угол 
30.00, введите [75] и выполните регенерацию. 

2. Щелкните по Relations > Add Param > Real Number. Введите [crank_angle] в качестве названия. 
Введите [0] в качестве значения параметра. 

3. Выберите опорную кривую, которая имеет угол для отображения ее параметров. Щелкните по Edit 
Rel; затем введите следующие строки. Обратите внимание на символьное название углового размера. 
crank_angle = crank_angle +30
IF crank_angle > 340

crank_angle = 0

ENDIF

D# = crank_angle D# is the symbolic name

for the angle

4. Щелкните по File > Exit > Yes для завершения: 
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5. Регенерируйте модель. Продолжайте регенерировать, пока сечение не вернется назад к 30° по 
отношению к опорному элементу ТОР. 

6. Сохраните деталь и закройте окно. 

УПРАЖНЕНИЕ 2: Создание Модели Кривошипа 
Задача 1. Исследуйте ассоциативность между скелетной деталью и сборкой. 

1. Откройте SKEL_ENGINE.ASM. 

2. Обратите внимание на полную ассоциативность. Система обновляет сборку для отображения всех 
изменений, выполненных в режиме Детали. 

Обратите внимание: 
После добавления опорных элементов по умолчанию к скелетной детали, можно создавать другую 
геометрию в сборке, используя Modify > Mod Skel. 
Задача 2. Настройте эту сборку так, чтобы компоненты являлись дочерними только по отношению к 
скелету. 

1. Щелкните по Design Mgr > Ref Control. Выберите Skeleton Model и Prohibit Out of Scope 
Reference из диалогового окна REFERENCE CONTROL. 

2. Щелкните по ОК > Done/Return. 

Задача 3. Настройте опорные элементы в скелете так, чтобы модель кривошипа сохранила 
собственную ориентацию по отношению к ее собственным опорным плоскостям при вращении. 

1. Щелкните по Modify > Mod Skel. Выберите скелетную модель. 

2. Щелкните по  > Through. Выберите в скелете ось A_1. Снова щелкните по Through. Выберите 
ось, показанную на следующем рисунке. Щелкните по Done . 

 
Рисунок 12: Добавление Опорной Плоскости 

3. Щелкните по . Выберите ось A_1. Щелкните по Normal. Выберите DTM2. Вернитесь в меню 
высшего уровня; щелкните по Done/Return три раза. 
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Рисунок 13: Завершенные Опорные Элементы 

Задача 4. Определить коленчатый вал вне контекста сборки. 

1. Щелкните по Component > Create. Введите [SAMPLE_SHAFT]. Щелкните по ОК > Locate Default 
Datums > Three Planes > ОК. 

2. Выберите в скелете DTM3 для определения первой плоскости. 

3. Выберите опорные элементы DTM2 и FRONT как другие две плоскости в скелете. 

Задача 5. Скопировать привязки в сборку для создания кривошипа. 
1. Скопируйте геометрию из скелета в вал. Щелкните по Feature > Create > Data Sharing > Copy 
Geom. 
2. Укажите элементы опорной оси для добавления к SAMPLE_SHAFT.PRT. Щелкните по Misc Ref > 
Define > Axis. Выберите оси, как показано на следующем рисунке. Щелкните по Dtm Plane. Выберите 
DTM1 в скелете детали. Щелкните по Ok. 

 
Рисунок 14: Выбор Элементов для Копирования 

3. Щелкните по ОК в диалоговом окне. 

4. Сохраните сборку и закройте окно. 

Задача 6. Система автоматически добавляет геометрию к детали вала. Измените вал на уровне 
детали. 

1. Откройте SAMPLE_SHAFT.PRT. 
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2. Создайте центральный вал детали. Создайте выдавливание с опцией both sides по отношению к 
опорному элементу DTM3. Щелкните по Close в диалоговом окне REFERENCES. Используйте 
окружность с диаметром 1.25 в качестве эскиза. Выдавите элемент на 12.25. 

 
Рисунок 15: Эскиз для Центрального Вала 

3. Создайте выдавливание на DTM4. Щелкните по Both Sides. Выберите соответствующую 
ориентирующую привязку. Нарисуйте сечение, как показано на следующем рисунке. Определите оси 
A1 и A2 в качестве привязок. 

 
Рисунок 16: Эскиз для Кулачка Кривошипа 

4. Выдавите элемент на глубину 2. 

5. Вырежьте отверстие для шатуна. Создайте выдавленный двухсторонний вырез, используя тот же 
эскиз и плоскость привязки. Создайте окружность для сечения, как показано на следующем рисунке. 
Удалите материал с внешней стороны сечения. Выдавите на глубину 1.5. 
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Рисунок 17: Эскиз Выреза 

 
Рисунок 18: Завершенный Вал 

6. Сохраните файл детали и закройте окно. 

7. Снова откройте SKEL_ENGINE.ASM. Обратите внимание, что вал обновился. Регенерируйте сборку 
несколько раз и убедитесь, что вал сохраняет связь со сборкой. 

8. Сохраните и сотрите всю сборку из памяти. 

УПРАЖНЕНИЕ 3: Использование Скелета для Завершения Сборки 
Задача 1. Изменить COMPLETE_SKELETON.ASM. 

1. Откройте COMPLETE_SKELETON.ASM. 

2. В сборке был добавлен вырез, чтобы можно было рассмотреть компоненты подробнее. 

3. Щелкните по Regenerate > Automatic. Обратите внимание, что компоненты обновляют свое 
местоположение из-за уравнений. Регенерируйте несколько раз и наблюдайте изменения. 

Совет: 
Можно выключить отображение осей и точек. 
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Рисунок 19: Измененный Скелет 

4. Измените такт сборки. Щелкните по Modify > Mod Skel. Выберите SAMPLE_MOTOR_SKEL.PRT из 
Дерева Модели. Выберите круглую опорную кривую. Попытайтесь изменить диаметр на 5. Прочитайте 
запрос в области сообщения. COMPLETE_SKELETON.LAY управляет параметром. 

Задача 2. Компоновка управляет некоторыми из параметров в сборке. Измените параметры в таблице 
компоновки. 

1. Откройте COMPLETE_SKELETON.LAY. 

 
Рисунок 20: Компоновка Размещения 

2. Щелкните по Modify. Выберите параметр 4-inch в таблице, рядом с записью STROKE. Введите [5]. 

3. Выберите размер 5-inch рядом с записью ROD LENGTH в таблице. Введите [7]. 

4. Вызовите компоновку. 

5. Сохраните компоновку и закройте окно. 

Задача 3. Проверить изменения, которые были сделаны в сборке. 

1. Щелкните по Window > Activate в меню. 

2. Регенерируйте сборку. Обратите внимание на то, что система обновила все модели относительно 
скелетной модели. 

Задача 4. Проверить связь родитель / потомок между компонентами. 



Pro/ENGINEER 2001 Углубленный Курс    

- 276 - 

1. Подавите шатуны в сборке. Щелкните по Component > Suppress. Выберите два шатуна. 
Регенерируйте сборку. Обратите внимание на то, что поршни сохраняют привязку к скелетной модели. 
2. Сохраните сборку и сотрите все объекты из памяти. Щелкните по File > Erase > Current > Done. 

Резюме 

В этой главе, Вы узнали что: 

• скелеты могут использоваться для симуляции движения в простых сборках. 

• Скелеты могут также помогать в определении отношений родитель / потомок, когда все 
компоненты собраны со скелетом. 

• Скелеты могут быть простыми или сложными, но типичными компонентами поверхностной или 
опорной геометрии. 

• Метод проектирования сверху-вниз может быть выполнен при помощи скелетов. Это 
достигается использованием элементов копирования существующей геометрии для создания 
новой, которая привязана к скелету. 
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Глава 12 
Скелеты с Распределенной 
Геометрией 
В этой главе Вы изучите методы совместного использования информации между 
различными конструкторскими группами при поддержании ассоциативности на уровне 
верхней сборке. 

Цели 
После завершения этой главы, Вы научитесь: 

• создавать скелеты для распределения существующей геометрии. 

• Разделять ассоциативную геометрическую информацию между моделями. 

Скелеты С Распределенной Геометрией 

Методы распределения детали имеет следующие преимущества при работе с большими проектами: 

• обеспечивает механизм для управления и сохранения формы, совмещения и 
функционирования в каждой подсборке, которая используется на верхнем уровне. 

• Обеспечивает доступ из подсборки к информации верхнего уровня без увеличения времени 
регенерации и перерисовки. 

• Позволяет нескольким конструкторам выполнять параллельное конструирование. 

• Снижает вероятность возникновения конфликтов на уровне сборок. 

Конструирование Распределенных Деталей 
Используя Component > Create, можно создавать в сборке распределенные детали и размещать их 
на опорных плоскостях высокого уровня по умолчанию. 
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Рисунок 1: Создание Распределенных Деталей 

Для использования скелета с распределенной геометрией в большом проекте, выполните следующие 
шаги. 

Таблица 1: Этапы Создания Скелетов с Распределенной Геометрией 

Этап Действие 

1 Добавить основные компоненты в сборку верхнего уровня, используя стандартные 
методы сборки 

Примечание: собираемые компоненты являются теми компонентами, которые 
определяют необходимые привязки к скелету. 

2 Создайте новую подсборку, используя шаблон. 

3 Создайте скелет, используя шаблон, и соберите его в подсборку в качестве 
первого компонента в местоположении по умолчанию. 

4 Скопируйте необходимые привязки в скелет, используя элементы совместного 
использования данных (data sharing features) - copy geom, shrinkwrap и т.д. 

5 Используйте элементы совместного использования данных в скелете для 
конструирования моделей в подсборках. 

Использование Геометрии Модели 
При ссылке на распределенную деталь в больших проектах, можно создавать индивидуальные 
опорные элементы и элементы поверхностей или отдельный элемент, который использует все 
геометрические привязки. 

Для создания или изменения скелета с распределенной геометрией в контексте сборки, можно 
создавать элемент Совместного Использования Данных (Data Sharing) типа copy geom (копирование 
геометрии) и shrinkwrap (псевдографика). Это имеет следующие преимущества перед ручным 
копированием скелета с распределенной геометрией: 

• Можно выбирать различные формы геометрии, типа осей, кривых и поверхностей в отдельном 
элементе. 

• Система автоматически связывает элементы совместного использования данных с 
одноименными слоями, если выбранный элемент связан со слоем в компоненте, из которого 
копируется геометрия. 
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• Элемент совместного использования данных не позволяет выбирать привязки из более чем 
одного компонента. 

• Элемент совместного использования данных автоматически обновляется, если сборка, в 
которой он был создан, находится в оперативной памяти. 

• Можно включать / выключать зависимости, которые позволяют контролировать проведение 
изменений. 

Копирование Поверхностей 
Поверхности - бесконечно тонкие элементы: 

• желтая кромка поверхности обозначает одностороннюю кромку. 

• Пурпурная кромка обозначает двухстороннюю кромку, касательную линию или силуэтную 
кромку поверхности. 

Используя Surface > Copy, можно дублировать любую другую поверхность элемента путем выбора 
требуемых поверхностей, типа присоединительной поверхности фланца. 

 
Рисунок 2: Распределенная Деталь для Разводки Труб 

Обратите внимание: 
Избегайте копирования поверхностей компонентов, собранных с распределенными деталями. Это 
может привести к созданию циклических ссылок. 

Использование Распределенной Детали на Уровне Подсборок 
После копирования поверхностей в узле, можно работать на уровне подсборок, собирая компоненты с 
геометрией распределенной детали. 
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Рисунок 3: Трубопровод, Добавленный в Узел 

 
Рисунок 4: Автоматическая Разводка Труб в Сборке Высокого Уровня 

Лабораторный Практикум 

Цель 
В этом практикуме, Вы создадите распределенную деталь, передающую важное назначение 
проекта. Использование распределенной детали позволяет иметь геометрию сборки 
высокого уровня в сессии без необходимости загружать всю сборку в оперативную память. 

Метод 
В Упражнении 1, Вы создадите геометрию на основании большой и сложной сборки. Вы используете 
распределенную деталь, чтобы копировать только те привязки, которые необходимы для конкретного 
компонента. 

В Упражнении 2, Вы создадите привязочную геометрию выхлопного устройства на основании сборки. 
Для экономии времени, будет создан скелет с распределенной геометрией для определения системы 
привязок выхлопного устройства. 
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УПРАЖНЕНИЕ 1: Создание Распределенной Детали 
Задача 1. Карбюраторы требуют точной пригонки в двигателе. Создайте распределенную деталь с 
этой информацией внутри нового узла. 

1. Перейдите в соответствующий рабочий каталог. 

2. Откройте M_ENGINE.ASM. 

 
Рисунок 5: Сборка Двигателя 

Задача 2. Экран сильно загроможден ненужными деталями. Используйте существующий слой для 
скрытия компонентов. 

1. Щелкните по View > Layers. Щелкните по CLEAN_UP_DISPLAY; щелкните по пиктограмме Blank. 

2. Перерисуйте экран и закройте диалоговое окно. 

 
Рисунок 6: Двигатель со Скрытым Слоем 

Задача 3. Определите узел и распределенную деталь для карбюратора. 

1. Щелкните по Component > Create > SubAssembly; введите [M_CARBURETOR]. Щелкните по ОК. 

2. Щелкните по Copy From Existing > Browse. Выберите START_ASM.ASM. Щелкните по Open > ОК. 

3. Щелкните по Default > ОК в выпадающем списке CONSTRAINT TYPE. 

Задача 4. Начать определение распределенной детали. 

1. Щелкните по Done/Return для перехода в меню высшего уровня. Щелкните по Modify > Mod 
Subasm. Выберите M_CARBURETOR.ASM. 
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2. Щелкните по Component > Create. Щелкните по Part в диалоговом окне. Введите 
[MAP_CARBURETOR]. Щелкните по ОК. 

3. Щелкните по Copy From Existing > Browse. Выберите START_PART.PRT. Щелкните по Open > ОК. 

4. Щелкните по Default в выпадающем списке CONSTRAINT TYPE; щелкните по ОК. 

 
Рисунок 7: Узел M_Carburator 

Задача 5. Скопировать некоторые из сборочных привязок из двигателя в узел карбюратора. 
Скопировать установочные поверхности и ось для карбюратора из блока двигателя. 

1. Дважды щелкните по Done/Return для вывода меню ASSEMBLY. Щелкните по Modify > Mod Part. 
Выберите MAP_CARBURETOR.PRT из Дерева Модели. 

2. Щелкните по Feature > Create > Data Sharing > Copy Geom. 

3. Дважды щелкните по Surface Refs. Выберите обе сопрягаемые поверхности для карбюратора. 
Увеличьте масштаб отображения. 
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Рисунок 8: Выбор Поверхностей 

4. Щелкните по Loop Surfs и снова выберите переднюю поверхность одной из деталей. Выберите 
одну из внешних кромок выбранной поверхности. Pro/ENGINEER автоматически выбирает все 
поверхности, смежные с выбранной поверхностью. 

5. Щелкните по Loop Surfs и снова выберите переднюю поверхность; затем выберите одну из 
внутренних кромок поверхности. 

Совет: 
Для подтверждения выбранной поверхности, используйте опцию Show > Mesh перед выбором Done. 
6. Повторите процесс для второго входного устройства; затем щелкните по Done в меню SURF 
SELECT. Не щелкайте по ОК. 

7. Дважды щелкните по Misc Refs. Выберите Axis в области ADD ITEM; выберите четыре оси, 
требуемых для установки карбюратора. Щелкните по Done Sel > ОК; затем щелкните по ОК в 
диалоговом окне. 

8. Сохраните M_ENGINE.ASM и вызовите M_CARBURETOR.ASM. Сборка должна отобразиться, как 
показано на следующем рисунке. 

9. Закройте все окна. 
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Рисунок 9: Завершенная Распределенная Деталь Карбюратора 

УПРАЖНЕНИЕ 2: Распределение Выхлопного Устройства 
Задача 1. Выхлопные трубы требуют точной пригонки на двигателе и раме вместе с различными 
местами монтирования на раму. Создайте распределенную деталь, которая содержит эту 
привязочную геометрию 

1. Откройте MAP_CART.ASM. 

2. Переориентируйте модель в соответствии с видом, аналогичным следующему рисунку. 

 
Рисунок 10: Вид 

Задача 2. Начать создание распределенной детали для сборки выхлопного устройства с определения 
узла в распределенной детали. 

1. Щелкните по Component > Create > SubAssembly. Введите [EXHAUST]. Щелкните по ОК. 

2. Щелкните по Copy From Existing > Browse. Выберите START_ASM.ASM. Щелкните по Open > ОК. 
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3. Щелкните по Default в выпадающем списке CONSTRAINT TYPE и по ОК для размещения 
компонента. 

Задача 3. Добавить распределенную деталь в качестве первого компонента в узле. Создать деталь в 
контексте сборки высокого уровня. 

1. Щелкните по Done/Return для вызова меню ASSEMBLY. Щелкните по Modify > Mod Subasm. 
Выберите EXHAUST.ASM из Дерева Модели. 

2. Щелкните по Component > Create > Part > Solid. Введите [MAP_EXHAUST]. 

3. Щелкните по Copy From Existing > Browse. Выберите START_PART.PRT. Щелкните по Open > ОК. 

4. Щелкните по Default в меню CONSTRAINT TYPE; щелкните по ОК для его размещения. 

Задача 4. Добавить копию элемента разделения данных для создания привязок, которые можно 
использовать на уровне узлов. 

1. Дважды щелкните по Done/Return для вызова меню ASSEMBLY. Щелкните по Modify > Mod Part. 
Выберите MAP_EXHAUST.PRT из Дерева Модели. 

 
Рисунок 11: Деталь Map_Exhaust 

2. Щелкните по Feature > Create > Data Sharing > Copy Geom. 

3. Дважды щелкните Surface Ref. Выберите сопрягаемые поверхности входного устройства. 

4. Используйте Loop Surfaces для копирования внешних и внутренних контуров поверхностей, 
используя тот же метод, который использовался для распределенной детали карбюратора. 
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Рисунок 12: Распределение Поверхностей Входного Устройства 

5. Дважды щелкните по Misc refs. Щелкните по Axis в области ADD ITEM. Выберите четыре оси, 
необходимые для установки выхлопных труб. Щелкните по Done Sel > ОК > ОК. 

Задача 5. Скопировать поверхности рамы, вокруг которой должно обернуться выхлопное устройство. 
1. Создайте другой элемент разделения данных для рамы. Щелкните по Create > Data Sharing > Copy 
Geom. 

 
Рисунок 13: Распределенная Рама 

2. Дважды щелкните по Surface Refs. Выберите показанные поверхности. Не забудьте выбрать обе 
стороны каждого цилиндра. 

3. Щелкните по ОК в диалоговом окне. 

4. Сохраните сборку и откройте MAP_EXHAUST.PRT. Деталь должна отображаться, как показано на 
следующем рисунке. 

5. Закройте окно и сотрите все посторонние модели из памяти. 
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Рисунок 14: Закрашенная Распределенная Деталь Выхлопного Устройства 

Резюме 

В этой главе, Вы узнали: 

• как создавать сборку высокого уровня, информация о которой становится доступной на уровне 
подсборки с использованием распределенной детали. 

• Как создавать элементы Совместного Использования Данных, которые можно использовать 
для копирования привязок в распределенные детали. 

• Как создавать подсборки в контексте большой сборки. 

• Как создавать детали в режиме Сборки. 
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