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Глава 1 
Углубленное Эскизирование и 
Геометрия 
В этой главе Вы изучите, как создавать и изменять сложные геометрические объекты. 

Цели 
После завершения этой главы Вы сможете: 

• создавать эллипсы, кривые второго порядка, осевые точки и скругления. 

• Создавать и образмеривать сплайны. 

• Изменять сплайны в процессе определения условий касательности. 

• Использовать опции Replace и Text. 

Расширенные Геометрические Элементы 

В большинстве случаев простых эскизных объектов, типа дуг, линий и окружностей вполне 
достаточно. Для создания сложных форм уже требуются опции эскизирования расширенной 
геометрии. 

Углубленные опции эскизирования включают: 

• оси, перпендикулярные плоскости эскиза в указанных точках. 

• Кривые второго порядка (conics) для создания эллиптических, параболических и 
гиперболических сечений. 

• Эллиптические скругления (скругление между двумя эскизными объектами) 

• Сплайны. 

Создание Осей, Перпендикулярных к Эскизной Плоскости 
Используя Axis Point, можно создавать оси, перпендикулярные эскизной плоскости в указанной точке. 
Этот тип осей не является опорным элементом. Это ось в составе эскизного элемента. 

После эскизирования и размещения точки, появляется ось. Она подобна тому типу осей, которые 
система отображает при создании цилиндров. 

Эскизные Кривые Второго Порядка 
Используя опцию Conic можно создавать эскизные кривые второго порядка (conics) для построения 
эллиптических, параболических и гиперболических сечений. Для построения кривой второго порядка 
укажите две конечные точки и выберите третью промежуточную точку, как при создании дуги по трем 
точкам. 
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Ввод Параметрических Значений 
Для определения кривой второго порядка следует указать значение параметра �Rho�, который 
является отношением BE/DE, где АЕ = ЕС, как показано наследующем рисунке.  

 
Рисунок 1: Определение RHO 

Значения параметра кривой второго порядка задаются в пределах от 0.05 до 0.95. Следующие 
значения имеют особый смысл: 

• от 0.05 до < 0.5 - эллиптическая дуга 

• 12 −   - является истинным эллипсом, нормальным эллиптической четверти 
дуги. 

• 0.5   - парабола 

• от > 0.5 до 0.95  - гиперболическая дуга 

Построение Сечений Кривых Второго Порядка 
Для построения кривой второго порядка можно использовать следующие три способа, как показано на 
предыдущем рисунке: 

Задача 1. Положение двух конечных точек определяется размерами или допущениями о совпадении 
со смежными вершинами объекта. 

Задача 2. Параметр rho. Этот размер создается аналогично радиусу. 

Задача 3. Наклон кривой второго порядка в каждой конечной точке, определенной угловыми 
размерами или допущениями касательной к смежным объектам или осевой линии. 
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Рисунок 2: Использование Значения Rho 

Использование Точек Эскиза 
Кривую второго порядка можно привязывать путем размещения двух конечных точек и указывая 
третью, промежуточную известную точку, через которую должна пройти кривая второго порядка. 
Известная точка может являться эскизной точкой, опорной точкой, вершиной детали и т.д. 
Pro/ENGINEER самостоятельно определяет значение «rho». 

Следующий рисунок иллюстрирует требуемую схему образмеривания 

 
Рисунок 3: Использование Эскизной Точки 

Создание Эллиптических Скруглений 
С использованием опции Elliptical Fillet можно создавать скругление между двумя эскизными 
объектами тем же способом, что и при скруглении радиусом. 

Необходимо разместить конечные точки эллиптической части используя линейные размеры или 
значения радиуса X и Y. 
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Рисунок 4: Схема Образмеривания Эллиптического Скругления 

Создание Сплайнов 
Сплайны � это кривые, гладко проходящие через любое количество промежуточных точек. Их можно 
создавать используя опцию Spline. 

Для управления формой сплайна можно образмеривать любые внутренние точки, а также угол 
касательной и радиус кривизны в конечных точках сплайна. 

Создание Сплайнов 
Для создания сплайна можно: 

• нарисовать точки. 

• Выбрать существующие эскизные точки. 

• Выбрать цепочку ранее нарисованных эскизных объектов. 

Использование Контрольных Прямоугольников 
Также, можно использовать опцию Control Poly для создания контрольных прямоугольников, как 
показано на следующем рисунке: 



  Pro/ENGINEER 2001 Углубленный курс 

- 13 - 

 
Рисунок 5: Сплайн с Контрольными Прямоугольниками 

Обратите внимание: 
При использовании Select Points для создания сплайна путем выбора существующих эскизных точек, 
созданный сплайн не будет связан с этими точками. 

Если в ответ на запрос системы эскизные или импортированные точки не будут удалены, то 
необходимо образмерить отдельные эскизные точки. 

Изменение сплайнов 
Опции модификации эскизных сплайнов отличаются от опций модификации эскизных объектов. 
Можно перетаскивать эскизные точки; или модифицировать внутренний контрольный 
прямоугольник. 

 
Рисунок 6: Диалоговое Окно Модификации Сплайна 
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Использование Опции Замены 

Замена Эскизных Объектов 
При попытке удалить эскизный объект, который является потомком, появляется предупреждающее 
сообщение, предостерегающее от удаления родительского объекта. 

Другим способом избежать конфликта элементов является замена (replace) геометрии на новый 
эскизный объект. 

При переопределении объекта одна его часть сохраняет идентификатор старого объекта, а другая 
часть получает новый идентификатор. Для сохранения потомка можно использовать новый объект 
для замены старого. 

Замена Размеров 
Размеры старых объектов обычно можно удалять без последствий. Однако, размеры также можно 
заменять. 

При удалении размера и создании нового для переопределения схемы образмеривания, система 
переопределяет символьные имена (т.е. sd# в режиме Эскизирования, и d# в режиме Детали). 

Обратите внимание: 
Для определения размеров существующего элемента, можно использовать Известный (Known) 
размер в Среде эскизирования. Система назначает ему символьное имя в форме kd#. Его можно 
использовать при создании уравнений, но необходимо помнить, что известные размеры создают 
отношения родитель / потомок с геометрией, выбранной для образмеривания. 

Вставка Текста 

Вставка и Изменение Эскизного Текста 
Диалоговое окно TEXT можно использовать для Вставки (Insert) текста вместе с эскизными 
объектами, а также для изменения текстового стиля. 

 
Рисунок 7: Диалоговое Окно Текста 
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Диалоговое окно TEXT имеет следующие поля: 

• Font � стандартные шрифты типа cal_alf, cal_grek, filled, font, font3d, isofont, Leroy и norm_font. 

Обратите внимание: 
Для использования шрифтов сторонних разработчиков установите опцию конфигурации pro_font_dir с 
указанием полного пути к каталогу со шрифтами. 

• Aspect ratio � введите новый коэффициент форматного соотношения или используйте бегунок 
для изменения значения. 

• Slant Angle � эта опция изменяет наклон букв текста. 

• Place Along Curve � выберите переключатель для добавления или удаления текста вдоль 
кривой. Щелкните по FLIP для определения ориентации текста вдоль кривой. 

Лабораторный Практикум 

Цель 
В этом практикуме, Вы изучите дополнительные методы создания эскизных элементов. 

Метод 
В Упражнении 1, сплайн создается путем считывания точек данных из файла и определения 
последнего сечения, которое может быть повторно использовано при создании элемента. 

В Упражнении 2, выполняется работа над сплайном для создания модели с использованием 
различных инструментов эскизирования. 

В Упражнении 3, создается и редактируется эллиптическое скругление. 

В Упражнении 4, показана процедура создания и редактирования кривой второго порядка путем 
сохранения кривой второго порядка в качестве сечения и последующего создания твердотельной 
геометрии по этому сечению. 

Инструменты 
ПИКТОГРАММА ОПИСАНИЕ 

   Создает сплайн через несколько точек 

   Создает ссылочную систему координат (reference coordinate system) 

   Вставляет зависимость коллинеарности 

   Вставляет зависимости 

   Создает эскизную опорную кривую 

   Вкл/выкл отображения опорной плоскости 

   Вкл/выкл отображения размеров 

   Вкл/выкл динамической обрезки 

   Делает два элемента касательными 

   Выбирает первичные объекты 
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   Создает круговое скругление 

   Создает эллиптическое скругление 

   Вкл/выкл отображения опорных осей 

   Выбирает геометрию 

   Создает кривую второго порядка 

   Создает текст 

   Создает эллипс 

   Разделяет сечение 

   Зависимость симметрии 

   Зеркально отображает геометрию 

Упражнение 1: Импорт Внешних Данных Сплайна 
Задача 1. Создать сплайн и использовать его при построении сопряженной части лопасти. 

1. Создайте новый эскиз с именем WING. 

2. Нарисуйте вертикальную и горизонтальную осевые линии. 

Задача 2. Создать сплайн 

1. Щелкните по  (Создание сплайна через несколько точек). 

2. Постройте сплайн через три точки и щелкните по  для его завершения. Образмерьте в 
соответствии со следующим рисунком. 

 
Рисунок 8: Создание Сплайна по Трем Точкам 

Задача 3. Считать внешние данные для управления формой сплайна путем привязки сечения к 
локальной системе координат. 

1. Щелкните по  (Создание системы координат). Разместите систему координат в точке 
пересечения осевых линий. 

2. Выберите сплайн и щелкните по  > Modify. 
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3. В диалоговом окне MOD SPLINE щелкните по ярлычку Coordinates, затем щелкните по Read. 
Выберите WING.PTS. Щелкните по Open. 

4. Прочитайте сообщение. Щелкните по Yes для вставки точек сплайна. 

5. Определите нижнюю часть сечения лопасти. Нарисуйте горизонтальную линию слева направо, 
совпадающую с конечными точками сечения лопасти. 

 
Рисунок 9: Горизонтальная Линия, Совпадающая с Конечными Точками Сечения Лопасти 

6. Сохраните сечение, затем щелкните по  в Менеджере Намерений. 

Задача 4. Создать выдавливание, используя последнее созданное сечение. 

1. Создайте деталь с названием WING.PRT. 

2. Щелкните по Insert > Protrusion > Blend > General > Done > Smooth > Done. 

3. Укажите FRONT в качестве эскизной плоскости. Щелкните по  для принятия направления по 
умолчанию. Щелкните по ТОР в качестве привязки «вид сверху». Закройте диалоговое окно 
REFERENCES. 

4. Щелкните по Sketch > Data from File. Выберите WING_SECTION.SEC в диалоговом окне. Щелкните 
по Open. 

5. Щелкните по . Перетащите сечение приблизительно в место пересечения опорных плоскостей. 

6. Введите [20.0] в качестве масштабного коэффициента, затем щелкните по . 

7. Отмените отображение DATUM и увеличьте отображение сечения. Щелкните по  >  для 
совмещения каждой осевой линии с соответствующими линиями привязки. 

 
Рисунок 10: Совмещение Сечения 

8. Щелкните по  для перехода к следующему сечению. 

9. Введите [0.0], [0.0], [5.0] для поворота вокруг осей X, Y, Z. 

Задача 5. Начать создавать новое сечение в новом окне эскизирования. 

1. Измените длину сечения на [15.0]. 
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Рисунок 11: Размещение Сечения 

2. Щелкните по  для переключения на следующее сечение. Когда система запросит, следует ли 
переходить к следующему сечению, ответьте NO. 

3. Введите [18.0] в качестве глубины сечения. Результирующая лопасть должна быть похожа на 
следующий рисунок. 

 
Рисунок 12: Размещение Сечения 

4. Выберите выдавливание. Щелкните по  > Modify > All. Измените все три угла на 15° и 
регенерируйте модель. 

5. Сохраните модель и сотрите ее из оперативной памяти. 

Упражнение 2: Работа со Сплайнами 
Задача 1. Нарисовать сплайн. 

1. Создайте новую деталь с именем Spline, используя шаблон по умолчанию. 

2. Выберите опорный элемент FRONT. Щелкните по  (вставить опорную эскизную кривую). 

3. Закройте диалоговое окно REFERENCES. Выключите отображение опорных плоскостей . 

4. Нарисуйте две окружности и прямоугольник, как показано на следующем рисунке. 
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Рисунок 13: Эскиз двух Окружностей и Прямоугольника 

5. Щелкните по  (отображение размеров). 

6. Щелкните по  (Динамическая обрезка) и обрежьте объекты в соответствии со следующим 
рисунком. 

 
Рисунок 14: Обрезка Геометрических Объектов 

7. Щелкните по  для создания сплайна. 

8. Привяжите левую часть по касательной, используя  (зависимость касательности). 

 
Рисунок 15: Добавление Зависимостей 

9. Выберите сплайн. Щелкните по  > Modify. 

10. Щелкните по Add. Выберите несколько точек на сплайне. 

11. Щелкните по Move. Разместите точки приблизительно, как показано на следующем рисунке. 
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Рисунок 16: Размещение Точек Эскиза 

12. Щелкните по Create Control Poly. 

Обратите внимание: 
Исходные точки сплайна должны быть образмерены. 

13. Щелкните по Delete Control Poly. 

14. Щелкните по Display Curvature. Переместите несколько точек для отображения кривизны. 

 
Рисунок 17: Перемещение Точек 

15. Снимите Display Curvature. Щелкните по  в диалоговом окне MOD SPLINE. 

16. Щелкните по  для отображения размеров. Завершите схему образмеривания, как показано на 
следующем рисунке. 

Обратите внимание: 
Не все точки сплайна должны быть образмерены. 
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Рисунок 18: Отображение Размеров 

Задача 2. Создать размер касательности правой вершины сплайна. 

1. Щелкните по . Выберите правую вершину сплайна и вертикальную линию. 

2. Щелкните по  для размещения углового размера. 

3. Выберите угловой размер. Щелкните по . Увеличьте чувствительность (sensitivity) бегунка до ¾. 
Используйте колесико для динамического изменения угла. 

4. Введите угол [180]. Щелкните по . 

5. нарисуйте вертикальную осевую линию, как показано на следующем рисунке. 

 
Рисунок 19: Создание Осевой Линии 

6. Щелкните по  для завершения элемента. 

7. Щелкните по  (выбрать первичный объект). Выберите опорную кривую. 

8. Щелкните по Insert > Protrusion > Revolve. 
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9 Перетащите кривую на требуемый угол. Щелкните  на фоне для регенерации. 

10. Необязательно: Создайте модель оболочки и раскрасьте внутреннюю поверхность, как показано 
на следующем рисунке. 

 
Рисунок 20: Окончательная Модель 

Упражнение 3: Создание и Редактирование Эллиптических Сопряжений 
Задача 1. Создать новую деталь с названием ADV_SCETCH.PRT, используя шаблон по умолчанию. 

1. Выберите опорную плоскость ТОР. 

2. Щелкните по Insert > Protrusion > Extrude. 

3. Создайте геометрию, как показано на следующем рисунке. 

 
Рисунок 21: Эскиз Прямых Линий 

4. Добавьте круговые и эллиптические скругления, как показано на следующем рисунке, используя  

и  соответственно. 
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Рисунок 22: Добавление Скруглений 

5. В соответствии со следующим рисунком измените схему образмеривания для эллиптического 
скругления. 

6. Щелкните по . Выберите эллиптическое скругление. Щелкните по . Выберите Х-радиус. 
Удалите горизонтальный размер 1.5. 

7. Повторите предыдущий шаг для Y-радиуса. Удалите вертикальный размер 1.0. 

 
Рисунок 23: Удаление Горизонтального и Вертикального Размеров 

8. Выйдите из Эскиза. Нажмите ОК. 

9. Используя Dynamic Modify, измените глубину выдавливания на значение между 0.75 и 1.0. 
щелкните по Regenerate. 

10. Включите отображение опорных осей . Обратите внимание на то, что никаких осей не было 
создано. 

Задача 3. Создать осевые точки. 

1. Щелкните по  (выбрать первичный объект). Выберите последнее созданное выдавливание. 

2. Щелкните по  > Redefine. 

3. Переопределите эскиз. Вставьте три осевые точки (axis point), используя Scketh > Axis Point, как 
показано на следующем рисунке. 
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Рисунок 24: Вставка Трех Осевых Точек. 

4. Завершите элемент. Обратите внимание на созданные оси. 

Задача 4. Использовать функцию замены. 

1. Щелкните по  (выбрать геометрию). 

2. Удерживая <SHIFT> , выберите три кромки, как показано наследующем рисунке. 

 
Рисунок 25: Выбор Кромок для Скругления 

3. Щелкните по  > Round Edges. Используйте функцию Dynamic Modify, для создания радиуса 
между 0.125 и 0.15. Обратите внимание, что радиус следует по касательной. 

4. Выберите выдавливание. Щелкните по  для переопределения эскиза. 

5. Выберите линию 45° и попытайтесь ее удалить. Прочитайте предупреждающее сообщение. 
Щелкните по NO. 

6. Нарисуйте кривую второго порядка с касательными обеих точках, используя . 

7. Измените значение Rho на 0.20. 
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Рисунок 26: Эскиз Кривой Второго Порядка 

8. Замените привязки, используемые линией под 45°, на кривую второго порядка. 

9. Выберите кривую второго порядка, затем щелкните по Edit > Replace. 

10. Прочитайте предупреждающее сообщение. Выберите линию 45°. 

11. Щелкните по YES для удаления размеров, связанных с линией. 

12. Измените размеры, как показано на следующем рисунке и завершите элемент. 

 
Рисунок 27: Образмеривание 

Задача 5. Создать эскизный текст. 

1. Возвратите вид модели по умолчанию и щелкните по  Выберите верхнюю поверхность. 

2. Щелкните по  для создания опорной кривой. 

3. Щелкните по  и нарисуйте сплайн, как показано на следующем рисунке. 
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Рисунок 28: Эскиз сплайна 

4. Выйдите из эскиза и завершите опорную кривую сплайна. 

5. Начните создание другой кривой, как и прежде. 

6. Щелкните по  (эскизный текст). Нарисуйте линию, используя начало опорной кривой в качестве 
привязки, как показано на следующем рисунке. 

 
Рисунок 29: Создание Линии в Качестве Привязки 

7. Введите [Proe] в диалоговом окне TEXT. Установите шрифт CG Times. 

8. Щелкните по Place Along Curve. Выберите сплайн и переверните текст, при необходимости. 

9. Щелкните по  для выхода из диалогового окна TEXT. 

10. Перетащите сплайн и/или линию определения текста для динамического изменения. 



  Pro/ENGINEER 2001 Углубленный курс 

- 27 - 

 
Рисунок 30: Динамическое Изменение 

11. Завершите элемент текста вдоль опорной кривой. 

12. Щелкните по . Выберите элемент текста вдоль опорной кривой. 

13. Щелкните по Insert > Protrusion > Extrude. Перетащите, примерно, на глубину 0.25. 

14. Регенерируйте и закрасьте модель. 

 
Рисунок 31: Выдавленная и Закрашенная Модель. 

15. Выберите выдавленный текст. Щелкните по  > Supress. 

16. Выберите текст по опорной кривой. Щелкните по Insert > Cut > Extrude. Перетащите на требуемую 
глубину. 

17. Сохраните модель и закройте окно. 

Упражнение 4: Создание Корпуса Зеркала 
Задача 1. Открыть модель 
1. Откройте MIRROR_MOUNT.PRT 
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Рисунок 32: Модель Основания Зеркала. 

Задача 2. Начать определение выдавливания, используя базовое сопряжение со сглаживанием. 

1. Щелкните по Insert > Protrusion > Blend > General > Done > Smooth > Done. 

2. Выберите верхнюю поверхность основания зеркала, как показано выше. 

3. Щелкните по , чтобы принять направление по умолчанию. Щелкните по Bottom. Выберите 
DTM3. 

Задача 3. Создать систему координат для первого сечения. 

1. Выключите отображение . 

2. Нарисуйте сплайн, используя  в месте пересечения линий привязок. 

Задача 4. Определить эллипс, используя схему образмеривания по умолчанию 

1. Используйте  (эллипс) для создания эллипса в месте пересечения линий привязок. 

 
Рисунок 33: Создание Эллипса 

2. Измените размеры: Ry = 70, Rx = 50. 
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Задача 5. Поделить эллипс на четыре части, чтобы его можно было сопрячь с последним сечением, 
состоящим из четырех эллиптических сечений. 

1. Щелкните по  (разделить сечение) и выберите эллипс в четырех местах его пересечений со 
вспомогательными линиями. 

2. Добавьте осевые линии к сечению вдоль DTM1 и DTM3. 

3. Щелкните по  (зависимость симметричности) и назначьте симметрию относительно обоих 
осевых линий. 

 
Рисунок 34: Создание Осевых Линий 

4. Сохраните сечения для использования в следующем под-сечении. Щелкните по File > Save & Copy. 
Введите [ellipse] и нажмите ОК. 

5. Щелкните по пиктограмме . 

Задача 6. Выполнить вращение относительно третьего сечения. 

1. Щелкните по Sketch > Data from File. Выберите ELLIPSE.SEC в диалоговом окне. Щелкните по 
Open. 

2. Щелкните по  и создайте горизонтальный и вертикальный размеры. В случае конфликта 
удалите размеры Rx и Ry. Повторно установите симметрию при необходимости. 

 
Рисунок 35: Вертикальный и Горизонтальный Размеры 
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3. Щелкните по  > Yes для создания третьего сечения. 

4. Введите [45] [0] [0] для поворота третьего сечения. 

Задача 6. Выполнить третье сечение при помощи параболических кривых второго порядка. 

1. Определите систему координат эскиза. 

2. Нарисуйте в системе координат вертикальную и горизонтальную осевые линии. 

3. Нарисуйте  (кривую второго порядка) в верхнем левом квадранте. 

 
Рисунок 36: Создание Кривой Второго Порядка 

4. Удалите наклонную осевую линию. 

5. Разместите левую конечную точку относительно осевой линии, используя диаметральный размер. 

Щелкните по . 

6. Выберите левую конечную точку, осевую линию и снова левую конечную точку. Щелкните по  
для размещения размера. 

7. Измените размеры, как показано на следующем рисунке. 

 
Рисунок 37: Измененные Размеры 

8. Выберите сечение кривой второго порядка. Щелкните по  (зеркальное отображение геометрии). 
Выберите вертикальную осевую линию. 

9. Повторите зеркальное отображение двух сечений кривых второго порядка относительно 
горизонтальной осевой линии. 

10. Завершите сечение, как показано на следующем рисунке. Удалите зависимость симметрии 
относительно горизонтальной линии и добавьте зависимость касательности. 
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Рисунок 38: Полностью Образмеренный Эскиз 

11. Выберите крайнюю правую вершину между верхней и нижней кривой. Щелкните по  > Start 
Point. 

12. Щелкните по . Щелкните No на запрос, если требуется перейти к следующему сечению. 

13. Введите глубину [100] для второго сечения. 

14.Введите глубину [200] для третьего сечения. 

15. Выполните предварительный просмотр и закрасьте модель. 

Совет: 
Есть возможность определить условия касания в первом и последнем сечении базового сопряжения 
(general blend). 

16. Определите первое сечение базового выдавливания касательным к основанию корпуса зеркала. 
Дважды щелкните по элементу Tangency. 

17. Щелкните Yes на запрос, если требуется определить касательную для первого конца. 

18. Выберите верхнюю поверхность для всех четырех касательных привязок, как показано на 
следующем рисунке. 

 
Рисунок 39: Выбор Привязок 
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19. Не определяйте условие касательности для второго конца. В ответ на запрос ответьте No. 

20. Постройте элемент. Щелкните OK для создания элемента. 

 
Рисунок 40: Завершенная Модель 

21. Сохраните модель и сотрите ее из оперативной памяти. 

Резюме 

В этой главе Вы научились: 
• манипулировать объектами в новой среде эскизирования. 
• Определять и изменять сплайны, а также считывать точки из внешнего файла. 
• Создавать и сохранять сечения эскиза для последующего использования. 
• Создавать эллипсы и определять различные схемы образмеривания в соответствии с 
назначением конструкции. 
• Создавать сечения по кривым второго порядка, когда сечение не является простым эллипсом. 
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Глава 2 
Уклоны и Скругления 
В этой главе обсуждается использование уклонов и скруглений для завершения 
конструкции детали. Вы также научитесь создавать переходы между несколькими 
скруглениями для более сложной геометрии. 

Цели 
В этой главе Вы изучите: 

• подготовку моделей для литья или штамповки путем добавления элементов уклона. 

• Добавление сложных уклонов к модели. 

• Создание скруглений с одной или несколькими ссылками. 

• Создание скруглений кромка-поверхность и поверхность-поверхность. 

• Создание скруглений по цепочке. 

Введение в Уклоны 

Определение 
Элемент Уклона добавляет уклоны к отдельным поверхностям или серии выбранных планарных 
поверхностей. Элемент уклона можно создавать путем добавления угла (+/- 30°) к существующим 
поверхностям штампованных или литых деталей. Уклон может добавлять или удалять материал от 
детали. 

 
Рисунок 1: Уклон для Поковки 
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Рекомендации по Использованию Уклонов 
Учитывайте следующее при создании уклонов: 

• создавать уклоны можно только для поверхностей, сформированных табулированными 
цилиндрами или плоскостями. 

• Направление уклона должно быть перпендикулярным к нейтральной плоскости, если 
поверхность уклона � цилиндрическая. 

• Нельзя создавать уклоны к поверхностям, имеющим скругления по кромке. Однако, можно 
сначала создать уклон, а затем скруглить кромки. 

• Для включения уклона в модель, имеющую скругления, уклон следует добавлять перед 
скруглением кромок. 

• При добавлении уклона к оболочковой детали перед добавлением элемента оболочки, 
система сохраняет постоянной толщину стенок. 

Создание Уклонов 

Следующий рисунок иллюстрирует процесс определения уклона элементы в модели. Элемент уклона 
можно применять к плоским, цилиндрическим и сплайновым поверхностям. 

 
Рисунок 2: Определения Уклона 
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Типы Уклона 
На следующем рисунке иллюстрируются все разновидности элемента уклона, доступные в 
Pro/ENGINEER. 

 
Рисунок 3:Разновидности Элемента Уклона 

Создание Уклонов с Нейтральной Плоскостью 
Для создания уклона с нейтральной плоскостью (neutral plane draft), можно выбратьвариант без 
разделения или с разделением поверхностей по плоскости или по эскизу. 

Если линия разъема поковки находится в середине поверхности уклона, разделите поверхности, как 
показано на следующем рисунке. 
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Рисунок 4: Уклоны с Нейтральной Плоскостью 

Создание Уклонов с Нейтральной Кривой 
Используйте уклон с нейтральной кривой, когда область, которая должна остаться с постоянным 
размером, не плоская. 

Для создания уклона по нейтральной кривой (neutral curve draft), можно выбрать без разделения или 
с разделением поверхностей по кривой или по поверхности. Как и в случае элемента уклона с 
нейтральной плоскостью, если линия разъема поковки находится в середине поверхности уклона � 
разделите поверхности. 

 
Рисунок 5: Уклон с Нейтральной Плоскостью без Разделения 
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Рисунок 6: Разделение по Поверхности Уклона 

 
Рисунок 7: Разделение по Кривой Уклона 

Введение в Скругления 

Определение 
Скругление � это элемент Pro/ENGINEER, который может добавлять или удалять материал из 
модели. Геометрия должна быть касательной к смежной геометрии во всех точках по кромке. 

Создание Простых Скруглений 
Простые скругления состоят из единственного набора привязок, в то время как сложные скругления 
могут содержать несколько наборов привязок вместе с различными опциями перехода в местах 
стыковки. 
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Рисунок 8: Простое и Сложное Скругления 

Для определения простого скругления можно использовать различные методы. Независимо от 
выбранного метода, необходимо определить элементы для определения формы, радиуса и 
местоположения элемента. 

Выбор Привязок 
Привязки для элементов скругления следует выбирать внимательно по двум причинам: 

• в случае удаления одной из привязок скругления система должна перестроить весь элемент 
скругления. 

• Тип выбранной привязки влияет на форму скругления и его удлинение. С этими опциями 
выбора следует поэкспериментировать для полной проработки геометрии скругления. 

 

 
Рисунок 9: Выбор Поверхностей Скругления 

При выборе поверхностей для набора геометрии скругления, Pro/ENGINEER пытается определить 
скругление касательным к выбранной поверхности. Если смежные поверхности касательны к 
выбранной поверхности или поверхностям, система автоматически пытается продолжить геометрию 
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скругления по этим касательным поверхностям. Однако, можно прекратить скругление до смежных 
поверхностей. 

Настройка Удлинения Скругления 
В некоторых случаях, можно продолжить элемент скругления или остановить его в некоторой точке на 
выбранных привязках, которые система предлагает автоматически. 

Примечание: 
Дополнительно выбранные привязки создают отношения родитель / потомок в элементе скругления. 

 
Рисунок 10: Опции Удлинения Скругления 

Определение Значений Радиуса 
После определения привязок, необходимо определить радиус скругления. 

• Постоянный радиус 

• Переменный радиус 

• По кривой 

• Полное скругление 
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Рисунок 11: Опции Радиуса 

Использование Точек или Вершин 

Можно выбрать опорную точку, вершину, кривую, или конечную точку кривой через которую должно 
пройти скругление. Выбранный объект должен лежать на поверхности, смежной с геометрией. 
Система не назначает радиусный размер скруглению. Радиус получается в зависимости от положения 
другой геометрии. 

Примечание: 
Использование точки или вершины для определения размера скругления создает отношения 
родитель / потомок между элементом скругления и выбранный точкой. 

Создание Сложных Скруглений 
Сложные скругления дают большую гибкость при создании трудоемкой геометрии. Одно из главных 
преимуществ элемента сложного скругления в том, что оно дает возможность создавать переходы 
между наборами скруглений. Набор скруглений � набор привязок с атрибутами и значениями радиуса, 
созданных с теми же опциями и атрибутами, что и простое скругление. Используя наборы скругления, 
можно комбинировать скругления "поверхность с поверхностью" со скруглением кромок или 
определять скругления с несколькими радиусами. 

Использование Переходов 
Создавая переходы между наборами скруглений, можно использовать большее количество различных 
геометрических форм в месте пересечения наборов без необходимости ограничивать гибкость 
модели. Элемент перехода также позволяет определить, как Pro/ENGINEER должен обрабатывать 
места пересечений наборов скруглений с геометрией модели. 
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Рисунок 12: Образец Переходов Скругления 

Установка Перехода по Умолчанию 

Переход между наборами скругления можно настраивать для соответствия форме геометрии 
скругления следующими способами: 

 
Рисунок 13: Переходы в Угле 

Создание Наборов Скруглений 
Наборы скруглений можно создавать путем прокатывания шара или скругляя поверхность 
перпендикулярно к спайну (spine). 

• Прокатывание шара напоминает прокатывание шара между двумя привязками. 

• Форма, перпендикулярная к спайну, похожа на создание поверхности скругления путем 
протягивания дуги перпендикулярно выбранному спайну. 

Настройка Формы Поперечных Сечений Скругления 
По умолчанию, система создает круговое поперечное сечение скругления определенное с истинным 
радиусом, но можно управлять поперечным сечением, используя коническое сечение. Скругление с 
таким сечением использует два значения для управления своей формой: значение радиуса и 
значение параметра кривой второго порядка (rho). 

• Значение радиуса определяет точку касательной модели. Значение Rho определяет форму 
собственной кривой второго порядка, как показано в предыдущем рисунке. Rho - отношение 
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ВЕ / DE, где сегменты AE =EC. Можно использовать значения параметра кривой второго 
порядка между .95 и .05. Некоторые из этих значений имеют определенный смысл: 

! от . 05 до < .5 эллиптическое скругление 

! 12 −   стандартный квадрант эллиптического скругления 

! . 5   параболическое скругление. 

! от > .5 до .95 гиперболическое скругление 

• Использование значения (истинного эллипса) для конического параметра создает круглую 
форму элемента скругления: 

 
Рисунок 14: "Rho" 

 
Рисунок 15: Форма Скругления 

Создание Геометрии Со Скруглениями 

При создании простых или сложных скруглений, можно применять методы использования 
поверхностей для проработки требуемой геометрии. Вместо создания всей геометрии скругления с 
использованием элементов поверхностей, можно фактически использовать элемент для генерации 
поверхности. При создании скругления, необходимо выбрать одну из следующих опций: 
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Рисунок 16: Создание Требуемой Геометрии 

Советы при Создании Скруглений 
В случае трудностей при создании конкретного элемента скругления, необходимо разбить его на 
отдельные элементы скруглений, или изменить на сложный тип скругления и добавить переход. Если 
эти методы не разрешают проблему, выполните что-либо из следующего: 

• укажите другой радиус. 

• Используйте другие опции скругления (Surf-Surf, Edge-Surf и т.д.) 

• Создайте скругление в виде поверхности. Используя методы натягивания поверхности, можно 
вручную исправить проблемные области. 

• Создайте элементы протягивания или выдавливания, вырезы и т.д. 

Лабораторный Практикум 

Цель 
В этом практикуме, Вы получите практические навыки создания элементов уклона и 
скругления в качестве завершающих элементов. 

Метод 
В Упражнениях 1 и 2, Вы изучите, как вставлять уклоны по нейтральной плоскости и нейтральной 
кривой. 

В Упражнении 3, Вы изучите некоторые углубленные методики создания уклонов. 

В Упражнении 4, Вы используете скругления для завершения задней части шарнира подвески. Так как 
эта деталь является отливкой, она потребует скруглений большинства кромок. Будут созданы 
скругления edge-to-surface (кромка-поверхность) и surface-to-surface (поверхность-поверхность) с 
использованием автосопряжения. 

В Упражнении 5, Вы изучите некоторые углубленные методики скругления. 

В Упражнении 6, Вы поэкспериментируете с различным контекстом скруглений по цепочке. 
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Инструменты 
Таблица 1: Пиктограммы для Создания Сложной Геометрии 

ПИКТОГРАММА ОПИСАНИЕ 

   список сохраненных видов 

   использовать кромку 

УПРАЖНЕНИЕ 1: Вставка Уклонов по Нейтральной Плоскости 
Задача 1. Открыть модель и вставить простой уклон. 

1. Открыть DRAFT_PLANE.PRT в соответствующем рабочем каталоге. 

 
Рисунок 17: Деталь 

2. Щелкните по Insert > Draft. 

3. Щелкните по , чтобы принять по умолчанию Neutral Pln. 

4. Щелкните по  еще раз, чтобы принять Tweak ,No Split ,Constant. 

5. Выберите две поверхности, показанные на следующем рисунке. 

 
Рисунок 18:Выбор Поверхностей для Уклона 

6. Щелкните по  >  и выберите поверхность, показанную на следующем рисунке в качестве 
нейтральной плоскости. 
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Рисунок 19:Выбор Нейтральной Плоскости 

7. Выберите Use Neut Pln для автоматического использования нейтральной плоскости в качестве 
плоскости привязки. 

8. Отображается стрелка, указывающее направление. Введите [-10] в качестве угла уклона. 

9. Щелкните по Preview и обратите внимание, что основание цилиндра увеличилось в размерах. 

10. Щелкните по  для завершения уклона. 

 
Рисунок 20:Завершенный Элемент Нейтрального Уклона 

Задача 2. Создать другой уклон с переменными углами. 

1. Щелкните по Insert > Draft > . 

2. Щелкните по Variable > Done. 

3. Щелкните по Intent Surfs и выберите поверхность, показанную на следующем рисунке. Система 
автоматически выбирает все боковые кромки выдавливание. 

 
Рисунок 21: Выбор Изменяемой Поверхности 

4. Щелкните по  и выберите опорный элемент ТОР в Дереве Модели в качестве нейтральной 
плоскости. 
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5. Выберите поверхность, показанную на следующем рисунке в качестве плоскости привязки. 

 
Рисунок 22: Выбор Плоскости Привязки 

6. Щелкните по  >  и введите углы уклона [+10] для левой части и [-10] для правой части. 

7. Щелкните по  для завершения элемента. 

 
Рисунок 23: Завершенная Модель с Переменными Углами 

8. Щелкните по Insert > Draft . Обратите внимание, что материал удаляется от верхней части и 
добавляется к основанию. 'Талия' остается неизменной. 

 
9. Измените два угла в правой части на [-20] и выполните Regenerate. 
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Рисунок 24: Регенерированная Модель с Переменными Углами 

Задача 3. Создать уклон, используя разделение по плоскости. 

1. Щелкните по Insert > Draft > . 

2. Щелкните по Split at Pln > . 

3. Щелкните по Intent Surfs и выберите поверхность, показанную на следующем рисунке. 

 
Рисунок 25: Выбор Изменяемой Поверхности 

4. Щелкните по  и выберите опорный объект ТОР в Дереве Модели в качестве нейтральной 
плоскости. 

5. Выберите поверхность, показанную на следующем рисунке в качестве плоскости привязки. 

 
Рисунок 26: Выбор Плоскости Привязки 
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6. Введите угол уклона [+13] и щелкните по  для завершения элемента. 

 
Рисунок 27: Завершенный Элемент Уклона 

Задача 4. Исследовать гибкость уклона, созданного на основании изменяемой цепочки. 

1. Выберите HEX из Дерева Модели и щелкните по  > Redefine. 

2. Войдите в эскиз и удалите шесть линий, оставляя конструктивную окружность. 

3. Нарисуйте сплайн, подобный изображенному на следующем рисунке. 

 
Рисунок 28: Эскиз Сплайна 

4. Завершите переопределение и посмотрите, как уклон адаптируется к новой геометрии. 

 
Рисунок 29: Переопределенный Элемент Уклона 

5. Сохраните модель и закройте окно. 
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УПРАЖНЕНИЕ 2: Вставка Уклона по Нейтральной Кривой 
Задача 1. Открыть модель и вставить уклон с разделением по поверхности в верхней модели. 

1. Откройте DRAFT_CURVE.PRT 

 
Рисунок 30: Элемент Уклона по Нейтральной Кривой 

2. Щелкните по Insert > Draft > Neutral Curve > Done. 
3. Щелкните по Tweak > Split at Srf > Both Sides > Dependent > Constant > Done. 

4. Выберите поверхности, показанные на следующем рисунке, используя Indiv Surfs. 

 
Рисунок 31: Выбор Индивидуальных Поверхностей 

5. Щелкните по Intent Surfs. Выберите скругление, показанное на следующем рисунке. Щелкните по 
Done для продолжения. 
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Рисунок 32: Выбор Поверхности Скругления 

6. Этот тип уклона требует двух нейтральных кривых (или набора кромок). Для первой кривой 
используйте Tangent Chain, чтобы выбрать верхний набор кромок, как показано на следующем 
рисунке. 

 
Рисунок 33: Выбор Верхнего Набора Кромок 

7. Щелкните по Done > Tangent Chain, чтобы выбрать нижний набор кромок, как показано на 
следующем рисунке. 

 
Рисунок 34: Выбор Нижнего Набора Кромок 
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8. Щелкните по Done. Выберите поверхность разъема. Щелкните по Sel By Menu > Parting_Quilt > 
Select. 

9. Для выбора плоскости направления растяжения (pull direction), щелкните по Sel By Menu > Top > 
Select . 
10. Обратите внимание на направление зеленой стрелки уклона, введите [10.0°] и ОК. 

Задача 2. Вставить разделение уклона по кривой в нижней модели 

1. Вставьте другой уклон по нейтральной кривой. Используйте атрибуты Tweak > Split at Crv > Both 
Sides > Dependent > Constant. 
2. Используйте предыдущие методы для выбора поверхностей нижней модели, как показано на 
следующем рисунке. 

 
Рисунок 35: Выбор Поверхности в Нижней Модели 

3. Для выбора нейтральной кривой, щелкните по Curve Chain. Выберите опорную кривую. Затем 
щелкните по Select All > Done. 

4. Выберите плоскость OFFSET в качестве плоскости привязки. 

5. Обратите внимание на направление зеленой стрелки уклона, введите [10°] и щелкните по ОК. 

6. Выберите плоскость OFFSET и используйте  > Modify для изменения размера смещения на 
[2.0]. 

7. Щелкните по  > Front и измените масштаб изображения, как показано на следующем рисунке. 
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Рисунок 36: Вид Спереди 

8. Обратите внимание, что верхняя модель увеличилась в размере, в то время как нижняя модель 
уменьшилась. 

9. Сохраните модель и закройте окно. 

Упражнение 3 � Необязательное: Создание Сложных Уклонов 
Задача 1. Открыть DRAFT_SKETCH.PRT и создать уклон на прямоугольном выдавливании в верхней 
части детали, используя не-параллельную нейтральную плоскость и плоскость привязки. 

1. Откройте DRAFT_SKETCH.PRT. 

 
Рисунок 37: Образец Детали для Создания Уклона 

2. Щелкните по Insert > Draft >  > . 

3. Выберите поверхности, которые нужно наклонить, как показано на следующем рисунке. 

 
Рисунок 38: Выбор Поверхностей для Уклона 
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4. Выберите нейтральную плоскость, как показано на следующем рисунке. 

 
Рисунок 39: Выбор Нейтральной Плоскости 

5. Выберите опорную плоскость ТОР из Дерева Модели в качестве плоскости привязки для отсчета 
угла. 

6. Введите [-5.0] в качестве угла уклона и завершите элемент. 

7. Щелкните по  > Front и изучите созданные углы уклона. 

 
Рисунок 40: Углы Уклона 

Задача 2. Вставить разделение уклона по эскизу. 

1. Щелкните по Insert > Sketch. 

 
Рисунок 41: Вставка Разделения по Эскизу 
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2. Щелкните по Insert > Draft >  . 

3. Щелкните по Split at Skt >  . 

4. Выберите поверхность, показанную на следующем рисунке в качестве поверхности уклона. 

 
Рисунок 42: Выбор Поверхности Уклона 

5. Выберите поверхность, показанную на следующем рисунке в качестве нейтральной плоскости. 

 
Рисунок 43: Выбор Нейтральной Плоскости 

6. На запрос эскизной плоскости, выберите поверхность уклона. 

7. Выберите опорный элемент ТОР в качестве верхней плоскости привязки. 

8. Щелкните по Insert > Sketch. 

9. Щелкните по  и выберите пять сегментов опорной кривой, как показано на следующем рисунке. 
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Рисунок 44: Выбор Сегментов Опорной Кривой 

10. Завершите эскиз, введите [-7.0] и [7.0] в качестве углов уклона и завершите элемент. 

 
Рисунок 45: Завершенная Модель 

11. Сохраните модель и закройте окно. 

УПРАЖНЕНИЕ 4: Создание Простых и Сложных Скруглений 
Задача 1. Вставить скругление "кромка-поверхность" для создания гладкого перехода в месте, где 
шарнир получает коническую форму и соединяется с подвесной тягой. 

1. Откройте RR_KNUCKLE.PRT. 
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Рисунок 46:Шарнир 

2. Щелкните по Insert > Round > Simple > Done. 

3. Определите атрибуты скругления. Щелкните по Constant > Edge-Surf > Done. 

4. Выберите кромку и цилиндрическую поверхность, как показано на следующем рисунке. 

 
Рисунок 47: Выбор Кромки и Цилиндрической Поверхности 

5. Введите [1.0] в качестве радиуса и щелкните по ОК для создания скругления. 

6. Повторите скругление для другой стороны детали. 
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Рисунок 48: Повтор Элемента Скругления 

Задача 2. Вставить скругление между основным телом детали и нижним цилиндром, который 
соединяется с подвеской. 

1. Щелкните по Insert > Round > Simple > Done. 

2. Определите атрибуты скругления. Щелкните по Constant > Surf-Surf > Done. 

3. Выберите две поверхности, показанные на следующем рисунке. 

 
Рисунок 49: Выбор Поверхностей 

4. Введите [0.5] в качестве радиуса и щелкните по ОК для создания элемента. 
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Рисунок 50: Модель После Создания Элемента 

5. Щелкните по Insert > Round > Advanced > Done. 

6. Определите атрибуты для набора. Щелкните по Constant > Surf-Surf > Done. 

7. Выберите две поверхности привязки, как показано на следующем рисунке. 

 
Рисунок 51: Выбор Привязок 

8. Введите [0.2] в качестве радиуса. Щелкните по ОК, чтобы принять набор скругления. 

9. Щелкните по Done Sets > Preview для просмотра геометрии. Обратите внимание, что нижняя 
кромка скругления прямая. 

 
Рисунок 52: Просмотр Геометрии 
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Задача 3. Добавить переход к скруглению 

1. Щелкните по Transitions > Define. 

2. Определите кромки, между которыми будет создан переход. Выберите две внутренних зеленых 
кромки. Щелкните по Done Sel > Done > Done Trans. 

3. Обратите внимание, что система автоматически добавляет сопрягающий переход (blend transition). 

 
Рисунок 53: Автоматический Сопрягающий Переход 

4. Щелкните по ОК для создания скругления. 

5. Сохраните деталь и сотрите ее из оперативной памяти. 

УПРАЖНЕНИЕ 5: Создание Сложных Скруглений 
Задача 1. Использовать функциональные возможности скругления. 

1. Откройте MULTI_ROUND.PRT 

 
Рисунок 54: Деталь с Несколькими Скруглениями 

2. Откройте сохраненный вид. Щелкните по  > Quick _Round. 

3. Вставьте полное скругление. Щелкните по Insert > Round > Simple. Используйте атрибуты для Full 
Round > Edge Pair. 
4. Выберите кромки, показанные на следующем рисунке. Щелкните по ОК. 
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Рисунок 55: Выбор Кромок 

5. Щелкните по  для выбора кромки, показанной на следующем рисунке. Щелкните по  > 
Round Edges. 

 
Рисунок 56: Выбор Кромок для Скругления 

6. Протяните радиус до требуемого значения, и щелкните  на фоне. 

 
Рисунок 57: Перетаскивание Радиуса 
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Подсказка: 

Скругление может быть динамически отредактировано в любой момент при помощи  > Dynamic 
Modify. 

Задача 2. Поэкспериментируйте с переходами скруглений. 

1. Вызовите сохраненный вид. Щелкните по  > Mult_Trans. 

 
Рисунок 58: Серия Переходов 

2. Вставьте сложное скругление. Щелкните по Insert > Round > Advanced. 

3. Определите атрибуты первого набора скругления. Щелкните по Variable > Edge Chain и выберите 
касательную цепочку, показанную на следующем рисунке. 

 
Рисунок 59: Определение Атрибутов Первого Набора Скругления 

4. Щелкните по Done > Done и введите значения радиусов [0.0] и [2.50]. 

5. Щелкните по ОК > Add для начала определения второго набора скругления. 

6. Щелкните по Constant > Edge Chain. Выберите кромку ниже и щелкните по Done. 
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Рисунок 60: Выбор Кромки 

7. Введите радиус [1.50] и щелкните по ОК > Done sets для завершения набора скругления 2. 

8. Щелкните по Transitions > Add by Select, выберите левую зеленую кромку набора скругления 2 и 

нажмите  >  . 

9. Щелкните по Stop at Pnt > Done и выберите опорную точку с названием STOP. Щелкните по  > 

 . 

 
Рисунок 61: Щелчок по Опорной Точке Stop 

10. Начните определение набора скругления 3. Щелкните по Round Sets > Add. 

11. Установите атрибуты в Constant > Edge Chain и используйте Tangent Chain для выбора кромок, 
показанных на следующем рисунке. 

 
Рисунок 62: Установка Атрибутов Кромки 

12. Введите радиус [1.50] и щелкните по ОК > Done Sets. 
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13. Щелкните по Transitions > Add By Select. Выберите три (зеленые) кромки, как показано на 
следующем рисунке: 

 
Рисунок 63: Выбор Кромок для Переходов 

14. Щелкните по , и просмотрите доступные типы переходов, перемещая мышь по опциям меню 
Intersect, Corner Sphere, Corner Sweep и Patch. 

15. Выберите требуемый тип перехода и щелкните по  > Done Trans > Preview. 

16. Выберите между  и . На следующем рисунке показана сфера в угле. 

 
Рисунок 64: Твердотельная Модель 

 
Рисунок 65: Каркасное Отображение 
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17. Щелкните по Transitions > Redefine > Transition 2. Выберите другой тип перехода и завершите 
элемент скругления. На следующем рисунке показано протягивание в угле. 

 
Рисунок 66: Протягивание в Угле 

 
Рисунок 67:Каркасное Отображение 

18. Повторите процесс переопределения для других двух типов перехода. 

Задача 3. Использовать другие типы переходов в скруглении. 

1. Щелкните по  для вызова сохраненного вида Blend_Cont 
2. Вставьте скругление, используя Advanced, Constant и Surf-Surf. Выберите две поверхности, 
показанные на следующем рисунке. 

 
Рисунок 68: Выбор Поверхностей 
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3. Введите радиус [5.25], и обратите внимание, что скругление заполняет все вокруг. 

Совет: 
Используйте опорную точку CNTR для изменения центра вращения и более легкого манипулирования. 

4. Завершите Набор Скругления 1, щелкните по Transitions и выберите две кромки (зеленые), как 

показано на следующем рисунке и щелкните по . 

 
Рисунок 69: Выбор Кромок 

5. Щелкните по Blend Surfs и  >  >  > Preview. 

6. Закрасьте и повращайте для просмотра перехода. Не щелкайте по ОК. 

7. Скругление выглядит гладким и непрерывным на первый взгляд, однако, диаграмма кривизны 
покажет другое. 

8. Щелкните по Analysis > Surface Analysis. Выберите все поверхностные заплатки скруглений и 

щелкните по . Обратите внимание, что диаграмма искривления имеет прерывистости. 

 
Рисунок 70: Отображение Прерывистости на Диаграмме Кривизны 
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9. Закройте диалоговое окно SURFACE ANALYSIS, удалите переход и добавьте переход Continue в 
его место. 

10. Повторно выполните Surface Analysis и обратите внимание, что кривизна непрерывна. 

 
Рисунок 71: Непрерывная Кривизна 

Задача 4. Вставить скругление по опорной кривой 

1. Щелкните по  для вызова сохраненного вида Thru_Curve. 

2. Вставьте скругление, используя Simple > Thru Curve > Edge Chain, и выберите Tangent chain, 
показанный на следующем рисунке. 

 
Рисунок 72: Выбор Касательной Цепочки (Tangent Chain) 

3. Используйте Curve Chain и Select All для выбора всей опорной кривой. 

4. Щелкните по Rnd_Curve в Дереве Модели, и щелкните по  > Hide. Обратите внимание, как 
скругление следует за контуром кривой. 
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Рисунок 73: Скругление Следует За Контуром Кривой 

5. Необязательно: Измените эскиз Сплайна и регенерируйте скругление. 

УПРАЖНЕНИЕ 6: Создание Изменямых Цепочек 
Задача 1. Поэкспериментировать с Изменяемыми Цепочками (Intent Chain) 

1. Щелкните по  > Intent Chain. 

2. Щелкните по Insert > Round >  >  > Intent Chain, и Query Select в вершине, показанной на 
следующем рисунке. 

 
Рисунок 74: Выбор Вершины 

3. Существуют три возможных опции для элемента 51 (выдавливание в форме усиков), как показано в 
окне сообщения: 

• Изменяемая Цепочка (F51 X PART) 

• Изменяемая Цепочка (SIDE SRFS F51 X START SRFS F37) 

• Изменяемая Цепочка (SIDE EDGES) созданная элементом 51 

4. Примите третью опцию, щелкните по Done, введите радиус [1.0] и щелкните по ОК. 

Задача 2. Полностью переопределить эскиз и посмотреть на изменение скругления. 

1. Выберите Protrusion_C и переопределите Эскиз. 

2. Удалите все эскизные объекты, оставляя нетронутыми привязки. 

3. Сделайте эскиз прямоугольника, как показано на следующем рисунке. 
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Рисунок 75: Эскиз Прямоугольника 

4. Завершите элемент и обратите внимание на адаптируемость «Боковых Кромок» Изменяемой 
Цепочки управляемого скругления. 

 
Рисунок 76: Адптируемость Боковых Кромок 

5. Переопределите Protrusion_C на две стороны с глубиной [24.0]. 

6. Вызовите сохраненный вид Intent_Bot. Затем щелкните по View > Previous. 

7. Выберите Prot_F51, и  > Suppress. Разрешите подавление его связанного скругления. 

Задача 3. Создать другое скругление по Изменяемой Цепочке 

1. Повторите вышеупомянутую процедуру для вставки другого Скругления по Изменяемой Цепочке 
Prot_F50 .Выполните Query Sel для кромки, показанной на следующем рисунке и примите 
Изменяемую Цепочку (F50 X PART). 
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Рисунок 77: Вставка Другой Изменяемой Цепочки 

2. Введите радиус [1.0] и завершите элемент. 

3. Повторите для Prot_F49, но не используйте Изменяемую Цепочку (SIDE SRFS F49 X START SRFS 
F37). 

Примечание: 
Оба скругления визуально будут идентичны на этом этапе. 

4. Выберите сохраненный вид Intent_Top, выберите Prot_F50, и  > Modify. 

5. Щелкните по вертикальному размеру [10.0], измените его на [2 5] и выполните регенерацию. 

 
Рисунок 78: Выбор Вертикального Размера 

6. Выберите сохраненный вид Intent_Top, выберите PROT_F50, и  > Modify. 
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7. Щелкните  по вершине, показанной на следующем рисунке и протяните сечение, 
приблизительно, как показано на следующем рисунке. Выполните регенерацию. 

 
Рисунок 79: Регенерация Модели 

8. Обратите внимание на гибкость скругления. 

 
Рисунок 80: Гибкость Элемента Скругления 

9. Повторите процедуру протягивания для Prot_F49. Обратите внимание на различие в элементе 
скругления, оно взаимодействует только со своей изменяемой цепочкой (intent chain) (SIDE SRFS F49 
X START SRFS F37). 
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Рисунок 81: Элемент Скругления Взаимодействует Только со Своей Изменяемой Цепочкой 

10. Снова повторите процедуру протягивания на Prot_F50, как показано на следующем рисунке. 

 
Рисунок 82: Повторение Процедуры Протягивания 

11. Переопределите Prot_F49 и Prot_F50 с Одностороннего (One Side) на Двухсторонний (Both Sides), 
используя глубину [24.0]. 

12. Вызовите сохраненный вид Intent_Bot. 
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Рисунок 83: Отличающиеся Изменяемые Цепочки 

13. Обратите внимание, как две изменяемые цепочки, показанные выше, различаются, и щелкните по 
View > Previous. 

14. Создайте окончательное скругление, используя Изменяемую Цепочку �(END EDGES), созданную 
элементом 49�, как показано. Используйте радиус [0.50] 

 
Рисунок 84: Создание Окончательного Скругления 

15. Переопределите Эскиз для Prot_F49. Удалите всю геометрию, и нарисуйте окружность радиусом 
2.5. Закончите элемент и посмотрите, как адаптируется скругление. 
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Рисунок 85: Скругление Адаптируется к Новым Критериям 

Резюме 

В этой главе, Вы узнали как: 

• подготовить модель для отливки или штамповки путем добавления элементов уклона. 

• Использовать сложные типы уклонов для более сложных приложений. 

• Вставлять скругления с одним или несколькими наборами привязок. 

• Определять значения радиусов для скруглений. 

• Создавать переходы между наборами скруглений для более сложной геометрии. 

• Использовать различные скругления по изменяемым цепочкам (intent chain) 
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Глава 3  
Создание Сложной Геометрии 
В этой главе, Вы изучите, как использовать углубленные методики для создания и 
управления конструктивными элементами, отсутствие которых потребует нескольких 
шагов для создания. 

Цели 
После завершения этой главы Вы научитесь: 

• создавать сопряжения путем протягивания (swept blends). 

• Создавать элементы протягивания через переменные сечения (variable section sweeps). 

• Описывать типы различных сечений элемента протягивания и их назначение. 

• Описывать цели использования спиралевидных элементов протягивания. 

Сопряжение Протягиванием 

Элементы сопряжения протягиванием и элементы протягивания с переменными сечениями 
позволяют воплотить назначение конструкции модели следующим образом: 

• следовать по указанной траектории, которая контролируется параметрически. 

• Изменять поперечное сечение элемента вдоль указанной траектории. 

Создание Спайнов 
Для создания элемента сопряжения протягиванием, используется сопряжение нескольких поперечных 
сечений вдоль отдельной траектории, называемой спайном (spine). 

 
Рисунок 1: Элемент Сопряжения Протягиванием 
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• Поперечные сечения можно определять путем эскизирования или выбором их в указанной 
вершине сегмента или в опорных точках, размещенных на кривой. Спайновую траекторию 
можно создавать в виде разомкнутой или замкнутой петли. 

• При создании элемента сопряжения протягиванием можно определять дополнительные 
элементы, используя Blend Control и Tangency. 

Использование Элементов Сопряжения Протягиванием 
• Для создания элемента протягивания сопряжением все сечения должны пересекать 

траекторию. 

• Для использования замкнутой траектории необходимо создать два сечения: одно в начальной 
точке, второе в любом другом месте. 

• Для использования разомкнутой траектории используются сечения в начальной и конечной 
точках. 

• Для определения сечений элемента сопряжения протягиванием используются сегменты 
подлежащей кривой (underlying curve) или кромки, из которых создается составная кривая 
(composite curve). 

Элемент Протягивания через Переменные Сечения 

Для создания элемента протягивания через переменные сечения (VSS) одно переменное сечение 
протягивается вдоль одной или нескольких траекторий. 

Создание Спайнов, Нормальных к Оригиналу 
При создании спайнов, нормальных к оригиналу (normal-to-original spines), учитывайте следующие 
требования: 

• необходимо определить не менее одной дополнительной траектории, называемой х-вектором 
или траекторией к горизонтальному вектору. 

• Система использует эту траекторию для ориентирования сечения в процессе протягивания. 

• Плоскость сечения всегда перпендикулярна спайну в их месте пересечения, как показано на 
следующем рисунке. 
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Рисунок 1: Воздействие X-Вектора 

Придание Формы Дополнительными Траекториями 
После определения спайна и x-вектора, можно выбрать или нарисовать дополнительные траектории 
для определения формы протягиваемого сечения. 
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Рисунок 2: Использование Нескольких Траекторий 

Примечание: 
Не следует выполнять точное совмещение с известными вершинами. По возможности, следует 
избегать ненужного выравнивания в сечениях элемента протягивания через переменные сечения. 

Использование Параметра Траектории 
Когда система регенерирует элемент протягивания через переменные сечения, она автоматически 
оценивает внутренний параметр называемый trajpar (параметр траектории) . Это нормализованное 
значение между 0 и 1, представляющее процентную длину элемента протягивания в каждой точке 
вдоль траектории спайна. 

В начале элемента протягивания, значение trajpar - 0; в конце - 1. Можно использовать это значение в 
своих целях, записывая уравнения для управления сечением. 
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Рисунок 3: Использование Trajpar для Управления Сечением 

Параметр trajpar можно использовать для сведения поверхностей в нуль в любой точке траектории, 
используя сложные уравнения, управляющие сечением, или путем оценки элемента Опорной 
Диаграммы (evalgraph). 

 
Рисунок 4: Сведение Поверхности в Нуль 
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Рисунок 5: Использование Элемента Опорной Диаграммы 

Использование Элемента Протягивания Через Переменные Сечения 
При создании элементов протягивания через переменные сечения, учитывайте следующие 
требования: 

• элемент протягивания через переменные сечения не может являться первым элементом в 
модели, т.к. сначала используются опорные элементы по умолчанию. 

• Спайновая кривая должна содержать только касательные объекты, если не используется 
опция Pivot Dir. 

• Траектория х-вектора не может пересекать спайн. Однако любая конечная точка может 
находиться на спайне. 

• Все дополнительные траектории должны пересекать эскизную плоскость элемента 
протягивания, но они не обязательно должны иметь ту же длину, что и спайновая траектория. 

• Плоскость эскиза элемента протягивания может пересекать любую траекторию только один 
раз в любой данной точке элемента. 

• Если плоскость эскиза элемента протягивания не может пересечь все траектории в начальной 
точке элемента протягивания, можно использовать опорную точку (на спайне) для 
определения начальной точки. 
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Рисунок 6: Использование Опорной Точки для Определения Эскизной Плоскости 

Ориентирование Поперечных Сечений 
Элемент сопряжения протягиванием и элемент протягивания через переменные сечения позволяют 
контролировать, как система протягивает поперечное сечение относительно спайновой траектории. 

Следующие опции позволяют гибко определить элемент, позволяя указать ориентацию его 
поперечного сечения. 

• Перпендикулярно исходной траектории 

 
Рисунок 7:Перпендикулярно Исходной Траектории 

• Перпендикулярно траектории 

 
Рисунок 8: Перпендикулярно Выбранной Траектории 
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Рисунок 9: Перпендикулярно Центральной Плоскости (Pivot Plane) 

Спиралевидные Элементы Протягивания 

Для создания спиралевидного элемента протягивания, протягивается единственное сечение вдоль 
спиральной траектории, которая определяет профиль и значение шага. 

Создание Спиралевидных Элементов Протягивания 
• Сначала необходимо указать профиль элемента протягивания, используя Среду 

эскизирования. Следующий рисунок иллюстрирует сечение профиля и результирующий 
элемент пружины. 

 
Рисунок 6: Сечение Профиля и Элемент Пружины 

• Легко могут быть созданы разновидности профиля. Следующий профиль имеет три линейных 
сегмента. 
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Рисунок 7: Вариации Профиля с Тремя Линейными Сегментами 

• После определения профиля необходимо указать значение используемого шага. 

• После ввода шага необходимо нарисовать поперечное сечение. В примере выше сечением 
является обычная окружность, центрируемая в месте пересечения осевых линий. 

• Затем, система протягивает сечение по спирали с указанным шагом. 

Опции Спиралевидного Элемента Протягивания 
• Правая (Right) или Левая (Left) закрутка 

 
Рисунок 8: Правая и Левая Закрутка Спиралевидного Элемента Протягивания 

• По оси (Thru Axis) или Перпендикулярно траектории (Normal to Traj). 

 
Рисунок 9: Опции По Оси и Перпендикулярно Траектории 
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• С постоянным (Constant) или Переменным (Variable) шагом 

 
Рисунок 10:Элемент Протягивания с Постоянным и Переменным Шагом 

• При помощи эскизных точек и диаграммы можно управлять шагом, когда используется 
переменный шаг. Эскизные точки располагаются на исходном профиле, как показано на 
следующем рисунке. 

 
Рисунок 11: Эскизные Точки на Исходном Профиле 

• При добавлении исходных точек, они могут добавляться в соответствии с диаграммой шага 
(pitch graph), а значения шага для каждой точки вводятся, как показано на следующем рисунке. 

 
Рисунок 12: Значения Шага в Различных Точках 
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Лабораторный Практикум 

Цель 
В этом практикуме, Вы изучите методы, используемые при создании элементов 
сопряжения путем протягивания и элементов протягивания через переменные сечения. 

Метод 
В Упражнении 1, Вы создадите элемент сопряжения путем протягивания, включая все шаги, 
необходимые для создания узла впускное отверстие двигателя для карта. 

В Упражнении 2, элемент протягивания через переменные сечения создается с использованием 
диаграммы. 

Далее, Вы исследуете возможности элемент протягивания через переменные сечения, используя 
элементы trajpar и datum graph при создании геометрии. 

Инструменты 
Таблица 1: Пиктограммы для Создания Сложной Геометрии 

ПИКТОГРАММА ОПИСАНИЕ 

   Список сохраненных видов 

   Использование кромки 

   Отступ кромки 

   Выбор геометрии 

   Зависимость коллинеарности 

УПРАЖНЕНИЕ 1: Использование Элементов Сопряжения Протягиванием 
Задача 1. Открыть модели и сконфигурировать отображение. 

1. Сотрите все предыдущие модели из оперативной памяти и откройте ENGINE_BLOCK.PRT в 
соответствующем каталоге. 

2. Щелкните по  > Intake. 

 
Рисунок 13: Впускное Устройство Модели Блока Двигателя 

3. Изучите геометрию, составляющую впускное отверстие блока двигателя и закройте окно. 
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4. Откройте CARB_INTAKE_PORT.PRT. 

 
Рисунок 14: Модель Carb_Intake_Port 

5. Обратите внимание на лоскутные поверхности. Они являются элементами Скопированной 
Геометрии, отражающей геометрию, перемещенную с блока двигателя, рассмотренного ранее. 

Задача 2. Использовать скопированную геометрию и имеющиеся опорные кривые для создания 
детали ответного впускного коллектора, который «точно соответствует» и по касательной стыкуется с 
внутренними поверхностями. Начните с определения траектории. 

1. Выберите первый элемент Скопированной Геометрии (Copy Geometry) в Дереве Модели и 

щелкните по  > Hide. 

2. Щелкните по Insert > Protrusion > Swept Blend. 

3. Щелкните по Select Sec > NrmToOriginTraj > Done. 

4. Щелкните по Select Traj > Curve Chain и выберите опорную кривую, показанную на следующем 
рисунке. 

 
Рисунок 15: Выбор Опорной Кривой 

5. Щелкните по Select All > Done. 

Задача 3. Определить поперечные сечения для элементов сопряжения протягиванием 

1. Используя Select Curve, выберите восемь сегментов опорной кривой, которые формируют контур, 
показанный на следующем рисунке. Обратите внимание на местоположение начальной точки. (Можно 
использовать другую начальную точку). 
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Рисунок 16: Выбор Сегментов Опорной Кривой 

Совет: 
Используя опцию Sel Chain можно легко выбрать несколько непрерывных сегментов кривой. 

1. Щелкните по Done и используйте ту же методику для выбора восьми сегментов кривой для второго 
сечения, как показано на следующем рисунке. 

 
Рисунок 17: Выбор Кривой 

2. Убедитесь, что начальные точки этих двух сечений совмещены. При необходимости, щелкните по 
Start Point и выберите новое местоположение. 

3. Щелкните по Done > No > OK для завершения элемента. 

 
Рисунок 18: Завершенный Элемент 

Задача 4. Используя возможности элемента сопряжения протягиванием, создайте вырез, 
сохраняющий касательную к скопированной геометрии. 

1. Щелкните по Insert > Cut > Swept Blend > Done. 

2. Щелкните по Select Traj > Curve Chain. 

3. Выберите ту же кривую, которая использовалась в качестве траектории для выдавливания и 
щелкните по Select All. Необходимо использовать ту же начальную точку, что и для выдавливания. 
Щелкните по Done . 

4. Щелкните по Automatic > Done для автоматической ориентации эскизной плоскости. 

5. Щелкните по Next, чтобы пропустить определение промежуточных сечений. 
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6. Введите [0.0] для вращения вокруг оси Z. 

7. Щелкните по  > Chain и выберите две кромки скопированной геометрии, как показано на 
следующем рисунке. 

 
Рисунок 19: Выбор Кромки 

8. Щелкните по Accept для выбора всего контура. Обратите внимание на местоположение начальной 
точки. 

9. Щелкните по  > Automatic > Done. 

10. Введите [0.0] для Вращения вокруг оси Z. 

11. Щелкните по  > Loop и выберите поверхность, показанную на следующем рисунке. 

 
Рисунок 20: Выбор Поверхности 

9. Введите [-.125] для смещения. 

10. Начальная точка должна быть совмещена с начальной точкой первого сечения. При 

необходимости, выберите требуемое местоположение и щелкните по  > StartPoint. 

11. Щелкните по . Стрелка удаления материала должна указывать во внутрь сечения. Щелкните по 
ОК. 

12. Щелкните по Preview. Обратите внимание, что между вырезом и поверхностями скопированной 
геометрии имеется острый переход. (Поверхности на следующем рисунке показаны с использованием 
Анализа Поверхностей Методом Гауссовой Кривизны). 
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Рисунок 21: Анализ Поверхностей Методом Гауссовой Кривизны 

Задача 5. Устранить 'выступ', определяя касательную 

1. Щелкните по Tangency > Define. 

2. Щелкните по Yes для создания касательного сопряжения в первом конце. 

3. Система подсвечивает сечение синим цветом, а кромку отображает красным. 

 
Рисунок 22: Система Подсвечивает Кромку 

4. Выберите поверхность, показанную на следующем рисунке в качестве привязки касательной для 
подсвеченной кромки. 

 
Рисунок 23: Стандартная Привязка Поверхности для Кромки 

5. Продолжайте последовательно выбирать касательные поверхности для каждой подсвеченной 
красной кромки. 

Совет: 
Используйте Query Sel при определении касательной для сопряжения. Нельзя изменять одну из 
кромок по ходу построения (on the fly). Если, по ошибке, выбрана неправильная привязка, необходимо 
повторить весь процесс. 

6. Щелкните по No, чтобы не определять касательную на другом конце. 
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7. Щелкните по Preview. Обратите внимание, что вырез касателен к поверхностям впускного 
отверстия двигателя. (Поверхности на следующем рисунке показаны с использованием Анализа 
Поверхностей Методом Гауссовой Кривизны). 

8. Щелкните по ОК. 

 
Рисунок 24: Вырез Касателен к Поверхностям Впускного Отверстия Двигателя 

9. Скройте оставшиеся элементы Скопированной Геометрии. 

 
Рисунок 25: Модель После Скрытия Элементов 

2. [Необязательно] Создайте крепежные ушки на каждом конце узла подвода для завершения детали, 
как показано на следующем рисунке. 

 
Рисунок 26: Модель с Крепежными Ушками 

3. Сохраните деталь и закройте окно. 

УПРАЖНЕНИЕ 2: Создание Привязочных Кривых Элемента Протягивания 
Через Переменные Сечения 

Задача 1. Использовать опорные кривые в качестве траектории элемента протягивания через 
переменные сечения. 

1. Откройте BOTTLE.PRT 
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Рисунок 27: Исходная Модель 

Задача 2. Создать элемент протягивания через переменные сечения для тела бутылки. Начните с 
определения траектории 

1. Щелкните по Insert > Protrusion > Variable Section Sweep > NrmToOriginTraj > Done. 

2. Щелкните по Select Traj и выберите опорную кривую, показанную на следующем рисунке. 

 
Рисунок 28: Выбор Опорной Кривой 

3. Щелкните по  и проверьте, что начальная точка находится в нижней части кривой. (Если 
необходимо, щелкните по Start Point и измените). 

4. Щелкните по  > Select Traj > Curve Chain для определения X-вектора. 

5. Выберите крайнюю правую кривую. Щелкните по Select All >  . 

6. Продолжайте использовать Select Traj > Curve Chain и Select All >  для выбора оставшихся 
кривых в любом порядке. 

7. Щелкните по  . 
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Задача 3. Определите поперечное сечение. 

1. Нарисуйте прямоугольник со всем четырьмя сторонами, привязанными к существующим точкам 
эскиза. Нарисуйте сопряжения и, затем, образмерьте / привяжите, как показано на следующем 
рисунке. 

 
Рисунок 29: Скругления и Зависимости 

2. Щелкните по  > ОК. 

3. Скройте все опорные кривые, используя Дерево Модели. Обратите внимание, что вершина бутылки 
не цилиндрическая, а радиус на углах постоянен. 

 
Рисунок 30: Анализ Модели Бутылки 

Задача 4. Создать опорную диаграмму, которая будет управлять радиусом на углах бутылки. 

1. Щелкните по Insert > Datum > Graph. 

2. Введите [radius]. 

3. Для сохранения времени, вставьте ранее созданный эскиз. Щелкните по Sketch > Data From File > 
Radius.sec > Open. 
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Рисунок 31: Вставка Существующего Эскиза 

4. Обратите внимание на следующее: 

• диаграмма имеет 140 единиц по оси 'X', которая является высотой траектории спайновой 
кривой. 

• Диаграмма имеет горизонтальные сегменты по оси 'Y' со значениями 115 и 50. Деление 
каждого на 5 дает 23 и 10, которые относятся к размерам исходных кривых. 

5. Щелкните по . 

6. Для управления элементом протягивания через переменные сечения посредством радиуса, взятого 
из диаграммы, переупорядочьте его перед элементом протягивания через переменные сечения путем 
перетаскивания в Дереве Модели. 

Задача 5. Переопределить элемент протягивания через переменные сечения и связать его с 
диаграммой. 

1. Выберите выдавливание в Дереве Модели и щелкните по  > Redefine > Section > Sketch. 

2. Щелкните по Sketch > Relations > Add. 

3. Выясните номер размера для радиуса (в нашем примере Sd9). 

 
Рисунок 32: Размер Номер sd9 

4. Используя номер размера, введите [SD9=EVALGRAPH(�RADIUS�,TRAJPAR*140)/5  
(Обратите внимание, что 140 и 5 � значения по X и Y диаграммы, соответственно) 
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5. Щелкните по  > ОК. 

 
Рисунок 33: Изменение Радиуса на Бутылке 

6. Обратите внимание, что изменяющийся радиус формирует цилиндрическую поверхность в верхней 
части и 'сжимает' среднюю часть. 

Задача 6. Добавить несколько последних штрихов. 

1. Щелкните по Insert > Advanced > Radius Dome. 

2. Выберите поверхность основания, как показано на следующем рисунке. 

 
Рисунок 34: Выбор Поверхности Основания 

3. Щелкните по Sel By Menu > FRONT > Select. 
4. Введите [-25 0]. 

5. Щелкните по  и выберите кромку, показанную на следующем рисунке. 
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Рисунок 35: Выбор Кромки Основания 

6. Щелкните по  > Round Edges и протяните радиус до значения между 4.5 и 5.0 

 
Рисунок 36: Скругление Кромок 

7. Щелкните по Insert > Shell и выберите поверхность, показанную на следующем рисунке. 

 
Рисунок 37: Выбор Поверхности для Элемента Оболочки 

8. Введите [1.0] и щелкните по ОК. 
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Рисунок 38: Завершенная Модель 

9. Сохраните модель и сотрите ее из оперативной памяти. 

ДОПОЛНИТЕЛЬНОЕ УПРАЖНЕНИЕ 2: Использование Элемента Протягивания 
Через Переменные Сечения 

Задача 1. Изучить карт. Задача состоит в том, чтобы создать пользовательскую выхлопную трубу. 

1. Карт и отсек двигателя показаны на следующем рисунке. 

 
Рисунок 39: Карт и Отсек Двигателя 

2. Откройте EXHAUST_PIPE.ASM. 

 
Рисунок 40: Сборочный Узел Выхлопной Трубы 

3. Обратите внимание на следующее: 

• голубые поверхности скопированы с двигателя. 

• Зеленая поверхность (элемент сопряжения протягиванием) � является частью начатой 
выхлопной трубы. 
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• Оранжевая опорная кривая - предопределенная траектория, созданная для исключения 
операции копирования коричневых и белых поверхностей со сборки двигателя, которые не 
относятся к выхлопной трубе. 

Задача 2. Общая методика для создания второй траектории элемента протягивания через 
переменные сечения состоит в том, чтобы использовать ленточную поверхность. Создайте ленточную 
поверхность, которая повторяет существующую траекторию и используйте trajpar для изменения 
ориентации. Кромка этой ленточной поверхности формирует вторую траекторию для заключительного 
элемента протягивания через переменные сечения. 

1. Щелкните по EXHAUST_PIPE.PRT в Дереве Модели и щелкните по  > Open. 

 
Рисунок 41: Открытая Посредством Дерева Модели Деталь Выхлопной Трубы 

2. Щелкните по Insert > Surface > Variable Section Sweep > Pivot Dir > Done.. 
3. Выберите Опорный элемент ТОР из Дерева Модели. Щелкните по ОК. 

4. Щелкните по Select Trajectory > Curve Chai. 
5. Щелкните в любой точке опорной кривой и выберите Select All > Done > Done > Done > Origin 
Start.. 
Задача 3. Нарисовать следующую линию. 

 
Рисунок 42: Эскизная Линия 

1. Щелкните по Sketch > Relations > Add. 

2. Используя свой номер размера для углового размера (в нашем примере Sd3), введите следующие 
две строки: 

/*equation to rotate line 90-0 during length of trajectory 
sd3 =90 � trajpar *90 

3. Обратите внимание на изменения углов после регенерации. 

4. Щелкните по  > ОК. 
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Рисунок 43: Изменения Углов После Регенерации 

Задача 4. Создать и переупорядочить элемент диаграммы, используя существующий эскиз, который 
будет использоваться для управления шириной ленты. 

1. Щелкните по Insert > Datum > Graph и введите [Pipe_stretch]. 
2. Щелкните по Sketch > Data From File > Pipe_stretch > Open 

 
Рисунок 44: Управление Шириной Ленты при Помощи Элемента Диаграммы 

3. Щелкните по  . 

4. Используйте Дерево Модели для переупорядочивания диаграммы перед ленточной поверхностью. 

Задача 5. Связать элемент диаграммы с элементом протягивания через переменные сечения таким 
образом, чтобы он управлял шириной ленточной поверхности. 

1. Выберите ленточную поверхность в Дереве Модели и щелкните по  > Redefine > Section > 
Sketch. 

2. Щелкните по Sketch > Relations. Обратие внимание на номер размера длины (в нашем примере: 
sd5) и щелкните по Edit Rel. 
3. Используя свой номер размера, введите следующие строки под предыдущими: 

/*vary width of ribbon according to graph feature 
sd5=(d60/2)+evalgraph ("pipe_stretch",trajpar *100)/10 

Примечание: 
Диаметральный размер на круглом конце зеленой поверхности имеет номер d60. 100 и 10 � значения 
по осям X и Y диаграммы соответственно. 

5. Щелкните по  > ОК. 



  Pro/ENGINEER 2001 Углубленный курс 

- 99 - 

 
Рисунок 45: Измерение Длины 

Задача 6. Использовать две кромки ленточной поверхности в качестве траектории для 
заключительного элемента протягивания через переменные сечения. Элемент должен иметь круглое 
поперечное сечения, смежное с существующей зеленой поверхностью и иметь эллиптическое 
окончание на другом конце. 

1. Щелкните по Insert > Surface > Variable Sectio Sweep > NormToOriginTraj > Done. 

2. Щелкните Select Traj > Bndry Chain. Выберите опорную кривую, показанную на следующем 
рисунке. 

 
Рисунок 46: Выбор Опорной Кривой 

3. Щелкните по Select All > Done. 

4. Щелкните по Select Traj > Tangent Chain и выберите кромку ленточной поверхности, показанной на 
следующем рисунке. 
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Рисунок 47: Создание Касательной Цепочки 

5. Щелкните по Done > No Join > Done > Done > Open Ends > Done > Origin Start. 

 
Рисунок 48: Открытые Концы 

6. Щелкните по Sketch > Data From File > Pipe_Ellipse.sec > Open. 

Задача 7. Перетащить центр импортированного эскиза до его привязки к осевым линиям, как показано 
на следующем рисунке. 

 
Рисунок 49: Привязка Импортированного Эскиза к Осевым Линиям 
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1. Отредактируйте масштаб до [1.0] и щелкните по . 

2. Щелкните по , и выберите посредством Query Select две эскизные точки, показанные на 
следующем рисунке. 

 
Рисунок 50: Выбор Эскизных Точек 

3. Обратите внимание, что эллипс теперь соответствует окружности в начале траектории. 

4. Щелкните по  > ОК. 

 
Рисунок 51: Эллипс Соответствует Окружности 

5. Выберите ленточную поверхность и исходную кривую в Дереве Модели, щелкните по Hide. 

6. Щелкните по Insert > Surface Operatio > Merge и выберите две поверхности, показанные на 
следующем рисунке. 

 
Рисунок 52: Соединенные Поверхности 

7. Щелкните по  . 

8. Щелкните по Insert > Thin Protrusion > Use Quilt. 
9. Щелкните в любом месте поверхности выхлопной трубы, убедитесь, что стрелка материала 

указывает наружу, введите толщину [0.25], и щелкните по . 
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Рисунок 53: Создание Тонкостенного Выдавливания с Использованием Лоскутных Поверхностей 

10. Откройте EXHAUST_PIPE.ASM. 

 
Рисунок 54: Открытый Узел Выхлопной Трубы 

11. Сохраните модель и сотрите ее из оперативной памяти. 

ДОПОЛНИТЕЛЬНОЕ УПРАЖНЕНИЕ 2: Управление Вырезами при Помощи 
Элементов Опорной Диаграммы 

 
Рисунок 55: Рисунок Завершенного Кулачка 

Задача 1. Создать выдавливание вращения в качестве основания для кулачка и использовать 
опорную диаграмму для управления высотой элемента протягивания выреза через переменные 
сечения. 

Совет: 
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Может быть легче отмасштабировать значения Y при создании элемента диаграммы. Запомните 
масштабный коэффициент при записи уравнения. 

Резюме 

В этой главе Вы узнали что: 

• Элемент сопряжения протягиванием и элемент протягивания через переменные сечения 
позволяют создавать конструкции, которые следуют по траектории, управляемой 
параметрически. 

• Для создания элемента сопряжения протягиванием необходимо сопрячь несколько 
поперечных сечений по отдельной траектории. 

• Когда система регенерирует элемент протягивания через переменные сечения, она 
автоматически рассчитывает внутренний параметр, называемый trajpar. 

• Для создания элемента протягивания по спирали, отдельное сечение протягивается по 
спиральной траектории, которая определяется профилем и значением шага. 
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Глава 4 
Создание Поверхностей и Элементы 
Стиля 
В этой главе Вы научитесь создать твердотельную геометрию посредством 
использования методов создания поверхностей и элементов Стиля. Эти элементы 
являются частью Модуля Интерактивного Конструирования Поверхностей (ISDX). 

Цели 
После завершения этой главы Вы научитесь: 

• использовать поверхности для улучшения конструкции модели. 

• Создавать поверхности и манипулировать их отображением. 

• Использовать возможности ISDX. 

• Использовать принципы гибридного моделирования. 

• Использовать компоновку вида с одним и четырьмя окнами. 

• Создавать двух- и трехмерные кривые свободной формы. 

• Создавать поверхности свободной формы, используя граничные кривые. 

Роль Поверхностей при Конструировании Модели 

Ниже приведены лишь несколько путей, в которых поверхности используются при конструировании 
модели. Можно: 

• определять всю модель из элементов поверхностей. 

• Использовать поверхности для создания геометрии на существующей твердотельной модели. 

• Использовать поверхности, или геометрию, созданную на их основе, для привязки и создания 
другой геометрии. 

• Использовать поверхности, или геометрию, созданную на их основе, для привязки деталей в 
режиме Сборки. 

• Импортировать данные в различной форме в Pro/ENGINEER для создания поверхностей. 

Преимущества Использования Поверхностей 
Использование поверхностей при проектировании моделей имеет много преимуществ, позволяя 
делать следующее: 

• определять комплексную геометрию более гибким способом. 

• Увеличивать скорость регенерации. 

• Представлять мастер-модель без влияния масс-инерционных характеристик. 
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• Уменьшать количество элементов. 

• Уменьшать загромождение экрана путем гашения слоев. 

Управление Отображением Поверхностей 
Pro/ENGINEER различает поверхности с белыми и серыми скрытыми линиями твердотельной 
геометрии, отображая их желтым цветом, а их силуэтные кромки - пурпурным. 

Опции Поверхностей 

Работа в Режиме Детали 
Обычно, элементы поверхностей создаются с использованием тех же опций, которые используются 
для создания твердотельных элементов - а именно выдавливание, вращение, протягивание, 
сопряжение, сопряжение протягиванием, протягиванием через переменные сечения и протягиванием 
по спиральной траектории. 

Кроме того, можно использовать некоторые уникальные функциональные возможности поверхностей 
в режиме детали. Это: 

• Flat � создает планарные границы на поверхности  

 
Рисунок 1: Плоская Поверхность 

• By Boundaries � использует выбранные кривые в одном или нескольких направлениях для 
определения внешних границ поверхности. 

 
Рисунок 2: Поверхность по Границам 

• Offset � смещает элемент новой поверхности по отношению к существующей на указанное 
расстояние. 

 
Рисунок 3: Поверхность со Смещением 
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Открытые и Закрытые Окончания 
При создании поверхностей выдавливания, вращения, протягивания или сопряжения, если 
поперечное сечение имеет замкнутый контур, то можно использовать опцию Capped Ends для 
автоматического создания плоских поверхностей, закрывающих окончания элемента. 

Система автоматически объединяет две плоские поверхности с другими поверхностями и формирует 
замкнутый объем. Это показано на следующем рисунке. 

 
Рисунок 4: Открытые и Закрытые Окончания 

Слияние Поверхностей 
Один или несколько элементов поверхностей можно объединять в отдельную лоскутную поверхность 
(surface quilt). Обратите внимание на некоторые важные моменты в этом контексте: 

• при слиянии (merge) поверхностей, они поглощают старые поверхности и становятся их 
потомками. 

• Все односторонние кромки, которые становятся двухсторонними, изменяют свой цвет с 
желтого на пурпурный. 

• При отмене слияния старые поверхности восстанавливаются. 

 
Рисунок 5: Использование Слияния Соединением и Слияния Пересечением 

Создание Твердотельных Элементов 

Если поверхность / поверхность слияния (merged surface) простирается до или за границы 
твердотельной детали или, если она определяет замкнутый объем, - ее можно использовать для 
создания нового твердотельного или "тонкостенного" элемента. 

Используя ту же самую опцию Use Quilt, можно создавать различные элементы типа выдавливаний, 
пазов или вырезов. 
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Рисунок 6: Использование Поверхностей для Создания Твердотельных Элементов 

Конструирование при Помощи Интерактивных Поверхностей 

Модуль Конструирования интерактивных поверхностей (ISDX) предлагает сплайн-ориентированный 
моделлер свободной формы, который позволяет создавать двух- и трехмерные кривые и поверхности 
свободной формы. ISDX можно использовать для создания моделей поверхностей свободной формы, 
как часть: 

• концептуального дизайна. 

• Технического конструирования. 

• Обратного протипирования (Reverse styling). 

ISDX позволяет создавать элементы СТИЛЯ (STYLE). При помощи элемента Стиля, можно легко 
создавать кривые свободной формы и поверхности. Следующий рисунок иллюстрирует некоторые 
примеры моделей, созданных с использованием элементов Стиля. 

 
Рисунок 7: Модели, Созданные с Использованием Элементов Стиля 
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Использование Элементов Стиля 

Элемент Стиля может содержать несколько кривых и поверхностей или лоскутных поверхностей. Он 
отображается в ДЕРЕВЕ МОДЕЛИ как Style. 

 
Рисунок 8: Элемент Стиля в Дереве Модели 

 
Рисунок 9: Элемент Стиля с Несколькими Кривыми и Поверхностями 

Элемент Стиля открывает новую среду моделирования с одно- или четырехоконной компоновкой 
окна. 
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Рисунок 10: Четырехоконная Компоновка Окна 

Концепции Элемента Стиля 
Ниже приведены важные концепции элемента Стиля: 

• Четырехоконная компоновка � позволяет наблюдать модель со всех сторон одновременно. 

• Технология гибкой точки � позволяет привязывать кривую к другим элементам при помощи 
гибкой точки (soft point), которая может интерактивно размещена в требуемом месте. 

• Переключение отношений Родитель / потомок � Стиль предлагает гибкую иерархию 
создаваемых кривых и поверхностей. Отношения Родитель / потомок можно изменять. 

Гибридное Моделирование 

Большинство изделий являются комбинацией геометрических и свободных форм. Стиль предлагает 
уникальную ситуацию, где можно объединять традиционный элемент на основании параметрического 
моделирования Pro/ENGINEER с профилированием не подчиненных связям поверхностей свободной 
формы. Можно создавать кривые свободной формы и поверхности, которые могут быть привязаны к 
другим геометрическим элементам. 

Любое изменение в параметрической модели регенерирует элемент Стиля, позволяя свободно 
комбинировать поверхности свободной формы не подчиненные связям с геометрическими 
параметрическими поверхностями. 

Такая уникальная ситуация также позволяет выполнять весь проект изделия целиком в единой среде 
моделирования. 

Использование ISDX 

ISDX можно использовать для создания кривых и поверхностей свободной формы, где геометрия или 
не определена, или не требует большой гибкости. Также, ISDX можно использовать, когда назначение 
конструкции зависит от визуальных или эстетических критериев. 

Конкретно, ISDX можно использовать для создания: 
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• двух- и трехмерных кривых (привязанных или свободных). 

• Кривых На Поверхности (COS). 

• Художественных моделей. 

• Поверхностей сопряжения и перехода. 

• Поверхностей свободной формы совместно с параметрическими поверхностями в моделях 
технического конструирования. 

• Поверхностях обратного прототипирования. 

Создание Двух- И Трехмерных Кривых 
Можно использовать Стиль в качестве двухмерной или трехмерной Среды эскиза для создания 
кривых, не подчиненных связям, или кривых привязки. Эти кривые могут быть присоединены к 
элементам подобно точкам, кривым или кромкам, и могут использоваться для создания Стиля или 
других элементов Pro/ENGINEER. 

 
Рисунок 11: Определение Кривых в Трехмерном Пространстве 

 
Рисунок 12: Поверхность Сопряжения, Построенная на Основе Трехмерной Кривой Свободной 

Формы 
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Рисунок 13: Поверхности, Созданные из Трехмерных Кривых 

Создание Кривых на Поверхности 
Кривую на Поверхности (COS) можно создавать, эскизируя ее непосредственно на базовой 
поверхности или, используя инструмент Drop (Проецирования). Стиль позволяет легко 
манипулировать или модифицировать COS для передачи назначения проекта. COS можно 
использовать для построения последующих поверхностей или обрезать их. 

 
Рисунок 14: Использование COS для Сопряжения 

Создание Художественных Моделей 
Можно использовать интуитивные кривые и поверхности свободной формы для осмысления изделия. 
Уникальная возможность объединения параметрических поверхностей с поверхностями свободной 
формы дает возможность выполнить проект изделия на одной платформе и в единой базе данных. 
Концептуализация в ISDX дает доступ внутрь технических компонентов непосредственно в одной и 
той же детали или сборке при проектировании внешних форм тела. 

Можно также моделировать, используя изображения, которые могут применяться на основе базовых 
поверхностей, как показано на следующем рисунке. 
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Рисунок 15: (A) Эскиз (B) Эскиз на Основе Базовой Поверхности (C) Модель, Разработанная с 

Использованием Эскиза 

Создание Поверхностей Свободной Формы 
В процессе конструирования изделий может потребоваться наложить размеры для управления 
поверхностями свободной формы. В ISDX можно привязывать кривые и поверхности свободной 
формы к параметрическим кривым или поверхностям, позволяя таким образом управлять 
поверхностями свободной формы, используя размеры. 

 
Рисунок 16: Управление художественной Моделью При Помощи Размеров 

Создание Сопряжений и Переходов 
Стиль можно использовать для быстрого создания высококачественных сплайновых сопряжений в 
целях повышения эстетичности или гладкости изделий. Можно создавать касательные поверхности 
или переходные поверхности с непрерывной кривизной с интерактивным контролем над 
касательностью. 
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Рисунок 17: Типичные Поверхности Перехода 

 
Рисунок 18: Интерактивное Изменение Касательной 

Использование Художественных Поверхностей при Разработке Моделей 
Художественные поверхности (Style Surfaces) можно комбинировать с параметрическими 
поверхностями при создании поверхностей с высокой кривизной или поверхностей перехода. 

 
Рисунок 19: Поверхности Перехода с Высокой Кривизной 

Обратное Прототипирование 
Можно эффективно обрабатывать импортированные сканированные кривые и триангуляционные или 
поверхностные данные для построения художественных кривых и поверхностей. 

 
Рисунок 20: Обратное Прототипирование 
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Лабораторный Практикум 

Цель 
В этом практикуме, Вы изучите методы создания поверхностей с использованием 
Pro/SURFACE и ISDX. 

Метод 
В Упражнении 1, иллюстрируются базовые методы создания поверхностей, слияние их в лоскутную 
поверхность и использование их для создания твердотельной геометрии. 

В Упражнении 2, создаются поверхности с опциями Flat и Boundary. 

В Упражнении 3, с помощью элемента Стиль создается простая поверхность путем комбинирования 
функциональности несвязанных свободных форм параметрического моделирования. 

Инструменты 
Таблица 1: Пиктограммы Поверхностей и Элемента Стиль 

ПИКТОГРАММА ОПИСАНИЕ 

   Каркасное отображение 

   Создание опорной кривой 

   Отображение опорных плоскостей 

   Установка активной опорной плоскости 

   Создание и редактирование кривых 

   Отображение диаграммы кривизны 

   Удаление всех точек кривизны 

   Полная регенерация 

   Создание поверхности по граничным кривым 

УПРАЖНЕНИЕ 1: Создание Вырезов с Использованием Поверхностей 
Задача 1. Начать новую модель и создать первый элемент. 

1. Создать новую деталь, называемую [surf_cut], используя шаблон по умолчанию. 

2. Выберите Опорный элемент FRONT, щелкните по Insert > Surface > Extrude и создайте эскиз, как 
показано на следующем рисунке. 
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Рисунок 21: Эскиз для Выдавливания Поверхности 

3. Выйдите из Среды эскизирования, вызовите вид Default и протяните сечение на глубину, 
приблизительно [5.625]. 

 
Рисунок 22: Создание Размера Глубины 

4. Обратите внимание, что при этом методе создается Односторонняя поверхность (One Side), 

которая имеет открытые окончания (Open Ends). Щелкните по  для проверки этого утверждения 
(пурпурный и желтый). 

Задача 2. Переопределить поверхность, используя опции Двухсторонней поверхности (Both Sides) с 
Закрытыми окончаниями (Capped Ends). 

1. Выберите поверхность, и щелкните по  > Redefine. 

2. Щелкните по атрибутам и укажите Both Sides и Capped Ends. Затем, щелкните четыре раза по 

. Обратите внимание, что создана 'полая' поверхность (Пурпурная). 

 
Рисунок 23: Переопределение Закрытых Окончаний 
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Задача 3. Создать твердое тело из существующей поверхности. 

1. Щелкните по Insert > Protrusion > Use Quilt, выберите поверхность и щелкните по . Обратите 
внимание, что модель теперь твердотельная (белая). 

Задача 4. Создать первую из двух поверхностей, которые позже определят вырез. 
1. Щелкните по Insert > Surface > Revolve и используйте опции Both Sides и Open Ends. 
2. Выберите Опорный элемент RIGHT в качестве эскизной плоскости, щелкните по Okay и выберите 
Опорный элемент ТОР в качестве привязки Тор. 

3. Создайте эскиз (показанный на следующем рисунке), используя Сплайн с общим количеством пять 
точек. Обратите внимание на использование образмеренной конструктивной линии. Укажите 
горизонтальную осевую линию в качестве оси вращения. 

 
Рисунок 24: Создание Эскиза 

4. Закончите эскиз и выполните вращение поверхности на 180°. 

 
Рисунок 25: Эскиз После Вращения Поверхности 

Задача 5. Создать вторую из двух поверхностей, которые позже определят вырез. 

1. Щелкните по Insert > Surface > Extrude. Используйте опции One Sides и Open Ends. 

2. Выберите Опорный элемент ТОР в качестве эскизной плоскости, щелкните по Okay > Bottom, и 
выберите опорную плоскость FRONT. 

3. Нарисуйте эллипс, показанный на следующем рисунке. 

Совет: Используйте две осевые линии и четыре эскизных точки. 
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Рисунок 26: Создание Эскиза с Двумя Осевыми Линиями и Четырьмя эскизными Точками 

4. Завершите эскиз и используйте основание блока в качестве глубины Up to Surface. 

 
Рисунок 27: Использование Основания Блока в Качестве Глубины "До Поверхности" 

Задача 6. Создать слияние поверхностей и вырез. 

1. Щелкните по Insert > Surface Operation > Merge, и выберите два элемента поверхностей. 

2. Просмотрите различные опции Quilt Side до получения сетки, показанной на следующем рисунке. 

 
Рисунок 28: Требуемая Опция Quilt Side 

3. Завершите элемент слияния и щелкните по Insert > Cut > Use Quilt. 
4. Выберите поверхность и укажите сторону удаления материала для получения показанного выреза. 
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Рисунок 29: Элемент Выреза 

Задача 7. Добавить окончательные скругления к модели. 

1. Используйте  и <SHIFT> для выбора обоих кромок, показанных на следующем рисунке. Затем, 
скруглите кромки, как показано. 

 
Рисунок 30: Скругление Кромок Выреза 

2. [Необязательно] Удалите последние три элемента в Дереве Модели. Переопределите глубину 
второй поверхности на Up To Surface и, при помощи Query Select, выберите всю первую поверхность. 
Затем, повторно выполните слияние, вырез и скругления. Чем отличается слияние? 

УПРАЖНЕНИЕ 2: Создание Поверхностей по Границам 
Задача 1. Открыть модель, содержащую кривые и создать первую поверхность. 

1. Откройте SURF_CRV.PRT и скройте слой MISC_DTM. 
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Рисунок 31: Модель После Погашения Слоя 

2. Щелкните по Insert > Surface > Flat и выберите DTM3 в качестве эскизной поверхности. 

3. Щелкните по Okay > Right и выберите DTM4 в качестве плоскости привязки. 

4. Выберите только концы кривой в качестве привязки и нарисуйте эскиз, как показано на следующем 
рисунке. 

 
Рисунок 32: Эскизные Кривые 

5. Завершите эскиз и элемент. 

 
Рисунок 33: Завершенный Эскиз 

Задача 2. Создать следующую поверхность, используя Границы. 

1. Щелкните по Insert > Surface > From Boundaries > Blended > Done. Затем, выберите кривую, 
показанную на следующем рисунке. 



  Pro/ENGINEER 2001 Углубленный курс 

- 121 - 

 
Рисунок 34: Выбор Кривой 

2. Щелкните по Chain и выберите кромку, показанную на следующем рисунке. 

 
Рисунок 35: Выбор Кромки 

3. Щелкните по Done Sel > Done > Done Curves > OK. 

 
Рисунок 36: Поверхность, Созданная с Использованием Границ 

Задача 3. Создать опорные кривые для использования в качестве границ в следующей поверхности. 

1. Щелкните по  > Thru Points > . Затем, выберите две вершины справа на лево, как показано 
на следующем рисунке. 

 
Рисунок 37: Выбор Двух Вершин 

2. Щелкните по Done > Tangency > End и выберите показанную кромку. 
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Рисунок 38: Выбор Кромки 

3. Щелкните по Okay >  >  > ОК. 

 
Рисунок 39: Создание Кривой 

4. Повторите вышеупомянутый процесс для создания другой кривой. 

 
Рисунок 40: Создание Второй Кривой 

Задача 4. Создать поверхность с несколькими границами. 

1. Щелкните по Insert > Surface > From Boundaries > Blended > Done. 

2. Щелкните по Chain и при помощи Query Select выберите кромку поверхности (не кривую) как 
показано на следующем рисунке. 

 
Рисунок 41: Выбор Кромки Поверхности 

3. Щелкните по Done Sel > Done > Curve и выберите кривую, показанную на следующем рисунке. 
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Рисунок 42: Выбор Кривой 

4. Щелкните по Second Dir и выберите две кривые, показанные на следующем рисунке. 

 
Рисунок 43: Выбор Двух Кривых для Второго Направления 

5. Щелкните по Done Curves > ОК. 

Задача 5. Сделать границу, касательной к поверхности. 

1. Выберите вторую кривую в Дереве Модели и  > Hide. 

2. Обратите внимание, что граница не касательна к поверхности. 

 
Рисунок 44: Подсвеченная Граница 

3. Выберите последнюю поверхность и  > Redefine. 

4. Щелкните по Bndry Conds > Boundary #1 > Tangent > Done > OK. 

5. Щелкните по  >  для завершения элемента. Обратите внимание, что граница теперь 
касательна. 
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Рисунок 45: Касательная Граница, Формирующая Гладкую Поверхность 

Задача 6. Объединить эти три поверхности. 

1. Щелкните по Insert > Surface Operation > Merge и выберите поверхности, показанные на 
следующем рисунке. 

 
Рисунок 46: Слияние Поверхностей 

2. Завершите элемент и повторите для следующих поверхностей. 

 
Рисунок 47: Слияние Следующих Поверхностей 

3. Используйте опцию Round Edges на оставшейся твердотельной кромке. Протяните радиус. 
Введите [5.0]. 

 
Рисунок 48: Скругление Кромки 
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Задача 7. Создать скругления в вершине и сделать модель твердотельной. 

1. Щелкните по Insert > Surface Trim > Vertex Round. Выберите все четыре внешних угла лоскутной 
поверхности и введите значение [2.0]. 

2. Скройте слой ALL_CURVES. 

 
Рисунок 49: Создание Скруглений в Вершинах 

3. Щелкните по Insert > Solid > Thin Protrusion > Use Quilt и выберите лоскутную поверхность. 

4. Введите значение [0.50] и завершите элемент. 

 
Рисунок 50: Завершенный Элемент Лоскутной Поверхности 

5. Сохраните модель и сотрите ее из памяти. 

УПРАЖНЕНИЕ 3: Изучение Интерфейса СТИЛЯ 
Задача 1. Поэкспериментировать с существующим элементом Стиля. 

1. Установите рабочий каталог в ISDX. 

2. Откройте PALM.PRT. 
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Рисунок 51: Исходная Модель 

Обратите внимание: 
«LCD экран» фактически является изображением *.jpg, наложенным на модель Pro/E в виде текстуры. 

3. В Дереве модели, щелкните по STYLE id 89 и щелкните по  > Redefine. 

4. Обратите внимание на рабочую среду Стиля и, особенно, на новые инструменты, появившиеся в 
интерфейсе, как показано на следующем рисунке. 

 
Рисунок 52: Инструментальные Меню Стиля 

5. Сетка, отображаемая на плоскости ТОР, указывает, что Тор установлена в качестве активной 
плоскости. 

6. Щелкните по View > Active Plane Orientation. Плоскость ТОР устанавливается параллельно экрану. 

7. В окне, щелкните по  > Default Orientation. 
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Задача 2. Изменить расположение окон. 

1. Щелкните по View > Show All. 
2. Щелкните по Styling > Set Active Plane. Выберите плоскость Oblique из Дерева модели. 

3. В верхнем левом окне щелкните по  > Active Plane Orientation в выпадающем меню. 

4. Выполните вращение модели в любом окне. 

5. Щелкните по View > Default Orientation для восстановления изображения во всех окнах. 

6. Щелкните в любом окне, затем  > Show All. 
7. Восстановите активную плоскость. По щелчку правой кнопки мыши выберите Set Active Plane и 
выберите плоскость ТОР. 

8. Нажмите <CNTRL> + <D> для восстановления ориентации по умолчанию. 

Задача 3. Познакомьтесь с предустановками Стиля. 

1. Щелкните по  и . 

2. Щелкните по Utilities > Styling Preferences. 

3. Измените шаг сетки. В области сетки диалогового окна введите [15] и нажмите <ENTER> . 

 
Рисунок 53: Изменение Шага Сетки 

4. В области Display диалогового окна STYLING PREFERENCES, снимите переключатель Grid. 

5. В области Surface Mesh, переместите ползунок quality направо, чтобы сетка стала более плотной. 

6. Щелкните по  [Закраска]. 

7. В области surface mesh, щелкните по On для отображения сетки на закрашенной модели. 
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Рисунок 54: Отображение Сетки на Закрашенной Модели 

8. Отобразите модель без кривой и сетки. Щелкните по View > Shade. 
9. Закройте диалоговое окно STYLING PREFERENCES. 

10. Щелкните по  [Перерисовать]. 

Задача 4. Познакомьтесь с процедурой выбора. 

1. Щелкните возле набора кривых, как показано на следующем рисунке. 

 
Рисунок 55: Выбор Кривой из Группы 

2. Щелкните по  > Next для перебора команд в выпадающем меню. 

3. Выберите объекты из набора. Щелкните правой кнопкой мыши по Show Sel Bin. В диалоговом окне 
SELECTION, щелкните по Style: (1) Curve:CF-116. 

4. Завершите элемент Стиля, щелкните по . 

5. Закройте модель. 

УПРАЖНЕНИЕ 4: Создание Поверхности Стиля 
Задача 1. Начать новый элемент Стиля для тела прожектора. 

1. Откройте FLASHLIGHT.PRT в каталоге ISDX. 
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Рисунок 56: Исходная Модель 

2. Щелкните по Insert > Style. 

3. Если необходимо, щелкните по View > Show All для возврата к однооконному виду. 

4. Щелкните по  [Установка активной опорной плоскости] в боковом меню и, затем, выберите 
опорную плоскость FRONT. 

 
Рисунок 57: Установка Плоскости FRONT в Качестве Активной Опорной Плоскости 

Задача 2. Создать кривую и улучшить ее форму. 

1. Создайте плоскую кривую. Щелкните по  [Создание и редактирование кривых] > New > Planar, 
затем щелкните на активной плоскости в местах, как показано в следующем рисунке. 

 
Рисунок 58: Кривая 

2. Щелкните по  > FRONT. 

3. Щелкните по  > Edit >  [Отображение Диаграммы Кривизны] 

4. Щелкните по требуемым точкам кривой и растащите для получения формы кривой, приблизительно 
соответствующей показанной на следующем рисунке. Кривая должна быть расположена выше 
батарей. 
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Рисунок 59: Редактирование и Настройка Кривой 

5. Щелкните по ОК для завершения создания кривой. 

Задача 3. Создать другую кривую на нижней стороне. 

1. Щелкните по  > New > Planar, затем щелкните в местах на плоскости FRONT, как показано на 
следующем рисунке. 

 
Рисунок 60: Создание Нижней Кривой 

2. Улучшите форму кривой, используя те же методы, что и для предыдущей кривой, чтобы она 
приблизительно соответствовала предыдущему рисунку. 

3. Щелкните по ОК. 

Задача 4. Создать первую поперечную кривую и улучшить ее форму. 

1. Щелкните по  > DEFAULT. Затем щелкните по  [Стереть все точки кривизны] и выключите 

. 

2. Щелкните по  > New > Free. Нажмите и, удерживая <ALT> , щелкните по верхней кривой, затем 
щелкните по нижней кривой в местах, показанных на следующем рисунке. 

 
Рисунок 61: Задняя Часть Прожектора 
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3. Щелкните по Add, затем щелкните в следующих двух местах для добавления точек, как показано на 
следующем рисунке. 

 
Рисунок 62: Добавленные Точки 

4. Щелкните по Edit. Удерживая <SHIFT> , щелкните и протащите точки приблизительно, как показано 
на следующем рисунке. 

 
Рисунок 63: Создание Кривой, Путем Манипуляций Точками 

Задача 5. Сделать кривую, перпендикулярной плоскости FRONT. 

1. Выберите верхнюю конечную точку новой кривой. Щелкните по Tangent, измените ее тип на Normal 
и выберите плоскость FRONT. 

 
Рисунок 64: Создание Касательной к Плоскости FRONT 

2. Повторите вышеупомянутую процедуру для нижнего конца этой же кривой. 

Задача 6. Улучшить форму кривой. 

1. Щелкните по  > RIGHT. 

2. Щелкните по  и измените форму, управляя местоположениями точек и длинами касательных. 

 
Рисунок 65: Изменение Формы, Управляя Точками 
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3. Щелкните по ОК. 

Задача 7. Создать другую поперечную кривую в виде плоской кривой. 

1. Щелкните по  > Default. Затем щелкните по  и выберите плоскость RIGHT. 

2. Щелкните по  > New > Planar. Затем щелкните по Planar для открытия выпадающего меню. 
Введите [-75.0] в текстовом поле Offset. 
3. Щелкните по Styling > Snap для включения привязки. 

4. Щелкните по верхней кривой, щелкните по следующим двум точкам, в местах, показанных на 
активной плоскости; затем щелкните по нижней кривой. 

 
Рисунок 66: Создание Лицевой Части Прожектора 

5. Щелкните по Styling > Snap для выключения привязки. 

Задача 8. Наложить зависимости на касательные в конечных точках. 

1. Щелкните по Edit. Щелкните по конечной точке и  в меню Tangent, выберите Normal в меню 
быстрого вызова и выберите плоскость FRONT. 

2. Щелкните по  > RIGHT. 

3. Измените форму кривой, как показано на следующем рисунке. 

 
Рисунок 67: Изменение Формы, Управляя Точками 

4. В диалоговом окне CURVE, щелкните по ОК. 

5. Регенерируйте модель, щелкая по  [Регенерировать все] при необходимости. 

Задача 9. Создать поверхность по кривым Стиля. 

1. Щелкните по  [Создание поверхности по граничным кривым] и выберите четыре созданных 
кривых Стиля, как показано на следующем рисунке. 
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Рисунок 68: Выбор Граничных Кривых 

2. Щелкните по ОК. 

3. Щелкните по  для закраски модели. 

 
Рисунок 69: Переопределить местоположение смещенной плоскости. 

1. Выберите плоскую поперечную кривую, как показано. 

 
Рисунок 70: Выбор Плоской Поперечной Кривой  

2. Щелкните по  > Definition. 

3. Щелкните по Planar для распахивания поля, введите [- 90], нажмите <ENTER> и щелкните по ОК. 

4. Щелкните по  для регенерации элемента Стиля. 

 
Рисунок 71: Регенерированный Элемент Стиля 

Задача 11. Создать кривые и поверхности ручки. 

1. Щелкните по  и выберите опорный элемент FRONT, затем щелкните по  > Front. 

2. Щелкните по  > New > Planar и создайте две кривые, как показано на следующем рисунке. 
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Рисунок 72: Создание Двух Дополнительных Кривых 

3. Щелкните по  > New > Free и создайте первую поперечную кривую, как показано на следующем 
рисунке. Используйте <Alt> для привязки к существующим кривым. 

 
Рисунок 73: Создание Свободной Кривой 

4. Щелкните по Add и выберите место для средней точки, как показано. 

 
Рисунок 74: Выбор Местоположения Средней Точки 

5. Щелкните по Edit и используйте <SHIFT>, для протаскивания точки перпендикулярно плоскости 
FRONT. Сформируйте кривую, как показано на следующем рисунке. 
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Рисунок 75: Сформированная Кривая 

6. Используя те же методы, создайте новую кривую с формой, показанной на следующем рисунке. 

 
Рисунок 76: Создание и Формирование Второй Кривой 

7. Щелкните по ОК для закрытия диалогового окна CURVE. 

8. Щелкните по , выберите четыре кривые, формирующие ручку и щелкните по ОК. 

9. Щелкните по  для закраски модели. 

 
Рисунок 77: Создание Поверхности по Четырем Кривым Стиля 

10. Щелкните по Insert > Surface Operation > Merge. 

11. Выберите поверхность ручки, затем поверхность тела. 

12. Включите сетку для Quilt Sides, как показано на следующем рисунке. 
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Рисунок 78: Стороны Лоскутной Поверхности 

13. Щелкните по . 

14. Щелкните по Feature > Mirror Geom и выберите плоскость FRONT. 

 
Рисунок 79: Зеркально Отображенная Геометрия 

15. Щелкните по Insert > Surface Operation > Merge, выберите левую и правую половины тела 
прожектора и щелкните по . 

16. Выберите кромку, показанную ниже и щелкните по  > Round Edges. 

 
Рисунок 80: Скругление Кромок 

17. Введите значение радиуса [5.0]. 
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18. Повторите для другой стороны ручки. 

 
Рисунок 81: Скругленные Грани 

19. Щелкните по Insert > Thin Protrusion > Use Quilt и выберите лоскутную поверхность. 

20. Щелкните по стрелке Material Side, чтобы добавить материал INSIDE (Внутрь) поверхности. 

21. Введите значение толщины [2.0] и щелкните по . (Можно добавить кривые Стиля к слою и 
скрыть его) 

 
 

Рисунок 82: Завершенная Модель 

22. Сохраните и закройте модель. 

Резюме 

В этой главе, Вы узнали что: 

• при создании модели могут быть использованы поверхности. 

• Поверхности могут быть объединены в форме лоскутных поверхностей (quilts) по которым 
может быть создана твердотельная геометрия с использованием опций Use Quilt и Patch. 

• ISDX интегрирует поверхности свободной формы и параметрические модели для усиления 
существующих возможностей Pro/ENGINEER в части построении поверхностей, позволяя 
создавать такие формы изделий, которые требуют гибких поверхностей. 

• Стиль позволяет создавать геометрию, используя одно- или многооконную компоновку. 
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• При создании элемента Стиль добавляется новое меню Styling и появляется множество новых 
команд. 

• Кривые могут быть созданы в виде трехмерных или плоских кривых. 

• Для создания художественной поверхности необходимо иметь четыре соприкасающихся 
граничных кривых. 

• Для изменения формы поверхности следует манипулировать формой граничных кривых. 
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