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Добро Пожаловать в Справочную Систему PTC

PTC продолжает направление по обеспечению интегрированными интернет/интранет
решениями посредством программных продуктов i-серии, включая новаторские
изменения в этом выпуске Справки PTC.

Справка PTC интегрирована с полностью функциональным, гибким программным
обеспечением CAD/CAM и Управления Данными, поставляемым PTC. Просто укажите
требуемую тему. Справка PTC, может быть установлена на WEB сервере, позволяя
клиентам Сети обращаться к Справке PTC без необходимости прямого обращения к
компьютерам файловых серверов, сокращая, таким образом, сетевой трафик и
обеспечивая конфигурацию LAN/WAN.

Что Доступно в Справке PTC?

Справка PTC предлагает:

•  Новую систему справки с интегрированным оглавлением, индексом, и
возможностью поиска.

•  Полностью сертифицированный Internet Explorer 4.0 и выше и Netscape 4.06 и
выше.

•  Возможность инсталляции на сетевом сервере.

•  Полная контекстно-зависимая справка, дающая доступ к Справке PTC по щелчку
мыши.

•  Расширенная контекстно-зависимая справка в диалоговых окнах.

•  См. также подсказки для сопутствующих тем.

Где Находятся Конкретные Модули в Справке PTC?

Имеются четыре основных ветви в оглавлении Справки PTC: Welcome (Добро
Пожаловать), Pro/ENGINEER Foundation (Основы Pro/ENGINEER), Using Foundation
Modules (Использование Базовых Модулей) и Using Additional Modules (Использование
Дополнительных Модулей). Просмотрите следующий список для поиска требуемого
модуль в содержании.

•  Ассоциативная Топологическая Шина - CADDS5 Использование Базовых Модулей.

•  Ассоциативная Топологическая Шина - ICEM, Использование Базовых Модулей

•  Основы Сборки, Использование Базовых Модулей

•  Поведенческое Моделирование, Использование Дополнительных Модулей,
Дополнение Поведенческого Моделирования

•  Опции Файла Конфигурации Основы Pro/ENGINEER

•  Базовые понятия Pro/ENGINEER

•  Анимация Проекта, Использование Дополнительных Модулей, Расширенное
Поведенческое Моделирование

•  Инженер-машиностроитель (Expert Machinist), Использование Дополнительных
Модулей, Механическая обработка



•  Механизм Восстановления Принимаемых Данных, Использование Базовых
Модулей

•  Конструирование Механизмов, Использование Дополнительных Модулей,
Расширенное Поведенческое Моделирование

•  Моделирование Детали Основы Pro/ENGINEER

•  Pro/ASSEMBLY Использование Дополнительных Модулей, Расширенное
Дополнение Pro/ASSEMBLY.

•  Pro/CABLING Использование Дополнительных Модулей, Опции Разводки (Routing)

•  Pro/CASTING Использование Дополнительных Модулей, Инструментарий

•  Pro/CMM Использование Дополнительных Модулей, Компьютеризированные
Средства Контроля

•  Pro/COMPOSITE Использование Дополнительных Модулей, Расширенное
Дополнение по работе с Поверхностями

•  Pro/DETAIL Использование Базовых Модулей

•  Pro/DIAGRAM Использование Дополнительных Модулей, Опции Разводки (Routing)

•  Pro/DIEFACE Использование Дополнительных Модулей, Инструментарий

•  Pro/ECAD Использование Базовых Модулей

•  Pro/HARNESS-MFG Использование Дополнительных Модулей, Опции Разводки
(Routing)

•  Pro/INTERFACE Использование Базовых Модулей

•  Pro/LEGACY Использование Базовых Модулей

•  Pro/MOLDESIGN Использование Дополнительных Модулей, Инструментарий

•  Pro/NC Использование Дополнительных Модулей, Механическая обработка

•  Pro/NC-SHEETMETAL Использование Дополнительных Модулей, Механическая
обработка

•  Pro/PHOTORENDER Использование Базовых Модулей

•  Pro/PIPING Использование Дополнительных Модулей, Опции Разводки (Routing)

•  Pro/PROCESS для СБОРОК, Использование Дополнительных Модулей,
Расширенное Дополнение Pro/ASSEMBLY

•  Pro/PROCESS для MFG Использование Дополнительных Модулей, Механическая
обработка

•  Pro/PROGRAM Использование Базовых Модулей

•  Pro/REPORT Использование Базовых Модулей

•  Pro/REVIEW Использование Базовых Модулей

•  Pro/SCAN-TOOLS, Использование Дополнительных Модулей, Расширенное
Дополнение по работе с Поверхностями

•  Pro/SHEETMETAL Design, Использование Базовых Модулей

•  Pro/SURFACE Использование Дополнительных Модулей, Расширенное Дополнение
по работе с Поверхностями.

•  Pro/VERIFY Использование Дополнительных Модулей, Компьютеризированные
Средства Контроля.

•  Pro/WELDING Использование Базовых Модулей

•  Sketcher Основы Pro/ENGINEER



Посетите онлайновую базу данных технической поддержки PTC, которая содержит
тысячи Предлагаемых Методик.

Использование Справочной Системы Pro/ENGINEER

Справочная Система Pro/ENGINEERO (также, называемая Справка PTC) предлагает
Вам справочные темы, которые дадут Вам требуемую информацию в процессе работы.

Получение Справки При Выполнении Задачи

Вы можете получить Справку по вашей текущей задаче, когда Вы работаете в
диалоговом окне или с меню,  используя одну из этих трех процедур.

Для Получения Справки по Задачам в Диалоговом окне

1. Щелкните по кнопке What's This в правой части основной панели Pro/ENGINEER.

2. Щелкните в любом месте внутри диалогового окна. Искомая тема откроется в
Справочном окне. Искомая тема содержит перечень ссылок к вспомогательным темам
по задачам, которые Вы выполняете в диалоговом окне.

3. Щелкните по теме, которую Вы хотите прочитать.

4. Нажмите кнопку Back на панели броузера для возврата к первой теме и выберите
другую тему.

Для Получения Справки по Командам в Меню

1. Щелкните по кнопке What's This в правой части основной панели Pro/ENGINEER.

2. Щелкните по команде меню. Искомая тема откроется в Справочном окне. Искомая
тема содержит перечень ссылок к темам Справки по команде.

3. Щелкните по теме, которую Вы хотите прочитать.

Для Получения Справки по Вертикальным Меню

1. Щелкните по команде меню правой кнопкой мыши и удерживайте кнопку, пока не
появится окно GetHelp.

2. Перейдите на GetHelp и, затем, отпустите кнопку мыши. Искомая тема откроется в
Справочном окне. Искомая тема содержит перечень ссылок к темам Справки по
команде.

3. Щелкните по теме, которую Вы хотите прочитать.

Получение Справки Через Боковое Меню Справки PTC

При помощи Бокового Меню Справки PTC, Вы можете просматривать Содержание или
Индекс Справочной Системы PTC и получать справку в любой момент работы с
Pro/ENGINEER.

1. В меню Pro/ENGINEER выберите, Help > Pro/E Help System для отображения
исходной страницы Справки.

2. Выберите Contents - чтобы просмотреть темы Справки в функциональной области,
Index - чтобы просмотреть ключевые слова для определенной области или Search -
для поиска тем, соответствующих слову или фразе и в Содержании и в Индексе.



Краткие Сведения по Менеджеру Приложений

Менеджер Приложений - графический инструмент, который выполняет следующие
функции на платформах UNIX:

•  обеспечивает общий интерфейс для запуска программ PTC. Запускаете ли Вы
Pro/ENGINEER, Pro/MECHANICA или другие программы PTC, Вы можете
настраивать Менеджер Приложений для запуска этих программ одновременно или
отдельно.

•  Контролирует все окна, содержащие объекты Pro/ENGINEER и дает возможность
выносить одно или более таких окон на передний план вашего рабочего стола. По
мере вызова объектов в вашей сессии Pro/ENGINEER, Менеджер Приложений
создает кнопку для каждого объекта. В этом отношении, Менеджер Приложений -
также является менеджером окна рабочего стола.

•  Позволяет Вам настраивать число приложений, которые Вы можете запустить и
вариант, каким каждое приложение будет отображаться первоначально. Подобно
другим менеджерам рабочего стола, Менеджер Приложений позволяет Вам
настраивать способы работы с программами на вашем рабочем столе.

•  Для UNIX и NT систем, Менеджер Приложений обеспечивает доступ к меню
Pro/INTRALINK во время выполнения.

Компоненты Менеджера Приложений

Pro/ENGINEER автоматически отображает Менеджер Приложений, когда он выполняет
команду Startup. Для NT систем, Менеджер Приложений присутствует в трее панели
задач (рядом с часами).

Панель меню состоит из двух типов кнопок:

•  кнопка Start  - отображает меню команд, которые Вы можете использовать для
запуска или выхода из программ. Для систем UNIX, Вы можете конфигурировать
это меню для включения приложения в вашу систему.

Обратите внимание: Из  Менеджера Приложений можно выйти, только завершив
работу всех приложений PTC.

•  кнопки Program (только UNIX) - Соответствуют всем окнам, открытым
программами, запущенными через Менеджер Приложений. Щелкните левой
кнопкой для запуска приложения; щелкните правой кнопкой мыши, чтобы свернуть
приложение.

Преимущество использования Менеджера Приложений заключается в легкости
управления окнами. Окна не потеряются друг за другом в процессе работы с четырьмя
или пятью приложениями.

Для Конфигурирования Меню Запуска Менеджера Приложения

Чтобы добавить или удалить имя программы из меню Start, выберите Preferences.
Страница Start Menu отобразит текущий список команд, доступных в меню Start
Менеджера Приложений. Используйте следующие команды для конфигурирования
меню Start.
Команда Функция
New Command Запрашивает название программы или командный скрипт.

Добавляет такое название в список доступных программ

Modify Command Позволяет Вам изменять название программы

Delete Command Удаляет выбранную программу из списка



Apply Применяет изменения в Менеджере Приложений для текущей
сессии

Save Сохраняет изменения в config.apm, конфигурационном файле,
который сохраняет список последних сессий

Обратите внимание: При указании команд, используйте полный путь к команде,
включая расширение.

Для Конфигурирования Кнопок Программ

Для систем UNIX, меню Options в диалоговом окне Preferences позволяет определять
опции внешнего вида Менеджера Приложений и программировать кнопки в менеджере.

Используйте следующие команды для конфигурирования Менеджера Приложений и
программных кнопок:

Команда Функция
Type Определяет начальное положение Менеджера Приложений на

вашем рабочем столе: горизонтально сверху, горизонтально снизу,
вертикально слева или вертикально справа.

Auto Hide Определяет, должен ли Менеджер Приложений автоматически
скрываться при отводе курсора

В меню File в диалоговом окне Preferences, Вы можете щелкнуть по этому элементу:

Save Сохраняет изменения в файле конфигурации config.apm, который
сохраняет эти параметры настройки для последующих сессий

Для сохранения измененных параметров настройки Менеджера Приложений, выберите
Save. Таким образом Вы можете использовать эти же параметры настройки от сессии к
сессии.

Основное Окно Pro/ENGINEER

Интерфейс пользователя Pro/ENGINEER включает меню, панели пиктограмм, области
сообщения и графическую область для объектов Pro/ENGINEER. Меню ограничены
двумя уровнями вложенности. Меню включает следующее:

•  Меню File - опции для управления файлами (открытие, создание, сохранение,
печать и т.д.).

•  Меню Info - опции для выполнения запросов или создания сообщений (например,
отображение списка элементов или проверки последовательности).

•  Меню View - опции для управления отображением модели и эффективности
отображения.

•  Меню Datum - опции для создания типов базовых элементов, таких как точки, оси,
плоскости и т.д.

•  Меню Utilities - опции для настройки рабочей среды и других инструментов.

•  Меню Applications � опции, позволяющие Вам переключаться из одного режима
Pro/ENGINEER в другой и запускать сопутствующие приложения

•  Меню Analysis - опции для анализа параметров моделей. Используйте эти команды
для отображения информации по моделям.

•  Меню Window - опции для открытия, закрытия, изменения размеров и
переключения между окнами Pro/ENGINEER.



•  Меню Help - опции для доступа к контекстно-зависимой справке, информации
технического сопровождения и Индексу справочной системы.

Обратите внимание: Если опция меню не соответствует текущему состоянию окна или
объекта в окне, опция недоступна.

Использование Нескольких Окон Pro/ENGINEER

Каждый объект Pro/ENGINEER, который Вы открываете, появляется в окне,
содержащем меню, панели пиктограмм и область сообщения, дополнительно к
графической области.

Вы можете выполнять множество операций из меню верхнего уровня в нескольких
окнах одновременно без прерывания незаконченной операции.

Если Вы имеете несколько открытых окон, только одно из них активно в каждый момент
времени, но Вы можете выполнять некоторые функции в неактивных окнах. Для
активизации окна, выберите Activate из меню Window.

Чтобы увидеть какие функции Вы можете выполнять в неактивном окне, покажите меню
в этом окне.

Использование Интерфейса Пользователя Pro/ENGINEER

Панели пиктограмм

Панели пиктограмм содержат значки, ускоряющие доступ к часто используемым
командам меню. По умолчанию, панели пиктограмм состоят из горизонтально
расположенных кнопок, находящихся непосредственно под основным меню.

Вы можете получить справку по кнопкам панели и можете также добавлять и удалять
кнопки из панелей пиктограмм.

Информационные Области

Каждое окно Pro/ENGINEER имеет область сообщения внизу окна и строку состояния
для отображения коротких справочных сообщений. Кроме того, когда указатель
проходит по названиям меню, командам меню, кнопкам панели и некоторым элементам
диалогового окна появляются всплывающие подсказки.

Область Сообщения

Все сообщения, связанные с выполняемой работой в сопутствующем окне
отображаются в такой области сообщения. Область сообщения имеет видимый
"поясок", отделяющий ее от графической части окна. Для увеличения или уменьшения
числа видимых строк сообщения, перетащите поясок, нажимая и удерживая левую
кнопку мыши на пояске, в требуемое местоположение.

Стандартные полосы прокрутки в области сообщения позволяют Вам просматривать
прошлые сообщения.



Сообщения разбиты на пять категорий:

 Подсказки

 Информационное сообщение

 Предупреждение

 Ошибка

 Критическое состояние

Строка состояния

Под областью сообщений находится короткая область Справки, которая динамически
отображает короткие контекстно-зависимые справочные сообщения. Если Вы
перемещаете ваш указатель поверх команды меню или опции диалогового окна, в этой
области появляется короткое описание.

Всплывающие Подсказки

Сообщения строки состояния также появляются в маленьких желтых полях около опции
меню, элемента диалогового окна или кнопки панели, которую указатель пропускает.
Они называются всплывающими подсказками (tooltips).

Файл Регистрации Сообщения (Message Log)

Для просмотра последних сообщений, в меню Info, выберите Message Log. Все
сообщения текущей сессии появятся в диалоговом окне прокрутки.

Акселераторы и Мнемоника

Акселераторы и мнемоника - горячие клавиши к командам в области главного меню.

Акселератор - последовательность сочетания клавиш, альтернативных выбору
специфической команды меню при помощи мыши. Для использования акселератора,
удерживая клавишу CTRL нажатой, нажмите соответствующую клавишу. Например, для
сохранения модели, нажмите CTRL-S, а для вывода на печать, нажмите CTRL-P.
Клавиатурные сокращения для акселераторов отображаются рядом с командами меню.



Мнемоника - символы, которые Вы используете для перехода между меню в области
главного меню. Мнемоника сокращает движения мыши и обеспечивает более быструю
работу, если Вы предпочитаете работать с клавиатуры.

Мнемоника обозначена подчеркнутыми символами в названиях меню. Например,
мнемоника для File - F, а мнемоника для Open - 0.

Для выбора Open из меню File, используйте мнемонику вместо мыши:

1.Удерживая клавишу ALT нажмите F. Появится меню File.

2. Нажмите 0. Откроется диалоговое окно File Open.

Всплывающее Меню Toolchest

Используйте всплывающее меню Toolchest для изменения инструментальной панели и
меню. Вы можете иметь панели пиктограмм сверху, слева и справа от вашего окна.
Чтобы открыть требуемое меню Toolchest, нажмите правую кнопку мыши на верхней,
левой или правой инструментальной панели.

Используя всплывающее меню Toolchest, Вы можете настраивать рабочую область
следующим образом:

•  для отображения в инструментальной панели кнопок для команд в специфических
меню или наборов функций, выберите меню или имя функции, связанное с
командами, для которых Вы хотите отобразить значки.

•  Для добавления кнопки к инструментальной панели, нажмите Commands.
Откроется диалоговое окно Customize и отобразится страница Commands.
Следуйте командам в диалоговом окне.

•  Для изменения положения кнопок в окне, нажмите Toolbars. Откроется диалоговое
окно Customize и отобразится страница Toolbars. Выпадающие списки справа
позволят Вам размещать кнопки для каждого меню или отображать наборы сверху,
слева или справа от окна.

Ввод Данных

После выбора некоторых из меню, Pro/ENGINEER требует ввода информации. В этом
случае, звучит сигнал и появляется подсказка внизу окна. Вы можете выключить
сигнал,  выбирая Environment в меню Utilities и выключая Ring Message Bell в
диалоговом окне Environment.
Вы можете принять значение по умолчанию или удалить его и ввести новое значение.
Все команды меню неактивны, пока данные не введены и не подтверждены. Завершите
ввод данных одним из следующих способом:

•  нажмите ENTER .

•  нажмите зеленую кнопку с галочкой.

•  нажмите среднюю кнопку мыши.

Обратите внимание: Вы можете прерывать операции ввода данных, нажимая ESC или
щелчком по красной кнопке X.

Вырезка и Вставка Текста в Окнах

Вы можете использовать мышь или клавиатуру для вырезания или копирования и
вставки текста из окна терминала и вводить его в поле ввода данных Pro/ENGINEER.
Вы можете также вырезать или копировать текст из Информационного Окна
Pro/ENGINEER и вставлять в окна терминала. Вы можете вырезать, копировать и



вставлять текст из окна сообщений. Однако, Вы не можете вырезать и вставлять текст
подсказки в области сообщения или коротком справочном тексте.

Ввод Арифметических Выражений

Когда у Вас запросят числовое значение, Вы можете вводить арифметическое
выражение, включающее цифры, функции, операции и символьные имена параметров.
Например:

Enter value [2.53]: 2 * ((3/8) /7) +ceil (d5)

Поддерживаются следующие основные арифметические операторы:

+ сложение

- вычитание

/ деление

 * умножение

() группировка, например, d0 = (di-d2) *d3

^ возведение в степень

Работа с Дробными Числами

Ввод и отображение размеров может производится в дробном или десятичном
формате. Если Вы работаете с дробями вместо десятичных значений, Вы должны
вводить число как уравнение. Например, введите значение11/8  как 1+1/8. Это значение
отобразится как "1-1/8". Вы можете создавать дроби автоматически, используя опции
файла конфигурации, или Вы можете работать в десятичном формате и
конвертировать требуемые размеры в дроби.

Использование Диалоговых окон

Любая опция меню, заканчивающаяся точками (...) указывает на потребность в
дальнейшей информации. В большинстве случаев, открывается диалоговое окно.
Диалоговые окна, например, открываются при создании и поиске файлов, при печати
файлов, подобно другим Windows-программам.

Вы вводите информацию в диалоговое окно, начиная сверху поля и перемещаетесь к
низу. В некоторых диалоговых окнах, содержимое нижних элементов зависит от того,
что Вы сделали наверху.

Всякий раз, когда необходим выбор опции, Вы будете видеть стрелку выбора. Если Вы
щелкните по стрелке, открывается список, содержащий доступные опции.

Многие диалоговые окна содержат раскрывающиеся секции, обозначенные белым
треугольником. Если Вы щелкните по треугольнику, секция появится или исчезнет.

Синие полосы разделяют основные группы в диалоговом окне. Синий цвет обозначает
настраиваемость. Группы содержат связанные элементы. Каждая группа имеет метку.

Обратите внимание: Как правило, опция или поле в диалоговом окне недоступны,
если:

•  опция не соответствует состоянию окна, объекта или типу программы (Деталь,
Сборка, Эскиз, Компоновка и т.д.).

•  модуль, требуемый для их использования, не установлен. Например, если
Pro/INTRALINK не установлен, некоторые кнопки в диалоговом окне File Open
недоступны.



Диалоговые Окна с Несколькими Функциями

Большинство диалоговых окон поддерживает набор связанных функций. Например, все
функции переориентации вида, изменения масштаба изображения, панорамирования,
вращения и центра вращения доступны в диалоговом окне Orientation.

Многие диалоговые окна также являются динамическими: опции изменяются при
осуществлении выбора. Например, диалоговое окно Orientation изменяется в
зависимости от выбора в поле Type.

Второй пример диалогового окна с несколькими функциями - диалоговое окно
Component Placement, которое объединяет функции для фиксированного и
комплексного размещения.

Диалоговое окно Component Placement - также является примером использования
ярлычков. Когда Вы нажимаете ярлычок типа Place или Move, в диалоговом окне
отображается соответствующая страница.

Выполнение Действий По Умолчанию

Все диалоговые окна в Pro/ENGINEER имеют кнопку по умолчанию, обозначенную
темной черной рамкой вокруг кнопки. Вы можете быстро выполнять заданное по
умолчанию действие тремя различными способами:

•  Переместить указатель на кнопку и нажать ее.

•  Нажать среднюю кнопку мыши в любом месте экрана.

•  Нажать ENTER .

Настройка Интерфейса Пользователя

Вы можете настраивать ваш интерфейс пользователя несколькими способами.

Создание Клавиатурных Макрокоманд, Кнопок и Изображений
Кнопок

Вы можете использовать команду Mapkeys в меню Utilities для:

•  Создания клавиатурных макрокоманд (часто используемые последовательности
команд, которые связаны с нажатиями определенных клавиш).

•  Определения обозначений для кнопок, если они добавляются к инструментальной
панели. Обозначения отображаются в инструментальной панели, когда
пользователь выбирает функцию "Отображать текст в кнопках панели".
Обозначение также используется, когда Вы добавляете макрокоманду к меню,
используя диалоговое окно Customize.

•  Ввода описания каждой макрокоманды, которые помогают Вам следить за
определенными макрокомандами.

Настройка Панели Пиктограмм, Кнопок Панели и Местоположение
Области Сообщений

Вы можете использовать команду Customize Screen в меню Utilities для:



•  Добавления, удаления и перемещения кнопок панели. Дополнительно к
первоначальным доступны многие другие кнопки панели.

•  Создания ваших собственных кнопок панели и изменения изображений на кнопках.

•  Добавления, удаления и перемещения макрокоманд и команд верхнего уровня в
меню.

•  Настройка местоположения области сообщений.

•  Выбора Дерева Моделей, размера окна и настройки изображения меню.

Редактирование Файла Конфигурации

Вы можете загружать и редактировать файл конфигурации, чтобы настроить работу
Pro/ENGINEER при его запуске. Используйте Preferences в меню Utilities.

Настройка Менеджера Меню Панелей

Вы можете настраивать меню панелей Menu Manager, которые отображаются на
правой стороне вашего экрана при открытии модели (боковые меню). Если не имеется
никакого системного значения по умолчанию для требуемого меню, Вы можете
устанавливать ваше собственное значение по умолчанию, используя файл
menu_def.pro.

Подобно файлу конфигурации, этот файл загружается в процессе инициализации
Pro/ENGINEER. Сначала просматривается каталог системных значений по умолчанию,
затем текущий рабочий каталог. Если в системе menu_def.pro для конкретного меню
определено вхождение значения по умолчанию, то любые противоречивые
определения в локальном файле игнорируются.

Настройка Менеджера Меню

Значения Меню По Умолчанию

Если не имеется никакого системного значения по умолчанию для конкретного меню,
Вы можете устанавливать ваше собственное значение по умолчанию, используя файл
menu_def.pro. Подобно файлу конфигурации, этот файл загружается в процессе
инициализации Pro/ENGINEER. Сначала просматривается каталог системных значений
по умолчанию, затем текущий рабочий каталог. Если вхождение по умолчанию для
конкретного меню уже определено в системе menu_def.pro, то любые противоречивые
определения в локальном файле игнорируются.

Примечания:

•  Установка пункта меню, как заданного по умолчанию варианта меню заставляет
этот пункт меню автоматически выбираться всякий раз при вводе меню.

•  Составные меню для установки меню по умолчанию не поддерживаются.

Формат для определения меню по умолчанию:

menuname menuitem

где:

•  menuname - заголовок, отображаемые вверху меню. Если заголовок состоит из
более, чем одного слова, пробелы между словами должны быть заменены на #



(Например, menuname для меню DIM PNT PNT должно быть введено как
dim#PNT#PNT).

•  menuitem - опция в меню menuname. Если опция состоит из более, чем одного
слова, Вы должны заменить пробелы между словами на # (например, ввести
menuitem Edge Tangent, как edge#tangent).

Примечания:

•  может существовать только один пробел между menuname и menuitem, указанным
по умолчанию.

•  Регистр вхождений не имеет значения.

примеры:
ORIENTATION Default -- когда меню ORIENTATION активизируется, то автоматически
выбирается Default.
dwg#size а - когда меню DWG SIZE активизируется, то автоматически выбирается
размер А.

Если, в момент запуска, указанное пользователем меню по умолчанию недоступно, оно
игнорируется. Если одно то же название меню используется в файле menu_def.pro
дважды, более позднее вхождение отменяет более раннее. Система не сообщает о
каких либо ошибках в меню по умолчанию.

Вы должны работать с файлом menu_def.pro очень тщательно чтобы избежать ошибок;
должны знать заранее результат, к которому может привести меню по умолчанию и
всегда помнить, какие пункты файла меню установлены по умолчанию. Например,
установка Create, заданная по умолчанию для меню Feature приведет к непрерывному
циклу создания элемента, который может быть остановлен, только завершением
сессии Pro/ENGINEER.

Установка какого либо размера рисунка по умолчанию для меню DWG SIZE - другой
пример некорректного поведения; установленный размер рисунка будет автоматически
выбираться всякий раз при создании рисунка, и может легко привести к созданию
рисунка на листе неправильного размера до обнаружения ошибки.

Чтобы избежать автоматической загрузки файла menu_def.pro по ошибке, следуйте
следующей инструкции:

•  Создавайте файл menu_def.pro, только когда Вы уверены, что будете использовать
его в следующей сессии Pro/ENGINEER. Переименуйте или удалите файл по
завершении сессии.

•  Сохраняйте файл в рабочем каталоге под различными именами. Перед запуском
сессии Pro/ENGINEER, в которой файл будет использоваться, переименуйте его в
menu_def.pro. Переименуйте или удалите файл по завершении сессии.

Опции Добавления Меню

Вы можете добавлять пункты меню для применения ваших клавиатурных макрокоманд
посредством графического интерфейса; Вы также можете использовать их для вызова
других приложений или команд.

Для Макрокоманд Клавиатуры

Опции добавления меню - один из вариантов размещения ваших клавиатурных
макрокоманд на видимом месте. Это делает их более доступными, их невозможно
забыть и более вероятно их частое использование.

Для создания новой опции меню, добавьте в ваш файл menu_def.pro строку в одном из
следующих форматов:

setbutton menuname menuitem "ActionDefinition" "ShortHelp"



... Или ...

setbutton menuname menuitem "ActionDefinition"

Элементы этих определений следующие:

•  menuname - заголовок меню. Он обычно, но не всегда, соответствует тому, который
отображается в поле заголовка в верхней части меню. Чтобы быть абсолютно
уверенным в том, что menuname есть, включите опции файла конфигурации
button_name_in_help. Как только Вы установите курсор над опцией меню,
соответствующий menuname и menuitem отобразится в строке состояния. Если
заголовок состоит из более чем одного слова, замените символами # все пробелы в
menuname (например, cosm#view для view cosm).

•  menuitem - название новой опции меню, когда она появляется в меню. Если опция
состоит из более, чем одного слова, замените символами # все пробелы в
menuitem (например, shade#obj для shade obj).

ActionDefinition - последовательность щелчков меню, выборов в диалоговых окнах и
вводов пользователя, которая будет активизирована новой опцией. Синтаксис для
ActionDefinition - подобен макрокоманде клавиатуры. Если определение setbutton не
помещается в одной строке, укажите [\ < CR >] (наклонная черта влево, перевод
каретки) и продолжите на следующей строке. Полная длина определения setbutton не
должна превышать 250 символов.

ShortHelp - текстовая строка, используемая, как подсказка для новой опции меню. Если
опущено (при использовании второго формата), для подсказки используется строка по
умолчанию User defined action (действие, определяемое пользователем).

Правила для Пользовательских Пунктов Меню

•  Вы не может использовать setbutton для изменения существующих опций меню
Pro/ENGINEER (то есть пунктов меню, существующих в файлах системного меню).

•  Вы должны удостовериться, что название пользовательского элемента уникально
для всех пунктов на экране в любой данный момент, и что все команды,
упомянутые в ActionDefinition доступны на момент выполнения действия. Например,
если Вы выбираете Shade Obj (см. пример ниже) в режиме Drawing, это приведет к
ошибке.

•  максимальное число символов в menuitem, разрешенное системой, - 19. Вы можете
использовать 12 символов, чтобы соответствовать ширине стандартного меню
Pro/ENGINEER или изменить ширину меню.

Вы должны указать menuitem и ShortHelp точно так, как они появляются на экране.
Элементы для menuname не зависят от регистра. ActionDefinition тоже не зависят от
регистра, за исключением ввода с клавиатуры.

Примеры Пользовательских Опций Меню
Пример 1 - Тонирование текущего объекта.

[@setbutton MAIN Shade#Obj #view;#cosmetic;\

#shade;#display;#done-return; Shade an object.]

Пример 2 - Сохранение текущего объекта

[@setbutton MAIN Save#Obj #dbms;#save;;\

#done-return; Save an object.]

Пример 3 - Сохранение текущей детали и отображение меню списка названий для
вызова другой. Обратите внимание, что ActionDefinition ссылается на другую
пользовательскую опцию меню (Save Obj, определенную выше). Глубина вложенности
в таких случаях не должна превышать 5 уровней.

[@setbutton PART Switch#Prt #Save Obj;\



#Quit Window;#Mode;#Part;#Search/Retr;\

Switch to another part. (Переключиться к другой детали)]

Обратите внимание: Когда Вы используете пользовательскую опцию меню в другом
определении setbutton или макрокоманде клавиатуры, не забудьте изменить
символы #, если таковые вообще имеются, обратно на пробелы.

Для Других Приложений

В Pro/ENGINEER возможно выполнить любую команду, путем определения опции меню
и связанной команды в файле menu_def.pro. Это дает возможность Вам запускать
другие приложения, типа вашего структурного пакета анализа или сетевой
документации. Команды выполняются на уровне оболочек из окна запуска.

Формат для этого следующий:

@setbutton_exec UTILITIES menuitem ActionDefinition ShortHelp

•  UTILITIES - название специального меню, где добавляется опция.

Обратите внимание: Если Вы вводите меню с именем, отличным от UTILITIES,
команда видна, но не может быть выполнена.

•  menuitem - название новой опции в том виде, как она должна появится в меню. Если
имеется более одного слова в опции, замените символами # все пробелы между
словами. Например, чтобы определить пункт меню Doc Viewer, введите Doc#Viewer.

•  ActionDefinition - команда и опции команды, которые выполняют новую опцию.

•  ShortHelp - короткое справочное сообщение, описывающее опцию меню. При
отсутствии, строка по умолчанию - User defined action (Пользовательское действие).

Ширина Меню

Стандартная ширина меню Pro/ENGINEER в панелях меню Menu Manager - 12
символов. Иногда, когда Вы используете библиотеки или вызываете объекты, которые
требуют более 12 символов для отображения уникального названия, Вы можете
увеличить число отображаемых символов - максимум до 19.

Выполняйте это, изменяя опции файла конфигурации:

set_menu_width value (число в пределах от 13 до 19)

Это увеличит все меню Pro/ENGINEER до указанной ширины. Вы можете затем
отмасштабировать окна Pro/ENGINEER во избежание чрезмерного перекрытия и
выхода за экран изображения меню.

Обратите внимание: Когда Вы изменяете значение, Вы должны запустить новую
сессию для того, чтобы изменения вступили в силу.

Шрифт Меню

Опция файла конфигурации menuitem_font дает возможность определять шрифт,
используемый пунктами меню Pro/ENGINEER.

UNIX

Значение должно являться названием шрифта, доступного на X-сервере, с запущенным
Pro/ENGINEER. Для вызова списка шрифтов вашей платформы, выполните команду
xlsfonts. Заданный по умолчанию шрифт для большинства платформ - Adobe-Helvetica-
Bold-R-Normal, 12 или 14 точек.



Пример:

Чтобы определить шрифт `Palatino-bold', введите:

menuitem_font palatino-bold

Windows NT /95

Шрифт определяется комплексным значением следующим образом:

menuitem_font -fontname -height -weight -italics,

где:

fontname - любой шрифт, находящийся в Панели управления Windows;

height - высота шрифта (12, 14, 16 и т.д.);

weight - вес шрифта (400 = regular, 700 = полужирный)

italics - 0 (без курсива) или 1 (курсив).

Пример 1:

Чтобы определить следующий шрифт: Ariel, 12 пунктов, стандартный, не курсив
установите опции следующим образом:

menuitem_font -ariel-12-400-0

Пример 2:

Чтобы определить следующий шрифт: Times New Roman, 14 пунктов, полужирный,
курсив установите опции следующим образом:

menuitem_font -Times New Roman-14-700-1

Система автоматически корректирует высоту и ширину меню для соответствия размеру
указанного шрифта. Обратите внимание, что, когда Вы изменяете шрифт, Вы должны
открыть новую сессию, чтобы изменения вступили в силу.

Обратите внимание: опция menuitem_font не работает с Японской версией
Pro/ENGINEER.

Вид Меню

Опция 3d_menu_buttons файла конфигурации дает возможность выбирать, будут ли
опции меню объемными или стандартными. Разрешенные значения для опции
следующие:

no - (по умолчанию) опции меню отображаются плоскими.

yes - опции меню при активизации или подсвечивании становятся трехмерными.

Высота меню немного увеличивается, когда опции меню имеют объемный вид.
Поэтому, в ситуациях, где Вы имеете несколько меню на экране, Вы можете получить
некоторое (дополнительное) каскадирование.

Обратите внимание: когда Вы изменяете значение, Вы должны начать новую сессию,
чтобы оно вступило в силу.

Создание Базового Элемента

Вы можете создавать все типы базовых элементов (точки, оси, плоскости, системы
координат, кривые, диаграммы и анализы) в верхнем меню Datum.

В процессе создания элемента, изучения модели, сборки компонентов и других
операций, Вам потребуется выбрать одну или более базовых точек, осей, плоскостей,



и-или систем координат, в то время как зачастую, требуемый базовый элемент не
существует. Нет необходимости прерывать вашу текущую операцию для работы с
меню Feature и создавать требуемый базовый элемент.

Вы можете создавать базовые точки, оси, плоскости и системы координат в любое
время из верхнего меню. Вы можете создавать эти элементы даже в процессе создания
другого элемента, затем использовать их в качестве вспомогательных для этого
элемента. На любом этапе создания элемента, размера или анализа, когда базовый
элемент необходим, Вы можете его создать.

Это применяется даже для вложенных базовых элементов, где точка, ось и плоскость
должны быть созданы просто для справочных целей, например, для смещения
базового элемента.

Использование Диалоговых Окон Подтверждения

Многие функции используют диалоговые окна подтверждения. Для использования
диалогового окна подтверждения, нажмите Yes или No
Информация в поле изменяется, в зависимости от функции.

Использование Всплывающих Меню

В разных ситуациях, при щелчке и удерживании правой кнопки мыши отображается
маленькое всплывающее меню рядом с указателем. Это всплывающее меню содержит
контекстно-зависимый список часто используемых действий. Следующие разделы
описывают некоторые из них.

Всплывающее Меню Дерева Модели

Всплывающее меню Дерева Модели содержит ярлык изменения и отчета по
элементам, компонентам и примечаниям трехмерных элементов. Для отображения
этого всплывающего меню, выберите элемент в дереве и нажмите правую кнопку
мыши. Появляющееся всплывающее меню содержит команды, соответствующие
элементу или элементам, которые Вы выбрали.

Обратите внимание: всплывающее меню Дерева Модели работает только в том
случае, если Вы сначала выбрали элемент в Дереве Модели.

Всплывающее меню Sketcher

Используйте всплывающее меню Sketcher в режиме Sketcher для быстрого
переключения между эскизированием, изменением, образмериванием или удалением
эскизных элементов. Вы можете также отменить и восстановить предыдущие действия.

Чтобы открыть это меню, нажмите правую кнопку мыши когда курсор находится в окне
Sketcher. Появляющееся всплывающее меню, содержит контекстно-зависимый список
команд.

Всплывающего Меню Drawing

Используйте всплывающее меню Drawing в режиме Drawing для перемещения или
изменения видов и выносных элементов. Чтобы открыть это меню, нажмите правую
кнопку мыши, когда курсор находится в окне рисунка.



Всплывающее Меню Toolchest

Используйте всплывающее меню Toolchest для изменения положения
инструментальной панели и меню. Так как Вы можете иметь кнопки панели сверху,
слева и справа от вашего окна, появляющееся меню изменяется соответственно.
Чтобы открыть требуемое меню Toolchest, нажмите правую кнопку мыши верхней,
левой или правой инструментальной панели.

Используя всплывающее меню Toolchest, Вы можете настраивать меню пиктограмм
следующим образом:

•  для отображения пиктограмм инструментальной панели конкретного меню или
набора функций, выберите меню или имя функции, связанное с командами.

•  Чтобы добавить пиктограммы к инструментальной панели, нажмите Commands.
Откроется диалоговое окно Customize с отображенной страницей Commands.
Следуйте инструкциям в диалоговом окне.

•  Чтобы изменить положение значков в инструментальной панели, нажмите Toolbars.
Откроется диалоговое окно Customize с отображенной страницей Toolbars.
Раскрывающиеся списки справа позволят Вам размещать пиктограммы для каждого
меню или устанавливать команды в верхнем, левом или правом окне.

Файлы Pro/ENGINEER

При создании и выполнении операций с файлами Pro/ENGINEER применяются
следующие требования:

•  Названия всех файлов Pro/ENGINEER ограничены 31 символом. Объект, имеющий
более 31 символа в названии не может быть создан или найден.

•  Скобки ( [ ] { } или ( ) ) и точки (.) не могут использоваться в именах файлов и
каталогов.

•  Не буквенно-цифровые символы (типа, # и %) не могут использоваться в именах
файлов и каталогов. Файлы и каталоги объектов, которые содержат не буквенно-
цифровые символы в именах, не отображаются в диалоговых окнах Pro/ENGINEER
и не могут быть найдены. Pro/ENGINEER запрещает любую попытку сохранить
новые файлы объектов с такими символами в именах.

•  Для названий файлов и каталогов Pro/ENGINEER, используйте только символы в
нижнем регистре.

Если Pro/ENGINEER находит два или более каталогов в пути, которые имеют общий
родительский каталог и одинаковые названия (за исключением различных комбинаций
символов в верхнем и нижнем регистре), он ищет только в каталоге с самыми первыми
прописными буквами (так как их значения ASCII более низкие). Это правило
сохраняется, даже если Вы вводите полный путь и в нужном регистре. Например, если
Pro/ENGINEER находит три каталога с именами аВс, АВс и Авс, он ищет только в
каталоге ABc.

•  Pro/ENGINEER всегда сохраняет объекты и файлы на диске с именами файлов в
нижнем регистре.

•  При указании пути можно использовать специальные символы, типа тильды (~) и
двух точек (..), чтобы указать относительный путь. Однако, лучше всегда указывать
абсолютный путь (от корня) чтобы избежать проблем после изменения рабочих
каталогов или использования одного и того же файла конфигурации в другом
каталоге запуска.



Создание Новых Файлов и Использование Шаблонов

Вы можете создавать новый эскиз, деталь, сборку, обрабатываемую модель, рисунок,
формат, сообщение, диаграмму, компоновку, обозначение, или обмениваться файлами
в Pro/ENGINEER, используя диалоговые окна New File Options.

Для открытия диалогового окна New выберите New в меню File. Вы можете
использовать это диалоговое окно для:

•  Выбора типа создаваемого файла, например, эскиза, детали или сообщения.

•  Если требуется, выберите подтип, например Solid для Part.

•  Введите имя для вашего файла или используйте имя по умолчанию.

•  Выберите файл шаблона, используемого в создании новой модели.

Обратите внимание: При создании нового объекта, шаблон автоматически
предлагается для любого типа объекта, поддерживаемого шаблоном.

Используется Также может
использоваться Для Имя по

умолчанию
Sketch

(Эскиз)
Создание нового эскиза s2d####.sec

Part

(Деталь)

Solid

(Тв. тело)
Создание новой модели
детали prt####.prt

Composite

(Составная деталь)

Создание составной модели
детали.

prt####.prt

Sheetmetal Создание sheetmetal модели
детали.

prt####.prt

Assembly

(Сборка)

Design

(Конструкция)

Создание модели сборки. asm####.asm

Interchange

(Обмен данными)

Создание файла обмена
данными.

asm####.asm

Verify

(Контроль)

Создание контрольной сборки. asm####.asm

Process Plan

(Технологический
процесс)

Создание технологического
процесса для модели сборки.

asm####.asm

Manufacturing

(Обработка)

NC Part

(Обработка детали)

Создание детали для
обрабатываемой модели.

mfg####.mfg

NC Assembly

(Обработка сборки)

Создание сборки для
обрабатываемой модели.

mfg####.mfg

CMM

(КИМ)

Создание
последовательности
перемещений КИМ
(Координатная
Измерительная Машина) для
обрабатываемой модели.

mfg####.mfg

Sheetmetal Создание модели sheetmetal. mfg####.mfg



Cast

(Отливка)

Создание модели отливки. mfg####.mfg

Mold

(Литейная Форма)

Создание модели литейной
формы.

mfg####.mfg

Dieface

(Вставки Штампа)

Создание модели вставки
штампа.

mfg####.mfg

Harness

(Кабельные Жгуты)

Создание кабельных жгутов
для производственной модели

mfg####.mfg

Process Plan

(Технологическая
Операция)

Создание технологической
операции для
обрабатываемой модели.

mfg####.mfg

Drawing

(Рисунок)

Создание рисунка модели. drw####.drw

Format

(Форматка)

Создание файла форматки
для рисунка или компоновки.

frm####.frm

Report

(Отчет)

Создание отчета для модели. rep####.rep

Diagram

(Диаграмма)

Создание двухмерной
диаграммы электрических,
трубопроводных, силовых,
нагревательных и
вентиляционных сборок.

dgm####.dgm

Layout

(Компоновка)

Создание двухмерного
концептуального эскиза для
модели или сборки.

lay####.lay

Markup

(Обозначение)

Создание файла обозначений
для объекта.

mrk####.mrk

Name

(Имя)

Укажите имя файла или
используйте имя по
умолчанию.

Copy From

(Копировать из)

Отображает диалоговое окно
Choose Template (Выберите
Прототип), где Вы можете
выбрать файл прототип (по
желанию, для деталей и
сборок).

Создание Нового Эскиза

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Sketch.
3. Укажите имя файла для эскиза, или используйте заданное по умолчанию имя, и
нажмите OK.
Дополнительная Информация:



Формат заданного по умолчанию имени файла: s2d####.sec

Создание Новой Детали

Вы создаете модели путем формирования элементов. Чтобы создать элементы, Вы
должны сначала создать новую деталь.

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Part.
3. В Sub-type, выберите Solid.
4. Опционально: Если Вы хотите использовать прототип модели для твердотельной
детали, нажмите Copy From и укажите требуемый файл.

5. Укажите имя файла детали или используйте заданное по умолчанию имя, и нажмите
OK.
Обратите внимание: объекты New создаются, используя прототипы по умолчанию.
Если Вы хотите в интерактивном режиме выбрать прототип модели, который нужно
использовать, снимите флажок Use Default Templates.

Совет: для создания детали в контексте сборки:

1. в Дереве Модели, выберите сборку, в которой будет находится деталь.

2. Нажмите правую кнопку мыши и выберите Component > Create.
3. Используйте диалоговое окно Component Create для создания файла детали.

Дополнительная Информация:

формат заданного по умолчанию имени файла: prt####.prt

Создание Новой Детали Sheetmetal

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Part.
3. В Sub-type, выберите Sheetmetal.
4. Укажите имя файла для детали или используйте заданное по умолчанию имя, и
нажмите OK.
Обратите внимание: объекты New создаются, используя прототипы по умолчанию.
Если Вы хотите в интерактивном режиме выбрать прототип модели, который нужно
использовать, снимите флажок Use Default Templates.

Совет: для создания детали в контексте сборки:

1. В Дереве Модели, выберите сборку, в которой будет находится деталь.

2. Нажмите правую кнопку мыши и выберите Component > Create.
3. Используйте диалоговое  окно Component Create, чтобы создать файл детали.

Дополнительная Информация:

Формат заданного по умолчанию имени файла: prt###.prt



Преобразование Детали в Sheetmetal

Для открытой детали, выберите Applications > Sheetmetal.

Создание Новой Составной Детали

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Part.
3. В Sub-type, выберите Composite.
4. Укажите имя файла для детали или используйте заданное по умолчанию имя, и
нажмите OK.
Дополнительная Информация:

Формат заданного по умолчанию имени файла: prt###.prt

Создание Новой Сборки

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Assembly.
3. В Sub-type, выберите Design.
Обратите внимание: объекты New создаются, используя прототипы по умолчанию.
Если Вы хотите в интерактивном режиме выбрать прототип модели, который нужно
использовать, снимите флажок Use Default Templates.

4. Укажите имя файла для сборки или используйте заданное по умолчанию имя, и
нажмите OK.
5. Вы увидите второе диалоговое окно New File Options, который позволит Вам в
интерактивном режиме выбрать прототип и указать значения параметров в модели
прототипа.

Если Вы всегда хотите видеть диалоговое окно New Files Options, установите опцию
force_new_file_options_dialog в Yes.

Совет: для создания детали в контексте сборки:

1. В Дереве Модели, выберите сборку, в которой будет находится деталь.

2. Нажмите правую кнопку мыши и выберите Component > Create.
3. Используйте диалоговое  окно Component Create, чтобы создать файл детали.

Дополнительная Информация:

Формат заданного по умолчанию имени файла: asm####.asm

Создание Нового Рисунка

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Drawing.



3. Укажите имя файла рисунка или используйте заданное по умолчанию имя, и нажмите
OK.
4. В диалоговом окне New Drawing укажите размер листа и ориентацию; или, укажите
или выберите название формата.

5. Щелкните по OK. Откроется окно рисунка. Откроются диалоговые окна Simplified
Rep или Instance, в которых Вы должны выбрать требуемый вариант и нажать OK.
Дополнительная Информация:

Формат заданного по умолчанию имени файла: drw####.drw

Создание Новой Обрабатываемой Модели

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Manufacturing.
3. В Sub-type, выберите NC Assembly, NC Part, NC Expert, CMM, Sheetmetal, Cast,
Mold, Dieface, Harness или Process Plan.
4. Укажите имя файла модели или используйте заданное по умолчанию имя, и нажмите
OK.
Дополнительная Информация:

Формат заданного по умолчанию имени файла: mfg####.mfg

Создание Новой Модели Литейной Формы

Для создания новой модели литейной формы:

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Manufacturing.
3. В Sub-type, выберите Mold.
4. Укажите имя файла модели литейной формы или используйте заданное по
умолчанию имя, и нажмите OK.
Обратите внимание: объекты New создаются, используя прототипы по умолчанию.
Если Вы хотите в интерактивном режиме выбрать прототип модели, который нужно
использовать, снимите флажок Use Default Templates.

5. Вы увидите второе диалоговое окно, New File Options, которое позволит Вам в
интерактивном режиме выбрать прототип и указать значения параметров в модели
прототипа.

Если Вы всегда хотите видеть диалоговое окно New Files Options, установите опцию
force_new_file_options_dialo в Yes.

Дополнительная Информация:

Формат заданного по умолчанию имени файла: mfg####.mfg

Создание Новой Модели Отливки

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.



2. В Type, выберите Manufacturing.
3. В Sub-type, выберите Cast.
4. Укажите имя файла модели отливки или используйте заданное по умолчанию имя, и
нажмите OK.
Обратите внимание: объекты New создаются, используя прототипы по умолчанию.
Если Вы хотите в интерактивном режиме выбрать прототип модели, который нужно
использовать, снимите флажок Use Default Templates.

5. Вы увидите второе диалоговое окно, New File Options, который позволит Вам в
интерактивном режиме выбрать прототип и указать значения для параметров в модели
прототипа.

Если Вы всегда хотите видеть диалоговое окно New Files Options, установите опцию
force_new_file_options_dialog в Yes

Дополнительная Информация:

Формат заданного по умолчанию имени файла: mfg####.mfg

Создание Новой Компоновки

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Layout.
3. Укажите имя файла для компоновки или используйте заданное по умолчанию имя, и
нажмите OK.
4. В диалоговом окне New Layout, определите размер листа и ориентацию; или,
укажите или выберите название формата.

5. Щелкните по ОК.
Дополнительная Информация:

Формат заданного по умолчанию имени файла: lay####.lay

Создание Новой Обрабатываемой Конструкции Штампа

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Manufacturing.
3. В Sub-type, выберите Dieface.
4. Укажите имя файла для файла проекта штампа или используйте заданное по
умолчанию имя, и нажмите OK. Откроется диалоговое окно Open.

5. В диалоговом окне Open, укажите имя конструкции детали для модели штампа или
перейдите в каталог, содержащий деталь и выберите ее.

Дополнительная Информация:

Формат заданного по умолчанию имени файла: mfg####.mfg

Создание Нового Файл Форматки

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.



2. В Type, выберите Format.
3. Укажите имя файла форматки или используйте заданное по умолчанию имя, и
нажмите OK.
4. В диалоговом окне New Format определите размер листа и ориентацию; или,
укажите или выберите название формата:

Формат заданного по умолчанию имени файла: frm####.frm

Создание Нового Сообщения

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Report.
3. Укажите имя файла сообщения или используйте заданное по умолчанию имя, и
нажмите OK.
4. В диалоговом окне New Report, определите размер листа и ориентацию; или,
укажите или выберите название формата:

Формат заданного по умолчанию имени файла: rep####.rep

Создание Нового Файла Обозначения

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Markup.
3. Укажите имя файла для обозначения или используйте заданное по умолчанию имя, и
нажмите OK.
4. В диалоговом окне Markup, перейдите в каталог, где содержится файл, который Вы
хотите обозначить. Выберите тип объекта в списка Type ((Part, Assembly и т.д.),
выберите файл, и нажмите Open.
Дополнительная Информация:

Формат заданного по умолчанию имени файла: mrk####.mrk

Создание Новой Диаграммы

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Diagram.
3. Укажите имя файла для диаграммы или используйте заданное по умолчанию имя, и
нажмите OK.
4. В диалоговом окне New Diagram, определите размер листа и ориентацию; или,
укажите или выберите название формата.

5. Щелкните по ОК.
Дополнительная Информация:

Формат заданного по умолчанию имени файла: dgm####.dgm



Создание Нового Файла Обмена Данными

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Assembly.
3. В Sub-type, выберите Interchange.
4. Щелкните по ОК.
Дополнительная Информация:

Формат заданного по умолчанию имени файла: asm####.asm

Создание Файла Наследования Данных для Детали

В Pro/ENGINEER, Вы можете использовать двух- или трехмерные данные или
графические объекты, созданные другими CAD-системами. Они называются файлами
наследования данных.

Для создания файла наследования данных для детали:

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Part.
3. В Sub-type, выберите Solid.
Обратите внимание: объекты New создаются, используя прототипы по умолчанию.
Если Вы хотите в интерактивном режиме выбрать прототип модели, который нужно
использовать, снимите флажок Use Default Templates.

4. Укажите имя файла детали или используйте заданное по умолчанию имя, и нажмите
OK.
5. Выберите Applications > Legacy.
6. Используйте команду в меню LEGACY PRT на правой панели.

Совет: для создания детали в контексте сборки:

1. В Дереве Модели, выберите сборку, в которой будет находится деталь.

2. Нажмите правую кнопку мыши и выберите, Component > Create.
3. Используйте диалоговое  окно Component Create, чтобы создать файл детали.

Дополнительная Информация:

Формат заданного по умолчанию имени файла: prt####.prt

Создание Нового Файла Наследования Данных для
Сборки

В Pro/ENGINEER, Вы можете использовать двух- или трехмерные данные или
графические объекты, созданные другими CAD-системами. Они называются файлами
наследования данных.

Для создания файла наследования данных для сборки:

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.



2. В Type, выберите Assembly.
3. В Sub-type, выберите Design.
Обратите внимание: объекты New создаются, используя прототипы по умолчанию.
Если Вы хотите в интерактивном режиме выбрать прототип модели, который нужно
использовать, снимите флажок Use Default Templates.

4. Укажите имя файла для сборки или используйте заданное по умолчанию имя, и
нажмите OK.
5. Вы увидите второе диалоговое окно, New File Options, которое позволит Вам в
интерактивном режиме выбрать прототип и указать значения для параметров в модели
прототипа.

6. Выберите Applications > Legacy.
7. Используйте команду в меню LEGACY ASM на правой панели.

Если Вы всегда хотите видеть диалоговое окно New Files Options, установите опцию
force_new_file_options_dialog в Yes.

Совет: для создания детали в контексте сборки:

1. В Дереве Модели, выберите сборку, в которой будет находится деталь.

2. Нажмите правую кнопку мыши и выберите, Component > Create.
3. Используйте диалоговое  окно Component Create, чтобы создать файл детали.

Дополнительная Информация:

Формат заданного по умолчанию имени файла: asm####.asm

Создание Нового Файла Наследования Данных для
Рисунка

В Pro/ENGINEER, Вы можете использовать двух- или трехмерные данные или
графические объекты, созданные другими CAD-системами. Они называются файлами
наследования данных.

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Drawing.
3. Укажите имя файла для рисунка или используйте заданное по умолчанию имя, и
нажмите OK. Появляется второе диалоговое окно .

4. Выберите Applications > Legacy.
5. Используйте команду в меню LEGACY DWG на правой панели.

Дополнительная Информация: формат имени файла Default: drw####.drw

Создание Новой Контролируемой Сборки

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Assembly.
3. В Sub-type, выберите Verify.
4. Укажите имя файла контролируемой сборки или используйте заданное по умолчанию
имя.



5. Используйте меню VERIFICATION для поиска конструкции модели и набора (или
наборов) сканированных данный.

Дополнительная Информация:

Формат заданного по умолчанию имени файла: asm####.asm

Создание Новой Технологической Операции Сборки

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Assembly.
3. В Sub-type, выберите Process Plan.
4. Укажите имя файла технологической операции или используйте имя по умолчанию.

5. Используйте команду меню ASM PROCESS в правой панели.

Дополнительная Информация:

Формат заданного по умолчанию имени файла: asm####.asm

Создание Новой Технологической Операции Обработки

1. Выберите File > New из меню, или щелкните по          в инструментальной панели.
Откроется диалоговое окно New.

2. В Type, выберите Manufacturing.
3. В Sub-type, выберите Process Plan.
4. Укажите имя файла для технологической операции или используйте имя по
умолчанию.

5. Используйте команды меню MANUFACTURING в правой панели.

Дополнительная Информация:

Формат заданного по умолчанию имени файла: mfg####.mfg

Выбор Рабочего Каталога

Вы можете выбирать различные рабочие каталоги в процессе работы в Pro/ENGINEER,
используя диалоговое окно Select Working Directory.

Чтобы открыть диалоговое окно Select Working Directory, в меню File выберите
Working Directory. Вы можете использовать это диалоговое окно для указания нового
рабочего каталога.

Рабочий каталог - каталог, который Вы устанавливаете для файлов Pro/ENGINEER. Вы
должны иметь права чтения/записи в этом каталоге. Pro/ENGINEER обычно запускают
из Вашего рабочего каталога.

Используйте Для

Отображения каталога на уровень выше текущего каталога.

Отображения файлов, находящихся в памяти.



Отображения текущего рабочего каталога.

Используйте меню Favorites, в котором Вы можете:

Save location - сохранять текущий favorite каталог.

Remove location - удалять текущий favorite каталог.

Browse favorites - выполняет поиск в Ваших favorite каталогах.

Отображает содержимое каталога в виде списка файлов.

Отображает информацию по версии Pro/INTRALINK. (Вы должны 
инсталлировать Pro/INTRALINK и иметь лицензию, чтобы использовать 
эту кнопку.)

 

Look In Default Выберите каталог по умолчанию
для отображения этого
диалогового окна

Sort By > Model Name Выполняет сортировку файлов в
алфавитном порядке по имени
модели

Sort By > Markup/Instance Name Выполняет сортировку по
указанному обозначению или
имени вхождения

All Versions Отображает все версии объектов

Retrieve as View Only Вызывает объект только в режиме
View

directory list Дважды щелкните по имени
каталога для его выбора

Name Отображает имя выбранного
каталога

Type Перечисляет только каталоги (Вы
не можете выбрать тип)

Предварительный Просмотр Файлов При Поиске

Кнопка Preview в диалоговом окне File > Open позволяет Вам предварительно
просматривать объекты PTC без точного знания их названий. Предварительный
просмотр при поиске удобен, когда Вам требуется открыть объект PTC для внедрения
некоторой конструкции, например, или, когда Вы должны указать компонент для сборки.

Preview - мощный инструмент для выбора не только детали и сборки, но также и
рисунков, компоновок, диаграмм, сообщений, графических изображений моделей и
других различных типов файлов. Когда Вы выбираете файл в броузере, Pro/ENGINEER
отобразит соответствующую информацию в правой части диалогового окна.

Обратите внимание: для получения быстрого доступа к информации
предварительного просмотра, Pro/ENGINEER использует информацию, сохраненную в
файле, указанном в запросе. Файлы должны быть сохранены в версии Pro/ENGINEER,
которая поддерживает предварительный просмотр. Это также означает, что объект
будет отображаться подобно тому,  в каком состоянии он был сохранен. Например,



если слой базовых кривых был скрыт при сохранении файла, этот слой будет скрыт и
при предварительном просмотре.

Предварительный Просмотр Деталей

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. Выберите файл из списка или введите имя файла в текстовое поле Name.

3. Щелкните Preview. Деталь появится в области предварительного просмотра в
каркасном отображении, без силуэтов.

Обратите внимание: Если в правой части диалогового окна появляется сообщение
Preview not available (предварительный просмотр не доступен), Вы должны сохранить
деталь в Pro/ENGINEER Версии 18.0 или выше.

4. Для отображения тонированной детали, измените опцию save_model_display файла
конфигурации на одну из опций тонирования. По умолчанию эта опция установлена в
каркасное отображение, так как тонирование значительно увеличивает размер файла.

5. Если Вы хотите увидеть составную прозрачную деталь, используйте
инструментальную панель для переключения в перспективный вид и, затем, нажмите
правую кнопку мыши и выберите Flythrough.

Предварительный Просмотр Сборки

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. Выберите файл из списка или введите имя файла в текстовое поле Name.

3. Щелкните по Preview. Сборка первого уровня вложенности появится в области
предварительного просмотра.

Примечания:

•  Если в правой части диалогового окна появляется сообщение Preview not available
(предварительный просмотр не доступен), Вы должны сохранить сборку в
Pro/ENGINEER Версии 2000i или выше.

•  Оставшаяся часть сборки загружается в фоновом режиме. Если Вы выберете
другой файл или закроете диалоговое окно, загрузка файла будет отменена.
Preview работает лучше всего, когда опция save_model_display файла
конфигурации установлена в shading_lod, так как эта опция позволяет сжимать
отображение сборки и ее компонентов, пока оставшиеся файлы загружаются.

•  Предварительный просмотр Сборки - хороший способ просмотреть детали, когда
Вы помните, где они используются в сборке, но не знаете их названий. Начните,
загружать сборку. Когда Вы увидите сжатую сборку, или деталь, которую Вы ищете,
выберите ее в графическом окне. Отображение переключится на вид только этой
детали. Если Вы выбрали не ту деталь или подсборку, используйте обратную
стрелку на инструментальной панели, чтобы возвратиться к сборке и выбрать
другую деталь или подсборку.

Предварительный Просмотр Рисунков

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. Выберите файл из списка или введите имя файла в текстовое поле Name.



3. Щелкните Preview. В области предварительного просмотра появится первый лист
рисунка. Вы можете панорамировать и изменять масштаб изображения этого рисунка,
как если бы Вы находились в основном графическом окне.

Обратите внимание: Если появляется сообщение Preview not available
(предварительный просмотр не доступен), Вы должны сохранить рисунок в
Pro/ENGINEER Версии 2000i или выше и Вы должны установить опцию
save_drawing_picture_file файла конфигурации в embed или both.

4. Для прокрутки листов, нажмите правую кнопку мыши и выберите пункт в меню,
которое появляется.

Обратите внимание: Если Вы просматриваете несколько различных рисунков, Вы
можете перемещаться назад и вперед по истории, используя кнопки "вперед" и "назад"
на инструментальной панели.

Открытие Эскиза

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-Lmks.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library и т.д.).

3. Опционально: В списке Type, выберите Sketch.
4. Выберите эскиз и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .sec

Открытие Детали

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите RDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Part; в списке Sub-type, выберите All, Solid,
или Skeleton Model.
4. Выберите деталь и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .prt



Создание или Открытие Упрощенного Представления

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра рабочего пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type в диалоговом окне File Open, выберите тип объекта,
Part, Assembly, и т.д.

4. Выберите файл из списка или введите имя файла в текстовое поле Name.

5. Нажмите Open Rep.

6. В диалоговом окне Open Rep, выберите Master Rep, Geometry Rep или Graphics
Rep.
7. Если Вы хотите создать новую сборку, обработку или представление рисунка,
выберите Create New Simplified Rep.
8. Нажмите OK, и следуйте запросам.

Упрощение Представления

Упрощенные представления уменьшают время регенерации, поиска и отображения и
позволяют Вам изменять рабочую среду для включения только требуемой
информации.

Например, Вы можете удалить подсборку, с которой пока не работаете.

Вы можете упростить геометрию детали путем удаления некоторых из ее элементов
или, ограничивая определенную область работы. В рисунках, Вы можете создавать
виды упрощенных представлений.

Открытие Упрощенных Представлений по Умолчанию

Вы можете настроить систему на отображение подсказки, позволяющей Вам выбрать
упрощенное представление.

С опцией open_simplified_rep_by_default файла конфигурации, установленной в Yes
(значение по умолчанию - No), при открытии соответствующего объекта, система
автоматически открывает диалоговое окно Open Rep, запрашивая Вас выбрать
упрощенное представление для вызова.

Работа с упрощенными представлениями рекомендуемая манера работы и наличие
диалогового окна Open Rep помогает Вам исключить открытие крупных объектов в их
Основных Видах по ошибке и, таким образом, большие затраты времени.

Открытие Детали Sheetmetal

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.



2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра рабочего пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Part; в списке Sub-type, выберите All, Solid,
или Skeleton Model.
4. Выберите деталь и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .prt

Открытие Составной Детали

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра рабочего пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Part; в списке Sub-type, выберите All, Solid,
или Skeleton Model.
4. Выберите деталь и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .prt

Открытие Сборки

Режим Сборки дает Вам возможность размещать компоненты деталей и подсборок
вместе в форме сборки и, также, проектировать детали на основании того, как они
собираются вместе. Для открытия сборки:

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра рабочего пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Assembly; в списке Sub-type, выберите
Design.



4. Выберите сборку и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .asm

Открытие Рисунка

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра рабочего пространства Pro/INTRALINK, нажмите PDM-LINKS.
Для просмотра специальных файлов по опциям каталога в файле config.pro, выберите
требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: Выберите Drawing в списке Type.

4. Выберите рисунок и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .drw

Открытие Рисунка Только для Чтения

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Type диалогового окна File Open, выберите Drawing.
3. Перейдите к каталогу, где находится требуемый объект, используя список Look In и
кнопку Up One Level

4. Нажмите кнопку Option в верхнем правом углу диалогового окна.

5. Выберите Retrieve Drawing as View Only в появившемся меню.

6. Выберите рисунок (файл типа .drw) и нажмите Open.

Открытие Обрабатываемой Модели

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра рабочего пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).



3. Опционально: Выберите Manufacturing в списке Type и All, NC Part, NC Assembly,
CMM, Sheetmetal, Harness, Mold, Cast, Dieface или Pre-18.0 MFG в списке Sub-type.

4. Выберите модель и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .mfg

Открытие Модели Литейной Формы

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра рабочего пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: Выберите Manufacturing в списке Type и Mold в списке Sub-type.

4. Выберите файл модели литейной формы и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .mfg

Открытие Модели Отливки

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра рабочего пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Manufacturing; в списке Sub-type, выберите
Cast.
4. Выберите модель литейной формы или отливки и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .mfg

Открытие Обрабатываемой Конструкции Штампа

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.



•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра рабочего пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Manufacturing; в списке Sub-type, выберите
Dieface.

3. Выберите файл модели вставки штампа и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .mfg

Открытие Компоновки

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: Выберите Layout из списка Type.

4. Выберите файл компоновки и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .lay

Открытие Файла Форматки

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

2. Опционально: Выберите Format из списка Type.

3. Выберите файл формата и нажмите Open.

Открытие Сообщения

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:



•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Report.
4. Выберите файл сообщения, и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .rep

Открытие Файла Обозначения

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  (пропущено в оригинале примечание переводчика)

3. Опционально: В списке Type, выберите Markup.
4. Выберите файл обозначения и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .mrk

Открытие Диаграммы

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Diagram.
4. Выберите файл диаграммы и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .dgm

Открытие Файла Обмена Данными

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.



•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Assembly; в списке Sub-type, выберите
Interchange.
4. Выберите файл обмена данными и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .asm

Открытие Файла Наследования Данных Детали

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Part; в списке Sub-type, выберите All, Solid,
или Skeleton Model.
4. Выберите деталь и нажмите Open.
5. Выберите Applications > Legacy.
6. Используйте команды в меню LEGACY PRT в правом меню.

Дополнительная Информация:

Заданный по умолчанию тип файла: .prt

Открытие Файла Наследования Данных Рисунка

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Drawing.
4. Выберите рисунок, и нажмите Open.
5. Выберите Applications > Legacy.
6. Используйте команды в меню LEGACY PRT в правом меню.



Дополнительная Информация:

Заданный по умолчанию тип файла: .sec

Открытие Файла Наследования Данных для Сборки

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Assembly; в списке Sub-type, выберите
Design.
4. Выберите сборку и нажмите Open.
5. Выберите Applications > Legacy.
6. Используйте команды в меню LEGACY PRT в правом меню.

Дополнительная Информация:

Заданный по умолчанию тип файла: .asm

Открытие Контролируемой Сборки

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-LINKS.

•  Для просмотра специальных файлов по опциям каталога в файле config.pro,
выберите требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: Выберите Assembly из списка Type, и Verification из списка Sub-type.

4. Выберите контролируемую сборку и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .asm

Открытие Технологической Операции для Сборки

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.



•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-LINKS.
Для просмотра специальных файлов по опциям каталога в файле config.pro, выберите
требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Assembly; в списке Sub-type, выберите
Process Plan.
4. Выберите технологическую операцию сборки и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .asm

Открытие Технологической Операции Обработки

1. Выберите File > Open из меню, или щелкните по          в инструментальной
панели.

2. В списке Look In диалогового окна File Open:

•  Для просмотра файлов, находящихся в памяти, нажмите In Session.

•  Для перехода к другому диску или каталогу, выберите имя диска или каталога.

•  Для просмотра пространства Pro/INTRALINK, нажмите PDM-LINKS.
Для просмотра специальных файлов по опциям каталога в файле config.pro, выберите
требуемый тип файлов (Format Directory, Pro/Library, и т.д.).

3. Опционально: В списке Type, выберите Assembly; в списке Sub-type, выберите
Process Plan.
4. Выберите технологическую операцию обработки модели и нажмите Open.
Дополнительная Информация:

Заданный по умолчанию тип файла: .mfg

Импортирование Модели

Вы можете создавать новую модель, импортируя объект.

1. Выберите File > Import > Create New Model. Откроется диалоговое окно Import New.

Используйте Щелкните или
выберите

Для

Look In Диск или имя каталога Перехода к другому диску или каталогу

PDM-связь Ищет пространство Pro/INTRALINK

Имя каталога типа
Format и Pro/Library

Перечисляет специальные файлы для
которых вы установили каталоги в файле
config.pro

список
файлов

Выбора (одним щелчком) или открытия
(двойным щелчком) файлов в каталоге

Отображения каталога на уровень выше текущего каталога.

Отображения файлов, находящихся в памяти.



Отображения текущего рабочего каталога.

Используйте меню Favorites, в котором Вы можете:

Save location - сохранять текущий favorite каталог.

Remove location - удалять текущий favorite каталог.

Browse favorites - выполняет поиск в Ваших favorite каталогах.

Отображает содержимое каталога в виде списка файлов.

Отображает информацию по версии Pro/INTRALINK. (Вы должны 
инсталлировать Pro/INTRALINK и иметь лицензию, чтобы использовать 
эту кнопку.)

 

Look In Default Выберите каталог по умолчанию
для отображения этого
диалогового окна

Name Отображает имя выбранного
каталога

Type Перечисляет только каталоги (Вы
не можете выбрать тип)

2. Перейдите в каталог, где расположен требуемый объект, используя список Look In,
кнопку Up One Level или обе функции.

3. Опционально: В списках Type и Sub-type, выберите требуемый тип формата.

4. Выберите файл, содержащий объект.

5. Щелкните по Open. Откроется диалоговое окно Import New Model.
Используйте Для

From: Отображает имя импортируемого файла

Type Перечисляет различные файлы, в зависимости формата
импортируемого файла

Import 2D Views Выберите файл, типа рисунка

Name Укажите имя открываемого файла или используйте имя по
умолчанию

Импортирование Тонированного Изображения

1. Выберите File > Import > Image. Откроется диалоговое окно Open.

2. Выберите имя файла из списка доступных файлов.

3. Нажмите Open для импорта указанного файла тонированного изображения.

4. Найдите и выберите файл изображения (файл типа .shd).

Используйте Щелкните или
выберите

Для

Look In Диск или имя каталога Перехода к другому диску или каталогу



PDM-связь Ищет пространство Pro/INTRALINK

Имя каталога типа
Format и Pro/Library

Перечисляет специальные файлы для
которых вы установили каталоги в файле
config.pro

список
файлов

Выберите (одним щелчком) или откройте
(двойным щелчком) файлы в каталоге

Отображения каталога на уровень выше текущего каталога.

Отображения файлов, находящихся в памяти.

Отображения текущего рабочего каталога.

Используйте меню Favorites, в котором Вы можете:

             Save location - сохранять текущий favorite каталог.

Remove location - удалять текущий favorite каталог.

Browse favorites - выполняет поиск в Ваших favorite каталогах.

Отображает содержимое каталога в виде списка файлов.

Отображает информацию по версии Pro/INTRALINK. (Вы должны 
инсталлировать Pro/INTRALINK и иметь лицензию, чтобы использовать 
эту кнопку.)

 

Look In Default Выберите каталог по умолчанию
для отображения этого
диалогового окна

Sort By > Model Name Выполняет сортировку файлов в
алфавитном порядке по имени
модели

Sort By > Markup/Instance Name Выполняет сортировку по
указанному обозначению или
имени вхождения

All Versions Отображает все версии объектов

Name Отображает имя выбранного
каталога

Type Перечисляет только каталоги (Вы
не можете выбрать тип)

Добавление Импортированного Файла к Модели

1. Если Вы импортируете файл, которые содержат слои и-или твердотельные модели
из форматов IGES, STEP, SET, VDA, PDGS, CATIA или Neutral, установите в config.pro
опцию intf_in_layer_asm_dialogs в Yes для отображения диалогового окна Layer Import
Options в процессе импорта.



2. Из меню в окне модели, выберите File > Import > Append to Model. Откроется
диалоговое окно Import Append.

Используйте Щелкните или
выберите

Для

Look In Диск или имя каталога Перехода к другому диску или каталогу

PDM-связь Ищет пространство Pro/INTRALINK

Имя каталога типа
Format и Pro/Library

Перечисляет специальные файлы для
которых вы установили каталоги в файле
config.pro

список
файлов

Выберите (одним щелчком) или откройте
(двойным щелчком) файлы в каталоге

Отображения каталога на уровень выше текущего каталога.

Отображения файлов, находящихся в памяти.

Отображения текущего рабочего каталога.

Используйте меню Favorites, в котором Вы можете:

             Save location - сохранять текущий favorite каталог.

Remove location - удалять текущий favorite каталог.

Browse favorites - выполняет поиск в Ваших favorite каталогах.

Отображает содержимое каталога в виде списка файлов.

Отображает информацию по версии Pro/INTRALINK. (Вы должны 
инсталлировать Pro/INTRALINK и иметь лицензию, чтобы использовать 
эту кнопку.)

 

Look In Default Выберите каталог по умолчанию
для отображения этого
диалогового окна

All Versions Отображает все версии объектов

Name Отображает имя выбранного
каталога

Type Перечисляет только каталоги (Вы
не можете выбрать тип)

3. Выберите тип импорта в списке Type.

4. Выберите название файла в списке доступных файлов.

5. Нажмите OK, чтобы запустить процесс импортирования указанного файла.

6. В зависимости от типа импорта, может произойти следующее:

•  Откроется Информационное Окно с файлом регистрации импорта. Нажмите Close
для закрытия Информационного Окна.



•  Откроется диалоговое окно Layers Import Options. Сделайте необходимые
изменения в диалоговом окне и нажмите OK.

7. Если Вы импортируете трехмерную информацию в файл открытой детали, откроется
диалоговое окно Choose Solid Options and Placement. Сделайте требуемые
изменения и нажмите OK. Pro/ENGINEER попытается автоматически создать
твердотельное выдавливание, если импортированные данные содержат замкнутые
лоскутные поверхности.

Используйте Для

Выберите требуемую координатную систему.

Отображает меню GET COORDS и GET SELECT для создания или 
выбора системы координат.

Protrusion Создает твердотельное выдавливание из импортированной
геометрии и добавляет ее к существующей геометрии детали

Cut Создает разрез твердым телом существующей геометрии, используя
импортированную геометрию

Surfaces Представляет импортированную геометрию набором лоскутных
поверхностей. При возможности, смежные поверхности сшиваются

Система импортирует указанный файла в открытый файл.

Объекты Импортирования

Вы можете импортировать объекты других форматов в ваши файлы объектов
Pro/ENGINEER, используя команду Import в меню File. Вы должны иметь лицензию
Pro/INTERFACE и инсталляцию для импорта форматов, отличных от VRML.

Вы можете создавать новую модель или импортировать изображение до или после
того, как Вы открываете файл. Вы можете добавлять данные к отображаемой модели
после того, как Вы откроете файл.

Вы можете выборочно импортировать слои и-или твердотельные модели из следующих
типов файлов:

� IGES

� STEP

� SET

� VDA

� PDGS

� CATIA

Вызов Файлов Между Платформами

Файлы Pro/ENGINEER, находящиеся на системе UNIX и переданные в систему Windows
без использования двоичного (binary) метода изменяются таким образом, что не могут
быть вызваны.

Эти файлы должны быть переданы посредством двоичного метода для сохранения их
формата. Файлы, которые уже были переданы без использования двоичного метода,
могут быть исправлены для вызова в Pro/ENGINEER.



Pro/ENGINEER проверяет вызываемые файлы, чтобы определить, должен ли файл
быть скорректирован. Если Pro/ENGINEER определит, что файл должен быть
исправлен, появляется диалоговое окно, давая Вам возможность исправить ошибку.

Вы можете отменить процесс вызова и не исправлять никаких файлов, или Вы можете
продолжать процесс вызова файла, позволяя Pro/ENGINEER исправлять и
восстанавливать требуемые файлы. Другие файлы, которые зависят от вызываемого
файла (например, файлов деталей для сборки) будут автоматически исправлены и
вызваны.

Примечания:

•  процесс исправления увеличивает общее время вызова модели Pro/ENGINEER и
может уменьшить количество доступного места в файле подкачки на вашей
системе.

•  Вы может использовать опцию correct_windows_ascii_xfer файла конфигурации для
выполнения автоматического исправления файла без запроса.

Вы можете использовать утилиту командной строки dos_to_binary для вызова
отдельных файлов или вызова всех файлов в указанном каталоге. Синтаксис для этой
утилиты - dos_to_binary [-inf] [-r] file.prt.l, где file.prt.l - название вызываемого файла.
Если версия файла не определена, используется самая последняя версия.

Несколько файлов могут быть скорректированы, указанием имени каждого файла и
отделением один от другого пробелом. Если Вы указываете имя каталога, используя
опцию -r, все файлы в этом каталоге будут вызваны.

Если используется утилита командной строки, указанные файлы проверяются на
предмет, необходимо ли исправление. Если исправление необходимо, файл
вызывается и сохраняется с нарастающим индексом. Например, если вызывается
sphere.prt.2, исправленный файл будет называться sphere.prt.3.

Обратите внимание: файл не отмечается, как измененный для Pro/PDM или
Pro/INTRALINK.

Вызов Файлов из Других Каталогов

Вы можете вызвать объект из другого каталога, указав путь к каталогу при вводе имени
объекта.

Если Вы не указали каталог вызова объекта, Pro/ENGINEER сначала ищет объект в
текущей сессии (в памяти), затем в текущем рабочем каталоге и, наконец, в каталогах
по пути поиска файлов. Отсюда следует два вывода:

•  Будьте внимательны, давая одинаковые имена деталям в различных каталогах.
Вызванная деталь может не являться той, которую Вы хотите.

•  При вызове модели со связанными зависимостями, Pro/ENGINEER пытается
автоматически вызвать компоненты сборки или модели рисунка в следующих
местах (в указанном порядке):

1. В сессии (в памяти)

2. Текущий рабочий каталог

3. Каталог, содержащий сборку или чертежный файл

4. Каталоги в пути поиска файлов.

Если компоненты сборки или модели рисунка отсутствуют в любом из этих мест, Вы
должны вызвать составляющие детали или модели рисунка перед вызовом сборки или
рисунка.



Вызов Объектов Посредством Групповых Символов

Когда Вы вызываете объекты, Вы можете вводить групповые символы для их имен,
расширений и названий каталогов. Вы не можете использовать групповые символы в
месте номеров версии.

Синтаксис:

•  звездочка (*) может заменять любое количество символов.

•  вопросительный знак (?) может заменять любой символ. Когда вопросительный
знак введен один, Вы получаете полный листинг соответствующих объектов в
каталоге.

Вызов Более Ранних Версий

Хотя Pro/ENGINEER автоматически восстанавливает самую последнюю сохраненную
версию объекта, Вы можете вызвать любую предыдущую версию,  вводя полное имя
файла с расширением и номером версии (например, bracket.prt.5).

Если Вы не знаете конкретный номер версии, Вы можете ввести номер относительно
самой последней версии. Например, чтобы вызвать деталь на две версии назад
введите partname.prt.-2.

Примечания:

•  В качестве разделителя номера версии, используйте точку ( . ).

•  Если объект находится в текущей сессии (в памяти), Pro/ENGINEER, игнорирует
любой номер версии, который Вы добавляете при вызове.

Вы можете также вызывать другую версию детали, уже находящейся в памяти, пока
даете детали новое имя. Деталь вызывается в подокно под новым именем.

Вызов Графики

Следующие опции уменьшают время, которое требуется для вызова графики и
переключения между окнами в Pro/ENGINEER:

•  Сохраняйте текущее графическое отображение, когда Вы сохраняете объект на
диске. Цель этой опции, в быстром отображении, после вызова объекта,
графического отображения моделей с большим количеством объектов, типа
больших сборок или рисунков.

В этих случаях, модель вызывается (если она не сохранена с геометрией) и
графическое изображение появляется без повторного расчета. Для сохранения
отображения объекта, используйте опцию save_display файла конфигурации.

•  Используйте опцию retain_display_memory файла конфигурации для сохранения в
памяти графического отображения в окне Pro/ENGINEER. Когда Вы возвращаетесь
к объекту, с которым Вы работали прежде, графика загружается быстрее.



Удаление Файлов

Стирание Объектов в Памяти

Объект - это файл, который Вы создаете, используя модуль Pro/ENGINEER (например,
эскиз, модель детали, обрабатываемая модель, модель сборки, модель литейной
формы, диаграмма или компоновка).

Каждый раз, когда Вы сохраняете объект, используя команду Save в меню File, Вы
создаете новую версию объекта и записываете ее на диск. Pro/ENGINEER
последовательно нумерует каждую версию сохраненного файла объекта (например,
box.sec.1, box sec.2, box sec.3).

Если Вы закрываете окно, используя команду Close из меню Window, отображаемый
объект удаляется, но он остается в памяти, пока сессия активна. Стирание объекта
удаляет его из памяти, но не с диска.

Примечания:

•  Вы не можете стирать объекты, пока сборки или рисунки, которые ссылаются на
них, активны.

•  Стирание объекта не всегда стирает из памяти те объекты, к которым эта операция
относится (например, стирание сборки не обязательно удаляет ее компоненты).

Удаляемые Объекты

Каждый раз, когда Вы сохраняете объект, используя команду Save меню File, Вы
создаете новую версию объекта в памяти и записываете предыдущую версию на диск.
Pro/ENGINEER последовательно нумерует каждую версию файла сохраняемого
объекта (например, box.sec. 1, box sec.2, box sec.3).

Вы можете использовать команду Delete для освобождения дискового пространства и
удаления старых, ненужных версий объектов:

· Delete > All versions
· Delete > Old versions
Обратите внимание: Вы не можете удалять деталь или подсборку, которая
используется в сборке или рисунке во время текущей рабочей сессии, пока сборка или
рисунок не будут удалены.

Вы можете быстро удалять файлы Pro/ENGINEER с диска (любые файлы с номерами
версии) в окне операционной системы, используя сценарий очистки (purge script),
который загружается при инсталляции Pro/ENGINEER.

Чтобы использовать сценарий очистки, укажите строку удаления, где строка - фильтр,
для соответствующих файлов.

Если Вы не включили строку, система удаляет все версии файлов сборок, файлов
деталей, файлов базовых кривых и т.д., кроме последних версий. Если Вы включаете
строку, система удаляет только те файлы, которые соответствуют строке. Строка может
содержать групповые символы: (*) соответствует любому количеству символов, (?)
соответствует единственному символу. Для предотвращения интерпретации
подстановочных знаков в UNIX, используйте наклонную черту влево перед (*) и (?).



Стирание Текущего Объекта из Памяти

Для стирания объектов верхнего уровня и выбранных под-компонентов, отображаемых
в активном окне:

1. Выберите File > Erase > Current.
2. Подтвердить запрос на стирание.

Для сборок, обрабатываемых моделей и рисунков, открывается диалоговое окно Erase.
Вы можете использовать диалоговое окно Erase для удаления объекта и связанных с
ним  объектов из памяти.

Используйте Для
Current Object Отображения имени файла текущего объекта

Associated Objects Выбора имен файлов объектов, ссылающихся на
текущий объект

Выбирает все объекты.

Снимает выделение со всех объектов.

Для деталей, форматов, компоновок, обозначений и других типов объектов,
открывается диалоговое окно подтверждения.

Дополнительная Информация:

Вы можете настраивать вашу инструментальную панель (используйте Utilities >
Customize Screen) для включения кнопок File для Erase Current и Erase Not Displayed и,
затем, щелкая по требуемой кнопке в инструментальной панели.

Вы можете использовать опцию prompt_on_erase_not_disp файла конфигурации для
отображения запроса на стирание объектов.

Стирание Неотображаемых Объектов из Памяти

Для стирания всех неотображаемых объектов из памяти:

1. Выберите File > Erase > Not Displayed.

Открывается диалоговое окно Erase Not Displayed, перечисляющее неотображаемые
объекты. Это диалоговое окно позволяет Вам стирать все объекты в текущей сессии, за
исключением тех, которые отображаются в настоящее время и любых объектов, на
которые ссылаются отображаемые объекты. Например, если вхождение сборки
отображается, основное вхождение и его компоненты не стираются.

2. Щелкните по ОК.
Дополнительная Информация:

Вы можете настраивать вашу инструментальную панель (используйте Utilities >
Customize Screen) для включения кнопок File для Erase Current и Erase Not Displayed и,
затем, щелкая по требуемой кнопке в инструментальной панели.

Вы можете использовать опцию prompt_on_erase_not_disp файла конфигурации для
отображения запроса на стирание объектов.



Сохранение Неотображаемых Объектов

Вы можете использовать опцию файла конфигурации, для предохранения от стирания
измененных, не сохраненных объектов, которые в настоящее время не отображаются.

Вы можете безопасно закрывать окно, содержащее измененную деталь, без потери
вашей работы и система, поэтому, не выдает предупреждающее сообщение. Однако,
когда Вы стираете все объекты, не отображаемые в настоящее время, Вы можете по
неосторожности потерять объекты, которые Вы изменили, но еще не сохранили.

Установите опцию prompt_on_erase_not_Disp файла конфигурации в режим,
отображать ли подсказку, позволяющую Вам сохранять измененные и не сохраненные
объекты. Если установить в Yes, то, когда Вы выберете File > Erase Not Disp, система
выдаст подсказку для каждого измененного, не сохраненного объекта, давая Вам
возможность сохранить объект до того, как он будет стерт. Когда установлено в No
(значение по умолчанию), система немедленно стирает все неотображаемые объекты.

Удаление Старых Версий Объектов с Диска

Для удаления всех версий объекта кроме версии с наивысшим номером версии:

1. Выберите File > Delete > Old Versions.
2. На запрос, нажмите зеленую галочку или нажмите RETURN, для подтверждения
стирания старых версий текущего объекта, или введите название объекта, который Вы
хотите удалить.

Удаление Всех Версий Объекта на Диске

Для удаления всех версий текущего объекта, из меню:

1. выберите, File > Delete > All Versions. Открывается диалоговое окно Delete All
Confirm.

2. Нажмите Yes для удаления всех версий текущего объекта.

Если объект является вхождением, то ни вхождение, ни основной элемент не могут
быть удалены. Если объект является основным элементов, и Вы выбрали его для
стирания, он будет удален.

Сохранение Объектов

Вы можете сохранять объекты в файлы на диске, используя команду Save в меню File.

Обратите внимание: Если Вы удаляете объект из памяти или выходите из
Pro/ENGINEER без сохранения, все изменения будут потеряны.

Как правило, система сохраняет объекты на диске только, если они были изменены.
Если Вы выбираете элемент для переопределения, но не делаете никаких изменений,
система предполагает, что Вы изменили объект и завершили его переопределение.

Вы можете использовать опцию save_objects файла конфигурации для сообщения
системе, что необходимо сохранять.

Неизмененные объекты сохраняются только в следующих случаях:

•  если объект, выбранный для сохранения, отсутствует в каталоге назначения

•  если опция save_objects файла конфигурации установлена в All



•  если опция save_objects файла конфигурации установлена в changed_and_specified
(изменить_и_указать примечание переводчика), а текущий объект - верхний объект
сборки

•  если изменения были проведены для зависимого объекта, а опции
propagate_change_to_parents файла конфигурации,  установлены в Yes.

Сохранение объекта на диске создает файл с форматом
имя_объекта.тип_объекта.номер_версии. Например, если Вы создаете деталь с
именем bracket, он сохраняется сначала в файле bracket.prt.1.

Сохранение объекта на диске не перезаписывает существующий ранее файл объекта;
для сохранения более ранних версий, система сохраняет объект в новый файл с тем
же названием объекта, но с модифицированным номером версии.

Файлы объектов сохраняются в формате, который может быть передан и использован
на других аппаратных платформах. Это гарантирует совместимость с новыми версиями
программного обеспечения.

Новые объекты сохраняются в текущем рабочем каталоге. Однако, по умолчанию,
объекты, вызванные из других каталогов, сохраняются в их собственных каталогах.
Если Вы хотите сохранить объекты в текущем каталоге, Вы должны использовать
опцию override_store_back файла конфигурации.

Если Вы вызвали объект из каталога только для чтения, Вы можете сохранять объект в
текущем рабочем каталоге, используя опцию save_object_in_current файла
конфигурации.

Если Вы вызвали объект, используя относительный путь (например, ../partname), такой
же путь будет использоваться для сохранения его в первоначальный каталог. Так, если
Вы изменили рабочий каталог в промежутке между вызовом и сохранением, объект
может быть сохранен не в том каталоге. Будьте внимательны, когда используете
относительные имена пути.

Сохранение Объекта на Диск

1. Выберите File > Save в меню или нажмите в инструментальной панели. В
области сообщения рядом с подсказкой появляется имя файла.

2. Укажите новое имя или используйте существующее.

3. Нажмите зеленую галочку или нажмите ENTER. (Для отмены операции сохранения,
нажмите красный X или нажмите ESC.)

Дополнительная Информация:

Объекты сохраняются в их оригинальных каталогах, если Вы не установили опцию
override_store_back конфигурации в Yes.

Если override_store_back установлен в No (настройка по умолчанию), Вы не имеете
прав записи в оригинальный каталог, если опция save_object_in_current конфигурации
установлена в Yes, то объекты сохраняются в текущем каталоге.

Сохранение с Рисунками

По умолчанию, Pro/ENGINEER сохраняет модель с рисунком только, если в ней были
сделаны изменения. Вы можете использовать опцию save_modified_draw_models_only
файла конфигурации для сохранения модели, каждый раз при сохранении рисунка.



Сохранение Копии Объекта на Другом Диске или Каталоге

1. Выберите File > Save в меню или нажмите в инструментальной панели.

2. В текстовом поле New Name диалогового окна Save As, укажите имя файла.

3. Для сохранения в другой каталог, выберите требуемый каталог в списке Look In.

4. Щелкните по ОК.
5. Для сохранения на другой диск или каталог под тем же именем, используйте File >
Backup.
Дополнительная Информация:

Объекты сохраняются в их оригинальных каталогах, если Вы не установили опцию
override_store_back конфигурации в Yes.

Если override_store_back установлен в No (настройка по умолчанию), Вы не имеете
прав записи в оригинальный каталог, опция save_object_in_current конфигурации
установлена в Yes, то объекты сохраняются в текущем каталоге.

Сохранение Объектов под Другим именем и в Другой
Каталог

Вы можете сохранять копию указанного объекта, используя диалоговое окно Save As:

•  File > Save As
или

•  Выберите значок Save As
Вы можете сохранять копию в том же каталоге или в другой каталог, давая, в любом
случае, копии новое имя. Вы можете использовать диалоговое окно Save As для:

•  Перехода, в случае необходимости, к другим каталогам.

•  Выбора файла для сохранения.

•  Указания имени нового файла.

Используйте Для
Look In Диск или имя каталога Перехода к другому диску или каталогу

PDM-связь Ищет пространство Pro/INTRALINK

Имя каталога типа
Format и Pro/Library

Перечисляет специальные файлы для
которых вы установили каталоги в файле
config.pro

список
файлов

Выберите (одним щелчком) или откройте
(двойным щелчком) файлы в каталоге

Отображения каталога на уровень выше текущего каталога.

Отображения текущего рабочего каталога.

Используйте меню Favorites, в котором Вы можете:



             Save location - сохранять текущий favorite каталог.

Remove location - удалять текущий favorite каталог.

Browse favorites - выполняет поиск в Ваших favorite каталогах.

Отображает содержимое каталога в виде списка файлов.

Отображает информацию по версии Pro/INTRALINK. (Вы должны 
инсталлировать Pro/INTRALINK и иметь лицензию, чтобы использовать 
эту кнопку.)

 

[list of object names] Выберите из списка объектов в
памяти

Select Отображает меню GET SELECT
для указания компонента сборки
для объекта

Model Name Отображает имя файла для
выбранного объекта

New Name Укажите имя для копирования
объекта

Сохранение Объектов, вызванных с Сервера PDM или
INTRALINK

Если Вы хотите сохранить объект, вызванный с сервера PDM или INTRALINK,
каталогом назначения всегда будет являться текущий каталог.

Если объект был вызван с сервера PDM или INTRALINK и не был изменен, объект
может быть сохранен в текущем каталоге в любом из следующих случаев:

•  если опция save_objects файла конфигурации установлена в All;

•  если файл объекта уже не существует в рабочем каталоге.

Тип создаваемого файла зависит от установки опции save_unchanged_pdm_object
файла конфигурации.

Переименование Объекта

Для переименования файла:

1. Выберите, File > Rename. Открывается диалоговое окно Rename.

2. В текстовом поле New Name, укажите имя для файла.

3. Выберите Rename in session или Rename on disk and in session.
Предупреждение: Переименование файла на диске создаст проблемы при вызове
модели, которая не участвует в сессии и которая зависит от предыдущего имени
файла. Например, деталь не может быть вызвана для сборки.

Нажмите OK. Появляется диалоговое окно Rename Success, если переименование
прошло успешно. Если имя уже существует, появляется диалоговое окно Name Exists.



Используйте Для
Model Отображения имени текущего объекта

Отображения меню доступного объекта

Select Отображает меню GET SELECT для указания
компонента сборки для объекта

New Name Укажите новое имя объекта

Rename in session Изменяет имя объекта, находящегося только в памяти

Rename on disk and in
session

Изменяет имя объекта, находящегося и в памяти, и на
диске

Сжатие Файлов

Для экономии пространства, файлы объектов могут быть сохранены в сжатом формате.
Сжатые файлы требуют больше времени для чтения и записи, но составляют от 1/2 до
1/3 размера несжатых файлов. Они также полностью совместимы между системами.

Для сохранения файлов объектов в сжатом формате используйте опцию
compress_output_files файла конфигурации.

Резервное Копирование Объекта

Чтобы сделать резервную копию объекта, находящегося в памяти:

1. Выберите File > Backup. Открывается диалоговое окно Backup с именем модели в
поле Model Name.

2. В списке Look In выберите резервный каталог.

3. В текстовом поле Backup To укажите имя для резервной копии файла.

4. Щелкните по ОК.
Примечания:

•  Версии резервных объектов в резервном каталоге сбрасываются в 1.

•  Вы должны иметь право на запись в резервный каталог.

•  Если Вы копируете сборку, рисунок или обрабатываемый объект, Pro/ENGINEER
сохраняет все его сопутствующие файлы в указанном каталоге.

•  Если сборка имеет зависимые группы обмена (interchange groups), такие группы не
сохраняются в резервном каталоге при копировании сборки.

•  Если Вы делаете изменения в модели после ее копирования и, затем, сохраняете
модель, изменения сохраняются в резервном каталоге.

Экспорт Объектов в Другие Форматы

Вы можете экспортировать компоненты или объекты вашей модели в другие форматы,
используя команду Export в меню File.

Для использования этой функции в меню File, выберите Export > Model. Появляется
меню EXPORT.



Вы можете использовать это меню для экспорта модели, выбранных компонентов или
элементов модели из открытого файла рисунка, формата рисунка, компоновки, детали
или сборки.

Используйте Для экспорта из Экспорт только по имени
файла

Опции
экспорта

IGES Рисунок, Формат
Рисунка, Компоновка

Деталь или Сборка
Да Да

Neutral Деталь или Сборка Да

STL Деталь или Сборка

Render Деталь или Сборка

Inventor Деталь или Сборка

Optegra

VIS

XPatch

VRML Деталь или Сборка

3DPAINT Сборка

PATRAN Geom Деталь Да

COSMOS Geom Деталь Да

SUPRTB Geom Деталь или Сборка Да

CatiaFacets Деталь или Сборка

SET Рисунок, Формат
Рисунка или
Компоновка

Деталь или Сборка

Да Да

VDA Деталь или Сборка Да

PDGS Деталь или Сборка Да

ECAD Деталь или Сборка

CGM Рисунок, Деталь или
Сборка Да

STEP Рисунок, Деталь или
компоновка

Деталь или Сборка
Да Да

PHOTORENDER Деталь или Сборка Да

CATIA Деталь или Сборка Да

CADDS5 Деталь или Сборка Да

Использование Опций Экспорта

Диалоговое окно, используемое для экспорта, содержит тип экспорта в заголовке. Для
некоторых типов экспорта из сборок добавляется дополнительная область. Если опция
серая или не видна, она не доступна для этого типа экспорта.

Опции Export для STEP, IGES, CATIA, VDA и SET следующие:



Использование К
Используйте Для

Wireframe Edges Экспортирует только кромки (не
поддерживает экспорт в Neutral)

Surfaces (default) Экспортирует все поверхности модели и
кромки поверхностей (не поддерживает
экспорт в Neutral)

Solids Экспортирует поверхности вдоль их
топологии (поддерживает экспорт только в
CATIA и STEP)

Shells Экспортирует только оболочки
(поддерживает экспорт только в CATIA и
STEP)

Datum Curves and Points Экспортирует базовые элементы (не
поддерживает экспорт в Neutral)

Customize Layers Открывает диалоговое окно Customize
Layers

Quilts Отображает меню GET SELECT и
выбирает лоскутные поверхности для
экспорта (доступна только для опции
Geometry при экспорте лоскутных
поверхностей)

Coordinate System Выберите существующую систему
координат

Отображает меню GET COORDS и GET SELECT для создания или 
выбора системы координат модели

File Structure Выберите файловую структуру

Options Проверяет имя конфигурационного файла
и дает доступ к Pro/TABLE для
добавления опций config.pro

Диалоговые окна для STL, Render, Inventor, CATIA Facet, Optegra VIS, Xpatch, VRML,
3Dpaint, Patran Geom, Cosmos, Geom, Suprtb Geom, PDGS, ECAD и CADDS отличаются
меньшим количеством вариантов выбора.

Вы можете экспортировать файл в VRML либо до, либо после открытия файла. Экспорт
в другие форматы должен производится после открытия файла.

Примечания:

•  Вы должны иметь опцию лицензии Pro/WEB PUBLISH для экспорта файлов
Pro/ENGINEER в файла формата VRML.

•  Вы должен иметь лицензию и инсталляцию Pro/INTERFACE для экспорта в
форматы, отличные от VRML.

•  Подробную информацию по экспорту выбранных слоев и управлению качеством
экспортируемых файлов, см. справку.

•  Информацию по определенным форматам, доступным для каждого режима или
типа Pro/ENGINEER, см. справку.



Экспорт Модели в Другой Формат

Вы можете экспортировать компоненты или объекты вашей модели в другие форматы,
используя команду Export в меню File.

Для использования этой функции, в меню File, выберите Export > Model. Появляется
меню EXPORT.

Вы можете использовать это меню для экспорта моделей или выбранных компонентов
или элементов модели из открытого рисунка, формата рисунка, компоновки, детали или
файла сборки.

Используйте Для экспорта из Экспорт только по имени
файла

Опции
экспорта

IGES Рисунок, Формат
Рисунка, Компоновка

Деталь или Сборка
Да Да

Neutral Деталь или Сборка Да

STL Деталь или Сборка

Render Деталь или Сборка

Inventor Деталь или Сборка

DXF Рисунок, Формат
Рисунка, Компоновка Да

DWG Рисунок, Формат
Рисунка, Компоновка Да

VRML Деталь или Сборка

3DPAINT Сборка

PATRAN Geom Деталь Да

COSMOS Geom Деталь Да

SUPRTB Geom Деталь или Сборка Да

CatiaFacets Деталь или Сборка

SET Рисунок, Формат или
Компоновка

Деталь или Сборка
Да Да

VDA Деталь или Сборка Да

PDGS Деталь или Сборка Да

ECAD Деталь или Сборка

CGM Рисунок, Деталь или
Сборка Да

STEP Рисунок, Деталь или
компоновка

Деталь или Сборка
Да Да

PHOTORENDER Деталь или Сборка Да

CATIA Деталь или Сборка Да

CADDS5 Деталь или Сборка Да

WWW Сборка Да



Экспорт Изображений

Вы можете экспортировать изображение из открытого рисунка, детали или сборки. Для
экспорта изображения:

1. Выберите File > Export > Image. Открывается диалоговое окно Export.

Используйте Для
Look In Диск или имя каталога Перехода к другому диску или каталогу

PDM-связь Ищет пространство Pro/INTRALINK

Имя каталога типа
Format и Pro/Library

Перечисляет специальные файлы для
которых вы установили каталоги в файле
config.pro

список
файлов

Выберите (одним щелчком) или откройте
(двойным щелчком) файлы в каталоге

Отображения каталога на уровень выше текущего каталога.

Отображения текущего рабочего каталога.

Используйте меню Favorites, в котором Вы можете:

             Save location - сохранять текущий favorite каталог.

Remove location - удалять текущий favorite каталог.

Browse favorites - выполняет поиск в Ваших favorite каталогах.

Отображает содержимое каталога в виде списка файлов.

Отображает информацию по версии Pro/INTRALINK. (Вы должны 
инсталлировать Pro/INTRALINK и иметь лицензию, чтобы использовать 
эту кнопку.)

 

Working Directory Выберите текущий рабочий
каталог

New Name Укажите имя файла для
экспортируемого объекта или
используйте имя по умолчанию

Type TIFF Открывает диалоговое окно
Shaded Image Configuration

JPEG Открывает диалоговое окно
Shaded Image Configuration

Shaded Image Немедленно обрабатывает
изображение

EPS Открывает диалоговое окно
Shaded Image Configuration

TIFF (Snapshot) Выдает запрос на создание TIFF
(Только для чертежей)

2. Сделайте необходимые изменения в диалоговом окне Shaded Image Configuration,
затем нажмите OK.



Используйте Для
Размеров

Size Выберите стандартный размер или Переменный размер

Height Выберите собственную высоту размеров (только для
Переменных размеров)

Width Выберите собственную ширину размеров (только для
Переменных размеров)

Top Margin Выберите верхнее поле для размеров (только для
Переменных размеров)

Left Margin Выберите левое поле для размеров (только для Переменных
размеров)

Единиц измерения

Inches Задает размеры в дюймах

Millimeters Задает размеры в миллиметрах

DPI Выберите разрешение выходного формата (100, 200, 300 или
400 точек на дюйм)

Image Depth list Выберите глубину цвета изображения (8-битовое
индексированное, 24-битовое RGB, монохромное или оттенки
серого)

Система обрабатывает файл и создает файл с соответствующим типу экспорта
расширением.

Экспорт Объектов в VRML

1. В меню, выберите File > Export > Direct VRML.
2. В диалоговом окне Direct VRML Export, введите Object Name (Имя объекта) или
используйте Browse для указания исходного файла для преобразования в VRML.

3. Введите имя в Output Path, используйте заданный по умолчанию путь или укажите
путь для сохранения конвертированного файла.

4. Опционально: для изменения параметров настройки Quality, Parameters и View,
нажмите Setup, измените параметры настройки и нажмите OK.
5. Нажмите OK в диалоговом окне VRML Export.
Вы можете экспортировать файл в VRML либо до, либо после того, как Вы его откроете.
Экспорт в другие форматы должен производится после открытия файла.

Примечания:

•  Вы должны иметь опцию лицензии Pro/WEB PUBLISH для экспорта файлов
Pro/ENGINEER в файла формата VRML.

•  Вы должен иметь лицензию и инсталляцию Pro/INTERFACE для экспорта в
форматы, отличные от VRML.

•  Подробную информацию по экспорту выбранных слоев и управлению качеством
экспортируемых файлов, см. справку.

•  Информацию по определенным форматам, доступным для каждого режима или
типа Pro/ENGINEER, см. справку.



Вывод на Печать, Плоттер и Конфигурирование Принтера

Печать и Вывод на Плоттер

Вы можете печатать файлы следующими способами:

•  в меню File Вы можете печатать со следующими опциями: масштабирование,
обрезание, отображение графики на экране или отправление задания
непосредственно на принтер. Вы можете также печатать из этого меню
тонированные изображения. Вы можете создавать файлы печати текущего объекта
(эскиз, деталь, рисунок, сборка или компоновка) и посылать их в очередь печати
графопостроителя. Интерфейс печати в форматы HPGL и POSTSCRIPT
стандартный.

•  Использовать утилиту Pro/BATCH для создания командного файла печати или
чертить графические файлы без указания команд в интерактивных меню.
Командный файл содержит список объектов, выводимых на печать. Например, Вы
можете послать задание в конце рабочего дня, и графические файлы будут
созданы и напечатаны без вашего участия.

Примечания для печати:

•  Невидимые линии выводятся на экран серыми, но на бумаге они пунктирные.

•  Вы не можете чертить, когда опция Use Fast HLR в диалоговом окне Environment
включена.

•  Когда Pro/ENGINEER чертит системные линейные шрифты, он масштабирует их по
размеру листа. Он не масштабирует пользовательские линейные шрифты, которые
не чертятся, как отображаются.

Вы можете использовать опцию use_software_linefonts файла конфигурации, чтобы
удостовериться, что графопостроитель чертит пользовательский шрифт точно так, как
он отображается в Pro/ENGINEER.

•  При активном меню CROSS SEC, Вы можете чертить поперечные сечения в режиме
Part или Assembly.

•  С лицензией Pro/PLOT, Вы можете сохранять графические файлы в формате
Calcomp, Gerber, HPGL2 и Versatec.

•  Так же как и для Версии 10.0, необязательные модули Pro/CALCOMP, Pro/HPGL2,
Pro/VERSATEC и Pro/GERBER не доступны для новых клиентов. Эти модули
используются для поддержки тех, кто уже имеет их.

Конфигурирование Принтера

Вы можете конфигурировать ваш принтер, используя диалоговое окно Printer
Configuration, доступное из диалогового окна Print. Если Вы печатаете тонированное
изображение, вместо диалогового окна Printer Configuration появляется диалоговое
окно Shaded Image Configuration

Печать Объектов

1. Когда Вы выбираете File > Print, открывается диалоговое окно Print со следующими
полями и опциями.

Поле/Опция Назначение
Destination Отображает имя принтера по умолчанию



Вы можете перейти на другой принтер, щелкнув по этой пиктограмме и 
выбрав его из списка. Или Вы можете выбрать Add Printer Type, который

содержит список дополнительных принтеров. Выбранный принтер сохраняется
для сессии.

Configure Открывает диалоговое окно  Printer
Configuration, позволяя Вам изменить
опции настройки принтера

To file Открывает диалоговое окно Print to File
(Печать в файл),

To printer Выберите эту опцию для печати на
принтер

# of Copies Укажите количество копий печати от 1 до
99

Plotter command Укажите команды операционной системы
для печати (получите их от Вашего
системного администратора или из
руководства по операционной системе
вашего компьютера)

2. Если Вы выбираете переключатель To file, определите содержимое и структуру
файла печати и нажмите OK. Откроется диалоговое окно Print to File, имеющее
следующие опции:

Опция Назначение
Create Single File Создает новый единственный файл

Create Separate File Создает отдельный файл. Если вы создаете новый файл и
выбираете All (Все) или Range (Диапазон) в поле Sheets
диалогового окна Print, система помещает каждый лист
рисунка в отдельный файл печати. Система прибавляет номер
листа к имени файла печати.

Append to File Добавляет текущие данные для печати к существующему
файлу печати.

Name Укажите имя выходного файла. Используйте кнопку Browse
для навигации по структуре каталогов и указанию положения
выходного файла. При этом любое расширение по умолчанию
перезаписывается.

Если Вы не указали каталог, система сохраняет файл печати в
текущем рабочем каталоге и добавляет расширение .plt к
имени файла. Если Вы хотите различать расширения файлов
для каждого типа плоттера, установите опцию plot_names
файла конфигурации в Yes.

Заполните диалоговое окно Print to File, чтобы определить структуру, название и
расположение каталога файла и нажмите OK.
3. Если Вы выберете флажок To printer, то укажите листы (если доступно), количество
и команду для печати.

4. Если Вы хотите вывести на экран, выберите Screen из списка Destination.

5. Нажмите OK в диалоговом окне Print.

6. Если Вы выводите на экран, выберите Repaint из меню View.

Печать Файлов Pro/ENGINEER из Windows NT или 95

1. Выберите File > Print. Открывается диалоговое окно Print.



2. Заполните диалоговое окно Print, чтобы установить число листов и копий, которые
Вы хотите напечатать.

3. Щелкните по ОК. Открывается следующее диалоговое окно Print. Это - Диспетчер
печати MS.

4. Нажмите OK в диалоговом окне Print, чтобы послать задание на принтер или в файл.

Обратите внимание: Тонированные чертежи не могут быть сгенерированы
диспетчером печати Microsoft.

Изменение Атрибутов Перьев для Печати

Вы можете изменять атрибуты и назначать собственные линейные шрифты, толщину,
или цвет пера, используя файл table.pnt. Любой атрибут, который Вы определяете,
перезаписывает команды по умолчанию.

Формат ввода в файле table.pnt следующий:

pen # pattern values units; thickness value units; color values; <color_name>;

где

•  pattern - указывает определение печатаемого линейного шрифта, создаваемого
согласно определенным значениям для данных единиц измерения. Система
создает значения в следующем порядке: длина первого линейного сегмента, длина
первого пробела, длина второго линейного сегмента, длина второго пробела и т.д..
Например: образец пера 3.1 .05 .025.05.

•  thickness - определяет толщину печатаемой линии в данных единицах измерения.

•  color - определяет цвет, используемый для печати; определяет цвет красного,
зеленого и синего пропорционально в масштабе от 0 до 1. Работает только на
цветных графопостроителях.

•  <color_name> - Соответствует заданному по умолчанию цвету Pro/ENGINEER,
который система назначает конкретному типу объекта (для вызова заданных по
умолчанию цветов системы, выберите Utilities > Colors > System > Scheme >
Default.)

При изменении атрибутов перьев, имейте в виду следующее:

•  Вы может назначать более одного цвета одному и тому же перу в файле table.pnt.

•  Вы может отделять несколько имен цветов пробелами или запятыми.

•  Вы может отделять атрибуты точками с запятой.

•  Вы может включать любой или все атрибуты для каждого пера.

•  Те атрибуты, которые не были включены в файл table.pnt, остаются неизменными,
как при обычной печати.

Пример: Файл table.pnt

Ниже приведен образец файла table.pnt:

pen 1 color 0.0 0.0 0.7; highlite_color

pen 2 thickness .5 cm; letter_color

pen 5 pattern 1.0 0.1 0.5 .01 in; color 1.0 0.0 1.0; drawing_color

При создании файла table.pnt, Вы можете:



•  Использовать единицы измерения в дюймах (in) или в сантиметрах (cm) и
смешивать их в определениях шрифта; например, Вы можете определить образец
шрифта в дюймах, а толщину в сантиметрах.

•  Использовать наклонную черту влево (\) в конце строки для продолжения на
следующей строке.

•  Использовать восклицательный знак (!) в начале строки файла, чтобы сделать ее
комментарием.

Ниже приведен другой пример файла table.pnt:

!Восклицательные знаки в этом файле означают комментарии

!

!Назначает черчение желтых примитивов пером 1

pen 1 thickness 0.1 cm; letter_color

!Назначает черчение невидимых линий пером 2

pen 2 pattern 0.1, 0.1 in; thickness 0.1 cm; half_tone_color

!Назначает черчение геометрических линий пером 3

pen 3 drawing_color

!Назначает черчение линий sheetmetal пером 5

pen 5 thickness 0.1 in; attention_color

Переназначение Цвета Pro/ENGINEER Другому Перу

Файл table.pnt также дает возможность переназначать цвета Pro/ENGINEER другому
перу, чтобы перезаписать раскладку цветов по умолчанию. Следующая таблица
показывает заданное по умолчанию соответствие между названием системного цвета и
фактическим проявлением на экране.

Таблица соответствия цветов
COLOR_NAME Visible Color
attention_color (внимание) Зеленый

letter_color (буквы) Желтый

highlite_color (подсветка) Красный

drawing_color (рисунок) Белый

background_color (фон) Темно синий

half_tone_color (полутон) Серый

edge_highlite_color (подсветка ребер) Синий

dimmed_color (неяркая подсветка) Серый

magenta_color (пурпур) Пурпурный

section_color (сечение) Голубой

Если Вы изменяете заданный по умолчанию цвет, используя термошкалу, система
запоминает имя цвета, соответствующее объектам с измененным цветом. Однако, если
Вы переназначаете тип линий объекта, это изменяет связанное с ним имя цвета и
система чертит объект, как определено для этого цвета.

Обратите внимание: Pro/ENGINEER чертит объекты по назначенным им цветам.
Пользовательские цвета всегда выводятся Пером 1. Если Перо 1 имеет заданный по



умолчанию образец, толщину и т.д., система отражает это значение по умолчанию в
чертеже.

Определение Таблицы Распределения Перьев по
Умолчанию

Распределение перьев по умолчанию используется, если не был создан другой файл
распределения перьев и Pro/ENGINEER сконфигурирован на использование этой
таблицы. Для указания распределения перьев по умолчанию, просто удалите любую
ссылку на файлы таблицы перьев из файлов config.pro и PCF и удалите все файлы с
именем table.pnt из всех рабочих каталогов.

Когда Вы укажете объект Pro/ENGINEER для черчения, система назначит ему перо, на
основании системного цвета по умолчанию, соответствующего этому типу объекта.
Когда перо чертит объект, оно использует ширину линии и линейный шрифт, связанный
с конкретным цветом. Например, система использует перо #1 для черчения всех
объектов, которые имеют в Pro/ENGINEER белый цвет и одинаковую ширину линии и
толщину.

Если ваш графопостроитель поддерживает восьмиперьевой графопостроитель и Вы
хотите использовать их для черчения, установите опцию use_8_plotter_pens файла
конфигурации в Yes. Следующая таблица иллюстрирует распределение перьев по
умолчанию. Графопостроитель, поддерживающий четыре пера, использует первые
четыре пера, указанные в таблице.

Номер
пера Системный цвет Распределение

1 Геометрия (белый) Видимая геометрия (чертит все сплошные линии, за
исключением особо оговоренных случаев).

Кривые (коричневый) Линии плоскостей поперечных сечений; чертятся, как
искусственные линии.

Объем (пурпурный) Стрелки и текст плоскостей поперечных сечений.

Форматки рисунков и рамки.

Текст ярлычков.

Линейный шрифт осевыми линиями белого цвета.

2 Буквы (желтый) Все элементы чертятся сплошными линиями, за
исключением особо оговоренных случаев.

Размерные линии.

Выноски.

Осевые линии. Чертятся штрихпунктиром.

Линии геометрических допусков.

Весь текст (за исключением текста плоскостей
поперечных сечений)

Позиции

Штриховка

Желтая часть базовых плоскостей

Линейный шрифт осевыми линиями желтого цвета

3 Скрытые линии
(серый)

Скрытые линии: чертятся в виде штриховых линий,
текст - пунктиром



4 Подсветка (красный) Все элементы чертятся сплошными линиями:

Красная часть базовых плоскостей

Сетка сплайновых поверхностей (не чертится в
чертежах)

5 SheetMetal (зеленый) Элементы листового металла

6 Сечения (голубой) Элементы сечений эскизов

7 Скрытые меню
(серый)

Переключатели сечений, недоступные размеры и
текст, коинциндентные касательные кромки

8 Подсветка кромок
(голубой)

Сетка сплайновых поверхностей

Пример: Сегментирование и Печать Чертежей Postscript

Пример 1: Сегментированные Чертежи

Когда Вы хотите начертить полноразмерный чертеж, а ваш графопостроитель
обрабатывает меньшие размеры бумаги, выберите переключатель Segmented на
странице Model диалогового окна Printer Configuration. Pro/ENGINEER начертит
чертеж полного размера, но по частям, соответствующим выбранному размеру бумаги.
Следующая иллюстрация показывает, как чертится каждая часть с границей отреза -
засечка обозначает выравнивание, а обозначения колонок/строк показывают, как
собирать весь чертеж. Плоттеры HP7475a и HP7440A не поддерживают разбиение
чертежей на части.

При задании размера бумаги, имейте в виду, что сегментированный размер рисунка
меньше фактического размера бумаги из-за засечек совмещения.

Обратите внимание: Сегментированные чертежи доступны только при черчении
двухмерных чертежей. Они не доступны в трехмерном режиме.



Пример 2: Печать Postscript

Вы можете генерировать чертежи Postscript  для любого графопостроителя или
лазерного принтера, который может обрабатывать данные Postscript . Вы можете также
использовать их в документах, созданных электронными издательскими системами,
которые могут включать данные Postscript . Выходной формат соответствует
Postscript 2.0 (включается директива ограничивающей рамки). Вам может понадобится
поворот чертежа Postscript, чтобы начертить его правильно (см. следующую
иллюстрацию).



Конфигурирование Страницы Принтера

1. Выберите File > Print. Откроется диалоговое окно Print.

2. Выберите принтер из списка Destination.

3. Нажмите Configure, чтобы установить опции принтера по умолчанию. Открывается
диалоговое окно Printer Configuration на ярлычке Page.

Используйте Для
Size list Выберите размер бумаги следующих размеров A, B, C, D,

E, F, A0, A1, A2, A3, A4, переменный (по умолчанию А)

Height Укажите высоту бумаги для переменного размера (по
умолчанию 8.5 дюймов)

Width Укажите ширину бумаги для переменной ширины (по
умолчанию 11 дюймов)

Offset X Укажите отступ по горизонтали при печати

Offset Y Укажите отступ по вертикали при печати

Label Include Укажите, будет ли печататься обозначение (по
умолчанию, не печатается)

Height Укажите высоту обозначения (по умолчанию 0.125
дюйма)

Units Inches or Millimeters Укажите единицы измерения (по умолчанию дюймы)

Конфигурирование Масштаба Модели и Форматирование
для Печати

1. Выберите File > Print. Открывается диалоговое окно Print.

2. Выберите принтер из списка Destination.

3. Нажмите Configure, чтобы установить опции принтера по умолчанию. Откроется
диалоговое окно Printer Configuration. Если Вы конфигурируете принтер для печати
тонированного изображения, открывается диалоговое окно Shaded Image
Configuration.

4. Нажмите ярлычок Model в диалоговом окне Printer Configuration.



Используйте Для
Plot list Выберите тип плоттера (см. список и описание ниже)

Plot Scale Укажите масштаб плоттера (по умолчанию 1)

Segmented При необходимости, выберите сегментацию печати

With Format При необходимости, выберите печать с форматкой

Layers All Visible Печать всех видимых слоев

By ID Печать указанных слоев

Layers By ID field Укажите печатаемый слой

Quality list Выберите качество интерфейса для проверки совпадающих
линий. Доступны опции No line check (не проверять линии), No
overlap check (не проверять наложение), Simple overlap check
(упрощенная проверка наложений) и Complex overlap check
(Комплексная проверка наложений)

Типы Печати

Опции в plot list следующие:

•  Full Plot (Полная Печать) - Создает чертеж всего объекта (объекты печатаются
так, как если бы Вы выбрали View > Pan/Zoom > Refit).

•  Clipped (Обрезка) - Создает чертеж, ограниченный рамкой. Укажите границы
рисунка вокруг вычерчиваемой области. Эта область будет выведена на бумагу в
ее собственном положении относительно нижнего левого угла.

•  Based on Zoom (По окну; установлено по умолчанию) - Создает масштабируемый,
обрезанный чертеж. Масштабирование и обрезание берутся из размера бумаги и
установки текущего окна в графическом окне.

•  Plot Area (Область Печати) - Создает чертеж, сдвигая область внутри указанной
рамки в нижний левый угол листа и масштабируя указанную область для
соответствия указанному пользовательскому масштабу.

•  Model Size - Масштабирует чертеж по указанному масштабу модели. Например,
если Вы введете .25, система создаст чертеж модели в масштабе 1/4. Этот вариант
действует только для трехмерных объектов.

ОБРАТИТЕ ВНИМАНИЕ: Clipped и Plot Area действуют только, когда Вы изменяете
размер листа и масштабный коэффициент. Чертеж масштабируется, если Вы
изменяете размер листа в ярлычке Page. Если будет указан любой из этих вариантов,
после нажатия OK и закрытия диалогового окна Print, система запросит указать
область, которую нужно начертить. Переместите курсор в один угол и перетащите его к
по диагонали в противоположный угол области, которую нужно начертить.

Конфигурация Тонированных Изображений

Диалоговое окно Shaded Image Configuration имеет следующие опции:

Size Укажите стандартный или пользовательский размер из списка

Height Укажите пользовательский размер по вертикали (если Вы указали
Variable в списке размеров Size)

Width Укажите пользовательский размер по горизонтали (если Вы указали
Variable в списке размеров Size)



Top Margin Укажите размер верхнего поля (если Вы указали Variable в списке
размеров Size)

Left Margin Укажите размер левого поля (если Вы указали Variable в списке
размеров Size)

Units Установите пользовательский размер в дюймах или миллиметрах

DPI Укажите разрешение при выводе на печать. Выберите 100 dpi, 200
dpi, 300 dpi, 400 dpi

Image Depth Укажите глубину цвета изображения. Выберите 8-битные
индексированные цвета или 24-битные RGB.

Предварительный Выбор Объектов в Графическом Окне

В диалоговом окне Selection, Вы можете изменять или описывать текущий выбранный
в графическом окне элемент (элемент, компонент или трехмерное примечание). Вы
можете повторно подсвечивать выбранный элемент/компонент/трехмерное примечание
после перерисовки экрана.

Вы можете выбирать элементы и добавлять их в буфер выбора. Вы можете выбирать
элементы в графическом окне без указания, что Вы намереваетесь делать с ними

Файлы Конфигурации Графопостроителя

Вы можете сохранять или изменять название файла .pcf в поле Destination
диалогового окна Print или создавать из файла.

После инсталляции Pro/ENGINEER, дополнительно к указанным в файлах
конфигураций графопостроителей доступны те, которые Вы укажете.

Вы можете также использовать файл конфигурации графопостроителя (filename.pcf) в
интерактивном и пакетном черчении для предварительной установки некоторых или
всех опций черчения. Система отображает название вашего файла .pcf без
расширения, в списке справа от поля Destination в диалоговом окне Print. Если в
Вашем файле .pcf определена опция button_name, эта строка появляется в списке.

При создании файлов конфигурации графопостроителя, имейте в виду следующие
требования:

•  Вы можете работать с файлом конфигурации графопостроителя локально или
размещать его в другом месте. Если Вы размещаете его в другом месте, Вы
должны указать его местоположение,  установкой опции pro_plot_config_dir в файле
конфигурации config.pro.

•  Вы должен вводить содержимое и имя файла конфигурации графопостроителя в
нижнем регистре.

•  опция принтера - обязательна.

•  Все численные параметры для опций конфигурации графопостроителя -
обязательны.

Ниже приведен образец файла конфигурации графопостроителя:

Plotter (плоттер) postscript

plotter_command (команда плоттера) plot

plot_names (имя плоттера) yes

rotate_plotting (поворачивать рисунок) no

paper_size (размер бумаги) e



plot_segmented (сегментировать рисунок) yes

plot_scale (масштабировать рисунок) model 2

В предшествующем примере файл .pcf указывает системе печатать рисунок любого
размера на принтер Postscript размера Е. Обратите внимание, что файл конфигурации
установлен для создания сегментированного рисунка.

Следующий список представляет действительные опции для файлов конфигурации
графопостроителя. Значение по умолчанию для каждой опции выделено курсивом.

Обратите внимание: Эти опции - не соответствуют опциям файла конфигурации
Pro/ENGINEER.

Allow_file_naming

Yes, No

•  Yes - Ввести имя файла печати.

•  No - Система использует название объекта, как заданное по умолчанию имя
графического файла.

Button_name

Строковое

Добавляет указанное имя в список. Иначе, система использует имя файла
конфигурации графопостроителя.

Button_help

Строковое

Предоставляет интерактивную справку по элементу, указанному в опции button_name.

Create_separate_files

Yes, No

Определяет значение по умолчанию в диалоговом окне Print to File.

•  Yes - устанавливает значение по умолчанию Создавать Отдельные Файлы.

•  No - по умолчанию создается отдельный файл.

Delete_after_plotting

Yes, No

Если установлено в Yes, удаляет графический файл из каталога, в котором он
находится после завершения печати.

Interface_quality

0, 1, 2, 3

Определяет тип проверки накладывающихся линий при печати или экспорте
двухмерного файла, типа IGES, перед созданием файла. Интерпретирует значения
следующим образом:

•  0 - Не проверять накладывающиеся линии и не объединять линии в перо одного
цвета.

•  1 - Не проверять накладывающиеся линии, но объединять линии в перо одного
цвета для печати.

•  2 - Частично проверять кромки с двумя вершинами и объединять линии в перо
одного цвета для печати.



•  3 - Делать полную проверку всех кромок, лежащих одна против другой, независимо
от количества вершин, шрифта или цвета. Объединяет линии в перо одного цвета
для печати.

Paper_size

Размер бумаги, переменные единицы X Y

Определяет специфический размер листа, выводимого на печать (например, A1). Вы
можете указать пользовательский размер, вводя переменную с размером бумаги и
единицами измерения.

Paper_size_allowed

Список возможных размеров бумаги

Определяет все размеры бумаги (отделенные пробелами) которые могут
использоваться для вашей модели графопостроителя, например, а b с. Этот параметр
ограничивает размеры, перечисленные в Size, теми, которые указаны только в Вашем
списке.

Pen_slew

No_slew, значение

Устанавливает скорость пера графопостроителя, по x- и y-осям, где значение может
быть в диапазоне от 0.1 до 100.

Pen_table_file

Путь и имя

Определяет таблицу распределения перьев по умолчанию, которая заменяет другую
информацию по распределению перьев.

Plot_area

yes x1 y1 x2 y2 no

Устанавливает кнопку Plot Area в списке Plot диалогового окна Plot Configuration, в
значение по умолчанию.

Plot_access

create, append, default (создать, добавить, по умолчанию)

Создает новый графический файл или добавляет новые данные к другому
графическому файлу.

Plot_clip

yes x1 y1 x2 y2 no, default

Установка в Yes, выводит часть рисунка на печать. Х- и y-координаты - обязательны.
Это нормированные, значения от 0.0 до 1.0 (0,0 соответствует левому нижнему углу
чертежа) которые указывают часть рисунка, выводимую на печать. Например, чтобы
отсечь половину окна в центре экрана, строка должна быть следующей: plot_clip yes
0.25 0.25 0.75 0.75.

Plot_drawing_format

Yes, No, default

Если установлено в no, выводит на печать график без форматки.



Plot_file_dir

Имя каталога

Определяет каталог, в который система сохраняет файлы печати. Используйте полный
путь, например, /home/users/plotfiles.

Plot_label

yes, no, default

Если установлено в yes, выводит на печать с меткой.

Plot_label_height

<значение> дюймы <значение> см.

Устанавливает высоту меток. Введите числовое значение для этой опции с единицами
измерения в дюймах (in) или сантиметрах (cm).

Plot_layer

current, by_layer #, default (текущий, по слою#, по умолчанию)

Определяет слой рисунка, который нужно начертить. В by_layer#, символ # является ID
номером слоя.

Plot_linestyle_scale

Любое положительное число, 1.0

Определяет коэффициент масштабирования для шрифта с пунктирными линиями в
вашем рисунке. Введите любой положительный номер, например 2.0, как значение для
этой опции.

Plot_names

yes, no

•  Yes - дает описательное расширение файлам печати в процессе их создания.
Расширения следующие:

•  hp - графопостроители Hewlett-Packard

•  hp2 - графопостроители Hewlett-Packard hpgl2

•  cal - графопостроители Calcomp

•  версия - графопостроители Versatec

•  ger - фотографопостроители Gerber

•  ps - графопостроители Postscript (включая цветные)

•  No- все графические файлы получают расширение .plt.

Обратите внимание: Pro/BATCH не поддерживает эту опцию.

Plot_roll_media

Yes, No

•  Yes - рулонный тип носителей.

•  No - тип носителей соответствует настройке по умолчанию конкретного принтера.

Plot_scale

fit_paper, model #, plot #, default



Определяет коэффициент масштабирования модели или рисунка для печати, где # -
значение масштаба от 0.01 до 100.0.

Plot_segmented

yes, no, default

Если установлено в yes, генерирует сегментированный рисунок.

Plot_sheets

current, range low high, default, all (текущий, диапазон нижний верхний, по умолчанию,
все)

Определяет листы для черчения. Чтобы указать диапазон листов, установите нижнее и
верхнее значение диапазона.

Plot_translate

<value>, <x value> <y value>, <x value> <y value> <units>

Устанавливает смещение рисунка от его начала координат. Введите только значение x-
смещения или оба значения y-смещения и x-смещения. Вы можете указать только
единицы измерения (типа mm) при указании смещения в обоих направлениях.
Например:

Plot_translate .25

Или

Plot_translate .25 .35

•  Выполняет смещение 0.25 в направлении X и 0.35 в направлении Y.

Обратите внимание: Если указывается единственное значение, оно используется и
для x, и для y.

Plot_to_scale_full_window

yes, no

Масштабирует печатаемый файла до полного размера экрана.

Plot_with_panzoom

yes, no

Определяет печать рисунка по масштабу окна или весь рисунок.

•  Yes - печатается изображение в окне.

•  No - печатается весь рисунок.

Plotter_command

command, windows_print_manager <plotter or printer name>

Определяет системные команды, используемые при печати на принтер в Вашей
системе. Например:

•  В UNIX, Вы можете указать команду графопостроителя следующим образом:

Plotter_command Ip -d <plotter_name>

или

Plotter_command Ipr -P <plotter_name>

•  В Windows NT или Windows 95, Вы можете указать команду графопостроителя как:

plotter_command windows_print_manager <plotter or printer name



Plotter_handshake

hardware, software (аппаратно, программно)

Устанавливает тип последовательности инициализации handshake (синхронизации)
графопостроителя, генерируемой в файле печати. Для каждого из этих двух режимов,
Вы должны установить порт данных ведущего компьютера:

•  Программный режим handshake - Xon/Xoff.

•  Аппаратный режим handshake требует аппаратного управления.

Обратите внимание: Проконсультируйтесь с вашим системным программистом для
получения дополнительной информации относительно handshake.

plotter

desired plotter name (Требуемое название графопостроителя)

Устанавливает заданный по умолчанию графопостроитель при создании графических
файлов.

Rotate_plotting

Yes, No

•  Yes - Вращает чертеж Postscript на 90° против часовой стрелки при печати. То есть
горизонталь на экране соответствует короткому краю бумаги.

•  No - Не вращает чертеж Postscript. При печати деталей и сборок предполагается
альбомный формат (то есть горизонталь на экране соответствует длинному краю
бумаги.

Обратите внимание: Не влияет на тонированные изображения Postscript.

Установка Других Опций Принтера

1. Выберите File > Print. Открывается диалоговое окно Print.

2. Выберите принтер из списка Destination.

3. Нажмите Configure, чтобы установить по умолчанию опции вашего принтера.
Откроется диалоговое окно Printer Configuration
4. Нажмите ярлычок Printer в диалоговом окне Printer Configuration.

Используйте Для
Pen Table File checkbox Применения таблицы распределения перьев по

умолчанию

Pen Table File field Укажите имя таблицы

Velocity Если используется, укажите скорость пера
(сантиметры в секунду)

Cutter Installed Указывает, будет ли включен нож для бумаги

Handshake Xon/Xoff or Hardware Выберите тип инициализации плоттера

Sheet Type Sheet or Roll Если используется, выберите тип бумаги

Rotation Укажите поворот изображения (0 или 90 градусов)



Завершение Работы в Pro/ENGINEER

Для выхода из Pro/ENGINEER:

1. Выберите File > Exit.
2. В диалоговом окне CONFIRMATION, нажмите Yes.
Вы можете установить опцию allow_confirm_window файла конфигурации в no, чтобы
предотвратить появление диалогового окна CONFIRMATION.

Ваши файлы не будут сохранены после выхода, если Вы не установите опцию
prompt_on_exit файла конфигурации в yes. В этом случае, система запросит Вас
сохранить объект за объектом. Вы можете ответить следующим образом:

Y или Yes - Сохраняет объект и переходит к следующему объекту.

N или No - Не сохраняет объект и переходит к следующему объекту.

A Или All - Сохраняет все объекты в памяти и выходит (никакие вопросы не задаются).

Q или Quit - Завершает сеанс Pro/ENGINEER без сохранения каких либо опций. Для
выхода из Pro/ENGINEER, в меню File выберите Exit. Откроется диалоговое окно
подтверждения.

Списки Материалов (BOMs)

Вы можете создавать список материалов (BOM), перечисляющий все детали и
параметры детали в текущей сборке. Вы можете создавать BOM для сборок в режиме
Assembly или из сборочных чертежей в режиме Drawing, используя диалоговое окно
BOM.

Вы можете конфигурировать выходной формат BOM опцией BOM_format файла
конфигурации. Заданный по умолчанию выходной формат для BOM разделен на два
раздела:

•  breakdown - Перечисляет имена, тип и количество вхождений каждого компонента и
подкомпонента.

•  summary - Перечисляет общее количество каждой детали, включенной в сборку.
Summary - "список необходимых покупок" всех деталей, необходимых для
формирования сборки из деталей.

Файл Формата BOM по умолчанию

Пользовательский выходной формат BOM определяет отдельно формат раздела
breakdown и раздела summary. Вы можете включать одну или обе секции, но Вы
должны определить заголовки столбца, содержимое ряда и формат отображения для
каждого включенного раздела.

Пользовательский формат файл содержит комбинацию текста и команд
форматирования. Общая компоновка BOM определена следующими командами
разделов, которые вставляются в начале строки:



•  breakdown - эта команда стоит в начале раздела breakdown BOM. Строки текста
после команды .breakdown вставляются, как заголовки к каждой конструкции
breakdown.

•  summary - эта команда стоит в начале раздела summary BOM. Строки текста после
команды .summary вставляются как заголовки к разделу summary.

•  titles, row - эти команды могут использоваться в пределах каждого раздела BOM для
определения заголовков столбца и информации, которая будет включена в
повторяющиеся строки BOM.

В любом пункте в формате файла, Вы можете указать системный или
пользовательский атрибут:

•  %$ - знак процента со знаком доллара указывает, что следующее слово - один из
трех системных атрибутов: name, type или quantity (название, тип или количество).
Например, %$type.

•  % - Любое слово, предшествующее знаку процента является только
пользовательским параметром.

Текст, который не является частью имени параметра, печатается так, как он введен.
Например, чтобы напечатать символ доллара перед пользовательским атрибутом
цены, введите $%price.

Системные и пользовательские параметры могут сопровождаться спецификатором
формата стиля языка C, включенным в квадратные скобки ( [ ] ) который указывает тип
данных и ширину распечатки значения атрибута. Эти спецификаторы формата
необязательные, но могут быть необходимы для правильного выравнивания столбца.

Примеры спецификаторов формата следующие:

•  [4s] - предшествующий параметр - строковая переменная (текст), и ширина поля - 4.

•  [3d] - предшествующий параметр - целое число, и ширина поля - 3.

•  [6.2f] - предшествующий параметр - переменная с плавающей точкой
(вещественное число). Полная ширина поля - 6 (включая десятичную точку), и 2
цифры следуют за десятичной точкой. Пример: 400.25.

•  [8.8s] - предшествующий параметр - строковая переменная. Ширина поля - 8, а
более длинные строки обрезаются до 8 символов.

Обратите внимание: Ширины поля могут отменятся строками, которые появляются
после указанного поля. Используйте этот формат для обеспечения надлежащего
размера ширины поля.

•  [-4s] - текст в этом поле выровнен по левому краю. (Знак "минус" указывает левое
выравнивание).

В каждом из предшествующих спецификаторов формата, символ необязательный;
Pro/ENGINEER определяет тип пользовательского параметра (строка, целое число или
плавающая точка) если Вы его опускаете.

Обратите внимание: Вы не можете использовать функцию BOM в меню Info для
печати параметров, определенных, как параметры типа "примечания".

При вводе поля [%[$total(item)]] в файле формата (где item может являться
пользовательским названием параметра) производится вычисление общего количества
для item. При вводе в пределах команды row, общее количество рассчитывается только
для этой строки. Во всех остальных местах команде $total () необходима
предшествующая команда .row, а общее количество рассчитывается для всех
элементов в пределах подсборки или сборки. Вы можете также использовать [% [$total
($quantity)]], где quantity - системный атрибут.

Обратите внимание: В %$total(item) перед item или $quantity не ставится знак
процента (%).



Система проверяет файл формата на наличие ошибок. Если ошибка найдена, файл
формата BOM появляется в окне Information с подсвеченной ошибкой.

Пример: BOM

Пример двигателя вертолета - сборка, используемая для следующего примера BOM.
Модель Сборки Двигателя Вертолета



 



Создание BOM

1. В области главного меню, выберите Info > BOM. Откроется диалоговое окно BOM.

2. Под Select Model, выберите Top level или Subassembly.
3. Если Вы выбрали Subassembly, используйте меню GET SELECT для выбора
подсборки в текущем окне.

Обратите внимание: Для восстановления меню GET SELECT, нажмите кнопку Select

4. Под Include, выберите или снимите переключатели Skeletons и Unplaced, чтобы
указать - в каком виде они должны появится в BOM.

5. Нажмите OK и выберите Screen, File или Both в меню INFO OUTPUT. Система
отобразит BOM в окне Information.

6. Если требуется, используйте меню File, Edit и View в окне Information для
сохранения, редактирования, поиска, закрытия или просмотра номера строки в окне
BOM Information.



BOM и Масс-Инерционные Характеристики

В Каркасном Режиме

При работе с каркасной моделью в сборке, Pro/ENGINEER генерирует информацию
Списка материалов (BOM) и информацию по масс-инерционным характеристикам,
которая точно отражает конструкцию модели и пользовательские или по умолчанию
масс-инерционные характеристики. Однако, сборка BOM и масс-инерционные
характеристики сборки полностью игнорируются в каркасных моделях при работе с
деталями.

В Мастер-Представлениях (Master Representations)

Чтобы получить полный BOM или масс-инерционные характеристики Мастер-
Представления при работе с упрощенным представлением, Вы должны переключиться
в Мастер-Представление. Pro/ENGINEER включает имеющиеся компоненты в расчеты
масс-инерционных характеристик, так как они находятся в сессии. При этом не
включаются исключенные компоненты, пока они не будут включены в сессию. Масс-
инерционные характеристики отображают только то, что находится в настоящий
момент на экране.

BOM перечисляет все компоненты сборок, которые находятся в сессии. Если Мастер-
Представление не находится в сессии, BOM будет не точным. Pro/PDM обеспечивает
полный BOM без вызова объектов. В Pro/REPORT, BOM доступен только тогда, когда
Вы вызываете сборку как Мастер-Представление.

Для подмененных объектов, Pro/ENGINEER имеет доступ к именам исходного и
подмененного объекта. Масс-инерционные характеристики подмененного компонента
доступны, поскольку компонент находится в сессии. Если они были назначены через
режим Interchange, масс-инерционные характеристики исходного объекта доступны в
подмененном компоненте.

Определение Формата BOM

1. Используя системный редактор, создайте файл выходного формата BOM.

2. Добавьте следующую опцию в конфигурационном файле:

Bom_format formatname.fmt

3. В Pro/ENGINEER, добавьте пользовательские параметры для деталей и сборки,
используя команду меню RELATIONS Add Param.
4. Выберите Info > BOM. BOM появляется в окне Information и сохраняется в файле.

Обратите внимание: Компоненты сборки, которые скрыты на слое или подавлены в
сборке, перечисляются в BOM для сборки так, как будто они отображены.

Получение Информации по Выбранным Элементам

В информационном окне элемента, Вы можете исследовать информацию по элементам
и графике модели. Информация элемента включает слои объекта и статус. Вы можете
подсвечивать элементы в слоях, которые скрыты в пределах структуры слоев.



Вы можете также осуществлять поиск в пределах структуры слоев и структуры Модели.
Развертывание и сворачивание Структуры Модели становится доступно после
закрытия диалогового окна этой модели.

Для запроса информации по элементу

1. В меню, нажмите Info > Feature или Info > Regen Info
2. Используйте меню GET SELECT для выбора элемента.

Система отображает информацию по элементу в окне Information и сохраняет
информацию в файл с именем feature.inf. Вы можете сохранить файл с другим именем
и редактировать его в окне, используя меню File, Edit и View.

Совет: Информация по Элементу, Включая Слои
Объектов Элемента

Для запроса информации по элементу, нажмите Feature и Regen Info в меню Info.

В информационном окне элемента, Вы можете исследовать информацию по элементам
и графике модели. Информация элемента включает слои объекта и статус. Вы можете
подсвечивать элементы в слоях, которые скрыты в пределах структуры слоев.

Вы можете также осуществлять поиск в пределах структуры слоев и структуры Модели.
Развертывание и сворачивание Структуры Модели становится доступно после
закрытия диалогового окна этой модели.

Перечисление Всех Моделей или Элементов Компонента

1. Для отображения списка всех элементов и сопутствующей информации по текущей
модели.

В меню, выберите Info > Feature List. Если Вы находитесь в сборке, открывается
диалоговое окно Feature List.
a. Под Select Model, нажмите кнопку выбора для информации, которую Вы хотите
получить (Top Level, Subassembly, Part или Skeleton).

b. Используйте меню GET SELECT для выбора элемента модели.

Обратите внимание: Для восстановления изображения меню GET SELECT, нажмите
кнопку Select
2. Щелкните по Apply.
3. Выберите Screen, File или Both в меню INFO OUTPUT. В окне Information появляется
требуемая информация и сохраняется в файл с именем feature.lst.

4. Вы можете сохранить файл под другим именем и редактировать его в окне,
используя меню File, Edit и View.

Отображение Подробной Информации По Всей Модели

Для отображения информации по всей модели, включая единицы измерения, элементы
и дочерние компоненты, выберите в меню Info пункт Model. Появляется диалоговое
окно Model Info.

Для отображения информации по модели, в меню,

1. Выберите Info > Model. Если Вы находитесь в сборке, открывается диалоговое окно
Model Info.



a. Под Select Model, нажмите кнопку выбора для информации, которую Вы хотите
получить (Top Level, Subassembly, Part или Skeleton).

b. Если появляется меню GET SELECT, выберите подсборку, деталь или каркас, по
которым Вы хотите получить информацию.

Обратите внимание: Для восстановления изображения меню GET SELECT, нажмите
кнопку Select
с. Щелкните по Apply.
2. В окне Information появляется требуемая информация и сохраняется в файл с
именем part-name.inf.n, где part-name - название модели. n - номер версии файла.

Информация зависит от того, что Вы выбрали.

Выберите Для
Top Level Показывает информацию модели по сборке верхнего уровня

Subassembly Показывает информацию модели по конкретной сборке

Part Показывает следующую информацию модели по детали:

стандартные элементы;

подавленные элементы;

системы координат;

поперечные сечения;

справочные размеры;

незаконченные элементы

Детали помечаются метками, если они являются базовыми или
вхождениями. Для использования в детали опции Name, деталь
должна быть создана или вызвана во время рабочей сессии.

Skeleton Показывает информацию по каркасу модели

По умолчанию, система перечисляет только названия объектов в окне Model Info.
Однако, Вы можете использовать опцию display_full_object_path файла конфигурации
для отображения полного пути объектов, наряду с типом объекта и суффиксами
номера версии.

Отображение Команд Сборки для Выбранных
Компонентов

Для отображения информации относительно того, как компонент в модели сборки был
собран в текущем окне и относительно его родительских и дочерних записей,
зависимостей и параметров, в меню:

1. Выберите Info > Component. Открывается диалоговое окно Component Constraints,
и появляется меню GET SELECT.

2. Выберите компонент, для которого Вы хотите получить информацию по
зависимостям. (Название компонента появляется в поле Component. Кроме того,
отображается информация Type, Comp Refs, Asm Refs и Offset, если она
используется)

3. Щелкните по Apply.
4. Информация по компоненту появляется в окне Information и в файле (с именем
component-name.memb).



5. Если требуется, используйте меню File, Edit и View в окне Information для
сохранения, редактирования или поиска информации и для закрытия окна Component
Information.

Отображение Информации по Версии Текущего Объекта

Для отображения информации по версии текущего объекта, если он был выбран из
базы данных изделия Pro/PDM, из меню:

1. Выберите Info > Audit Trail. Информация по версии появляется в окне Information и в
файле с именем, указанным в области сообщения. Каждый контрольный журнал
отображает:

•  Mod Time - дата и время последнего изменения объекта, в формате mm/dd/yy
hh:mm:ss

•  Rev - текущая версия объекта в его оригинальной базе данных

•  Rel Level - уровень текущей версии объекта в его оригинальной базе данных

•  User - владелец объекта в его базе данных

•  Action - перечень действий над объектом, включая выборку, сохранение,
переименование и копирование

•  Comment - комментарий, связанный с объектом в ходе подчинения, одобрения,
отклонения и т.д.

2. Если требуется, используйте меню File, Edit и View в окне Information для
сохранения, редактирования или поиска информации и для закрытия окна Component
Information.

Обратите внимание: опция info_output_mode файла конфигурации определяет
средства, которыми система создает контрольный журнал.

Перечисление Всех Обрабатываемых и Связанных
Моделей на Диске

Из меню:

1. Выберите Info > Pro/Engineer Objects. Открывается окно Information и отображается
список объектов.

2. В окне Information, Вы можете использовать

•  Полосы прокрутки - для просмотра списка

•  Меню File - для сохранения или закрытия списка

•  меню Edit - для редактирования списка

•  меню View - для добавления номеров линий к списку

Отображение Размера Модели

Для отображения размера модели, в меню Info, выберите Model Size.
После того, как Вы выберете модель, в окне Message появится ограничивающее поле с
диагональю, а вокруг выбранной модели появится зеленая рамка. Вы можете также
показать информацию в Дереве Модели.



Отображение Журнала Сообщений

Для отображения информации относительно сообщений, полученных в текущей сессии:

1. В меню Info, выберите Message Log. Открывается окно Information с требуемой
информацией.

2. Используйте меню File, Edit и View в окне Information для сохранения информации в
файле, редактирования файла или просмотра номеров строк.

Переключение Размерности Отображения

В режимах Assembly и Drawing, Вы можете переключать размерность с цифрового
отображения на символьное отображение.
Для использования этой функцию, в меню Info, выберите Switch Dims или нажмите
в инструментальной панели (используйте Customize Screen в меню Utilities для
размещения кнопки на инструментальной панели).

Информационное Окно

Нажмите кнопку Info в каком либо диалоговом окне для отображения информации,
сгенерированной какими либо функциями Pro/ENGINEER в окне Information.

Иногда Вас запросят сообщить системе, хотите ли Вы отобразить информацию в окне,
записать в файл, или выполнить и то, и другое. В других ситуациях, окно Information
открывается, как только Вы выбираете команду Pro/ENGINEER, требующую
информации.

Используйте меню в окне Information следующим образом:

•  File - для сохранения содержимого окна в файл

•  Edit - для редактирования содержимого окна

•  View - для отображения номера строки в окне

Получение Информации по Модели Отливки

Для отображения информации по отливке, из меню:

1. Выберите Info > Cast. Открывается диалоговое окно Cast Info открывается.

2. Под Show Info About, выберите или снимите галочку с

•  BOM

•  Components

•  Split Volumes

•  Created Volumes

•  Split

•  Last Volume
3. Под Output Results, выберите Screen, File или оба варианта и отредактируйте имя
файла, если требуется.



4. Щелкните по Apply для отображения данных в окне Information, записи данных в
файл (имя указано в области сообщения) или выберите оба варианта, в зависимости от
вашего выбора под Output Results.
5. Если требуется, используйте меню File, Edit и View в окне Information для
сохранения, редактирования или поиска и, затем, закрытия окна Cast Information.

Получение Информации по Диаграмме

Для отображения информации по диаграмме в текущем, активном окне, из меню:

1. Выберите Info > Wire List
2. Выберите Screen, File или Both в меню INFO OUTPUT
В зависимости от вашего выбора будут созданы, окно Information, файл (с именем,
указанным в информационной области окна Pro/ENGINEER) или оба, которые покажут:

•  Имя файла диаграммы

•  Имена кабелей / нитей

•  Имена проводников

•  Имена компонентов разъемов From и To (От и До)

•  Имена катушек

3. Если требуется, используйте меню File, Edit и View в окне Information для
сохранения, редактирования или поиска и, затем, закрытия окна информации по
компонентам.

Получение Информации по Движению Инструмента
(Toolpath) Sheetmetal

Для отображения информации по движению инструмента для модели sheetmetal в
текущем активном окне, из меню:

1. Выберите Info > Toolpath Display.
2. Выберите Tool & Path, Tool, Path или None.
3. Щелкните по ОК. Движение инструмента подсвечивается на модели.

Получение Информации по Проекту Sheetmetal

Для отображения данных по детали Sheetmetal в активном окне, из меню:

1. Выберите Info > Sheetmetal. Открывается диалоговое окно Sheetmetal Info.

2. Под Report, выберите Bend Report, Radii Report или Design Check.
Обратите внимание: Design Check проверяет деталь не по обозначенным правилам и
отображает любые отклонения. Эта проверка требует таблицы правил.

3. Под Output Results to, выберите Screen, File или и то, и другое и измените имя
файла, если требуется.

4. Нажмите OK для отображения информации.



Получение Информации по Жгутам (Harness) и Кабелям
(Cable)

Для отображения информации по жгутам и кабелям в сборке, из меню:

1. Выберите Info > Cable.
2. В диалоговом окне Cabling, выберите Information Type::

•  Harness Items - отображение списка используемых элементов

•  Harness Wirelist - отображает список проводов в жгуте, содержащий имена
кабелей, цвет, длину и положения От и До

•  Physical Routing - отображает следующее диалоговое окно с кнопками:

•  Length - выберите кабель для измерения

•  Path - выберите кабель для отображения его пути

•  Bundle Items - выберите связку для отображения ее компонентов

3. В диалоговом окне Cabling, выделите All, Individual или Partial для отображения
требуемой информации.

4. При Output to, выберите Screen, File или и то и другое, и отредактируйте имя файла,
если требуется.

5. Щелкните по Apply для отображения информации в окне Information, в файле, или и
то, и в другое, в зависимости от вашего выбора в Output to.
6. Если требуется, используйте меню File, Edit и View в окне Information для
сохранения, редактирования или поиска информации, затем закройте окно Cable
Information

Получение Информации по Модели Литейной Формы

Для отображения информации по литейной форме, из меню:

1. Выберите Info > Mold. Открывается диалоговое окно Mold Info.

2. Под Show Info About, выберите или снимите выбор с:

•  BOM

•  Components (Компоненты)

•  Split Volumes (Разделить Объемы)

•  Created Volumes (Создать Объемы)

•  Parting Surf (Поверхность разъема)

•  Split (Разделить)

•  Last Volume (Последний Объем)

3. Под Output Results, выберите Screen, File или и то и другое, и отредактируйте имя
файла, если требуется.

4. Щелкните по Apply для отображения данных в окне Information, записи данных в
файл (с именем, отображаемым в области сообщений) или и того и другого, в
зависимости от Вашего выбора под Output Results.
5. Если требуется, используйте меню File, Edit и View в окне Information для
сохранения, редактирования или поиска, затем закройте окно Mold Information.



Получение Информации по Последовательности
Процесса

1. В области главного меню, выберите Info > Process > Sequence Info.
2. Открывает окно Information, содержащую информацию по процессу.

Получение Информации по Процессу Установки

1. В области главного меню, выберите Info > Process > Step. Открывается диалоговое
окно Select Step.

2. Выберите шаг, по которому Вы хотите увидеть информацию и щелкните по Info.
Откроется окно Information, содержащее информацию.

3. Нажмите Close для закрытия диалогового окна.

Получение Информации по Обрабатываемой Модели

Для отображения информации по текущей активной обрабатываемой модели, из меню:

1. Выберите Info > Manufacturing. Откроется диалоговое окно Manufacturing Info.

2. Под Output Information for, выберите одну из следующих опций:

•  Manufacturing Model - отображает информацию в окне Information по модели,
включая:

•  Отчет по Последовательности Механической обработки (Тип Обработки,
Материал и Дату)

•  Информацию по Установке Оснастки

•  Полные Данные по Механической обработке

•  Список Операций

•  Operation - отображает Список Операций

•  NC Sequence - отображает список NC последовательности по текущей операции
или по всей операции

Mfg Geometry - отображает Список Геометрии для выбранных Geometry Type (Mill
Window, Mill Surface, Mill Volume или Turn Profile)
Route - отображает Route Sheet (Лист Последовательности) для сборки, содержащий
Seq. Machine и Sequence, Rmvd Vol, Set up Time и Run Time

3. В разделе Output Results To диалогового окна Manufacturing Info, выберите Screen,
File или и то и другое, и измените имя файла, если требуется.

4. Щелкните по Apply для отображения требуемой информации. (Если не существует
никаких элементов для осуществления выбора, появляется информационное
сообщение)

5. Нажмите Filter для отображения диалогового окна Manufacturing Information:
Filters, которое позволяет Вам выбрать или снять фильтры для отображения
информации.

6. Щелкните по Close для закрытия диалогового окна Manufacturing Info.



Анализ Модели

Вы можете анализировать свойства модели, используя диалоговое окно Model Analysis.
Это диалоговое окно включает раскрывающийся список Type, предлагающий
следующие типы анализа:

•  Масс-инерционные характеристики сборки (или Модели)

•  Масс-инерционные характеристики X-сечения

•  Односторонний объем

•  Зазор между парами

•  Общий зазор

•  Пересечение объемов

•  Общее пересечение

•  Короткая кромка

•  Тип кромки

•  Толщина

Обратите внимание: Для проверки на зазор и пересечение, точность расчетов
определяется точностью детали. Точность измерения зазора или пересечения объемов
управляется опцией measure_sig_figures файла конфигурации.

Если выбранные объекты не пересекаются, минимальный зазор отображается
графически в виде красной линии. На каждом конце линии появляется маленький
красный круг с перекрестными полосами для идентификации местоположения, в
котором измеряется зазор. Значение зазора появляется в Окне Сообщения. Если
имеется пересечение, система подсвечивает объем пересечения и выдает значение
или подсвечивает кривую или точку пересечения, в зависимости от Вашего выбора для
указанного элемента.

Разнесенные виды являются временными и не воздействуют на расчет зазора.
Отображение результатов в таких случаях, соответствуют неразнесенной модели.

Анализ Масс-инерционных Характеристик

Тип анализа Assembly Mass Properties доступен в режиме Assembly; тип Model Mass
Properties доступен в режимах Part и Drawing.

Для отображения, сохранения и редактирования отчета по масс-инерционным
свойствам модели, из меню:

Выберите Analysis > Model Analysis. Открывается диалоговое окно Model Analysis.

3. В списке Type, выберите Assembly Mass Properties для модели сборки или Model
Mass Properties для модели детали.

4. В Accuracy > Definition, выберите Use default accuracy или введите значение
относительной точности. Точность детали не должна быть меньше 1/100 точности
масс-инерционных характеристик.

5. В Coordinate System > Definition, выберите Use default accuracy для
использования заданной по умолчанию системы координат для ссылки при анализе.
Если Вы отмените Use default, появится меню GET SELECT, с предложением выбрать
или создать ссылочную систему координат.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select



6. Если Вы выбрали систему координат, система выполнит анализ. Результат
появляется под Results.
7. Если Вы выбрали Use Default, нажмите Compute для выполнения анализа.

8. Введите значения плотности или подтвердите значения по умолчанию на запрос и
нажмите клавишу RETURN.

9. При отображении окна Results, нажмите кнопку Info� для отображения сообщения в
окне Information. Отображение включает следующие свойства:

VOLUME (объем)

SURFACE AREA (площадь поверхности)

DENSITY (плотность)

MASS (масса)

CENTER of GRAVITY (центр тяжести)

INERTIA (инерция)

INERTIA TENSOR (тензор моментов инерции)

INERTIA AT CENTER OF GRAVITY (инерция в центре тяжести)

PRINCIPAL MOMENTS OF INERTIA (основные моменты инерции)

10. Используйте меню File, Edit и View  для сохранения, редактирования или поиска
сообщения.

11. Откройте часть диалогового окна Saved Analyses щелчком по треугольнику. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Вычисление Масс-инерционных Характеристик для
Поперечного Сечения

Для вычисления масс-инерционных характеристик поперечного сечения,

1. Из меню, выберите Analysis > Model Analysis. Открывается диалоговое окно Model
Analysis.

2. В списке Type, выберите X-Section Mass Properties. Появляется меню GET SELECT.

3. В разделе Setup, выберите X-Section Name и, либо выберите Use default accuracy,
либо введите значение Rel accuracy.
4. Выберите ссылочную систему координат или выберите Use default.
Обратите внимание: Если Вы хотите вернуть меню GET SELECT, нажмите кнопку
Select

5. Если Вы выберете систему координат, система выполнит анализ. Результат
появляется под Results.
6. Если Вы выберете Use Default, нажмите Compute для выполнить анализ.



7. Щелкните по кнопке Info для отображения результатов анализа в окне Information. Вы
можете также сохранять или редактировать анализ в этом окне.

8. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Вычисленные масс-инерционные характеристики для поперечного сечения включают
следующее:

•  Area - площадь поперечного сечения.

•  Центр тяжести - местоположение центра тяжести относительно указанной системы
координат. Центр тяжести и система координат отображаются графически на
модели.

•  Тензор инерции в начале указанной системе координат и оси.

•  Тензор инерции в центре тяжести и ориентируемый по осям указанной системы
координат.

Область основных моментов инерции - моменты инерции в центре тяжести
относительно основных осей.

•  основные координатные оси помечены, как 1 и 2 вместо x и y. В предшествующих
уравнениях, x - координата по основной оси 1, y - координата по основной оси 2.

•  Полярный момент инерции - полярный момент инерции поперечного сечения в
центре тяжести.

•  Матрица поворота и угол поворота - Поворот вокруг z-оси от осей координат до
основных осей, в матричной и угловой форме.

•  Радиус инерции - радиус инерции в центре тяжести относительно основных осей.

•  Момент сопротивления сечения и соответствующие точки - расчет для каждой
основной оси (например, 1-оси, 2-оси) делением площади момента инерции
относительно выбранной оси на расстояние до точки или точек поперечного
сечения, которые являются самыми дальними от выбранной оси. Эти точки имеют
самые нижние (чаще, отрицательные) и самый большие (чаще, положительные)
координаты по ортогональным основным осям в плоскости поперечного сечения.

Обратите внимание: масс-инерционные характеристики поперечного сечения не
доступны для эквидистантных поперечных сечений.



Расчет Масс-инерционных Характеристик для Детали или
Сборки

Вы можете устанавливать по умолчанию единицы массы для всех новых деталей и
сборок, которые Вы будете создавать с использованием опции pro_unit_mass файла
конфигурации.

Примечания:
Масс-инерционные характеристики могут быть рассчитаны, используя зависимые
параметры системы. Однако, масс-инерционные характеристики автоматически не
изменяются при изменении модели. Вы должны повторно вычислять масс-инерционные
характеристики, чтобы увидеть воздействие изменений модели.

Если были установлены границы размеров, расчеты масс-инерционных характеристик
базируются на значениях гипотетических размеров.

Если элемента подавлены, масс-инерционные характеристики будут рассчитаны таким
образом, как если бы эти элементы не существуют. Если деталь была упрощена для
целей сборки и содержит много подавленных элементов, масс-инерционные
характеристики могут быть назначены детали таким образом, чтобы эти значения
использовались в вычислении масс-инерционных характеристик сборки.

Если детали на слоях были подавлены в текущем виде, они продолжают
использоваться для вычисления масс-инерционных характеристик сборки.
Подавленные элементы воздействуют только на отображение объекта, а не его
построение.

Вычисленные масс-инерционные характеристики для детали или сборки включают:

•  Объем - общий объем модели

•  Площадь поверхности - площадь всей поверхности модели

•  Плотность - для масс-инерционных характеристик детали, указанная плотность
детали отображается здесь. Для масс-инерционных характеристик сборки,
выводится средняя плотность ее компонентов. Плотность каждой отдельной детали
используется в вычислении массы.

•  Масса - Полная масса модели

•  Центр тяжести - Местоположение центра тяжести относительно указанной системы
координат. Центр тяжести и система координат отображаются графически на
модели.

•  Тензор инерции в начале указанной системы координат и осей. Значения
вычисляются следующим образом:

и т.д.

и т.д

где r = указанная плотность детали.

•  Тензор инерции в центре тяжести и ориентируемый по осям указанной системы
координат



•  Основные моменты инерции - Моменты инерции в центре тяжести относительно
основных осей

и т.д.

•  Основные координатные оси, которые определяют новую систему координат,
помечены 1, 2, 3 вместо x, y, z. В предшествующем уравнении, y - координата по
основной оси 2, z - координата по основной оси 3.

•  Матрица поворота и углы поворота - поворот относительно координатных осей до
основных осей в матричной и угловой форме. Матрица поворота вычисляется
следующим образом:

Где j - угол поворота относительно 1 оси, q - угол поворота относительно 2 оси, а y -
угол поворота относительно 3 оси.

•  радиус инерции - радиус инерции в центре тяжести относительно основных осей

•  Для сборки, краткий перечень масс-инерционных характеристик ее компонентов

Вычисление Объема Одной Стороны Модели

Тип анализа One-Sided Volume частично доступен в режиме Drawing. Вы можете
использовать тип One-Sided Volume для вычисления объема модели с одной стороны
указанной плоскости, следующим образом:

Из меню, выберите Analysis > Model Analysis. Открывается диалоговое окно Model
Analysis.

1. В списке Type, выберите One-Sided Volume. Появляется меню GET SELECT.

2. В разделе Setup, выберите Use default accuracy или введите значение для Rel
accuracy.
3. Под Datum Plane, выберите базовую плоскость.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. Система выполнит анализ. Результат появляется под Results. Вы можете также
нажать Compute для выполнения анализа.

5. Нажмите кнопку Info, чтобы отобразить результаты анализа в окне Information. Вы
можете также сохранять или редактировать анализ в этом окне.



6. Откройте часть диалогового окна Saved Analyses, нажимая на треугольнике. Вы
можете использовать:

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

В вычисленной информации, значения смещения, данные для баз, отсчитываются от
выбранной базы, а базовая плоскость, которая была выбрана, имеет рядом слово
SELECTED. Также могут использоваться угловые базы, но никаких значений размеров
смещений в результате не появляется.

Вычисление Зазора Между Двумя Объектами

Тип анализа Pairs Clearance доступен в режимах Part, Assembly и Drawing. Вы можете
использовать тип Pairs Clearance для вычисления зазора между двумя объектами. Вы
можете выбирать одну или более поверхностей с обеих сторон для анализа зазора в
парах.

Обратите внимание: Покомпонентные изображения в сборке временные и не имеют
никакого влияния на вычисление зазора.

Для отображения информации по зазору или взаимопроникновению между двумя
объектами или примитивами (любая комбинация подсборок, деталей, поверхностей,
кабелей или примитивов) в модели, из меню,

1. Выберите Analysis > Model Analysis. Открывается диалоговое окно Model Analysis.

2. В списке Type, выберите Pairs Clearance. Появляется меню GET SELECT.

3. В списках From и To, выберите Surface, Cable, Whole part, Whole subasm и Single
entity. (Для деталей, список не содержит Whole part или Whole subasm)
Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. Если требуется, под From и To выберите Exclude и Include для лоскутных
поверхностей.

5. Если Вы выбираете поверхность, выберите Whole surface или Near pick.
6. В списке Projection Reference, выберите None, Plane, Linear Entity, Coordinate
System или View Plane.
7. Выберите ссылочный элемент для проецирования, если не было выбрано None.
Доступные опции None, Plane, Linear Entity, Coordinate System и View Plane.
8. Сделайте Ваш выбор модели From и To. Вы можете выбирать одну или более
поверхностей для первого ссылочного элемента.

9. Щелкните по Compute для выполнения анализа.

10. Нажмите кнопку Info для отображения результатов анализа в окне Information. Вы
можете также сохранять или редактировать результаты анализа в этом окне.

11. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели



Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Отображение Информации по Зазору

Тип анализа Global Clearance доступен в режимах Assembly и Drawing. Вы можете
использовать Global Clearance для вычисления зазора между каждой деталью или
подсборкой модели.

Обратите внимание: Покомпонентные изображения в сборке временные и не имеют
никакого влияния на вычисление зазора.

Для отображения информации (для сборки или рисунка) относительно зазора между
каждой деталью или подсборкой модели:

1. Из меню, выберите Analysis > Model Analysis. Открывается диалоговое окно Model
Analysis.

2. В списке Type, выберите Global Clearance.
3. Под Setup, выберите Parts Only для вычисления зазора для деталей или Sub-
assemblies only для вычисления зазора для подсборок.

4. В поле Clearance, введите минимальный необходимый зазор.

5. Под Harness, выберите Exclude или  Include для исключения или включения в
компоненты жгута для вычисления.

6. Щелкните по Compute для выполнения анализа.

7. Нажмите кнопку Info для отображения результатов анализа в окне Information. Вы
можете также сохранять или редактировать результаты анализа в этом окне.

8. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Отображение Взаимопроникновений Замкнутых Объемов
Лоскутных Поверхностей

Тип анализа Volume Interference доступен в режиме Part, Assembly и Drawing. Вы
можете использовать Volume Interference для проверки, что выбранная замкнутая
лоскутная поверхность не имеет ничего, проникающего в нее.

Проверка взаимопроникновения объемов используется в ECAD для обеспечения того,
что внутренняя/наружная области не нарушены. Для отображения информации по
взаимопроникновению объемов для замкнутой лоскутной поверхности, из меню,

1. Выберите Analysis > Model Analysis, Открывается диалоговое окно Model Analysis.

2. В списке Type, выберите Volume Interference. Появляется меню GET SELECT.

3. Выберите замкнутую лоскутную поверхность в модели для анализа.



Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. Система выполнит анализ. Результат появится под Results под заголовками #, Part
Name и Status. Вы можете также щелкнуть по Compute для выполнения анализа.

5. Нажмите кнопку Info для отображения результатов анализа в окне Information. Вы
можете также сохранять или редактировать результаты анализа в этом окне.

6. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Отображение Информации по Общему
Взаимопроникновению

Тип анализа Global Interference доступен в режимах Assembly и Drawing.

Для отображения информации (в рисунке или сборке) по взаимопроникновению между
каждой деталью или подсборкой в модели:

1. Из меню выберите Analysis > Model Analysis. Открывается диалоговое окно Model
Analysis.

2. В списке Type, выберите Global Interference.
3. Под Setup, выберите Parts only для вычисления взаимопроникновения деталей или
Sub-assemblies для вычисления взаимопроникновения для подсборок.

4. Под Quilt, выберите Exclude для исключения лоскутных поверхностей из вычислений
или Include для включения лоскутных поверхностей в вычисления.

5. Под Display, выберите Exact result для получения полного и подробного расчета или
Quick check для получения вычислений на высоком уровне.

6. Щелкните по Compute для выполнения анализа. Под Results появляется информация
под Part 1, Part 2 и Volume.

7. Нажмите кнопку Info� для отображения результатов анализа в окне Information. Вы
можете также сохранять или редактировать результаты анализа в этом окне.

8. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.



Сравнение Длин Кромок

Используйте тип анализа Short Edge для вычисления длины самой короткой кромки в
выбранном компоненте, затем определите, сколько кромок в модели короче этого края,
следующим образом:

1. Из меню, выберите Analysis > Model Analysis, Открывается диалоговое окно Model
Analysis, и появляется меню GET SELECT.

2. В списке Type, выберите Short Edge.
3. В случае необходимости, выберите деталь для анализа.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. В текстовом поле Edge Length, введите максимальную длину или используйте
заданную по умолчанию длину.

5. Щелкните по Compute для выполнения анализа.

6. Нажмите кнопку Info.. для отображения результатов анализа в окне Information. Вы
можете также сохранять или редактировать результаты анализа в этом окне.

7. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Отображение Информации по Типу Кромки

Анализ Edge Type доступен в режиме Part, Assembly и Drawing. Вы можете
использовать Edge Type для определения типа геометрии, используемой для создания
выбранной кромки, следующим образом:

1. Из меню, выберите Analysis > Model Analysis. Открывается диалоговое окно Model
Analysis.

2. В списке Type, выберите Edge Type. Появляется меню GET SELECT.

3. Выберите кромку для анализа.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. Система выполнит анализ. Результат появится под Results. Вы можете также
щелкнуть по Compute для выполнения анализа.

5. Нажмите кнопку Info.. для отображения анализа в окне Information. Вы можете также
сохранять или редактировать результаты анализа в этом окне.

6. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)



Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Проверка Толщины Детали

Тип анализа Thickness доступен в режимах Part и Assembly. Вы можете использовать
Thickness для проверки минимальной и максимальной толщины детали в модели.

Для проверки, является ли толщина детали больше максимального значения и-или
меньше минимального значения и вычисления проверяемой площади, из меню:

1. Выберите Analysis > Model Analysis. Открывается диалоговое окно Model Analysis.

2. В списке Type, выберите Thickness. Появляется меню GET SELECT.

3. Выберите деталь для проверки.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. В разделе Setup Thickness Check, нажмите Planes или Slices.
a. Выберите Start Point и End Point (для проверки) в модели.

b. Чтобы установить нескольких срезов, выберите Use number of slices, и введите
число или используйте значение по умолчанию.

c. В разделе Slice Direction, выберите Plane, Curve/Edge/Axis или Coordinate System
и выберите соответствующий объект.

d. Если Вы выберете Plane, выберите плоскость в модели,или создайте ее, используя
меню SETUP PLANE.

e. Измените значения Slice Offset и Thickness, в случае необходимости.

5. Система выполнит анализ. Результат появится под Results под заголовками #, >Max,
<Min и Area. Вы можете также щелкнуть по Compute для выполнения анализа.

Когда проверка толщины закончится, поперечное сечение будет подсвечено
следующим образом:

•  Желтый - Толщина лежит в пределах между указанными максимальными и
минимальными значениями.

•  Красная граница - Толщина превышает указанное максимальное значение.

•  Синяя граница - Толщина ниже указанного минимального значения.

6. Нажмите кнопку Info для отображения результатов анализа в окне Information. Вы
можете также сохранять или редактировать результаты анализа в этом окне.

7. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать:

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа



Пример: Проверка Толщины

Проверка Толщины, посредством плоскости

Проверка Толщины, посредством срезов



Измерение Геометрии Модели

Для измерения геометрии модели, типа длины, углов и площадей, в меню Analysis,
выберите Measure.
Диалоговое окно Measure имеет следующие элементы:

Используйте Для
Тип

Укажите тип геометрии, которую Вы хотите измерить. Перечень доступных типов,
см. таблицу Geometry Types.

Определение
Кривая / кромка

Выберите тип размера (кривая / кромка или цепочка).

Выберите кромку или кривую или укажите цепочку, выбирая две кромки
поверхности или два объекта кривой.

Результаты
Compute Вычисляет размер.

Info Открывает Информационное Окно для просмотра результатов и для
использования меню File, Edit и View , чтобы сохранить результаты в
файле, редактирования файла или просмотра номеров строк.

                         Сохраненный Анализ
Открывает часть диалогового окна Saved Analyses, которое предлагает
следующие варианты:

Name - введите название анализа для сохранения

Save - сохраняет анализ под указанным именем при сохранении модели

Retrieve - выполняет выбранный анализ (выберите из сохраненных анализов)

Delete - удаляет выбранный анализ

Обратите внимание: эта опция не доступна в режиме Drawing.

Типы Геометрии
Выберите Для
Curve Length Измерите длину выбранной кромки или кривой.

Distance Измеряет расстояния относительно базового объекта. Базовый
объект - объект, по отношению к которому вы проводите
измерения. После выбора базового элемента вы можете
измерить столько элементов, сколько требуется. Система будет
рассчитывать расстояния относительно первого элемента до тех
пор, пока вы не начнете новый процесс измерения выбором
нового базового элемента.

Angle Измеряет угол между двумя примитивами. Примитивами могут
быть оси, плоские кривые или плоские нелинейные кромки.

Area Измеряет площадь любой поверхности на детали или площадь
лоскутной поверхности, или площадь выбранной поверхности.

Diameter Измеряет диаметр части любой поверхности, которая была
создана путем вращения эскизного элемента или выдавливания
дуги или круга.



Transform Генерирует файл преобразования, содержащий матрицу
значений преобразования между двумя системами координат.
Эта информация сохраняется в соответствующем формате для
создания другой системы координат посредством опций системы
координат From File Datum.

Pro/ENGINEER проводит измерения относительно базового объекта. Базовый примитив
- первый объект, который Вы выбрали. После того, как Вы выбрали базовый примитив,
Вы можете измерять сколь угодно много других элементов. Система вычисляет каждый
размер относительно первого объекта, пока вы не начнете новый процесс измерения
выбором нового базового элемента.

Обратите внимание: В режиме Assembly, все размеры рассчитываются на основе
неразнесенных видов сборки (разнесение сборки, влияет только на вид компонентов
сборки).

Измерение Длины Кривой

Для измерения длины кривой в объекте в текущем, активном окне,

1. Из меню, выберите Analysis > Measure. Открывается диалоговое окно Measure и
появляется меню GET SELECT.

2. В списке Type, выберите Curve length.

3. Под Definition, выберите Curve/Edge или Chain.

4. Выберите соответствующие кривые, кромки или цепочки.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select слева от варианта, который Вы хотите изменить.

5. Система выполнит анализ. Результат появится под Results. Вы можете также нажать
Compute для выполнения анализа.

6. Нажмите кнопку Info для отображения анализа в окне Information. В окне Information,
Вы можете также сохранять и редактировать результаты анализа.

7. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Измерение Расстояния в Объекте

Для измерения расстояние в Объекте в текущем, активном окне,

1. Из меню, выберите Analysis > Measure. Открывается диалоговое окно Measure, и
появляется меню GET SELECT.

2. В списке Type, выберите Distance.
3. Под Definition, в списках From и To, выберите из следующих объектов для
измерения расстояния:

Any Entity Любой примитив



Vertex Вершина

Point Точка

Coordinate System Система координат

Line/Axis Линия / Ось

Plane Плоскость

Curve/Edge Кривая / Кромка

Surface Поверхность

Cable Кабель

Part (for assemblies only) Деталь (только для сборок)

Subassembly (for assemblies only) Подсборка (только для сборок)

4. Опционально: Под Projection Reference, выберите None, Plane, Line/Axis или View
Plane как ссылку для измерения.

5. Выберите соответствующие примитивы в вашем Объекте (следите за сообщениями
системы). Появляющаяся красная линия показывает измеряемое расстояние.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select слева от варианта, который Вы хотите изменить.

6. Щелкните по Compute, чтобы выполнить анализ. Под Results появляются расчетное
и проецируемое расстояния (если используется).
7. Нажмите кнопку Info для отображения анализа в окне Information. В окне Information,
Вы можете также сохранять и редактировать результаты анализа.

8. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Измерения Углов в Объекте

Для измерения углов в Объекте в текущем, активном окне,

1. Из меню, выберите Analysis > Measure. Открывается диалоговое окно Measure и
появляется меню GET SELECT.

2. В списке Type, выберите Angle.
3. Под Definition, в списках First Entity и Second Entity, выберите Curve/Edge, Axis,
Plane или Coordinate System.
4. Выберите соответствующие кривые, кромки или другие части геометрии (следите за
сообщениями системы).

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select слева от варианта, который Вы хотите изменить.

5. Система выполнит анализ. Вычисление появляется под Results. Вы можете также
нажать Compute для выполнения анализа.



6. Нажмите кнопку Info для отображения анализа в окне Information. В окне Information,
Вы можете также сохранять и редактировать результаты анализа.

7. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Измерение Нарисованных Объектов в Рисунках

Для измерения нарисованных объектов в рисунках, из меню:

1. Выберите Info > Measure Draft Entities. Открывается диалоговое окно Draft Measure
и появляется меню GET SELECT.

2. В списке Type, выберите тип рисунка для измерения (Distance, Angle, Intersection
Point или Tangent Point).
3. Под From и To, выберите первый и второй измеряемые объекты.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. Если Вы выбрали Angle, Вы можете выбрать Use horizontal для вычисления угла,
вместо выбора второго объекта.

5. Вычисления появляются под Results. Результаты включают Угол, Расстояние, Точку
пересечения и точку касания.

6. Щелкните по Compute для выполнения следующего анализа и по Info для
отображения результатов в окне Information.

7. Щелкните по Close для удаления диалогового окна.

Пример: Измерение Расстояний и Углов

Измерение Минимального Расстояния между Двумя Кривыми

Измерение Минимального Расстояния между Двумя Линейными Объектами



Измерение Угла между Плоскостью и Линией

Измерение Площади Объекта

Для измерения площади объекта в текущем, активном окне,

1. Из меню, выберите Analysis > Measure. Открывается диалоговое окно Measure и
появляется меню GET SELECT.

2. В списке Type, выберите Area.
3. Для вычисления площади проецируемой поверхности от плоскости, линии или оси,
под Definition, в списке Entity, выберите Surface, Quilt или Whole Model.
Обратите внимание: Это вычисление имеет предел погрешности около 0.15 %.

4. Выберите соответствующие кривые, кромки или другие части геометрии (следите за
сообщениями системы).

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select слева от варианта, который Вы хотите изменить.

5. Под Definition, в списке Projection Direction, выберите None, Plane, Line/Axis,
Coordinate System или View. Для всех вариантов выбора, за исключением None,
появляется меню GET SELECT.

6. Выберите направление, в котором Вы хотите проецировать.

7. Система выполнит анализ. Площадь поверхности или проецируемая площадь
поверхности появляются под Results. Вы можете также нажать Compute для
выполнения анализа.



8. Нажмите кнопку Info для отображения анализа в окне Information. В окне Information,
Вы можете также сохранять и редактировать результаты анализа.

9. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Измерение Диаметра в Объекте

Для измерения диаметра в Объекте в текущем, активном окне,

1. Из меню, выберите Analysis > Measure. Открывается диалоговое окно Measure и
появляется меню GET SELECT.

2. В списке Type, выберите Diameter.
3. Выберите поверхность для измерения диаметра.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select слева от варианта, который Вы хотите изменить.

4. Под Definition, под Datum Point, выберите или отмените Use Datum Point.
Появляется меню GET SELECT.

5. Если Вы выбрали Use Datum Point, выберите точку на поверхности для
образмеривания.

6. Система выполнит анализ. Результат появится под Results. Вы можете также
нажимать Compute для выполнения анализа.

7. Нажмите кнопку Info для отображения анализа в окне Information. В окне Information,
Вы можете также сохранять и редактировать результаты анализа.

8. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Генерирация Файла Преобразования

Для генерации файла преобразования, содержащего матрицу значений
преобразования между двумя системами координат объекта в текущем, активном окне,

1. Из меню, выберите Analysis > Measure. Открывается диалоговое окно Measure, и
появляется меню GET SELECT.

2. В списке Type, выберите Transform.
3. Выберите системы координат для 1st Coordinate System и 2nd Coordinate System.



Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select слева от варианта, который Вы хотите изменить.

4. Щелкните по Compute для выполнения анализа.

5. Нажмите кнопку Info для отображения анализа в окне Information. В окне Information,
Вы можете также сохранять и редактировать результаты анализа.

6. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Анализ Кривых

Вы можете анализировать свойства кривой, используя диалоговое окно Curve Analysis.

Для вызова диалогового окна Curve Analysis, выберите Analysis > Curve Analysis.
Используйте Для

Тип
Укажите тип кривой, которую Вы хотите анализировать. Перечень доступных

типов, см. таблицу Measurement Types.

Определение
Кривизна в

Выберите, что вы хотите измерить - кривизну кривой или кромки и вектор кривой в
точке на кривой.

Выберите кромку, кривую или точку.

Система координат

Выберите ссылочную систему координат

Результаты
Compute Вычисляет размер для данного типа геометрии. Результаты

отображаются в текстовом окне Results.

Display Отображает или изменяет установки масштаба и плотности при
измерении

Info Открывает Информационное Окно для просмотра результатов и для
использования меню File, Edit и View , чтобы сохранить результаты в
файле, редактирования файла или просмотра номеров строк.

                         Сохраненный Анализ
Открывает часть диалогового окна Saved Analyses, которое предлагает

следующие варианты:

Name - введите название анализа для сохранения

Save - сохраняет анализ под указанным именем при сохранении модели

Retrieve - выполняет выбранный анализ (выберите из сохраненных анализов)



Delete - удаляет выбранный анализ

Обратите внимание: эта опция не доступна в режиме Drawing.

Выберите Для
Curvature Отображает кривизну (1/радиус) кромки или кривой в выбранной

точке

Radius Отображает радиус (1/кривизну) кромки или кривой в выбранной
точке

Tangents Отображает вектор касательной к кромке или кривой в
выбранной точке.

Также отображает размер компонентов по dx, dy, dz касательного
вектора в окне сообщений. Вы можете выбрать или создать
справочную систему координат.

Deviation Отображает отклонение от кривой или кромки для кривой или
кромки до массива базовых точек или отсканированной кривой

Dihedral Angle Отображает угол между нормалями к двум поверхностям,
которые ограничивают кромку.

Info at Point Отображает угол между нормалями к поверхности в точке,
лежащей на кромке. Результат - измеренный угол и координата Х
точки на кривой.

График Касательной к Секущей или Кривизна

Эта функция позволяет Вам делать следующее:

•  Создавать одно или более планарных сечений поверхности, лоскутной поверхности
или детали для анализа.

•  Отображать и вызывать аналитическую информацию для каждой из этих секущих
кривых.

Вы можете устанавливать множество плоскостей, которые пересекают модель и
отображать кривые пересечений. Некоторые свойства анализа типа радиуса кривизны
могут быть отображены для этих получаемых сечений. Результаты можно просмотреть
в пространстве модели или на графике.

Если Вы изменяете положение плоскости, графики обновляются.

При изменении поверхностей, кривые сечений также обновляются. Аналитическая
информация может быть сохранена, используя Save Analysis. Может быть отображена
определенная аналитическая информация, типа кривизны для каждого кривой сечения.

Отображение Кривизны Выбранной Кромки или Кривой

Для отображения кривизны (1/радиус), включая минимальное и максимальное значения
кривизны выбранной кромки или кривой на объекте:

1. Из меню, выберите Analysis > Curve Analysis. Открывается диалоговое окно Curve
Analysis, и появляется меню GET SELECT.

2. В списке Type, выберите Curvature.
3. В списке Curvature at, выберите Curve or Edge или Point on Curve or Edge.
4. Выберите кривую или кромку на Объекте для анализа.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select  для соответствующего объекта.



5. Выберите или создайте ссылочную систему координат для вывода в виде текста
радиус-векторов.

6. Система выполнит анализ. Результат появляется на модели и под Results. Вы
можете также нажать Compute для выполнения анализа.

7. Нажмите Display, чтобы установить параметры Scale и Style для отображения и
вывода. Выберите Dynamic update в диалоговом окне Curvature � Display settings,
чтобы просматривать результаты расчета по мере выбора.

8. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность результатов анализа в этой
области. Разрешающая способность относится к местам по поверхности, где будут
сделаны и отображены вычисления. Выберите Dynamic update, чтобы просматривать
результаты расчета по мере выбора.

9. Нажмите кнопку Info, чтобы отобразить результаты анализа в окне Information в виде
текста. Вы можете также сохранять или редактировать результаты анализа в этом окне.

10. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Пример: Кривизна Выбранной Кромки или Кривой на
Объекте

Этот пример показывает кривизну (1/радиус), включая минимальные и максимальные
значения кривизны, выбранной кромки или кривой на Объекте.



Анализ Радиуса или Радиусов:

1. Из меню, выберите Analysis > Curve Analysis. Открывается диалоговое окно Curve
Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Radius.
3. В списке Radius at, выберите Curve or Edge или Point on Curve or Edge.
4. Выберите кривую, кромку или точку на объекте для анализа.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select   

5. Опционально: Выберите или создайте ссылочную систему координат для вывода в
текстовом виде радиус-векторов.

6. Система выполнит анализ. Результат появится под Results в виде значений Min.
Dihedral и Max. Dihedral. Вы можете также нажать Compute для выполнения анализа.

7. Нажмите Display, чтобы установить масштаб и параметры стиля для отображения и
вывода.

8. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность анализа в этой области.
Разрешающая способность относится к местам поверхности, где будут сделаны и
отображены вычисления. Выберите Dynamic update, чтобы просматривать результаты
расчета по мере выбора.

9. Нажмите кнопку Info, чтобы отобразить результаты анализа в окне Information. Вы
можете также сохранять или редактировать результаты анализа в этом окне.

10. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Отображение Касательного Вектора к Кромке или Кривой

Для отображения (красным) касательного вектора (первая производная) к кромке или
кривой на объекте,

1. Из меню, выберите Analysis > Curve Analysis. Открывается диалоговое окно Curve
Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Tangents.
3. Выберите кривую, кромку или точку на объекте для анализа.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select для соответствующего объекта.

4. Выберите или создайте ссылочную систему координат для отображения и вывода в
текстовом виде касательных векторов.



5. Система выполнит анализ. Результат появляется в виде красных стрелок на модели
под Results. Вы можете также нажать Compute для выполнения анализа.

6. Нажмите Display, чтобы установить параметры масштаба для отображения и
вывода.

7. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность анализа в этой области.
Разрешающая способность относится к местам поверхности, где будут сделаны и
отображены вычисления. Выберите Dynamic update, чтобы просматривать результаты
расчета по мере выбора.

8. Нажмите кнопку Info, чтобы отобразить текстовые результаты анализа в окне
Information. Вы можете также сохранять или редактировать результаты анализа в этом
окне.

9. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Анализ Отклонения от Кривой

Для анализа отклонения от кривой:

1. Из меню, выберите Analysis > Curve Analysis. Открывается диалоговое окно Curve
Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Deviation.
3. Выберите кривую или кромку, отклонение от которой Вы хотите измерить.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. Под Definition, в списке To, выберите Datum Point, Scan Curve или Datum Point
Array, и выберите точку, кривую или массив, от которых будете измерять отклонение.

•  Для выбора или создания базовой точки, используйте меню GET DATUMS и его
подменю.

•  Для выбора сканированной кривой или массива базовых точек, используйте меню
GET SELECT.

5. Система выполнит анализ. Результат появится под Results в виде значений Min.
Deviation и Max. Deviation. Вы можете также нажать Compute для выполнения анализа.

6. Нажмите кнопку Info для отображения результатов анализа в окне Information. Вы
можете также сохранять или редактировать результаты анализа в этом окне.

7. Нажмите Display, чтобы установить масштаб и параметры допуска для отображения
и вывода.

8. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели



Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Вычисление Двугранного Угла для Кромки или Кривой

Для вычисления максимального угла между нормалями к двум поверхностям,
ограничивающим выбранную кромку или точку на кривой (см. следующий пример)

1. Из меню, выберите Analysis > Curve Analysis. Открывается диалоговое окно Curve
Analysis, и появляется меню GET SELECT.

2. В списке Type, выберите Dihedral Angle.
3. Под Definition, в списке Dihedral Angle at, выберите Edge или Edge Point.
4. Выберите кромку или точку на объекте для анализа.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

5. Система выполнит анализ. Результат появится под Results. Вы можете также нажать
Compute для выполнения анализа.

6. Нажмите Display, чтобы установить масштаб и параметры стиля для отображения и
вывода.

7. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность анализа в этой области.
Разрешающая способность относится к местам по поверхности, где будут сделаны и
отображены вычисления. Выберите Dynamic update, чтобы просматривать результаты
расчета по мере выбора.

8. Нажмите кнопку Info, чтобы отобразить результаты анализа в окне Information. Вы
можете также сохранять или редактировать результаты анализа в этом окне.

9. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.



Отображения Вектора, Нормального к Кромке или Кривой

Нормаль к поверхности в выбранной точке - вектор нормальной кривизны. Основные
векторы кривизны определяются следующим образом: для каждой плоскости, которая
содержат нормальный вектор, имеется кривая пересечения этой плоскости с
поверхностью. Pro/ENGINEER оценивает все кривые пересечения, чтобы определить
максимальное и минимальное значение кривизны.

Может иметься только одно значение кривизны, если она одинакова для всех
плоскостей. Значение кривизны называется основной кривизной поверхности в
указанной точке.

Кривизна может быть положительной и отрицательной. Знак отрицателен, если кривая
поворачивается в направлении в направлении от нормали. Пересечение плоскостей,
которые содержат основную кривизну с касательной плоскостью, определяет основные
направления.

Нормальные и Основные Векторы Кривизны

Для отображения (красным цветом) нормального вектора (2-ая производная) к кромке
или кривой на объекте:

1. Из меню, выберите Analysis > Curve Analysis. Открывается диалоговое окно Curve
Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Info at Point.
3. Выберите точку на кривой или кромке объекта для анализа.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. Выберите или создайте ссылочную систему координат для вывода вектора кривизны
и касательной.

5. Система выполнит анализ. Результат появится под Results. Вы можете также нажать
Compute для выполнения анализа.

6. Нажмите Display, чтобы установить параметр Scale для отображения и вывода.

7. Нажмите кнопку Info, чтобы отобразить результаты в окне Information. Пример:



Вы можете сохранять или редактировать результаты анализа в этом окне.

Кроме того, в выбранной точке на поверхности, система отображает вектор, единичный
вектор нормали и два касательных вектора, чьи значения масштабируются до
абсолютных значений основной кривизны поверхности в выбранной точке. Векторы
указывают направления экстремума нормальной кривизны и являются
ортогональными.

На плоскостях, сферах и другие поверхностях, чья кривизна одинакова во всех
направлениях, система, выбирает векторы произвольно. Вектор, отображаемый
зеленым цветом показывает нормальную кривизну (единичный вектор нормали). Цвет
основного вектора кривизны зависит от значения кривизны и знака, следующим
образом:

•  Синий - Наибольшая отрицательная кривизна

•  Голубой - Наименьшая отрицательная кривизна

•  Красный - Наибольшая положительная кривизна

•  Оранжевый - Наименьшая положительная кривизна

8. Откройте часть диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать:

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

Обратите внимание: эта опция не доступна в режиме Drawing.

Анализ Поверхностей

В режимах Part и Assembly, Вы можете анализировать свойства поверхностей,
используя диалоговое окно Surface Analysis. Анализ поверхностей назначает номера
цветов в диапазонах отображения кривизны. Значения, близкие к красному концу
спектра указывают максимальную кривизну или уклон. Минимальные значения
кривизны лежат ближе к синему концу спектра.

Чтобы открыть диалоговое окно Surface Analysis, нажмите Analysis > Surface
Analysis.



ПУНКТ ФУНКЦИЯ

Тип
Указывает тип выполняемого анализа. Опции следующие:

Gauss Curvature - произведение наименьшей и наибольшей
нормальной кривизны к каждой точке поверхности.
При этом генерируется цвет, показывающий
положительные, отрицательный и нулевые значения
для цилиндров и плоскостей

Section Curvature - отображает в цвете кривизну параллельных сечений,
параллельных справочной плоскости детали.

Slope - отображает в цвете уклон поверхности относительно
справочной плоскости детали.

Porcupine - отображает изолинии и линейные сегменты,
нормальные к изолиниям детали.

Normals - отображает векторы, нормальные к выбранной
поверхности.

Deviation - рассчитывает отклонение, измеренное по нормали
от поверхности к точке указанной кривой или массиву
базовых точек

Reflection Curves - отображает кривые, которые представляют
отображение от линейных источников света на
поверхности, при взгляде в указанном направлении.

Highlight Curves - подсвечивает кривые на поверхности.

Info at Point - рассчитывает нормальные вектора кривизны в
указанной точке поверхности.

Radius - рассчитывает наименьший положительный и
отрицательный радиус для поверхности детали или
сборки.

Draft Check - анализирует конструкцию детали на предмет
необходимости уклона детали, используемой в
форме.

Offset Mesh - предварительный просмотр сети, эквидистантной
поверхности или лоскутной поверхности

Определение
Поверхность

Выберите тип поверхности (единичная поверхность, лоскутная
поверхность, или все поверхности модели) для которых вы хотите
выполнять анализ поверхности. Если вы выберете деталь, все
твердотельные поверхности детали будут проанализированы.

Выберите имя детали, если деталь выбирается в выпадающем списке
поверхностей или выберите поверхность или лоскутную поверхность.

Результаты
Compute Вычисляет размер для данного типа анализа. Результаты отображаются

в текстовом окне Results.

Info Открывает Информационное Окно для просмотра результатов и для
использования меню File, Edit и View , чтобы сохранить результаты в
файле, редактирования файла или просмотра номеров строк.



                         Сохраненный Анализ
Открывает часть диалогового окна Saved Analyses, которое предлагает
следующие варианты:

Name - введите название анализа для сохранения

Save - сохраняет анализ под указанным именем при сохранении модели

Retrieve - выполняет выбранный анализ (выберите из сохраненных анализов)

Delete - удаляет выбранный анализ

Установка Данных Отображения

Используйте диалоговое окно Setup, чтобы установить плотность, масштаб и другие
параметры анализа.

Отображение Анализа Гауссовой Кривизны Поверхности

Для отображения анализа гауссовой кривизны поверхности для детали:

1. Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно
Surface Analysis открывается и появляется меню GET SELECT.

2. В списке Type, выберите Gauss Curvature.
3. Под Definition, в списке Surface, выберите Surface, Quilt, Part и All Surfaces и
выберите объект для анализа.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. Система выполнит анализ. Вычисление появляется под Results в виде
значений Min. gauss и Max. gauss. Вы можете также нажать Compute для выполнения
анализа.

5. Нажмите Display, чтобы открыть диалоговое окно, которое позволит Вам
корректировать параметры настройки экрана. Выберите Dynamic update в диалоговом
окне Gauss Curvature � Display settings, чтобы просматривать результаты расчета по
мере выбора.

6. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность анализа в этой области.
Разрешающая способность относится к местам по поверхности, где будут сделаны и
отображены вычисления. Выберите Dynamic update, чтобы просматривать результаты
расчета по мере выбора.

7. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

8. Щелкните по Close для закрытия диалогового окна.



Пример: Гауссова Кривизна

Анализ поверхностей назначает номера цветов в диапазонах отображения кривизны.
Значения, близкие к красному концу спектра указывают максимальную кривизну или
уклон. Минимальные значения кривизны лежат ближе к синему концу спектра.

Гауссова кривизна - произведение наименьшей и наибольшей нормальной кривизны к
каждой точке поверхности. При этом генерируется цвет, показывающий
положительные, отрицательный и нулевые значения для цилиндров и плоскостей.
Значения, лежащие ближе к синему концу спектра обозначают наименьшие значения
кривизны.

Отображение Кривизны Сечений

Для отображения в цвете, кривизны поперечных сечений параллельных ссылочной
плоскости детали:

Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно Surface
Analysis и появляется меню GET SELECT.

1. В списке Type, выберите Section Curvature.
2. Под Definition, в списке Surface, выберите Surface, Quilt, Part и All Surfaces и
выберите объект для анализа.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

3. Выберите ссылочную плоскость.



4. Система выполнит анализ. Результат появляется на модели и под Results в виде
Min. sect. curvature и Max. sect. curvature.. Вы можете также нажать Compute для
выполнения анализа.

5. Нажмите Display для отображения диалогового окна, которое позволит Вам
корректировать параметры настройки экрана. Выберите Dynamic update в В
диалоговом окне Section Curvature � Display settings, чтобы просматривать
результаты расчета по мере выбора.

6. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность анализа в этой области.
Разрешающая способность относится к местам по поверхности, где будут сделаны и
отображены вычисления. Выберите Dynamic update, чтобы просматривать результаты
расчета по мере выбора.

7. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать:

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

8. Щелкните по Close для закрытия диалогового окна.



Пример: Отображение Кривизны с Назначенными для
Значений Цветами

Анализ поверхностей назначает номера цветов в диапазонах отображения кривизны.
Значения, близкие к красному концу спектра указывают максимальную кривизну или
уклон. Минимальные значения кривизны лежат ближе к синему концу спектра.



Отображение Уклона Поверхности

Для отображения в цвете, уклона поверхности относительно ссылочной плоскости на
детали:

1. Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно
Surface Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Slope.
3. Под Definition, в списке Surface, выберите Surface, Quilt, Part и All Surfaces и
выберите объект для анализа.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. В списке Reference Direction, выберите Plane, Coordinate System или Curve, Edge
или Axis.
5. Если требуется, нажмите Flip Direction для изменения направления расчета уклона.

6. Система выполнит анализ. Результат появится под Results. Вы можете также нажать
Compute для выполнения анализа.

7. Нажмите Display для отображения диалогового окна, которое позволит Вам
корректировать параметры настройки экрана. Выберите Dynamic update в диалоговом
окне Slope � Display settings, чтобы просматривать результаты расчета по мере
выбора.

8. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность анализа в этой области.
Разрешающая способность относится к местам по поверхности, где будут сделаны и
отображены вычисления. Выберите Dynamic update, чтобы просматривать результаты
расчета по мере выбора.

9. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать:

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

10. Щелкните по Close для закрытия диалогового окна.

Пример: Уклон Поверхности Относительно Ссылочной
Плоскости

Анализ поверхностей назначает номера цветов в диапазонах отображения кривизны.
Значения, близкие к красному концу спектра указывают максимальную кривизну или
уклон. Минимальные значения кривизны лежат ближе к синему концу спектра.



Отображение Изолиний и Линейных Сегментов
Нормальных к Изолиниям Детали

Для отображение изолиний и линейных сегментов нормальных к изолиниям детали:

1. Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно
Surface Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Porcupine.
3. Выберите поверхность для анализа.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. Под Curve Spacing, выберите Uniform или Customize.
5. Если требуется, скорректируйте значения для 1-ого и 2-ого направлений.

6. Щелкните по Compute для выполнения анализа. На модели появятся изолинии и
линейные сегменты.

7. Нажмите Display для отображения диалогового окна, которое позволит Вам
скорректировать параметры настройки экрана. Выберите Dynamic update в



диалоговом окне Porcupine � Display settings, чтобы просматривать результаты
расчета по мере выбора.

8. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность и интервал анализа в этой
области. Разрешающая способность относится к местам по поверхности, где будут
сделаны и отображены вычисления. Выберите Dynamic update, чтобы просматривать
результаты расчета по мере выбора.

9. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

10. Щелкните по Close для закрытия диалогового окна.

Пример: Изолинии и Линейные Сегменты, Нормальные к
Изолиниям Детали

Это изображение было создано, используя игольчатый анализ поверхности для
отображения изолиний поверхности и их нормалей.

Отображение Векторов, Нормальных к Поверхности

Для отображения векторов, которые являются нормальными к выбранной поверхности:

1. Из меню, выберите Analysis > Surface Analysis . В списке Type выберите Normals.
2. Выберите поверхность для отображения векторов.



Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

3. Выберите или создайте ссылочную систему координат. На модели отобразятся
векторы. (Нормальные векторы зеленого цвета и точки, вокруг выбранной
поверхности.)

4. Щелкните по Compute, чтобы выполнить следующий анализ.

5. Нажмите Display для отображения диалогового окна, которое позволит Вам
корректировать параметры настройки экрана.

6. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность и интервал анализа в этой
области. Разрешающая способность относится к местам по поверхности, где будут
сделаны и отображены вычисления. Выберите Dynamic update, чтобы просматривать
результаты расчета по мере выбора.

7. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать:

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

8. Щелкните по Close для закрытия диалогового окна.

Вычисления Отклонения Поверхности

Для вычисления отклонения, измеренного по нормали от поверхности до точек
указанной кривой или массива базовых точек:

1. Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно
Surface Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Deviation.
3. В списке From Surface, выберите Surface или Datum Plane и, затем, выберите на
детали объект, по отношению к которому Вы хотите измерить отклонение.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. В списке To, выберите Datum Point, Datum Curve, Datum Point Array, Scan Curve,
или Scan Curve Set для измерения от выбранной поверхности или плоскости и, затем,
укажите объект, который Вы выбрали.

5. Система выполнит анализ. Результат появится под Results. Вы можете также нажать
Compute для выполнения анализа.

6. Нажмите Display для отображения диалогового окна, которое позволит Вам
корректировать параметры настройки экрана.

7. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)



Delete - для удаления выбранного анализа

8. Щелкните по Close для закрытия диалогового окна.

Отображение Кривых Отражения

Для отображения, на детали, кривых отражения, которые представляют отображение
от линейных источников света на поверхности, при взгляде в указанном направлении:

1. Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно
Surface Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Reflection Curves.
3. В списке Surface, выберите Surface, Quilt, Part или All Surfaces и, затем, выберите
объект на модели.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. В списке Direction, выберите Plane, Coordinate System или Curve, Edge или Axis
(для Coordinate System, также выберите ось X, Y или Z) и, затем, выберите объект на
модели.

5. Щелкните по Flip Direction для изменения направления, обозначенного стрелкой на
модели.

6. В разделе Light Source Plane, щелкните по и выберите плоскость
источника освещения.

7. В разделе Light Source Axis, щелкните по и выберите ось источника
освещения.

8. В разделе Light Source Options, выберите:

•  Pick on surface - для указания источника освещения от точки поверхности. Затем,
щелкните по и выберите точку.

•  Default - для указания источника освещения поперек общей видимой поверхности.
Затем редактируйте # of sources, как требуется.

•  Range - для указания источника освещения от направления просмотра. Затем
укажите Distance и требуемый диапазон.

9. на модели отображаются кривые отражения. Нажмите Compute, чтобы выполнить
следующий анализ.

10. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать:

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

11. Щелкните по Close для закрытия диалогового окна.



Пример: Кривые Отражения

Отображение Подсветки Кривой

Для отображения подсветки кривой на детали:

1. Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно
Surface Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Highlight Curves.
3. В списке Surface, выберите Surface, Quilt, Part или All Surfaces и, затем, выберите
объект на модели.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. В списке Reference Direction, выберите Plane, Coordinate System или Curve, Edge
или Axis (для Coordinate System, также выберите ось X, Y или Z) и, затем, выберите
объект на модели.

5. Щелкните по Flip Direction для изменения направления, обозначенного стрелкой на
модели.

6. В разделе Slope Angle, выберите Near pick (и выберите точку на модели), Single
value (и набор значений Degrees) или Increment (и набор значений Degrees).

7. Подсветка кривой отобразится на модели. Нажмите Compute, чтобы выполнить
следующий анализ.

8. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать:

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)



Delete - для удаления выбранного анализа

9. Щелкните по Close для закрытия диалогового окна.

Оценка Вектора Нормальной Кривизны в Указанном Точке
на Поверхности

Для оценки вектора нормальной кривизны в указанной точке на поверхности:

1. Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно
Surface Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Info at Point.
3. В разделе Point, нажмите и выберите точку на модели.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. В разделе Coordinate System, нажмите и создайте, или выберите
ссылочную систему координат на модели.

5. Система выполнит анализ. Результат появится под Results. Вы можете также нажать
Compute для выполнения анализа.

6. Нажмите кнопку Info, чтобы отобразить результаты анализа в окне Information.

7. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

8. Щелкните по Close для закрытия диалогового окна.

Вычисление Наименьших Положительный и
Отрицательный Радиусов Поверхности

Для вычисления наименьших положительных и отрицательных радиусов поверхности
детали или сборки:

1. Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно
Surface Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Radius.
3. В списке Surface, выберите Surface, Quilt, Part или All Surfaces и, затем, выберите
объект на модели.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. Под Radius Type, выберите, хотите ли Вы вычислять минимальный внутренний
радиус, минимальный внешний радиус, или оба радиуса.



5. Система выполнит анализ. Результат появится под Results. Вы можете также нажать
Compute для выполнения анализа.

6. Нажмите Display, чтобы открыть диалоговое окно, которое позволит Вам
корректировать параметры настройки экрана.

7. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

8. Щелкните по Close для закрытия диалогового окна.

Выполнение Проверки Уклона на Детали

Для анализа детали на предмет необходимости введения уклона в деталь, которую
нужно использовать в форме:

1. Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно
Surface Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Draft Check.
3. В списке Surface, выберите Surface, Quilt, Part или All Surfaces и, затем, выберите
объект на модели.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. В списке Pull Direction, выберите Plane, Coordinate System или Curve, Edge или
Axis и, затем, выберите объект на модели.

5. Щелкните по Flip Direction для изменения направления, обозначенного стрелкой на
модели.

6. Под Angle Options, выберите One direction или Both directions для проверки, и
укажите значение для Draft angle.
Система выполнит анализ. Вы можете также нажать Compute для выполнения
анализа. На модели отобразятся цвета, которые символизируют уклоны. Диаграмма
показывает диапазоны цветов и какие углы (от минимума до максимума) обозначаются
каждым цветом.

7. Нажмите Display для отображения диалогового окна, которое позволит Вам
корректировать параметры настройки экрана. Выберите Dynamic update в диалоговом
окне Draft Check � Display settings, чтобы просматривать результаты расчета по мере
выбора.

8. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность анализа в этой области.
Разрешающая способность относится к местам по поверхности, где будут сделаны и
отображены вычисления. Выберите Dynamic update, чтобы просматривать результаты
расчета по мере выбора.

9. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели



Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

10. Щелкните по Close для закрытия диалогового окна.

Предварительный просмотр Эквидистантной Сети

Для предварительного просмотра сети, которая смещена от поверхности или лоскутной
поверхности:

1. Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно
Surface Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Offset Mesh.
3. В списке Surface, выберите Surface, Quilt, Part или All Surfaces и, затем, выберите
объект на модели.

Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. Введите значение в текстовом поле Offset Distance или используйте нулевое
значение по умолчанию.

5. На модели появляется сеть. Нажмите Compute, чтобы выполнить следующий
анализ.

6. Нажмите Display, чтобы открыть диалоговое окно, которое позволит Вам
корректировать установку Density.

7. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность анализа в этой области.
Разрешающая способность относится к местам по поверхности, где будут сделаны и
отображены вычисления. Выберите Dynamic update, чтобы просматривать результаты
расчета по мере выбора.

8. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

9. Щелкните по Close для закрытия диалогового окна.

Отображение Кривых Пересечений для Поперечных
Сечений

Для отображения касательности и кривизны для кривых пересечений на указанной
поверхности:

1. Из меню, выберите Analysis > Surface Analysis. Открывается диалоговое окно
Surface Analysis и появляется меню GET SELECT.

2. В списке Type, выберите Cross Sections.
3. Под Definition, в списке Surface, выберите Surface, Quilt, Part или All Surfaces и
выберите объект для анализа.



Обратите внимание: Если Вы хотите восстановить изображение меню GET SELECT,
нажмите кнопку Select

4. В списке Cross Section Planes, выберите одно из следующего:

•  Direction for a set - позволяет Вам выбирать начальный ссылочный элемент и
генерировать набор поперечных сечений из этого ссылочного элемента.

•  List of Plane - позволяет Вам выбирать или создавать набор плоскостей для
анализа.

5. (Если выбрано Direction for a set) В списке Reference Direction, выберите Plane,
Coordinate System или Curve, Edge или Axis.
6. (Если выбрано Direction for a set) Если требуется, нажмите Flip Direction для
изменения направления вычисления.

7. (Если выбрано Direction for a set) Под Plane Set Options, выберите одно из
следующего:

•  Single Section - Генерирует одну дополнительный плоскость для поперечного
сечения. Выберите или введите значение Offset для расстояния между
плоскостями.

•  Multiple Sections - Генерирует набор дополнительных плоскостей для поперечных
сечений. Выберите или введите значение Offset (для расстояния от ссылочного
направления) и значение Spacing (для расстояния между плоскостями). Введите
число плоскостей для положительного и для отрицательного направления.

8. Из списка Display of, выберите одно из следующего:

•  None - ничего не отображать, кроме плоскостей поперечного сечения.

•  Curvature - отображается кривизна поперечных сечений.

•  Radius of curvature - отображаются радиусы поперечных сечений.

•  Tangents - отображаются кривые к кривым сечений.

9. Система выполнит анализ. Результат появится под Results. Вы можете также нажать
Compute для выполнения анализа.

10. Нажмите Display для отображения диалогового окна, которое позволит Вам
корректировать параметры настройки экрана. Выберите Dynamic update в диалоговом
окне Cross Sections � Display settings, чтобы просматривать результаты расчета по
мере выбора.

11. Откройте область Computation Settings диалогового окна, нажимая на треугольник.
Вы можете корректировать разрешающую способность анализа в этой области.
Разрешающая способность относится к местам по поверхности, где будут сделаны и
отображены вычисления. Выберите Dynamic update, чтобы просматривать результаты
расчета по мере выбора.

12. Откройте область диалогового окна Saved Analyses, нажимая на треугольник. Вы
можете использовать:

Name - для ввода названия анализа для сохранения

Save - для сохранения анализ под указанным именем при сохранении модели

Retrieve - для выполнения выбранного анализа (выберите из сохраненных анализов)

Delete - для удаления выбранного анализа

13. Щелкните по Close для закрытия диалогового окна.



Отображение Ориентации по Умолчанию

Модель отображается в заданной по умолчанию ориентации вида, когда она создается
первый раз, а вызываемая модель вызывается в ориентации, в которой она была
сохранена.

Для отображения заданной по умолчанию ориентации вида, из меню:

� Выберите View > Default
 ИЛИ

� Используйте горячие клавиши: <Alt> + V, затем D
ИЛИ

<Ctrl> +D
Примечания:
Вы создаете ориентацию по умолчанию при создании объекта. Вы можете изменять
или устанавливать эту ориентацию в диалоговом окне Orientation.

Вид по умолчанию может быть установлен в изометрический, который всегда
вызывается триметрическим, или в пользовательский в диалоговом окне Orientation
или опциями ориентации файла конфигурации. Вы можете восстанавливать вид по
умолчанию в любое время.

Вы можете создавать покомпонентные изображения сборок. Покомпонентное
изображение показывает каждый компонент модели, отделенный от других
компонентов.

Вы можете использовать покомпонентное изображение, чтобы показать выравнивание
компонентов в сборке.

Возвращение к Предварительно Отображенной
Ориентации

В дополнение к виду по умолчанию, Вы можете создавать пользовательские виды.
Например, Вы можете создать вид сверху вашей модели с именем Top или вид модели
спереди с именем Front. Вы можете восстановить ранее отображаемый вид в любое
время.

Чтобы использовать эту функцию, используйте один из следующих методов:

•  На инструментальной панели, нажмите (Используйте Customize Screen

меню Utilities для размещения кнопки на инструментальной панели)

ИЛИ

•  Из меню, выберите View > Previous.
ИЛИ

•  Используйте горячие клавиши: <Alt> + V, затем V

Тонирование Вида Модели

Вы можете отображать модель в виде затененного изображения без воздействия на
сохраненный вид модели. Вы можете использовать тонированную модель для
просмотра контуров поверхности или печати копии модели.



Тонирование удаляется при перерисовке вида. Это может также быть установлено,
используя опции отображения файла конфигурации. Для тонирования текущего вида
модели:

•  Выберите View > Shade
ИЛИ

•  Щелкните по кнопке Shade на инструментальной панели Pro/ENGINEER.

(Используйте Customize Screen меню Utilities для размещения кнопки на
инструментальной панели)

ИЛИ

•  Используйте горячие клавиши: <Alt> + V, затем S.

Для тонирования вида модели, чтобы он оставался затененным в процессе
переориентации, используйте кнопку Shading ( ).

Разнесение и Сочленение Сборочного Вида

Вы можете создавать покомпонентные изображения сборок. Покомпонентное
изображение показывает каждый компонент модели, отделенный от других
компонентов. Вы можете использовать покомпонентное изображение, чтобы показать
соединение компонентов в сборке.

Для разнесения вида модели сборки, используйте один из следующих методов:

•  В  инструментальной панели, нажмите кнопку.

(Используйте Customize
Screen меню Utilities для размещения кнопки на инструментальной панели)

•  Из меню, выберите, View > Explode.
Обратите внимание: Для возврата в неразнесенное состояние, выберите Unexplode
из меню View.

Перерисовка Окна

Вы можете перерисовать вид для удаления всей временно отображаемой информации.
Перерисовка обновляет экран, но не регенерирует модель.

Для использования этой функции, из меню:

•  Выберите View > Repaint
ИЛИ

•  Нажмите кнопку REPAINT ( ) на инструментальной панели PRO/ENGINEER ИЛИ

•  Используйте горячие клавиши: <Alt> + V и при появлении меню
VIEW, нажмите R на клавиатуре для Repaint

ИЛИ

Нажмите <Ctrl> + R



Уточнение Положения Модели
При изменении ориентации модели, Вам может потребоваться изменить масштаб
отображения модели на экране, чтобы видеть всю модель. При этом модель займет 80
процентов экрана. Такой режим может также быть установлен опцией
fit_object_in_window файла конфигурации.

Для использования этой функции:

•  Выберите View > Refit
ИЛИ

•  Нажмите кнопку REFIT на инструментальной панели PRO/ENGINEER

ИЛИ

•  Используйте горячие клавиши: <Alt> + V, затем F

Обновление Рисунка Геометрии Модели

Вы можете обновлять рисунок геометрии модели регенерацией вида. Используйте эту
функцию при выключенном автоматическом обновлении геометрии, которые
происходят при изменении модели и переходе к другому окну, где она также
отображена.

Например, Вы изменяете деталь и хотите обновить рисунок для отображения
изменений. Этот режим можно также установить, используя опцию auto_regen_views
файла конфигурации.

Для восстановления вида:

1. В главном меню, выберите, View > Regenerate View (только в режиме Drawing)

2. Выберите:

•  Pick View - выберите вид для регенерации.

•  Current Sheet - регенерация текущего листа.

•  All Sheets - регенерация всех листов.

Использование ODUI для Разворачивания Утилит или
Отображения Дерева и Элементов

ODUI (Управляемый Пользователем Объектный Интерфейс) позволяет Вам показывать
или скрывать дерево элементов. Вы можете сворачивать и разворачивать утилиты
структуры дерева и страницы элементов. Эта возможность может использоваться
приложением, когда диалог ODUI находится на экране.

Вы можете сворачивать страницу, если требуется, когда прикладной элемент
активизирован. Элемент помещается на страницу только, когда она становится
доступной.

Диалоговое Окна Ориентации

Модель появляется с ориентацией вида по умолчанию в процессе создания и в любой
момент, когда она затем вызывается. Вы можете изменять заданную по умолчанию



ориентацию вашей модели или создавать новые ориентации, используя диалоговое
окно Orientation.

Для открытия диалогового окна Orientation:

Выберите View > Spin/Pan/Zoom (или <Alt> + V, затем Z). Появляется диалоговое окно
Orientation с выбранным типом Orient by Reference.

ИЛИ

Выберите View > Orientation (или <Alt> + V, затем О). Появляется диалоговое окно
Orientation с выбранным типом Orient by Reference.

ИЛИ

Щелкните по кнопке Orient ( ) на инструментальной панели Pro/ENGINEER

(или <Alt> + V, затем О). Открывается диалоговое окно с выбранным типом Orient by
Reference.

Диалоговое окно Orientation имеет следующие типы:

•  Angles (Только рисунок)

•  Dynamic Orient (Динамическая Ориентация)

•  Reference (Ссылочный)

•  Preferences (Предпочтительный)

Ориентация Вида

Для создания вида модели спереди, сзади, сверху, снизу, слева, справа, в
горизонтальной или вертикальной ориентации:

1. В главном меню, выберите View > Orientation или щелкните по пиктограмме
на инструментальной панели.

Открывается диалоговое окно Orientation с набором Type для Orient by reference.
Кнопка Select выбирается автоматически, открывается меню GET SELECT.

Кнопка Select, остается выбранной до выбора ссылки.

2. Опционально: По умолчанию, меню GET SELECT ориентирует передний плоскость.
Для изменения значения по умолчанию, нажмите, Options > Reference 1. Выберите из
следующего:

•  Front

•  Back

•  Top

•  Bottom

•  Left

•  Right

•  Horizontal Axis

•  Vertical Axis
3. Выберите плоскость или ось, используемую в качестве первой ссылки.

По завершении выбора, имя ссылки появляется в поле ссылки, например, DTM9:F28.

Для горизонтальных и вертикальных осей, вид сразу изменяется на выбранный.



4. Если горизонтальная или вертикальная ось не указаны в Reference 1, повторите
шаги 2 и 3 для Reference 2. По завершении  выбора, вид изменяется на указанный.

5. Для присвоения имени, установки, сохранения или удаления вида, нажмите
треугольник со стрелкой влево в разделе Saved Views и используйте любое из
следующего:

•  Save - укажите имя текущего вида в текстовом поле Name и нажмите Save для
сохранения текущего вида.

•  Set - Выберите имя из списка и нажмите Set для отображения выбранного вида.

•  Delete - выберите имя из списка и нажмите Delete для удаления выбранного вида.

6. Нажмите OK, чтобы принять изменения ориентации и закрыть диалоговое окно,
Cancel, чтобы прервать изменения ориентации и закрыть диалоговое окно или Undo,
чтобы отменить ваши изменения ориентации и начать сначала.

Обратите внимание: Вы можете также вручную переопределить ссылки, щелкая по
клавише любой ссылки.

Панорамирование и Зумирование Рисунков

Для панорамирования рисунка или изменения масштаба его отображения в указанной
части рисунка:

1. В главном меню, выберите View > Pan/Zoom. Открывается диалоговое окно
Pan/Zoom.

2. Под Pan, перемещайте бегунки для изменения горизонтального или вертикального
вида относительно экрана.

3. Под Zoom, перемещайте бегунки для увеличения или уменьшения рисунка на
экране.

4. Нажмите Refit для установки изображения рисунка таким образом, чтобы он был
полностью видим на экране.

5. Нажмите Center для выбора нового центра экрана. Рисунок отобразится
относительно нового центра экрана.

Вращение, Панорамирование и Зумирование с Мышью

Удерживая клавишу <Ctrl> и используйте

•  левую кнопку мыши для изменения масштаба изображения,

•  среднюю кнопку мыши для вращения, и

•  правую кнопку мыши для панорамирования.

Примечания:
Вы должны начинать операцию с перемещения курсора внутрь активной области.

Вы можете отпустить клавишу <Ctrl> и продолжать выполнять эти операции, пока
соответствующая кнопка мыши остается нажатой.

По умолчанию, на модели всегда присутствует символ Центра Вращения. Этот режим
устанавливается, используя опцию spin_center_display файла конфигурации. Символ
подобен символу Системы координат за исключением:

•  три оси центра вращения имеют, по умолчанию, три различных цвета - ось X -
красная, ось Y - зеленая и ось Z синяя (голубая), а оси системы координат - желтые.



•  маленький твердотельный шар позиционируется в подсказке каждой оси центра
вращения.

По мере вращения модели, центр вращения поворачивается синхронно с движением
мыши. Кроме того, шары на концах осей становятся больше, по мере перемещения к
наблюдателю (от экрана) и меньшими, по мере удаления (в экран). Вы можете
определять относительную ориентацию модели в любой момент, проверяя оси центра
вращения.

Для изменения масштаба изображения появляется лупа. Чтобы изменить масштаб
изображения окном, нажмите левую кнопку мыши один раз при нажатой <Ctrl> и
отпустите, затем переместите мышь, описывая окно.

Изменение Угла Вида

Когда Вы добавляете в рисунок новый вид, появляется диалоговое окно Orientation.
Для изменения углов в видах рисунка относительно нормальной, горизонтальной,
вертикальной или указанной кромки или оси:

1. Выберите Angles из раскрывающегося списка Type. Автоматически выбирается
кнопка Select, открывая меню GET SELECT. Кнопка Select остается выбранные до
выбора ссылки.

2. Под Options, нажмите Add для добавления ссылки ориентации или Delete для
удаления выбранной ссылки ориентации.

3. Под Reference, выберите тип ссылки, которую Вы хотите определить (Normal,
Vertical, Horizontal или Edge/Axis).

4. Используя меню GET SELECT, выберите кромку или ось, которую нужно
использовать в качестве указанной ссылки.

5. Под Angles, укажите величину угла для смещения ориентации.

6. Щелкните по Apply для отображения модели в ее заданном по умолчанию виде.

7. Для присвоения имени, установки, сохранения или удаления вида, нажмите
треугольник со стрелкой влево в разделе Saved Views и используйте любое из
следующего:

•  Save - укажите имя текущего вида в текстовом поле Name и нажмите Save для
сохранения текущего вида.

•  Set - Выберите имя из списка и нажмите Set для отображения выбранного вида.

•  Delete - выберите имя из списка и нажмите Delete для удаления выбранного вида.

8. Нажмите OK, чтобы принять изменения ориентации и закрыть диалоговое окно,
Cancel, чтобы прервать изменения ориентации и закрыть диалоговое окно или Undo,
чтобы отменить ваши изменения ориентации и начать сначала.

Изменение Положения или Размера Вида Модели

Для настройки угла вращения, размера или центрирования объекта в активном окне:

1. В области главного меню, выберите View > Spin, Pan, Zoom. Открывается
диалоговое окно Orientation, где опция Type установлена в Dynamic Orient.
2. Под Options > Pan, для перемещения объектов в окне горизонтально или
вертикально, настройте бегунки, введите значения или нажмите стрелки "вверх" или
"вниз".



3. Под Options > Zoom, для увеличения или уменьшения объекта в окне, настройте
горизонтальные или вертикальные бегунки, введите значения или нажмите стрелки
"вверх" или "вниз".

4. Нажмите Refit для установки изображения рисунка таким образом, чтобы он был
полностью видим на экране.

5. Нажмите Center для выбора нового центра экрана.

6. Под Spin:

•  Щелкните по кнопке Spin Center ( )  для поворота объекта вокруг центра
вращения:

•  Перемещайте бегунки Х, ( ), Y ( )

или Z ( ), введите значение, или щелчками по стрелкам

"вверх" или "вниз", скорректируйте поворот вокруг осей X, Y, или Z.

•  Нажмите кнопку Screen Center ( ), для вращения объекта вокруг

горизонтальной, вертикальной или нормальной к экрану оси

•  Перемещайте бегунки H ( ), V ( )  или

С ( ), введите значение или нажимайте стрелки "вверх" или
"вниз" для корректировки поворота вокруг горизонтальной

(X), вертикальной (Y) или центральной (Z) оси.

7. Нажмите Dynamic update для динамического изменения вида по мере внесения
изменений.

8. Для присвоения имени, установки, сохранения или удаления вида, нажмите
треугольник со стрелкой влево в разделе Saved Views и используйте любое из
следующего:

•  Save - укажите имя текущего вида в текстовом поле Name и нажмите Save для
сохранения текущего вида.

•  Set - Выберите имя из списка и нажмите Set для отображения выбранного вида.

•  Delete - выберите имя из списка и нажмите Delete для удаления выбранного вида.

9. Нажмите OK, чтобы принять изменения ориентации и закрыть диалоговое окно,
Cancel, чтобы прервать изменения ориентации и закрыть диалоговое окно или Undo,
чтобы отменить ваши изменения ориентации и начать сначала.

Ярлыки: На инструментальной панели, нажмите:

 Для увеличения масштаба отображения

 Для уменьшения масштаба отображения

 Для отображения объекта по его границам

 Для поворота объекта вокруг центра вращения



Пример: Ориентация по Ссылке

Вы можете ориентировать вашу модель, выбирая различные поверхности и
использовать их в качестве ссылки для ориентации. Эти ссылки могут являться
Передними или Задними (параллельно экрану), Верхними или Нижними
(перпендикулярно экрану, лицом вверх или вниз), и Левыми или Правыми
(перпендикулярно экрану и лицом вправо или влево). Модель автоматически изменяет
ориентацию после выбора второй поверхности.

Если две различные параллельные поверхности выбраны до выбора
перпендикулярной поверхности, второй выбор отменяет первый. Вы можете также
ориентировать вашу модель, выбирая отдельно горизонтальную или вертикальную ось
ориентации.

Установка Центра Вращения Объекта

Заданная по умолчанию ориентация объекта установлена в триметрическую (trimetric
примечание переводчика), но может изменяться на изометрическую или определяемую
пользователем. Центр вращения модели установлен, по умолчанию, в центре модели,
но может назначаться любой точке на экране.

Для установки центра вращения объекта:

1. Из меню, выберите View > Orientation.
2. В списке Type в диалоговом окне Orientation, выберите Preferences.
3. В опциях Spin Center в разделе Options, выберите одно из следующего:

•  Model center

•  Screen center

•  Point или vertex - Также выбирает точку или вершину на Объекте

•  Edge или axis - Также выбирает кромку или ось на Объекте

•  Coordinate system - Также выбирает систему координат на Объекте

4. Под View Origin, используйте Default или Custom, чтобы выбрать значение по
умолчанию или пользовательские виды рисунка и используйте меню GET SELECT,
чтобы выбрать ссылочный объект для начала координат вида.

5. Под Default Orientation,, выберите тип заданной по умолчанию ориентации, которую
Вы хотите создать (Isometric, Trimetric или User Defined) и установите угловое
положение пользовательской ориентации по умолчанию в направлениях X и Y.

6. Для присвоения имени, установки, сохранения или удаления вида, нажмите
треугольник со стрелкой влево в разделе Saved Views и используйте любое из
следующего:

•  Save - укажите имя текущего вида в текстовом поле Name и нажмите Save для
сохранения текущего вида.

•  Set - Выберите имя из списка и нажмите Set для отображения выбранного вида.

•  Delete - выберите имя из списка и нажмите Delete для удаления выбранного вида.

7. Нажмите OK, чтобы принять изменения ориентации и закрыть диалоговое окно,
Cancel, чтобы прервать изменения ориентации и закрыть диалоговое окно или Undo,
чтобы отменить ваши изменения ориентации и начать сначала.

Вы можете также устанавливать ориентацию, используя опции ориентации файла
конфигурации.



Сохранение Вида

Сохранение вида сохраняет ориентацию вида относительно экрана и любую
ориентацию панорамирования и зумирования, связанную с видом. Однако,
информация по тонированию и каркасному представлению не сохраняется с видом.

Когда Вы сохраняете виды по имени, отображение основывается на ориентации
модели по умолчанию. Если Вы изменяете ориентацию модели по умолчанию (с
изометрической на триметрическую), ориентация сохраненных видов изменяется
вместе с ней.

Поименованные виды замораживаются, если они вызываются с частично потерянными
ссылочными ориентациями (они сохраняют свою ориентацию, но не сохраняют
хронологию того, как эта ориентация была достигнута).

Для присвоения имени, вызова, сохранения или удаления сохраненного вида:

1. Из основного меню, выберите View > Saved Views
ИЛИ

•  Щелкните по кнопке Saved Views на инструментальной панели Pro/ENGINEER

ИЛИ

•  Щелкните оп стрелке Expand в диалоговом окне Orientation.

2. В диалоговом окне Saved Views, выберите вид, или укажите имя текущего вида.

3. Выберите из следующих опций:

•  Save - укажите имя текущего вида в текстовом поле Name (имя может быть до 80
символов длиной) и нажмите Save для сохранения текущего вида.

•  Set - Выберите имя из списка и нажмите Set (или дважды щелкните по имени) для
отображения выбранного вида.

•  Delete - выберите имя из списка и нажмите Delete (или дважды щелкните по имени)
для удаления выбранного вида. Текущий вид остается неизменным, при удалении
сохраненного вида.

•  Close - щелкните для удаления диалогового окна.

Совет: Горячая Клавиша для Отображения Сохраненных
Видов

Один из способов отображения или ориентирования модели или рисунка по
сохраненному виду состоит в том, чтобы выбрать View, затем Saved Views. Это
выполняется в диалоговом окне Saved Views.

Быстрый способ ориентирования модели или рисунка по требуемому сохраненному
виду состоит в использовании пиктограммы для Saved Views. Этот значок открывает
маленькое поле, перечисляющее все сохраненные виды. Просто выберите имя
сохраненного вида, и модель переориентируется по нему.

Диалоговое Окно Отображения Модели

Выбор отображения или скрытия требуемых элементов может влиять на
эффективность вращения или анимации. Нажмите View > Model
Display. Используйте диалоговое окно Model Display для:

•  Изменения отображения во время нанесения размерных допусков.



•  Переключение отображения в цвете вкл. или выкл.

•  Отображение или скрытие базовых величин, поверхностной сетки или силуэта при
вращении или анимации.

•  Изменение отображения кабеля от толстой до осевой линии

•  Отображение или скрытие ссылочных указателей

•  Изменение текущего стиля отображения модели

•  Изменение качества и деталировки кромок и линий

•  Изменение качества и деталировки тонированных областей

Изменение Отображения Размерных Допусков

Для изменения текущего отображения размерных допусков, используйте один из
следующих методов:

1. Щелкните по кнопке Tolerances on/off button ( ) на инструментальной
панели. Если эта кнопка отсутствует на инструментальной панели, Вы можете добавить
ее, выбрав Utilities > Customize Screen
ИЛИ

из меню, выберите View > Model Display. Открывается диалоговое окно Model Display.

2. Под Display на ярлычке General, выберите или снимите выбор с Dimension
tolerances.
3. Щелкните по Apply или OK.
Обратите внимание: Для постоянной установки опции, используйте опцию tol_display
файла конфигурации.

Отображение Кабелей Толстыми или Осевыми Линиями

1. В области главного меню, выберите View > Model Display. Открывается диалоговое
окно Model Display.

2. Под Display на ярлычке General, выберите или снимите выбор с:

•  Reference designators - для изменения отображения справочных указателей
кабельных соединения и ECAD компонентов.

•  Internal cable portions - изменение отображения частей кабеля, которые находятся
внутри компонентов кабеля.

3. Под Cable Display в ярлычке Edge/Line, выберите или снимите выделение:

•  Thick - для отображения кабеля с трехмерной толщиной для отображения
тонирования.

•  Centerline - для отображения осевой линии кабеля с точками местоположений
зеленого цвета.

4. Нажмите OK для сохранения изменений и закрытия диалогового окна или Apply для
сохранения изменений и продолжения работы в диалоговом окне.



Отображение или Скрытие Элементов в Процессе
Вращения или Анимации

Для изменения цвета, вращения или отображения модели:

1. В области главного меню, выберите View > Model Display. Открывается диалоговое
окно Model Display.

2. Нажмите ярлычок General.
3. Под Display, выберите Colors для цветов дисплея. Это также можно установить,
используя опции цветов файла конфигурации.

Обратите внимание: Вы можете также использовать кнопку Colors on/off ( ) на
инструментальной панели для переключения цветов дисплея. Используйте Customize
Screen в меню Utilities для размещения кнопок в инструментальной панели.

4. Под Display While Spinning, выберите:

•  Datums - для отображения базовых элементов в процессе динамического
вращения модели. Это может также быть установлено, используя опцию
spin_with_part_entities файла конфигурации.

•  Surface mesh - для отображения сети поверхности в процессе динамического
вращения модели.

•  Silhouette edges - для отображения кромок силуэта в процессе динамического
вращения модели. Это может также быть установлено, используя опцию
spin_with_silhouettes файла конфигурации.

5. Под View Change Animation, выберите:

•  Maximum seconds - устанавливает максимальное количество секунд, затраченных
на анимацию между видами.

•  Minimum seconds - устанавливает минимальное количество секунд, затраченных
на анимацию между видами.

Переключение Между Тонированным и Каркасным
Отображением

Изменение стиля отображения может быть полезно при визуализации модели.
Заданный по умолчанию каркасный метод отображения позволяет быстрее
перерисовывать экран. В отличие от тонированных изображений, каркасная модель и
модель со скрытыми линиями сохраняет свой характер, независимо от ориентации
модели.

Для изменения стиля отображения модели во время работы, нажмите одну из
следующих кнопок на инструментальной панели:

 Каркасное отображение (исходная настройка по умолчанию)

Скрытые Линии

Без Скрытых Линий

Тонирование



ИЛИ

1. Выберите Model Display из меню View. Открывается диалоговое окно Model Display.

2. Под Display Style на ярлычке General, выберите один из следующих стилей:

•  Wireframe

•  Hidden Line

•  No Hidden Line

•  Shading
3. Нажмите OK для сохранения изменений и закрытия диалогового окна или Apply для
сохранения изменений и продолжения работы в диалоговом окне.

Изменение Отображения Кромок и Линий

1. Из меню, выберите View > Model Display.
2. Нажмите ярлычок Edge/Line диалогового окна Model Display.

3. Под Edge Quality, выберите требуемое качество отображения (Medium, Low, High,
or Very High). Это может также быть установлено, используя опцию
edge_display_quality файла конфигурации.

4. Под Tangent Edges, выберите стиль кромок двух касательных поверхностей (Solid,
No Display, Phantom, Centerline, or Dimmed). Это может также быть установлено,
используя опцию tangent_edge_display файла конфигурации.

Обратите внимание: Вы можете также использовать кнопки стиля касательных кромок
( ) для изменения отображения касательных кромок

(используйте Customize Screen в меню Utilities для размещения кнопок на
инструментальной панели).

5. Под Options, выберите опции отображения из следующего:

•  Silhouette edges - включает отображение кромок силуэта.

•  Smooth lines - включает отображение всех невертикальных и негоризонтальных
линий, используя методы сглаживания.

•  Depthcue always - включает отображение глубины перспективы, когда диалоговое
окно Visibilities закрыто. Это может также быть установлено, используя опцию
depthcue_options файла конфигурации.

•  Clip always - включает обрезку изображения, когда диалоговое окно Visibilities
закрыто.

6. Под Cable Display, выберите следующее:

•  Thick - включает обрезку изображения, когда диалоговое окно Visibilities закрыто
(м.б. опечатка примечание переводчика).

•  Centerline - включает отображение осевой линии кабеля точками положений,
зеленого цвета.

Обратите внимание: Вы можете также использовать пиктограммы Cable thick style
( ) и Cable centerline style ( ) для изменения отображения кабеля.

(используйте Customize Screen в меню Utilities для размещения кнопок на
инструментальной панели).



7. Под Cable HLR, выберите Full, None или Partial для установки уровня удаления
скрытых линий в сборке кабелей. Это может также быть установлено, используя опцию
full_HLR_for_cables файла конфигурации.

Изменение Отображения Касательных Кромок

Для изменения стиля линии для кромок, где две поверхности - касательны, либо
используйте следующие пиктограммы инструментальной панели (используйте
Customize Screen в меню Utilities для размещения кнопок на инструментальной
панели):

Отображает касательные кромки в виде непрерывных линий.

Отображает касательные кромки в виде осевых линий.

 Отображает касательные кромки в виде пунктирных линий.

Полностью выключает отображение касательных кромок.

Отображает касательные кромки в виде серых линий

ИЛИ

1. В области главного меню, выберите View > Model Display. Открывается диалоговое
окно Model Display.

2. В списке Tangent Edges на ярлычке Edge/Line, выберите один из следующих стилей:

•  Solid

•  No Display

•  Phantom

•  Centerline

•  Dimmed
3. Нажмите OK для сохранения изменений и закрытия диалогового окна или Apply для
сохранения изменений и продолжения работы в диалоговом окне.

Этот режим может также быть установлен, используя опцию tangent_edge_display
файла конфигурации.

Управление Качеством Тонирования

Качество тонированной модели определяется размером треугольников, используемых
для тонирования на сплайновых поверхностях и поверхностях вращения. Чем выше
качество, тем более гладкие изогнутые поверхности проявляются при тонировании.
Плоские поверхности всегда проявляются одинаково, так что на них не воздействует
качество тонирования.

Для изменения качества и проявления тонированного изображения:

1. В области главного меню, выберите View > Model Display. Открывается диалоговое
окно Model Display.



2. Нажмите ярлычок Shade.

3. Под Quality, нажмите стрелки "вверх" или "вниз" для корректировки до требуемого
значения. Диапазон - от 0 до 10. Значение по умолчанию - 3. Установка 10 занимает
самое большое время при тонировании.

4. Под Shade, выберите любой из следующих элементов тонирования:

•  Surface features - использует элементы тонирования поверхностей при
тонировании модели. Это может также быть установлено, используя опцию
shade_surface_feat файла конфигурации.

•  With datum curves - отображает базовые кривые на тонированной модели. Это
может также быть установлено, используя опцию shade_with файла конфигурации.

•  With edges - отображает кромки более темными по отношению к смежным
поверхностям. Это может также быть установлено, используя опцию
show_shaded_edges файла конфигурации.

•  Small surfaces - тонирует очень маленькие поверхности.

•  Manufacturing reference mode - тонирует ссылочные обрабатываемые модели при
тонировании модели. Это может также быть установлено, используя опцию
shade_mfg_ref_models файла конфигурации.

5. Под Enable, выберите любое из следующего:

•  Textures - включает отображение текстур на тонированных моделях.

•  Transparency - включает прозрачность для модели в текущем окне.

•  Capped Clipping - накрывает плоскость, которая отсекает тонированные части
модели.

6. Щелкните по ОК.

Отображение или Скрытие Базовых Элементов

Для включения/выключения отображения базовых элементов, используйте любой из
следующих методов:

- В инструментальной панели выберите соответствующую кнопку, используя
подсказку.

- В меню нажмите View > Datum Display. Открывается диалоговое окно Datum
Display.

Под Display, выберите:

•  Datum Planes -отображает базовые плоскости и их названия. Это может также быть
установлено, используя опцию datum_display файла конфигурации.

•  Datum Axes - отображает базовые оси и их названия. Это может также быть
установлено, используя опцию axis_display файла конфигурации.

•  Point Symbols - отображает базовые точки и их названия. Это может также быть
установлено, используя опцию datum_point_symbol файла конфигурации.

•  Point Tags - отображает ярлычки базовых точек и их названия. Это может также
быть установлено, используя опцию файла конфигурации.

•  Coordinate Systems - отображает системы координат и их названия.

•  Spin Center - отображает символ центра вращения. Это может также быть
установлено, используя опцию spin_center_display файла конфигурации.



Под Point Symbol, используйте список для выбора типа символа, который Вы хотите
использовать при определении точки. Доступные опции Cross, Dot, Circle, Triangle и
Square.
Вы можете также использовать диалоговое окно Environment в меню Utilities для
изменения отображения базового элемента.

Отображение Анализа Модели

1. В области главного меню, выберите View > Analysis Display. Открывается
диалоговое окно Analysis Display, содержащее любые сохраненные анализы.
Перечисляется информация:

•  Значок глаза, показывающий, является ли анализ видимым ( ) или скрытым
( ).

•   значок, показывающий тип анализа, например, который представляет
пользовательский анализ. По умолчанию, показываются все типы.

•  название анализа.

2. Если Вы хотите ограничить отображение одним типом, выберите тип из
выпадающего списка Type.

 Нажмите кнопку Blank/Unblank, чтобы показать или скрыть анализ в
отображении модели. Нажмите Info для отображения имени, класса и типа
информации в области сообщений, по выбранному анализу.

Нажмите Settings для отображения диалогового окна для изменения масштаба и
плотности отображения. Для анализа вдоль кривой или кромки, Вы можете
устанавливать масштаб и плотность. Для анализа вдоль поверхности, Вы можете
устанавливать приращение (линейное, логарифмическое или двухцветное), спектр
(верхние и нижние пределы и чувствительность) и точность (нижняя, средняя, высокая
или очень высокая).

Совет: Опции Конфигурации Отображения Базового
Элемента

Вы можете изменять отображение базового элемента, используя любую из следующих
опции файла конфигурации:

•  datum_display

•  axis_display

•  datum_point_symbol

•  datum_point_tag_display

•  display_coordinate_sys

•  spin_center_display

Улучшение Качества Динамического Отображения

Вы можете уменьшить количество вычислений, которые система выполняет при
динамическом ориентировании тонированной модели, путем управления уровнем
детализации, на котором отображаются поверхности. Результат в том, что движения
модели кажутся более плавными и лучше синхронизируются с движущей силой.



Обратите внимание: эффективность использования уровней детализации (LODs) в
модели зависит от конфигурации вашей системы.

Для контроля системы управления:

1. Из меню, выберите View > Performance. Открывается диалоговое окно Performance.

2. Под Hidden Line Removal, выберите:

•  Fast HLR - включает аппаратное ускорение при динамическом вращении с
невидимыми линиями, базовыми элементами и осями.

Обратите внимание: При включении опции Fast HLR, печать становится не доступной.

3. Под Spin Displays per Second, выберите:

•  Enable - пытается обеспечить необходимое время, необходимое для отрисовки
кадра в процессе вращения.

•  Frames Per Sec - устанавливает минимальное количество отображений в секунду в
процессе вращения.

4. Под Level of Detail, выберите:

•  Enable - использует уровни детализации в тонированных моделях в процессе
динамической ориентации. Это может также быть установлено, используя опцию
lods_enabled файла конфигурации ..

•  Show detail % - устанавливает максимальный уровень детализации, которую
рассчитывает система. Диапазон - от 0 % до 100 %. Установка 100 % (значение по
умолчанию) представляет без потерь детализации. Установка 0 % представляет
почти полную потерю детализации.

Отображение Компонентов Процесса

Для установки характеристик отображения процесса (при работе в плане), из меню:

1. В области главного меню, выберите View > Model Setup > Process Display.
Открывается диалоговое окно Process Component Display.

2. Используя списки под Settings, выберите требуемый статус отображения:

•  Previous Components (предварительно собранные компоненты)

•  Current Components (компоненты, активные на текущем этапе)

Unused Components
3. Вы можете устанавливать Process Display или Selection Display для предыдущих,
текущих и неиспользованных компонентов процесса в любое из следующих состояний:

•  Current Environment (Текущая среда)

•  Phantom (Пунктирное)

•  Blank (Скрытое)

•  Wireframe  (Каркасное)

Сетка Поверхности Детали

Для создания сетки поверхности, чтобы оценить корректность геометрии детали:

1. Из меню, выберите View > Advanced > Mesh Surface или в инструментальной
панели, нажмите кнопку Mesh Surfaces.



 (используйте Customize Screen в меню Utilities для размещения кнопок на
инструментальной панели). Открывается диалоговое окно Mesh.

2. Под Surface, в списке, выберите тип изменяемой поверхности. Доступные опции -
поверхность и лоскутная поверхность.

3. Нажмите кнопку стрелки, чтобы отобразить меню GET SELECT и выбрать лоскутную
поверхность.

4. Под Meshed Spacing, используйте 1st Direction для корректировки интервала
между линиями сети в первом направлении и 2nd Direction для корректировки
интервала между линиями сети во втором направлении.

Сетка поверхности сохраняется только до перерисовки вида. Невидимые линии не
удаляются при изменении сетки детали.

Пример: Поверхность с Измененной Сеткой

Изменение Порога, Глубины Перспективы или Процента
Отсечения

Для изменения порога, глубины команды вызова и процента обрезки вида модели, из
меню:

1. Выберите View > Advanced > Visibilities. Открывается диалоговое окно Visibilities.

2. Скорректируйте бегунки или введите значения для:

•  Clip % - для изменения размещения плоскости отсечения (плоскость, проходящая
через тонированную модель, которая позволяет Вам отображать только часть
модели за плоскостью). Разрешенный диапазон - от 0 % до 100 %, где 0 % -
передняя сторона модели (ближняя к экрану). (для включения отображения
плоскости отсечения, выберите View > Model Display и используйте ярлычок Shade
диалогового окна Model Display.)



•  Depth Cue % - для изменения толщины линий каркаса таким образом, чтобы они
казались более темными по мере удаления от наблюдателя (от Вас) и светлее по
мере приближения от экрана (к Вам). Разрешенный диапазон - от 0 % до 100 %.
При 0%, все линии имеют максимальную яркость; при 100 %, все линии каркаса -
скрыты. (для включения каркасного отображения, выберите View > Model Display и
используйте ярлычок General диалогового окна Model Display.)

•  Threshold % - для изменения порогового значения. Этот параметр удаляет
поверхности, лоскутные поверхности или детали из вида в тонированном
изображении. Разрешенный диапазон - от 0 % до 100 %, где 0 % скрывает все
тонированные элементы, а 100 % отображает все тонированные элементы. (для
подготовки изображения к применению опции Threshholding, назначьте порог
палитры проявления, используя ярлычок Advanced диалогового окна Appearance
Editor: Выберите View > Model Setup > Color Appearances и нажмите Add.)

Добавление Перспективы к Виду Модели

Перспектива создает вид с одиночной точкой схода линий взгляда тонированной или
каркасной модели. Эти виды позволяют Вам наблюдать объект так, как если бы
положение вида следовало по кривой, оси, кабелю или кромке через или вокруг
объекта.

Вы выбираете направление обзора и, затем, управляете положением обзора по
траектории в любом направлении. Вы можете также вращать перспективный вид в
любом направлении, зумировать вид и изменять угол обзора в любой точке вдоль
траектории.

Для создания перспективного вида тонированной или каркасной модели с одиночной
точкой схода линий взгляда, из меню:

1. Выберите View > Advanced > Perspective. Открывается диалоговое окно Perspective.

2. В Type, выберите одно из следующего:

•  Fly-Through - используйте левую, правую и среднюю кнопки мыши для
перемещения объекта в окне Pro/ENGINEER следующим образом:

- Левая кнопка: при остановке, используйте для начала перемещения к объекту.
Нажатие левой кнопки несколько раз или удерживание ее нажатой увеличивает
скорость перемещения. Если Вы перемещаетесь от объекта, нажатие левой
кнопки замедляет обратное движение.

- Правая кнопка: при остановке, используйте для начала перемещения от
объекта. Нажатие правой кнопки несколько раз или удерживание ее нажатой
увеличивает скорость перемещения. Если Вы перемещаетесь к объекту,
нажатие левой кнопки замедляет обратное движение.

- средняя кнопка: при перемещении используйте для остановки всякого
движения. После остановки, нажатие и удерживание средней кнопки мыши
вращает точку обзора.

•  Walk Through - включает возможность Проход-Через (подобно "Пролет-Через", но
медленнее).

•  From/To - включает выбор двух базовых точек или вершин, которые определяют
направление обзора вдоль объекта.

•  Follow Path включает выбор оси, кромки, кривой или силуэта в качестве
направления обзора.

3. Под Options, выберите или снимите выбор флажка; или переместите бегунок,
щелкните по стрелке или введите значения для:

•  Dynamic Update - контролирует изменение отображения при корректировке
параметров настройки в этом диалоговом окне.



•  Eye Dist - перемещает точку обзора вдоль выбранной траектории через модель.
Если модель в настоящий момент затонирована и траектория полностью лежит
внутри модели, на экране ничего не будет видно, если в модели не имеются
пустоты.

•  Rotate Eye - устанавливает величину поворота вокруг горизонтальной,
вертикальной и центральной осей в пределах от -180 до +180 градусов.

•  Pan Eye - устанавливает горизонтальное и вертикальное положение дисплея.

•  Zoom- устанавливает процент увеличения изображения от 0 % до 100 %.

•  View angle - устанавливает угол обзора от 0 до 45 градусов.

4. для перспектив From/To или Follow Path, выберите элемент объекта, используя
меню GET SELECT.

5. Нажмите OK для установки значений или Undo для удаления сделанных настроек.

Изменение Параметров Настройки Среды Pro/ENGINEER

Вы можете управлять многими аспектами среды, в которой запускается Pro/ENGINEER
при помощи диалогового окна Environment.
для открытия диалогового окна Environment, нажмите Utilities > Environment в меню
или нажмите соответствующий значок в инструментальной панели.

Вы можете также изменять многие из этих параметров настройки, используя кнопки
панели. Нажмите Utilities > Customize Screen, чтобы получить подробную
информацию и разместить кнопки в инструментальной панели.

Отображение
ИСПОЛЬЗУЙТЕ ДЛЯ
Dimension Tolerances Отображения размеров модели с допусками

Datum Planes Отображения базовых плоскостей и их имен. Обратите
внимание, что выключение отображения базовой
плоскости, путем выключения флажка, не влияет на
базовую плоскость, которая установлена справочной
базой для геометрических допусков.

Datum Axes Отображения базовых осей и их имен. Обратите
внимание, что выключение отображения базовой оси,
путем снятия флажка в режиме Drawing, скрывает
только имена осей.

Point Symbols Отображения базовых точек и их имен

Point Tags Контроля отображения имен базовых точек отдельно от
символов базовых точек. При скрытии имен базовых
точек путем выключения флажка, положения базовых
точек остаются обозначенными символами Х.

Coordinate Systems Отображения систем координат и их имен

Spin Center Отображения центра вращения модели

3D Notes Отображения примечаний, созданных в режиме Part или
Assembly в окне модели.

Notes as Names Позволяет Вам переключаться между отображением
текста и имени примечания, если выбрана
вышеуказанная опция 3D Notes

Reference Designators Назначает каждый компонент сборки, как соединение в
Pro/CABLING или компонент, импортированный как



ECAD, отображает с его ссылочным указателем в
трехмерных видах сборки.

Thick Cables Отображения кабеля с трехмерной толщиной. Кабель
может быть затонирован. Эта опция и Centerline Cables
являются взаимно исключающими

Centerline Cables Отображает осевую линию кабеля точками
местоположений зеленого цвета. Эта опция и Thick
Cables являются взаимно исключающими

Internal Cable Portions Отображения части кабеля, которая скрыта в виде
другой геометрией

Model Tree Отображения окна Model Tree

Query Bin Отображения Query Bin при использовании опции Query
Sel в меню GET SELECT

Colors Отображения модели в цвете

Textures Отображения текстур на тонированных моделях

Snap Lines Отображения линий привязки (проявляются только в
режимах Model и Report)

Levels of Detail Делает возможным использование режима Levels of
Detail в тонированной модели в процессе динамического
манипулирования (панорамирование, зумирование и
вращение)

2D Arc Centers Отображения центров дуг (проявляются только в
режимах Model и Report)

Действия По Умолчанию
ИСПОЛЬЗУЙТЕ ДЛЯ
Ring Message Bell Звукового сигнала после каждого запроса или

системного сообщения

Save Display Сохранения объектов в их последнем состоянии. Это
позволяет в новой сессии вызывать объекты быстрее,
т.к. не надо проводить перерассчет графики.

Make Regen Backup Резервного копирования текущей модели или моделей
на диск перед каждой регенерацией: всякий раз, когда
Вы выбираете Regenerate и запускаете функцию,
которая завершается обязательной регенерацией, типа
Feature > Redefine. В конце сессии Pro/ENGINEER
автоматически удаляет созданные резервные файлы.

Snap to Grid Привязки точки ,выбранной на экране, к сетке. Это
иногда полезно в Sketcher.

Snap to Snap Lines Привязки примитивов (типа размеров, примечаний,
символов) к линиям привязки (проявляются только в
режимах Model и Report)

Keep Info Datums Контроля, как система обрабатывает базовые
плоскости, точки, оси и системы координат созданные
вами "на лету" с функциональностью Info. При
включении опции, система включает их в модель в
качестве элементов. При отмене, система стирает их
при выходе из режима Info.

Use 2D Sketcher Контроля исходной ориентации модели в режиме
Sketcher. При включении опции, модель изменяет



ориентацию после перехода Sketcher в двухмерный
режим. При отмене, ориентация модели после перехода
в Sketcher остается неизменной.

Use Fast HLR Включения аппаратного ускорения динамического
вращения со скрытыми линиями, базовыми плоскостями
и осями. Эффективность может быть различной для
различных систем и отображений.

Display Style Выбора одного из следующих стилей отображения
вашей модели:

Wireframe - модель отображается в каркасном режиме
без различения видимых и скрытых линий.

Hidden Line - скрытые линии отображаются серым
цветом.

No Hidden - скрытые линии не отображаются

Shading - все поверхности и твердотельные элементы
отображаются тонированными. Базовые плоскости, оси
и их элементы отображаются над тонированными
моделями, если выбран соответствующий флажок в
диалоговом окне Environment. Жгуты кабелей
отображаются на модели, даже если переменная
установлена в Centerline Cables. Опция конфигурации
shade_surface_feat также влияет на тонированное
изображение.

Default Orient Выбора одной из следующих ориентаций по умолчанию
для Ваших моделей:

Isometric - стандартная изометрическая ориентация

Trimetric - стандартная триметрическая ориентация

User Defined - пользовательская ориентация
(определяется опцией файла конфигурации options
x_angle and y_angle).

Tangent Edges Выбора одного из следующих стилей отображения
касательных кромок (т.е. кромок, формируемых двумя
касательными поверхностями) в вашей модели:

Solid - отображение касательных кромок непрерывными
линиями

No Display - скрытие касательных кромок

Phantom - отображение касательных кромок
пунктирными линиями

Centerline - отображение касательных кромок осевыми
линиями

Dimmed - отображение касательных кромок цветом в
Dimmed Menu

Вы также можете установить эти стили в опции
конфигурации tangent_edge_display

Когда Вы делаете изменения в диалоговом окне Environment, они действуют только
для текущей сессии. Когда Вы запускаете Pro/ENGINEER, параметры настройки среды
определяются вашим файлом конфигурации; иначе, -  значениями по умолчанию
конфигурации системы.



Установка Размерных Допусков

В производстве, Вы можете использовать геометрические допуски для определения
максимально допустимого отклонения от точного размера и формы, указанной
проектировщиками. Вы можете устанавливать стандарт допусков, типа ANSI или ISO.

Вы можете также использовать опцию tol_mode файла конфигурации.

Использование Дерева Модели

Дерево Модели содержит базовые и сложные элементы для манипулирования и
управления создаваемыми объектами. Для получения дополнительной информации,
нажмите клавишу справки в окне Model Tree.

Отображение Буфера Запроса

Когда Вы используете опцию Query Sel в МЕНЮ GET SELECT, открывается диалоговое
окно Query Bin.

Диалоговое окно Query Bin содержит все возможные элементы, которые Вы можете
выбрать в указанной точке экрана. Используйте мышь или стрелки ВВЕРХ и ВНИЗ для
подсветки требуемого элемента, затем нажмите Accept для выбора элемента и
возврата к сессии.

Совет: Другие Способы Изменения Параметров Настройки
Среды

Вы можете изменять параметры настройки несколькими способами:

•  Вы может изменять многие параметры настройки в диалоговом окне Environment,
используя элементы в меню View.

•  Вы может настраивать вашу инструментальную панель для добавления
дополнительных кнопок изменения параметров настройки, используя команду
Customize в меню Utilities.

•  Вы может изменять параметры настройки для каждой сессии, редактируя ваш файл
config.pro, используя Utilities > Preferences > Edit Config.

•  Вы можете устанавливать горячие клавиши для параметров настройки
Pro/ENGINEER, используя команду Mapkeys в меню Utilities и, затем, использовать
назначенные клавиши для изменения параметров настройки.

Диалоговое Окно Mapkeys

В диалоговом окне Mapkey, Вы можете создавать клавиатурные макросы, часто
используемых последовательностей команд на некоторых клавишах клавиатуры или
наборах клавиш.

При добавлении пользовательской горячей клавиши на вашу инструментальную
панель, Вы можете автоматизировать рабочий процесс. Вы можете использовать
горячую клавишу для отдельной команды меню. Если Вы - новичок, Вы можете
заимствовать горячие клавиши сотрудников без необходимости помнить загадочные
сокращения.

Вы можете использовать диалоговое окно Mapkeys, чтобы делать следующее:



•  Определять новые горячие клавиши;

•  просматривать, изменять и удалять существующие горячие клавиши

•  Выполнять горячие клавиши, выбирая из списка

•  Сохранять горячие клавиши в файле конфигурации

Для открытия диалогового окна Mapkeys, нажмите Utilities > Mapkeys.

ИСПОЛЬЗУЙТЕ ДЛЯ
New Определения новой горячей клавиши

Modify Изменения горячей клавиши, подсвеченной в списке

Run Запуска горячей клавиши, подсвеченной в списке

Delete Удаления горячей клавиши, подсвеченной в списке

Save Сохранения горячей клавиши в файле конфигурации

Changed Сохранения горячих клавиш, измененных в текущем
сеансе

All Сохранения всех горячих клавиш

Горячие Клавиши

Для определения горячих клавиш, Вы должны использовать диалоговое окно Utilities
> Mapkeys > New > Record Mapkey для ввода названия и описания горячей клавиши.
Название появляется на кнопке, добавленной к инструментальной панели, а описание
появляется в виде короткой справки, когда Вы подводите курсор мыши к этой кнопке.

После определения горячей клавиши, соответствующая кнопка появляется в
диалоговом окне Customize Toolbars под категорией Mapkeys. Вы можете затем
перетащить горячую клавишу на инструментальную панель точно так же как системные
кнопки.

Значительные возможности горячих клавиш включают возможность:

•  Делать паузу для ввода пользователя.

•  Более гибко управлять окном сообщений.

•  Выполнять команды операционной системы

Когда Вы определяете горячую клавишу, система автоматически записывает паузу,
когда Вы делаете выбор на экране, так, чтобы Вы могли выполнять новый выбор во
время работы макрокоманды. Также, Вы можете записывать паузы в любом месте
макрокоманды наряду с указанной пользователем подсказкой, которая будет
появляться в соответствующем месте выполнения макрокоманды.

Вы можете теперь создавать макрокоманды, которые выполняют сценарии и команды
операционной системы. Диалоговое окно Record Mapkey содержит ярлычок OS Script,
которая выполняет команды OS иначе, чем команды Pro/ENGINEER.

Если Вы не хотите использовать диалоговое окно Mapkey, Вы можете использовать
опцию файла конфигурации mapkey.



Определение Горячих Клавиш

1. Выберите Utilities > Mapkeys из меню, или нажмите соответствующий значок на
инструментальной панели (используйте Customize Screen в меню Utilities для
размещения кнопок в инструментальной панели). Появляется диалоговое окно
Mapkeys.

2. Щелкните по New. Открывается диалоговое окно Record Mapkey.

3. Введите последовательность клавиш, которая должна использоваться для
выполнения макрокоманды в текстовом поле Key Sequence.

Обратите внимание: для использования функциональных клавиш, ставьте перед ее
именем символ доллара ($). Например, для указания F3, введите $F3.

4. Укажите имя и описание горячей клавиши в соответствующих (необязательных)
текстовых полях.

5. В ярлычке Pro/E укажите, как система должна обрабатывать подсказки при
выполнении макрокоманды:

•  Record keyboard input - записать ввод с клавиатуры при определении горячей
клавиши и использовать его при выполнении макрокоманды.

•  Accept system defaults - принять значения системы по умолчанию при выполнении
макрокоманды.

•  Pause for keyboard input - сделать паузу для ввода с клавиатуры при выполнении
макрокоманды.

6. Нажмите Record, и запустите запись макрокоманды, выбирая команды меню в
соответствующем порядке.

7. Если требуется, нажмите Pause, чтобы указать, где делать паузу при выполнении
макрокоманды. Введите подсказку в диалоговом окне Resume Prompt. Затем нажмите
Resume и продолжайте запись макрокоманды. При запуске макрокоманды, система
сделает паузу, отобразит подсказку, которую Вы ввели и предложит Вам опции для
Resume (возобновления примечание переводчика) выполнения макрокоманды или
Cancel. (Отмены примечание переводчика)

8. Нажмите Stop по завершении записи макрокоманды.

OS Script tab: Позволяет Вам выполнять сценарий Операционной системы
посредством использования горячих клавиш Pro/ENGINEER. Это выгодно, потому что
Вы можете запустить этот сценарий OS без минимизации окна или перевода его в
фоновый режим.

Это аналогично использованию псевдонимов в UNIX. Пример сценария OS в том,
чтобы скопировать используемый файл конфигурации из каталога на жестком диске в
рабочий каталог так, чтобы Вы могли загружать файл в вашу сессию.

Добавление Горячих Клавиш в Меню

В диалоговом окне Customize, Вы можете настраивать меню, добавляя горячие
клавиши:

1. В меню нажмите, Utilities > Customize Screen. Система отображает диалоговое окно
Customize.

2. Нажмите ярлычок Commands.

3. Выберите Mapkeys в списке Categories.

4. Выберите макрокоманду в списке Mapkeys, чтобы видеть ее описание в поле
Description ниже.



•  для добавления горячей клавиши, перетащите ее в требуемое место меню.

•  для удаления горячей клавиши из меню, выберите ее и перетащите из меню.

•  для перемещения команды, выберите ее и перетащите из одного меню на другое.

•  для добавления меню или подменю к меню, перейдите в категорию New Menu и
перетащите новую команду меню в требуемое место меню. Затем Вы можете
перетащить другие элементы в it.include макрокоманды выбранного меню, нажмите
двойную стрелку для перемещения в список Added Mapkeys.

Настройка Ul (Пользовательского Интерфейса)

Вы можете настраивать пользовательский интерфейс в диалоговом окне Customize.
Чтобы открывать диалоговое окно Customize, нажмите, Utilities > Customize Screen.
Вы можете использовать это диалоговое окно для:

•  определения кнопок, которые появляются в инструментальных панелях окна;

•  добавления, удаления и перемещения горячих клавиш и других команд в/из меню

•  отображения или скрытия категорий панелей и настройки их местоположения на
экране

•  определения, будет ли расположена область сообщения ниже или выше
графического окна и будут ли появляться пиктограммы в меню.

•  контроля, присоединено ли Дерево Модели к окну модели или является
"плавающим" Вы можете также управлять заданным по умолчанию размером и
местоположением Структуры Модели.

Добавление Пользовательских Команд к Ul
(Пользовательскому Интерфейсу)

На странице Commands в диалоговом окне Customize, Вы можете создавать
инструментальные панели для собственных потребностей. Вы можете выбирать,
перетаскивать и отпускать кнопки, в нужных местах инструментальной панели
Pro/ENGINEER.

Commands Categories (Категории Команд примечание переводчика) состоят из
команд, которые являются наиболее полезными в базовых модулях, например,
Drawing, Sketcher и Manufacturing. Вы можете также перемещать кнопки, которые Вы
определили для горячих клавиш на инструментальную панель.

Для настройки экранных команд:

1. Из меню, нажмите, Utilities > Customize Screen. Система отображает диалоговое
окно Customize.

2. Нажмите ярлычок Commands.

3. Выберите категорию Pro/ENGINEER в списке Categories.

4. Система отображает кнопки, доступные для этой категории под Commands.
5. Нажмите кнопку и, затем, нажмите Description, чтобы увидеть текущее изображение
и текст для нажатой кнопки. Щелкните по изображению для возврата к диалоговому
окну.

6. Под Categories, выберите Mapkeys; под Mapkeys, выберите требуемую кнопку и
нажмите Modify Selection, чтобы выбрать из следующих опций:

•  Delete - удаляет выбранную кнопку.



•  Copy Button Image - копируют изображение выбранной кнопки в буфер обмена.

•  Paste Button Image - вставляет скопированное изображение кнопки на выбранную
кнопку.

•  Reset Button Image - сбрасывает выбранную кнопку к ее первоначальному
изображению.

•  Choose Button Image - отображает диалоговое окно Pick Mapkey Icon, чтобы
выбрать из набора созданных изображений.

•  Edit Button Image - отображает диалоговое окно Button Editor для редактирования
пикселов, которые составляют изображение выбранной кнопки.

•  Text Only - отображает текст только на выбранной кнопке.

•  Image and Text - отображает изображение и текст на выбранной кнопке.

•  Image Only - отображает только изображение выбранной кнопки (значение по
умолчанию).

Вы можете также выбрать системные команды и нажать Modify Select; в этом случае,
единственная доступная опция - Copy Button Image.
7. Перетащите кнопку на любую инструментальную панель в текущем окне.

8. Для удаления кнопки с инструментальной панели, перетащите ее с
инструментальной панели при открытом диалоговом окне Customize.

Добавление или Удаление Панели Пиктограмм

Используя страницу Toolbars в диалоговом окне Customize, Вы можете настраивать
меню, добавляя и удаляя функциональные клавиши на/с панелей пиктограмм в
верхней, левой или правой части окна Pro/ENGINEER. Вы можете также добавлять
пользовательские горячие клавиши к инструментальной панели.

Для настройки панели пиктограмм:

1. В меню нажмите, Utilities > Customize Screen. Система отображает диалоговое окно
Customize.

2. Нажмите ярлычок Toolbars.

3. Выберите поля инструментальной панели, которые Вы хотите отобразить на экране,
например, Datum Display.
4. Для каждой выбранной инструментальной панели, определите его позицию в окне
Pro/ENGINEER (Top, Left или Right).
5. Система перемещает все кнопки в соответствующую категорию инструментальной
панели к указанной позиции. Например, если Вы определяете Right для
инструментальной панели View, система перемещает Repaint, Zoom, и другие кнопки
категории View в правую часть окна.

Добавление Опций Меню, Используя Файл menu_def.pro

Вы можете добавлять пункты меню для выполнения клавиатурных макрокоманд через
графический интерфейс, и Вы можете также использовать их для вызова других
приложений или команд.



Для Макрокоманд Клавиатуры

Опции добавления меню - способ разместить ваши клавиатурные макрокоманды в
видимом месте. Это делает их более доступными, проще для запоминания и часто
используемыми.

Для создания новой опции меню, добавьте к вашему файлу menu_def.pro строку в
одном из двух следующих форматов:

setbutton menuname menuitem "ActionDefinition" "ShortHelp"

ИЛИ

setbutton menuname menuitem "ActionDefinition"

Элементы этих определений следующие:

- Menuname - заголовок меню. Он обычно, но не всегда, соответствует
отображаемому в поле заголовка над меню. Чтобы быть абсолютно уверенным в
том, что Menuname существует, включите опции button_name_in_help файла
конфигурации. Как только Вы переместите курсор над меню, соответствующие
menuname и menuitem появятся в строке состояния. Если заголовок состоит из
более чем одного слова, замените пробелы символом # в Menuname (например,
set#up для set up).

- menuitem - является именем новой опции меню, которая появляется в меню. Если
опция состоит из более чем одного слова, замените пробелы символом # в
menuitem (например, shade#obj для shade obj).

- ActionDefinition - последовательность указаний меню, указаний в диалоговом окне и
ввода пользователя, которая будет активизирована новой опцией. Синтаксис для
ActionDefinition подобен клавиатурным макрокомандам. Если определение setbutton
не помещается в одной строке, введите [\<CR>] (наклонная черта влево, перевод
каретки) и продолжайте в следующей строке. Полная длина определения setbutton
не должна превышать 250 символов.

- ShortHelp - текстовая строка, используемая как краткая справка для новой опции
меню. Если она опущена (когда используется второй формат), строковое
пользовательское действие по умолчанию используется для краткой справки.

Настройка Менеджера Меню при помощи menu_def.pro

Если не имеется никакого системного значения по умолчанию для конкретного меню,
Вы можете устанавливать ваше собственное значение по умолчанию, используя файл
menu_def.pro. Подобно файлу конфигурации, этот файл загружается в процессе
инициализации Pro/ENGINEER.

Сначала просматривается системный каталог по умолчанию (<loadpoint>/текст), затем
текущий рабочий каталог. Если вхождение меню по умолчанию уже было определено
для конкретного меню в файле, любые противоречивые определения локального
файла игнорируются.

Примечания:

•  Установка команды меню, как заданного по умолчанию выбора меню заставляет эту
команду меню автоматически выбираться всякий раз при выборе этого меню.

•  Структурированные меню не поддерживаются для меню по умолчанию.

Формат определения меню по умолчанию следующий:

menuname menuitem

, где



- menuname - заголовок, отображаемый над меню. Если заголовок состоит из более
чем одного слова, пробелы между словами должны быть заменены на # (Например,
menuname для меню DIM PNT PNT вводится как dim#pnt#pnt).

- menuitem - опция в меню menuname. Если опция состоит из более чем одного
слова, Вы должны заменить пробелы между словами на # (Например, вводите
menuitem Edge Tangent как edge#tangent).

Примечания:

•  может существовать только один пробел между menuname и menuitem, указанный
по умолчанию.

•  вхождения - не зависят от регистра.

Примеры

ORIENTATION Default - когда меню ORIENTATION активизировано, автоматически
выбирается Default.
dwg#size а - когда меню DWG SIZE активизировано, автоматически выбирается размер
А.

Если в процессе выполнения, пользовательское меню по умолчанию недоступно, оно
на этот момент игнорируется. Если одно и то же название меню используется в файле
menu_def.pro дважды, более позднее вхождение отменяет предыдущее. Система не
сообщает об ошибках для неправильных значений меню по умолчанию.

Работайте с файлом menu_def.pro, очень тщательно чтобы избежать проблем; заранее
представляйте к каким результатам могут привести те или иные значения по
умолчанию, и всегда помните, какие пункты меню файла установлены по умолчанию.
Например, установка Create, как выбор по умолчанию для меню Feature приведет к
непрерывному циклу создания элемента, который может быть остановлен только
завершением сессии Pro/ENGINEER.

Установка некоторого размера рисунка, в качестве значения по умолчанию для меню
DWG SIZE - другой пример опасного выбора; этот размер рисунка будет автоматически
выбираться всякий раз, когда рисунок будет создан и легко приведет к созданию
рисунка на листе неправильного размера прежде, чем ошибка будет найдена.

Для предотвращения автоматической загрузки файла menu_def.pro по ошибке,
следуйте одному из следующих действий:

•  создавайте файл menu_def.pro только, когда будете использовать его в следующей
сессии Pro/ENGINEER. Переименуйте или удалите файл по завершении сессии.

•  Сохраняйте файл в рабочем каталоге под различными именами. Когда Вы начнете
сессию Pro/ENGINEER, в которой файл будет использоваться, переименуйте его в
menu_def.pro. Переименуйте или удалите файл по завершении сессии.

Правила для Пользовательских Пунктов Меню

•  Вы не может использовать setbutton для изменения существующих опций меню
Pro/ENGINEER (то есть пунктов меню, существующих в файлах системного меню).

•  Вы должны сами проверить, что название пользовательского элемента уникально
среди всех элементов экрана в любой данный момент времени, и что все команды,
перечисленные в ActionDefinition, доступны в момент выполнения действия.
Например, если Вы выберете Shade Obj (см. пример ниже) в режиме Drawing, это
потерпит неудачу.

•  максимальное число символов в menuitem, разрешенном системой - 19. Вы можете
использовать только 12 символов для соответствия стандартному меню
Pro/ENGINEER или изменить ширину меню.



•  Вы должны вводить menuitem и ShortHelp точно так, как они появляются на экране.
Элементы для menuname - не зависят от регистра. ActionDefinition - чувствителен к
регистру, за исключением вводу с клавиатуры.

Пример: Пользовательские Опции Меню

Пример 1 - Тонирование Текущего объекта.

[@setbutton PART Shade#Obj #view;#shade;\

Shade an object.]

Пример 2 - Сохранение текущего объекта

[@setbutton PART Save#Obj #file;#save;;\

Save an object.]

Пример 3 - Сохранение текущей детали и отображение списка имен для
вызова другой.

Обратите внимание, что ActionDefinition ссылается на другую пользовательскую опцию
меню (Save Obj, определенную выше). Глубина вложения в таких случаях не должна
превышать 5 уровней.

[@setbutton PART Switch#Prt #File Obj;\

#Window;#Close window;#File;#Open;\

Switch to another part.]

Обратите внимание: когда Вы используете опцию пользовательского меню в другом
определении setbutton или макрокоманде клавиатуры, не забудьте изменить символы
#, если таковые имеются, обратно к пробелам.

Изменение Положения Области Сообщений

В ярлычке Windows диалогового окна Customize, Вы можете настраивать положение
области сообщения в окне Pro/ENGINEER.

Для настройки области сообщения:

1. В меню нажмите, Utilities > Customize Screen. Система отображает диалоговое окно
Customize.

2. Нажмите ярлычок Options.

3. Выберите следующие положения:

•  Над графическим окном

•  Под графическим окном

Опция windows_scale файла конфигурации позволяет Вам масштабировать окна
Pro/ENGINEER с указанным коэффициентом.

Файлы Конфигураций

Вы можете настраивать многие из режимов работы Pro/ENGINEER, определением
значений опций конфигурации в текстовом файле конфигурации. Например, файл
конфигурации может включать параметры настройки для форматов отображения



допусков, точности вычислений или количества цифр, используемых при
образмеривании эскизов. Вы можете использовать диалоговое окно Utilities >
Preferences для просмотра всех опций конфигурации и добавления, удаления или
изменения их, с целью изменения пути запуска Pro/ENGINEER от сессии к сессии.

Вообще, Вы должны изменять параметры настройки файла конфигурации до запуска
сессии Pro/ENGINEER. Если Вы хотите изменить среду в процессе работы, используйте
диалоговое окно Environment в меню Utilities. Некоторые опции, однако, могут быть
изменены только в файле конфигурации. В этом случае, Вы можете использовать
диалоговое окно Preferences для загрузки нового файла конфигурации с другим
именем и различными конфигурациями в процессе работы:

Вы можете использовать диалоговое окно Preferences для сохранения различных
версий файла конфигурации и отдельной их загрузки, в отличии от изменения
многочисленных требуемых опций.

Иерархия Файлов Конфигураций

Pro/ENGINEER считывает файлы конфигурации автоматически из нескольких областей.
Если специфическая опция присутствует в более, чем одном файле конфигурации,
используется самое последнее значение.

При запуске, Pro/ENGINEER сначала считывает защищенный системный файл
конфигурации, называемый config.sup. Затем он ищет и считывает файлы
конфигурации в следующих каталогов в указанном порядке:

1. loadpoint/text (loadpoint - каталог инсталляции Pro/ENGINEER) - Ваш системный
администратор, возможно, поместил файл конфигурации в это место, с целью
поддержки стандартов компании в части форматов и библиотек. Любой пользователь,
запускающий Pro/ENGINEERе от этого места, использует значения в этом файле.

2. Login directory - Это домашний каталог вашего входа в систему. Размещение здесь
вашего файла конфигурации позволяет Вам запускать Pro/ENGINEER из любого
каталога без необходимости иметь копию файла в каждом каталоге.

3. Startup directory - Это ваш текущий или рабочий каталог, откуда Вы запускаете
Pro/ENGINEER.

Обратите внимание: локальный файл config.pro (в вашем стартовом каталоге)
читается последним; поэтому, он отменяет любые конфликтующие вхождения опций
файла конфигурации. Однако, он не отменяет никаких вхождений config.sup.

Общие Правила для Опций Файла Конфигурации

Заданное по умолчанию имя файла конфигурации - config.pro.

Опции в файле конфигурации, в основном, используют следующий формат:

config_option_name value

, где config_option_name - опция, которую Вы хотите установить, а значение определяет
установку для этой опции.

Pro/ENGINEER имеет значение по умолчанию для каждой опции файла конфигурации.
Если Вы не добавляете опцию к вашему файлу конфигурации, Pro/ENGINEER
использует это значение по умолчанию.

Например, опция prompt_on_exit файла конфигурации сообщает Pro/ENGINEER,
запросить ли у Вас сохранить рабочие файлы при выборе File > Exit. По умолчанию,
Pro/ENGINEER выходит без запроса на сохранение изменяемых файлов. Если Вы
хотите изменить это, заданное по умолчанию, поведение, Вы можете добавить
следующую строку к вашему файлу конфигурации:

prompt_on_exit yes



Pro/ENGINEER считывает эту опцию при загрузке и впоследствии запрашивает Вас
сохранить любые изменяемые файлы перед выходом.

Загрузка Файла Конфигурации

Вообще, установки файла конфигурации делаются перед запуском сессии
Pro/ENGINEER. Если Вы хотите изменить рабочую среду в процессе работы, обычно
используют диалоговое окно Environment в меню Utilities. Некоторые опции, однако,
могут быть изменены только через файл конфигурации. В этом случае, Вы можете
загрузить новый файл конфигурации с другим именем и другой конфигурацией в
течение сессии:

1. Выберите Utilities > Preferences > Load Config.
2. Введите полный путь и имя файла конфигурации (config.pro - значение по
умолчанию). Нажмите OK или Apply в диалоговом окне Preferences. Pro/ENGINEER
обновится согласно новым параметрам настройки файла конфигурации. Если в новом
файле конфигурации имеются ошибки в окне запуска отобразятся сообщения об
ошибках.

Обратите внимание: некоторые изменения файла конфигурации, типа размера окна
или стирания не могут быть изменены в ходе рабочей сессии.

Установка Опций Конфигурации

1. Нажмите Utilities > Preferences. Открывается диалоговое окно Preferences.
Отображаются параметры настройки из последнего загруженного файла конфигурации.
Значок рядом с опцией показывает, будет ли редактирование применено немедленно,
применено к следующему вхождению созданного объекта или применено в следующей
сессии.

2. Обозначьте опцию, которую Вы хотите установить. Когда Вы подсвечиваете опцию в
списке, она появляется в строке с обозначением Option: в нижней части диалогового
окна.

3. В поле Value:, напротив Option:, введите новое значение. Если вводимые значения
установлены, например Yes или No, Вы можете использовать выпадающее меню для
выбора доступных значений; если значение требует целого числа, введите его.

4. После редактирования значения, нажмите Add/Change. Новое значение появляется
в окне списка опций. Пиктограмма статуса для редактируемой строки показывает, что
значение по умолчанию было изменено.

5. По завершении редактирования значений опций конфигурации, нажмите Apply или
OK. Изменения, которые могут применяться немедленно, появляются в UI.

Дополнительно, в рабочем каталоге автоматически создается файл конфигурации,
называемый current_session.pro. Этот файл содержит только измененные опции
конфигурации, с их новыми параметрами настройки. Если файл уже существовал, он
изменяется или новые параметры настройки добавляются в конец.

Использование Диалогового Окна Preferences

Используйте диалоговое окно Preferences для:

•  редактирования значений опций конфигурации в файлах конфигурации
Pro/ENGINEER;

•  отображения либо всех опций конфигурации и значений, либо только тех, которые
не являются значениями по умолчанию и загружаются локально;



•  определения исходного файла конфигурации для каждой отображенной опции
конфигурации;

•  сохранения копии файлов конфигурации с пользовательскими параметрами
настройки для текущих сессий.

Для вызова диалогового окну Preferences нажмите Utilities > Preferences.
Showing: выпадающий список, показывает последний считанный файл config.pro;
левая область окна показывает совокупные настройки, не являющиеся настройками по
умолчанию, которые считывались из каких либо файлов config.pro, находящихся в пути
поиска файлов в процессе загрузки Pro/E. Для каждой опции показываются значение,
статус и источник. Статус либо применен (непрерывные точки), либо конфликтующие
значения (штриховые точки). Конфликтующие значения означают, что два файла
конфигурации имеют отличающиеся значения для одной и той же опции. В этом случае
используется установка системного значения по умолчанию, пока Вы не сбросите
значение для сессии.

Источник - файл конфигурации и путь, из которого опция и значение берутся. Вы
можете использовать выпадающий список, чтобы показать опции конфигурации только
для каждого из источников.

Когда показано Current Session, снимите флажок Show Only Options..... для
отображения всех опций и значений, используемых в сессии. Когда флажок включен,
отображаются только опции и значения, загруженные из файлов config.pro.

Пиктограммы Application Effective

Пиктограмма слева от каждой опции указывает, будет ли применено изменение
немедленно или при следующем запуске. Значок молнии означает непосредственное
применение. Значок палочки означает, что изменение будет применено к следующему
созданному объекту. Пиктограмма экрана означает, что изменение будет применено в
следующей сессии.

Опции Редактирования и Значения

Когда Вы редактируете опции или значения, изменения сохраняются в файл, который
отображается в выпадающем меню Showing:, когда Вы применяете изменения. Если
отображается Current Session, изменения сохраняются в файле с именем
current_session.pro, который автоматически создается в текущем рабочем каталоге.

Для редактирования значения, выберите его в списке. Опция появляется в текстовом
поле Option:. Значение появляется в поле Value:. Если значение установлено,
например Yes или No, используйте выпадающий список. Если значение требует целого
числа, введите его.

Чтобы сбросить значение к системному значению по умолчанию, выберите значение и
нажмите Delete. Когда опция и значение будут удалены, система возвращается к
ссылочному значению умолчанию.

Управление Опциями
Используйте выпадающий список Sort: для сортировки опций в алфавитном порядке
или по категории. Вы можете также использовать кнопку Find для поиска опции,
используя текстовую строку. Например, если Вы введете ecad в поле Keyword,
диалоговое окно перечислит все опции, использующие ecad в их строках. Вы можете
также искать описания по ключевым словам. Вы можете изменять значения при поиске.
(Вы должны щелкнуть по  Apply в диалоге Preferences для сохранения изменений в
сессии.)



Запуск Вспомогательного Приложения

Для запуска, остановки, перечисления, регистрации или удаления вспомогательного
приложения:

1. Нажмите Utilities > Auxiliary Applications. Открывается диалоговое окно Auxiliary
Applications, перечисляя существующие вспомогательные приложения и их состояние.

2. Нажмите:

Register - для отображения диалогового окна Register auxiliary application для вызова
файла

Start - запуска выбранного приложения

Stop - остановки выбранного приложения

Delete - удаления выбранного приложения

Info - для отображения информации по всем существующим вспомогательным
приложениям в ИНФОРМАЦИОННОМ ОКНЕ

Перечисление, Получение или Выполнение Лицензии
Плавающего Модуля

Для получения лицензии плавающего модуля, нажмите Utilities > Floating Modules.
Открывается диалоговое окно Check_list, перечисляя плавающие модули.

Используйте Для
 Выделения всех модулей

 Снятия выделения со всех модулей

Pro/Web.Link

Pro/Web.Link дает возможность формировать пользовательские Web приложения,
которые взаимодействуют с Pro/ENGINEER через броузер Netscape Communicator Web.
Pro/Web.Link расширяет возможности этого броузера таким образом, что он может
распознавать и выполнять команды JavaScript для связи с сессией Pro/ENGINEER.

В сессии Pro/ENGINEER, Вы устанавливаете управление доступом к Pro/Web.Link в
диалоговом окне Pro/Web.Link Security.

Удаление Лицензии Pro/Web.Link

Если Вы хотите удалить собственную неиспользуемую Лицензию Pro/Web.Link (из-за
аварийного отказа программы, сбоя питания и т.д.), нажмите Utilities > Pro/Web.Link >
Release License.



Устанавливать Разрешения Доступа для Про / ткани.
Связь

Pro/Web.Link связывает Интернет с Pro/ENGINEER, давая Вам возможность
использовать его в качестве инструмента автоматизации и упрощения деталей
процесса проектирования.

Установка прав доступа для Pro/Web.Link:

1. В меню нажмите Utilities > Pro/Web.Link > Set Access Permissions. Открывается
диалоговое окно Pro/Web.Link Security
2. Проверьте Ваши права для Web страниц:

•  Read from Pro/E Session (чтение из сессии Pro/E)

•  Make changes in Pro/E Session (изменения в сессии Pro/E)

•  Read from File System (чтение файловой системы)

•  Write to File System (запись в файловую систему)

Запросите, при необходимости, новые права (если автоподсказка включена и Вы
вызывает функцию, которая требует прав, отсутствующих в  текущих параметрах
настройки).

3. Щелкните по ОК.

Регистрационные и Обучающие Файлы

Регистрационный файл - запись всех моментов выбора меню, диалоговых окон,
указаний элементов и вводов с клавиатуры конкретной рабочей сессии. Вы запускаете
регистрационные файлы для восстановления предыдущей рабочей сессии или для
исправления результатов некорректного завершения сессии.

Когда Вы запускаете регистрационный файл, система повторяет каждый выбор в
точном порядке, в котором он был сделан в исходной сессии.

Можно проводить самообучение с Pro/ENGINEER, используя обучающий
регистрационные файлы и обучающие текстовые файлы. Обучающиеся файлы имеют
директивы, проводящие Вас через примеры и отображение комментариев
(содержащихся в обучающем файле) в информационном окне.

Запуск Регистрационного или Обучающего Файла

Для запуска регистрационного или обучающего файла:

1. Выберите Trail/Training File из меню Utilities или нажмите соответствующий значок в
инструментальной панели (используйте Customize Screen в меню Utilities для
размещения кнопок в инструментальной панели). Откроется диалоговое окно Open.

2. Выберите регистрационный или обучающий файл.

Отображение Даты и Времени

Для отображения текущей даты и времени в области сообщений Pro/ENGINEER,
нажмите Utilities > Display Date/Time.



Сравнение Двух Файлов Детали

Вы можете сравнивать два файла детали или две различных версии файла детали,
для получения сообщения относительно элементов, которые отличаются в этих двух
деталях.

Для сравнения двух деталей:

1. Нажмите Utilities > Compare Part. Эта команда доступна только в режиме детали.
Откроется диалоговое окно Open, перечисляя файлы деталей в рабочем каталоге.

2. Перейдите к файлу детали, который Вы хотите использовать для сравнения и
откройте файл, чтобы сравнить его с вашей текущей деталью.

После выполнения сравнения система отображает диалоговое окно Part Comparison,
которое перечисляет все элементы, присутствующие в одной из деталей и
отсутствующие в другой. Вы можете делать следующее:

ИСПОЛЬЗУЙТЕ ДЛЯ
 Выбора следующего элемента в списке.

 Выбора предыдущего элемента в списке.

Info Отображения информации по выбранному элементу.

Сохранение Графического Изображения Модели

Для сохранения графического изображения детали или сборки:

1. Нажмите Utilities > Picture > Create.
2. Система сохраняет изображение в файле с именем <modelname>.pic.

Открытие Графического Изображения Модели

Для открытия графического изображения вашей детали или сборки:

1. Нажмите Utilities > Picture > Retrieve. Откроется диалоговое окно Open, перечисляя
только файлы графических изображений.

2. Выберите файл графического изображения для открытия.

Отображение Списка Сообщений Текущей Сессии

Для отображения списка системных сообщений Pro/ENGINEER для текущей сессии:

1. Нажмите Utilities > Message Info/Reclassify. Появляется окно Message Info со
списком сообщений.

Системные Цвета

Вы можете проводить множество изменений с цветами по умолчанию, поставляемых с
системой, и настраивая их для ваших нужд. Среди изменений, которые Вы можете
делать:

- определение, сохранение и открытие цветовой схемы

- Настройки цветов, используемых в графическом интерфейсе пользователя (GUI)



- Изменения всей вашей цветовой схемы на ранее определенную цветовую схему

- Изменение верхних или нижних цветов фона

- Переопределения основных цветов, используемых в моделях

- Назначения цвета, используемого объектом

- Сохранения цветовой схемы таким образом, чтобы Вы могли ее многократно
использовать

- Восстановления цветовой схемы, используемой ранее

Для информации относительно инициализации любого из этих изменений, см.
следующие темы.

Определение, Сохранение или Открытие Цветовой Схемы

1. Используйте меню диалогового окна System Colors следующим образом:

File > Open Восстанавливает ранее сохраненную цветовую
схему чтением файла системных цветов

File > Save Сохраняет цветовую схему в файл для
последующего использования

Scheme > Black on White Изменяет цветовую схему - черные примитивы на
белом фоне

Scheme > White on Black Изменяет цветовую схему - белые примитивы на
черном фоне

Scheme > White on Green Изменяет цветовую схему - белые примитивы на
темно-зеленом фоне

Scheme > Initial Возвращает цветовую схему к той, которая
определена настройкам файла конфигурации

Scheme > Default Возвращает цветовую схему к той, которая
определена системой по умолчанию

2. По завершении изменений системных цветов, нажмите OK в диалоговом окне
System Colors.

Переопределение Базовых Цветов

1. Нажмите Utilities > Colors > System.
2. В диалоговом окне System Colors, нажмите кнопку слева от флажка системного
цвета, который Вы хотите изменить.

Обратите внимание: система поддерживает 11 отдельных цветов. По умолчанию
назначены:

 ( Темный синий) - Фон (цвет фона в окнах Pro/ENGINEER.)

 (белый) - Геометрия (цвет, используемый для отображения
геометрии)



 (серый) - Невидимая линия (цвет, используемый для
отображения невидимых линий)

 (Желтый) - Символ (цвет, используемый для отображения текста)

 (Красный) - Подсветка - - Первичный (цвет, используемый для
отображения подсвеченной геометрии)

(нейтрально синий) - Подсветка - Кромки (цвет, используемый для
отображения подсвеченных кромок детали)

 (Светлосерый) - Подсветка - - Вторичный (цвет, используемый для
отображения подсвеченных областей типа слабой размерности и нетекущих

подразделов)

 (Зеленый) - Sheet Metal (цвет, используемый для отображения
поверхностей перемещения деталей Sheet Metal)

 (Оранжевый) - Кривые (цвет, используемый для отображения базовых
кривых)

 (Розовый) - Обрабатываемый Объем (цвет, используемый для
отображения Обрабатываемых Объемов при обработке и Литейных Объемов в

формах и отливках)

 (зеленовато-голубой) - Сечение (цвет, используемый для отображения
сечений в Sketcher)

3. В диалоговом окне Color Editor, скорректируйте RGB или HSV для создания цвета,
который Вы хотите. Например, чтобы установить Background в белый, переместите
бегунки R, G и B до конца вправо. Чтобы устанавливать Background в черный,
переместите бегунки до конца влево.

4. Когда Вы измените цветное определение, небольшое поле между кнопкой цвета и
типом примитива станет черным. Сбросьте цвет объекта назад к первоначальному.

5. Когда Вы закончите редактировать выбранный цвет, нажмите OK в диалоговом окне
Color Editor.
6. Повторить шаги 3 и 4 для изменения других цветов системы.

7. Нажмите OK в диалоговом окне System Colors.

Настройка Цветов Ul

1. Нажмите Utilities > Colors > System.
2. В диалоговом окне System Colors, нажмите кнопку слева от флажка для цвета GUI,
который Вы хотите изменить. Выбирайте из:

•  UI Editable Area (Область Редактирования)

•  UI Selected Area  (Область Выбора)



•  UI Background  (Фон)

•  UI Selected Text  (Выбранный текст)

•  UI Text (Текст)
Открывается маленькое диалоговое окно цветовой палитры.

3. Выберите цвет, который Вы хотите использовать для выбранного элемента. Если Вы
нажмете Other, откроется диалоговое окно Color Editor для создания вашего
собственного цвета.

4. Нажмите OK в диалоговом окне System Colors.

Совет: Изменение Системных Цветов, Используя Файл
Конфигурации

Вы можете изменять каждый из этих цветов при помощи файла конфигурации.
Ключевые опции:

- system_letter_color

- system_highlight_color

- system_colors_file

Вы можете вместо этого создать отдельный файл со всеми этими указанными
значениями и использовать следующие опции для определения местоположения.

- system_background_color

- system_hidden_color

- system_edge_high_color

- system_dimmed_menu_color

- system_volume_color

- system_section_color

- system_sheetmetal_color

- system_curves_color

Ключевое слово должно сопровождаться тремя десятичными значениями в диапазоне
от 0 до 100, которые определяют процент красного, зеленого и синего (в указанном
порядке) создаваемого цвета. Эти значения соответствуют тем, которые Вы видите в
полях R, G и B диалогового окна Color Editor.

Сохранение Текущей Цветовой Схемы

Для сохранения текущей цветовой схемы:

1. Нажмите Utilities > Colors > System.
2. В диалоговом окне System Colors, откройте меню File.

3. Нажмите, File > Save.
4. Используйте диалоговое окно Save для присвоения имени и сохранения файла
цветов.

Обратите внимание: Чтобы иметь эти цвета на назначенных местах в следующей
сессии, этот файл должен находится или в каталоге запуска, или обозначенным
ключевым словом system_colors_file в файле конфигурации.



Восстановление Существующей Цветовую Схему

Для восстановления существующей цветовой схемы, которую Вы предварительно
создали:

1. Нажмите Utilities > Colors > System. Открывается диалоговое окно System Colors.

2. Нажмите File > Open.
3. Выберите требуемую схему. (Имена файла для цветовых схем имеют расширение
файла .sci.)

4. Щелкните по ОК.

Установка Цветовой Схемы В Монохромную

Для изменения вашей общей цветовой схемы на существующую схему Pro/ENGINEER:

1. Нажмите Utilities > Colors > System. Открывается диалоговое окно System Colors.

2. В меню Scheme, выберите требуемую схему. Поставляемые схемы:

- Black on White (Черный на Белом)

- White on Black  (Белый на Черном

- White on Green (Белый на Зеленом)

- Initial (Исходная)

- Default (По умолчанию)

3. Щелкните по ОК.

Переназначение Цветов Объектов

В диалоговом окне Entity Colors, Вы можете изменять цвета, которые Pro/ENGINEER
использует для отображения некоторых объектов, типа базовых плоскостей или кромок
лоскутной поверхности.

Для переназначения цветов, используемых объектом:

3. Нажмите Utilities > Colors > Entity.
4. В диалоговом окне Entity Colors, нажмите кнопку слева от флажка для объекта,
который Вы хотите изменить.

5. В ярлычке Datum, Вы можете изменять назначения цветов для:

- Плоскости (+ Сторона [красный], - Сторона [желтый]. Тэг [тэг Имени, например,
DTM1])

- Ось (Осевая линия [собственно, ось], Тэг [тэг Имени, например,  A_1])

- Точка (Символ [X, который отмечает положение точки]. Тэг [тэг Имени Символа,
например, PNT1])

- Система координат (Ось, Тэг [тэг Имени, например, например, CSO])

В ярлычке Geometry, Вы можете изменять назначения цветов для:

- Внешних кромок Лоскутной поверхности
- Внутренних кромок Лоскутной поверхности
- Ссылок
- Поверхностей Sheetmetal



- Сети Сплайновой Поверхности (изменяется опцией конфигурации
mesh_spline_surf.)

6. Щелкните по цвету системы, который Вы хотите назначить объекту и нажмите OK.
7. Вы можете выбрать Scheme > Initial, чтобы сбросить все изменения цветов объектов
назад к первоначальным.

Изменение Цвета Верхнего и Нижнего Фона

1. В диалоговом окне System Colors, нажмите Edit. Открывается диалоговое окно
Blended Background.

2. Для изменения цвета верхнего или нижнего фона, выберите соответствующий
флажок.

3. Нажмите кнопку образца цвета слева от флажка. Открывается диалоговое окно Color
Editor.
4. Укажите новый цвет. Кнопка образца цвета примет новый цвет. Градации нового
цвета фона, который Вы выбрали, появятся в окне предварительного просмотра.

Обратите внимание: если Вы хотите, чтобы фон окон с трехмерными объектами,
автоматически обновлялся при изменении цвета фона, убедитесь, что выбрана опция
"Dynamically update model window". Это - опция по умолчанию.

Открытие Окна Терминала

Вы можете открывать окно терминала непосредственно из окна Pro/ENGINEER. Это
требуется, если Вы хотите использовать редактор командной строки для
редактирования файла конфигурации или выполнять другие команды операционной
системы. Вы должны выйти из окна терминала прежде, чем сможете продолжать
использовать другие функции Pro/ENGINEER.

Для открытия окна с командной строкой, нажмите Window > Open System.

Закрытие Окна

Вы можете удалить окно с экрана и продолжать сохранять объект, который был в этом
окне, в памяти. Имеются два способа удаления окна Pro/ENGINEER с экрана. Вы
можете:

- Щелкнуть по Window > Close, или
- Нажать File > Close Window.
Затем

- если в этом окне имелся объект, объект остается в памяти, пока сессия не
завершится.

- если имеется только одно окно Pro/ENGINEER, открытое на вашем рабочем столе,
команда Close удаляет активный объект из окна, но окно остается открытым.

Активизация Окна

Чтобы использовать все элементы Pro/ENGINEER, которые могут быть применены к
объекту, Вы должны активизировать окно, содержащее этот объект. В активном окне:

- в области заголовка появляются звездочки (*);



- все соответствующие функции меню этого окна становятся доступными;

- если Вы минимизируете активное окно, сворачиваются все окна;

- имя файла, связанное с объектом выбирается в списке открытых окон в меню
Window

- содержимое активного объекта отражается в Дереве Модели

Для активизации окна, нажмите Window > Activate или выберите объект из списка окон
в меню Window.

Разворачивание Окна

Чтобы увеличивать окно Pro/ENGINEER до его максимального размера, нажмите
Window > Maximize.

Восстановление Окна

Чтобы вернуть окно Pro/ENGINEER от его максимального размера к его
первоначальному размеру, нажмите Window > Restore.

Сброс Окна

Чтобы сбросить окно Pro/ENGINEER к его заданному по умолчанию размеру, нажмите
Window > Default Size.

Создание Нового Окна Pro/ENGINEER

Вы можете создавать окно Pro/ENGINEER, которое содержит копию объекта в текущем
окне. Например, Вам может потребоваться скопировать модель и, затем, создать
измененную версию модели, которую Вы затем переименуете.

Для создания нового окна на вашем рабочем столе, нажмите Window > New.
Если объект отображается в вашем текущем окне Pro/ENGINEER, он копируется в
новое окно. Новое окно Pro/ENGINEER становится активным окном.

Переключение Между Приложениями

Используйте меню Applications для переключения одного режима Pro/ENGINEER к
другому и запуска сопутствующего приложения. Доступны следующие приложения:

- Standard3/4 означает, что Вы не работаете в каком либо режиме приложения. Это -
значение по умолчанию и наиболее общий режим для использования. Это
означает, что Вы не вызываете меню или функциональность Piping, Cabling и т.д..

- Sheetmetal3/4 облегчает проектирование деталей из металлических листов. Вы
можете:

•  Проектировать детали из листа металла, определяя объем и поддержку
компонентов сборки.

•  Добавлять элементы листа металла типа стенок, изгибов и вырезов

•  Создавать таблицы гибов и порядок таблицы гибов



•  Создавать плоский образец детали

•  Создавать рисунок, содержащий "плоский образец" и " как предназначено" детали
sheetmetal и таблицу порядка гиба, используемую для производства

- Legacy3/4 предназначена для импорта и обновления трехмерных данных и
двухмерных рисунков в Pro/ENGINEER. Используя инструментальные средства
Pro/LEGACY, Вы можете создавать, изменять и удалять отдельные геометрические
объекты в пределах импортированных трехмерных данных, а также работать с
геометрией и подробной информацией в двухмерных рисунках.

- Scantools3/4 предназначен для т.н. "обратного" инжиниринга, эти функциональные
возможности позволяют проектировщикам делать следующее:

•  читать большие наборы данных;

•  отфильтровывать и структурировать сканированные данные;

•  автоматически совмещать и динамически управлять кривыми и поверхностями;

•  графически отображать в реальном времени обратную связь;

•  комбинировать стилизованные поверхности с параметрическими поверхностями и
твердотельными элементами;

•  изменять импортированные поверхности.

- � Mechanica3/4  показывает, как изделие будет функционировать в его рабочей
среде и позволяет разработчикам неспециалистам исследовать механические
характеристики альтернативных проектов без формирования прототипов. С этой
возможностью, Вы можете улучшать характеристики проекта на стадии разработки,
когда проще и дешевле проводить изменения.

- FEM3/4 использует Конечно-Элементное Моделирование (FEM) для создания
математической модели, которая представляет механическую деталь или сборку,
сконструированную в Pro/ENGINEER.

- Plastic Advisor3/4 позволяет быстро проектировать высококачественные и
технологичные пластмассовые детали, получаемые методом литья под давлением,
без экспертизы процесса обработки пластмассы. Plastic Advisor создает экранную
анимацию заполнения литейной формы и обеспечивает легкую для понимания
обратную связь технологичности, помогающую Вам создавать корректную
конструкцию без изменений в последнюю минуту и переделки дорогостоящих
пресс-форм.

- Mold/Casting3/4 в режиме Детали, если Вы выбираете Application, Вы получаете
Mold/Casting. Эта опция позволяет Вам создавать элементы литейной
формы/отливки типа Линии Разъема, Линии Уклона, Уклона, Касательного Уклона,
Эквидистантной Области, односторонней Обрезки, Ватерлиний и литников в
режиме Детали. Работа возможна только, если пользователь находится в сессии
где активны лицензии Pro/MOLDESIGN и-или Pro/CASTING (опция TOOL DESIGN).

- NC Post Processor3/ /4 используйте эту опцию для запуска NC постпроцессора
PTC, Pro/NC-GPOST. Постпроцессор используется для трансляции файлов CL,
сгенерированных Pro/NC в коды G/M для станков ЧПУ. Pro/NC-GPOST - инструмент,
используемый для разработки NC пост-процессоров для конкретных станков ЧПУ.
Вам потребуется по одному постпроцессору для каждого станка NC на вашем
предприятии.

Постоянные и Плавающие Лицензии

В Pro/ENGINEER, имеются два типа лицензий:

•  Постоянные Лицензии - если Вы имеете конфигурацию фиксированной лицензии,
Вы можете работать Pro/ENGINEER только на указанных машинах.



•  Плавающие Лицензии - конфигурация плавающих лицензий Pro/ENGINEER
позволяет лицензиям Pro/ENGINEER "перетекать" на любую машину, способную
запускать Pro/ENGINEER в сети. В этой конфигурации, возможность работать с
Pro/ENGINEER не ограничена конкретными машинами.

Когда Вы запускаете Pro/ENGINEER, никакая проверка состояния плавающих лицензий
не выполняется. Когда Вы выбираете приложение или режим, который требует
плавающей лицензии, Pro/ENGINEER выясняет, все ли позиции плавающей лицензии
заполнены. Если все позиции заполнены, Pro/ENGINEER отображает сообщение,
указывающее, что плавающая лицензия находится в использовании.

Справка

Используйте меню Help, чтобы получить доступ к интерактивной информации
сервисной информации для Pro/ENGINEER. Следующие команды доступны в меню
Help Pro/ENGINEER:

•  Pro/E Help System - отображает контекстно-зависимую систему интерактивной
справки. Когда Вы выбираете эту систему, открывается ваш системный броузер и
отображает дерево и средства поиска, чтобы помочь Вам в обнаружении
определенных разделов справки. Вы можете также обращаться к этим разделам,
выбирая контекстно-зависимую Справку в окнах, командах меню и диалоговых
окнах (см. What's This).

•  Customer Services Info - Отображает информацию по программе, включая версию,
информацию по лицензии, дату инсталляции и контактную информацию для
пользователя.

•  Round Tutor - Делает доступным или недоступным Pro/ENGINEER Feature Tutor.

•  About Pro/ENGINEER - Отображает информацию авторского права Pro/ENGINEER.

•  What�s This? - включает контекстно-зависимый режим справки.

Отображение Справки

Вы можете отображать интерактивную справку Pro/ENGINEER любым из следующих
способов:

 1. Щелкните левой кнопкой мыши по кнопке контекстно-зависимой помощи ( )
на инструментальной панели. Курсор изменит свой вид на курсор Режима справки.

2. Переместите курсор к опции меню, пиктограмме или диалоговому окну, для которого
Вы хотите получить справку.

3. Нажмите левую (или правую) кнопку мыши.

ИЛИ

a. Выберите Help > What�s This. Курсор изменит свой вид на курсор Режима справки.

b. Переместите курсор к опции меню, пиктограмме или диалоговому окну, для которого
Вы хотите получить справку.

4. Нажмите левую (или правую) кнопку мыши.

ИЛИ

Переместите указатель поверх активного пункта меню, чтобы отобразить короткое
описание в справочной области внизу основного окна.



Использование Справочной Системы Pro/ENGINEER

Используйте справочную систему Pro/ENGINEER для поиска информации по
использованию команд меню Pro/E, диалоговых окон и окон.

Чтобы запустить Pro/ENGINEER справочную систему, нажмите Help > Pro/E Help
System.
Вы можете также обращаться к справочной системе Pro/ENGINEER, нажимая на пункты
меню Pro/ENGINEER и диалоговые окна в контекстно-зависимом режиме справки.

Для перехода к этому режиму, нажмите Help > What's This.

Отображение Сервисной Информации Пользователя

Для получения сервисной информации пользователя, звоните вашему ближайшему
сервисному представителю. Для информации относительно вашего сервисного
представителя, нажмите Help > Customer Services Info. Открывается окно,
отображающее следующее:

•  Информацию по вашей инсталляции, включая лицензию и информацию по машине

•  Список установленных опций

•  Адрес штаб-квартиры компании PTC

•  Контактную информацию о сервисных представительствах во всех странах мира.

Включение Обучающей Программы Round Tutor

Обучающая программа Round Tutor была создана, чтобы помочь Вам приобрести опыт
при использовании мощных возможностей скругления Pro/ENGINEER.

Скругление кромок детали может явиться сложной операцией, требующей
углубленного понимания Pro/ENGINEER и требующей, чтобы Вы знали пути, которыми
методы конструирования и отношения родитель / потомок воздействуют на содержание
вашей конструкции.

Обучающая программа Round Tutor постепенно проводит Вас через процесс создания
скругления. На каждом шаге, Обучающая программа Round Tutor представляет ваши
опции и объясняет, как каждый вариант воздействует на конечный продукт.

Множество изображений Обучающей программы Round Tutor содержат перекрестные
ссылки на основные определения, подсказки, справочную информацию, знания
геометрии и полностью рассмотренные примеры. Подробности, содержащиеся в этих
примерах, доступны в формате Pro/ENGINEER на компакт-диске, чтобы Вы могли
исследовать модели и пробовать скруглить их самостоятельно.

Для включения Обучающей программы Round Tutor, нажмите Help > Round Tutor.
При создании скругления, обучающая программа постарается помочь Вам.

Отображение Информации о Версии

Вы можете отобразить версию и информацию авторского права вашей версии
Pro/ENGINEER. Для отображения этой информации, нажмите Help > About
Pro/ENGINEER.



Использование Контекстно-зависимой Справки

Контекстно-зависимая справка доступна для пунктов меню, пиктограмм
инструментальной панели и диалоговых окон. Для отображения справки:

1. Щелкните левой кнопкой мыши по пиктограмме What's This?
2. Сделайте одно из следующего:

•  Щелкните на значке инструментальной панели по которому Вы хотите получить
информацию.

•  Откройте меню и щелкните по опции меню, для которой Вы хотите справку.

•  если Вы открыли диалоговое окно, щелкните левой кнопкой мыши в любой области
открытого диалогового окна.

3. В окне броузера появляется справка. Закройте ее, когда Вы закончите, щелкая по X в
верхнем правом углу.

Функциональные Возможности i-Site

i-Site PTC является ресурсом, который Вы можете использовать, чтобы выяснить
общие тенденции развития промышленности и новости, а также получить информацию
по программам PTC, новости, советы, поддержку пользователей PTC.

i-Site является сервисом для клиентов PTC. Базирующийся на обратной связи
пользователя, i-Site будет развиваться и приспосабливаться для обеспечения
требуемой информации, отвечающей вашим потребностям.

Вы можете выключить запуск i-Site при запуске приложения PTC в опции i-Site
Preferences меню Help.

Включение/Отключение i-Site при Запуске

Вызовите диалоговое окно i-Site Preferences, щелкая по Help > Preferences i-Site. В
этом диалоговом окне, Вы можете указать, хотите ли, чтобы i-Site PTC появлялся,
каждый раз при запуске Pro/ENGINEER. Настройка по умолчанию использует его
появление каждый раз. Вы можете снять галочку, чтобы отменить этот режим.

В диалоговом окне, Вы можете также узнать более подробно про i-Site.

Структура Модели

Окно Model Tree перечисляет каждый объект конструкции в иерархически-
упорядоченном формате. Окно может быть плавающим или зафиксированным в
рабочей области. Если Вы имеете несколько открытых окон, Дерево Модели активно
для активного окна. Вы можете фильтровать отображение в структуре Модели по типу
элемента или по статусу, например, показывать или скрывать базовые объекты или
подавленные объекты. Вы можете использовать значок на основной инструментальной
панели для отображения или скрытия Дерева Модели. Вы можете также сохранять и
многократно использовать параметры настройки Дерева Модели в .cfg файле.

Значок рядом с каждым элементом дерева отражает тип объекта, например, сборку,
деталь, элемент или базовый элемент. Значок может также показывать видимость или
состояние завершения, например, подавленное или несгенерированное.

Выбор в Дереве Модели



Вы можете использовать Дерево Модели для выбора элемента или детали для
редактирования, когда они не видимы в графическом окне. Когда элемент выбран, Вы
можете нажимать правую кнопку мыши, чтобы выбрать определенные команды из
всплывающего меню.

Добавление Столбцов
Вы можете добавлять информационные столбцы к окну дерева модели, содержащие,
например, параметры и значения, назначенные слои или имя элемента для каждого
объекта. Вы можете использовать ячейки в столбцах для выполнения контекстно-
зависимого редактирования и стирание.

Переупорядочение Элементов
Вы можете переупорядочивать объекты в конструкции, перемещая их вверх или вниз в
дереве модели. Если Вы перемещаете дочерний объект на уровень выше его
родителя, родитель также перемещается, чтобы сохранить статус родитель/потомок.

Отображение Дерева Модели в Отдельном Окне

1. Нажмите, Utilities > Customize Screen. Появляется диалоговое окно Customize.

2. Нажмите ярлычок Options.

3. В параметрах настройки Default Model Tree, включите или снимите флажок Display
Model Tree as a Separate Window.
4. Щелкните по ОК.

Настройка Ширины и Положения Дерева Модели

1. Нажмите, Utilities > Customize Screen. Появляется диалоговое окно Customize.

2. Нажмите ярлычок Options.

3. Используйте бегунки Placement, Height и Width, чтобы установить требуемую
позицию.

4. Щелкните по ОК.

Отображение или Скрытие Дерева Модели

Для отображения или скрытия Дерева Модели:

В основной инструментальной панели, нажмите кнопку Model Tree on/off

Разворачивание или Сворачивание Списка Элементов в
Дереве Модели

В меню View > Model Tree Setup, выберите Tree > Expand или Tree > Collapse, с
последующим All, Branch или One.



Перечень Элементов и Деталей в Дереве Модели

Когда Вы вызываете модель, Pro/ENGINEER отображает информацию по ее геометрии
в активном окне. По умолчанию, он также отображает структуру модели в
иерархическом виде в окне Model Tree.

Когда Вы вызываете деталь или сборку, Дерево Модели отображает корневой объект
вверху дерева и подчиненные объекты под ним.

После отображения элементов верхнего уровня объекта в Дереве Модели, Вы можете
отображать более подробные элементы, связанный с любым из элементов или
деталей.

Добавление Столбцов Статуса и Типа к Дереву Модели

Вы можете быстро определять тип, подтип, и состояние элемента, глядя на
отображаемые столбцы или пиктограммы в Дереве Модели.

1. Нажмите View > Model Tree Setup > Column Display. Появляется диалоговое окно
Add/Remove.

2. В списке Type, укажите тип (например, обрезанная поверхность) и подтип (например,
выдавливание, вращение, протягивание и т.д) элемента.

Пиктограммы обозначают статус элемента, типа нерегенерированный, ошибочный и
т.д.

Перемещение Положения Вставки Дерева Модели

В Дереве Модели имеется значок в виде стрелки, которая указывает, где элементы
будут вставлены после создания. По умолчанию, он всегда находится в конце
Структуры Модели. Вы можете перетащить положение узла выше или ниже в дереве,
чтобы вставить элемент в другой точке. Когда узел переносится в новое положение,
модель прокручивается назад или вперед, в соответствии с перемещением узла
вставки.

Переупорядочивание Элементов в Дереве Модели

Вы можете переупорядочивать элементы в Дереве Модели, перемещая один или более
элементов в новое положение в списке элементов. Если Вы переместите дочернюю
деталь выше, чем ее родительская деталь, родительская деталь тоже переместится,
чтобы сохранить статус родитель/потомок.

Для переупорядочивания элементов:

1. Выберите один или более элементов одной и той же модели, которые Вы хотите
переместить в новое положение в списке элемента модели.

Обратите внимание: Чтобы выбрать более одного элемента, удерживайте клавишу
CTRL при щелчке левой кнопки мыши на каждом элементе. Для выбора группы
элементов, щелкните по первому (один конец диапазона) и удерживая клавишу SHIFT,
щелкните по последнему (другой конец диапазона).

2. Щелкните по одному из выбранных элементов левой кнопкой мыши и, удерживая
кнопку мыши, перетащите группу в новое положение в списке элементов, затем
отпустите кнопку мыши. Иллюстрация ниже показывает стрелки перетаскивания с
одним элементом, несколькими элементами и операцию перетаскивания
родитель/потомок.



Обратите внимание: Элементы, которые не могут быть переупорядочены, например
подавленные элементы или трехмерные примечания, отмечаются значком запрета при
попытке их перемещения.

Добавление Столбцов Информационных Параметров

Обратите внимание: параметры элемента могут применяться к любому элементу
объекта, в то время как параметры модели применяются только ко всей модели.

1. Нажмите View > Model Tree Setup > Column Display. Появляется диалоговое окно
для настройки столбцов в Дереве Модели.

2. В раскрывающемся списке Type, нажмите Model Params или Feat Params.
3. Укажите имя параметра в поле Name в левой нижней части диалогового окна.
Нажмите Enter. Таким образом автоматически добавляется новый параметр для
столбца Displayed в диалоговом окне.

4. Нажмите OK в диалоговом окне. Столбец добавлен к Дереву Модели.

5. Выберите элемент в Дереве Модели, к которому Вы хотите применить новый
параметр.

6. Щелкните в новом столбце параметра напротив выбранного элемента. Открывается
диалоговое окно.

7. Нажмите String, Real Number, Integer или Yes/No.
8. Щелкните по ОК. Выбранная ячейка остается подсвеченной, и текстовая область
ввода ниже меню в окне Model Tree становится активной.

9. Нажмите в поле и введите данные согласно типу параметра, который Вы выбрали.

10. Нажмите, Enter. В случае переменных чисел, система автоматически заполняет
десятичное число до шести знаков. В случае переменной Yes/No, система
автоматически заполняет ответ Y или N.

Удаление Параметра, используя Дерево Модели

Если Вы использовали View > Model Tree Setup > Columns для включения столбца в
Дерево Модели для параметров объекта, Вы можете выбрать ячейку, содержащую
параметр и нажать DEL, затем Enter. Ячейка и формат ячейки будут очищены.

Создание Примечания Модели, используя Дерево Модели

1. Щелкните правой кнопкой мыши по элементу в списке Model Tree.

2. Щелкните по Note Create > Feature.
3. Укажите имя примечания в поле Name или используйте значение по умолчанию.

4. Введите текст примечания в поле Text или нажмите Insert, чтобы вставить текст из
файла или из другого примечания.

5. (Необязательно) Выберите Symbols для вызова галереи символов, чтобы добавить
их к примечанию.



6. (Необязательно) Щелкните по Placement, чтобы указать опцию присоединения
примечания к отображенному объекту.

7. Нажмите OK, чтобы создать примечание и присоединить примечание к выбранному
объекту.

Изменение Примечания Модели, Используя Дерево
Модели

1. В Дереве Модели, выберите примечание модели.

2. Щелкните правой кнопкой мыши по примечанию для отображения меню команд.

3. Щелкните по Modify для отображения диалогового окна, используемого для
создания примечания модели.

4. Измените примечание модели и нажмите OK для сохранения изменения.

Отображение или Скрытие Элементов по Типу в Дереве
Модели

1. Нажмите View > Model Tree Setup.
2. Нажмите Tree > Show для отображения меню необязательных параметров
настройки.

3. Выберите одну или более команд в отображенном меню.

Выбор Объектов, Используя Дерево Модели

Всякий раз, когда Вам потребуется выбрать детали или элементы в Pro/ENGINEER, Вы
можете выбирать их из Дерева Модели, щелкая по названию элемента или детали.
Когда Вы выбираете объект в Дереве Модели, Pro/ENGINEER активизирует окно,
содержащее этот элемент или деталь и подсвечивает выбранный объект.

После того, как Вы выбрали элемент, используя Дерево Модели, Вы можете выполнять
часто используемые команды, соответствующие этому элементу. Каждый элемент,
который Вы выбираете, имеет уникальный набор команд.

Выбор Команд для Выбранных Элементов в Дереве
Модели

1. Выберите элемент или деталь, перечисленные в Дереве Модели.

2. Щелкните правой кнопкой мыши по элементу или детали для отображения меню
используемых команд, соответствующих этому элементу или детали.

3. Выберите команду из отображенного меню.

Повторное Использование Конфигурации Дерева Модели

1. Нажмите Utilities > Model Tree Settings > Save.



2. Примите заданное по умолчанию название tree.cfg или назначьте новое.

3. Щелкните по ОК.
Вы можете использовать опцию mdl_tree_cfg_file файла конфигурации для указания
файла конфигурации дерева, который будет загружен при запуске Pro/ENGINEER.

Обратите внимание: Нажмите Utilities > Model Tree Settings > Load для
восстановления файла конфигурации.

Выполнение Поиска с Единственным Условием,
Используя Дерево Модели

Для упрощения в поиске используется только один параметр для квалификации
элементов в Дереве Модели. Такой тип поиска обеспечивает наиболее общие
результаты.

1. Нажмите Tree > Search для отображения диалогового окна Search для Дерева
Модели.

2. Выберите тип информации в списке Type и соответствующие значения в списке
Value. Для существующих типов информации, существующие элементы появляются в
списке Value справа. Уточните ваши критерии, выбирая = (равно) или ! = (не равно).

Обратите внимание: Все, кроме одного, параметры непосредственно ссылаются на
тип столбца, доступный в Дереве Модели. Параметр Model Expression относится к
выражению, которое будет искаться в списке параметров Model.

3. Если Вы щелкните по типу Model Parameter, введите название параметра в
текстовом поле под списком Value.

4. Щелкните по Add/Change для добавления текущего определения критериев к списку
критериев поиска в нижней части диалогового окна.

5. Щелкните Find для выполнения поиска в Дереве Модели. Начните с верхней части
Дерева Моделей (или текущей ячейки, если она выбрана), поиска переходит к
следующему элементу, который отвечает критерию поиска.

6. Щелкните по Close при завершении поиска.

Примечания:

•  для удаления условий поиска и использования другого, выберите условие в списке
критериев поиска и нажмите Remove. Условие будет сброшено и может
использоваться новое условие.

•  Для изменения условия, выберите условие и нажмите Add/Change. Затем, Вам
представится возможность его переопределить.

Выполнение Поиска с Несколькими Условиями,
Используя Дерево Модели

Для выполнения более точного поиска, необходимо иметь несколько параметров
поиска. Средство поиска позволяет легко устанавливать и настраивать такие операции.

1. Нажмите Tree > Search для отображения диалогового окна Search для Дерева
Модели.

2. Выберите тип информации в списке Type и соответствующие значения из списка
Value. Для существующих типов информации, существующие элементы появляются в
списке Value справа. Уточните ваши критерии, выбирая = (равно) или ! = (не равно).



Обратите внимание: Все, кроме одного, параметры непосредственно ссылаются на
тип столбца, доступный в Дереве Модели. Параметр Model Expression относится к
выражению, которое будет искаться в списке параметров Model.

3. Если Вы щелкните по типу Model Parameter, введите название параметра в
текстовом поле под списком Value.

4. Щелкните по Add/Change для добавления текущего определения критериев к списку
критериев поиска в нижней части диалогового окна.

5. Повторите шаги со 2 по 4, пока все условия не будут определены. Как только
дополнительные условия будут включены в поиск, они появятся в списке критериев
поиска, отделенных заданным по умолчанию оператором AND. Для изменения этого
оператора, выберите его в списке и, затем, нажмите кнопку AND или OR над списком.

Элементы в круглых скобках рассчитываются вместе, как в следующем примере:

(условное выражение AND условное выражение) OR (условное выражение)

6. Щелкните Find для выполнения поиска в Дереве Модели. Начните с верхней части
Дерева Моделей (или текущей ячейки, если она выбрана), поиска переходит к
следующему элементу, который отвечает критерию поиска.

Примечания:

•  для удаления условий поиска и использования другого, выберите условие в списке
критериев поиска и нажмите Remove. Условие будет сброшено и может
использоваться новое условие.

•  Для изменения условия, выберите условие и нажмите Add/Change. Затем, Вам
представится возможность его переопределить.

Связывание URL с Объектом, Используя Дерево Модели

1. В Дереве Модели, выберите объект, с которым Вы хотите связать URL.

2. Щелкните правой кнопкой мыши по элементу в списке Model Tree для отображения
меню команд, связанных с этим объектом.

3. Щелкните по Note Create > Feature.
4. Введите Web адрес или название Web-сайта в поле URL.

5. (Необязательно) Щелкните по Open для запуска вашего броузера по умолчанию и
загрузите указанный URL в броузер.

6. Нажмите OK для создания примечания.

Обратите внимание: чтобы увидеть адрес, выберите Set up > Notes > Open URL и,
затем, выберите примечание в графическом окне.

Выбор в Графическом Окне

Выбор в графическом окне - это объектное действие, это означает, что Вы можете
заранее выбирать элементы в графическом окне без первоначального указания, что Вы
намереваетесь делать с ними.

Вы можете выбирать:

•  элементы;

•  компоненты;

•  трехмерные примечания.



Для выбора объекта, нажмите на объект, который Вы хотите выбрать. Pro/ENGINEER
подсветит выбранный объект красным. Для выбора нескольких объектов нажмите
SHIFT при выборе.

Обратите внимание: выбор с объектным действием также доступен в окне Model Tree.

Использование Меню GET SELECT

Выберите из следующих опций:

- Pick - выбирает видимую (не скрытую) геометрию и все базовой плоскости и оси.

- Pick Many - выбирает несколько объектов за раз. В некоторых случаях, система
запрашивает Вас выбрать две точки, которые определяют диагональ поля. Все
объекты, полностью попавшие в поле будут выбраны. В других случаях, появляется
меню PICK MANY.

- Query Sel - выбирает скрытую геометрию или, в случаях, когда могут быть выбраны
более одного элемента в выбранном точке, выберите требуемый элемент.
Подсвечивает все геометрические объекты в выбранном точке, начиная с первого
видимого геометрического объекта.

- Вы может также использовать кнопки мыши для выполнения операции Query Sel.
Используйте левую кнопку для выбора меню и выберите на экране, правую кнопку
для выбора Next или сброс для Query Sel и среднюю кнопку для выбора Accept.

- После того, как Вы выбрали на экране, используя Query Sel, появляется меню
CONFIRM.

- Sel By Menu - выбирает элементы по имени, внутреннему ID (идентификатору
примечание переводчика) или номеру регенерации. Появляется меню SPECIFY BY.

- Unsel Last - отменяет выделение последней кромки, поверхности, элемента или
наименования. Каждый раз, когда Вы выбираете Unsel Last, снимается выделение
со следующего объекта. С объектов снимается выделение в порядке, обратном
выбору - выбран последним, снимается первым.

- Unsel Item - снимает выделение с последнего наименования.

- Rehighlight - подсвечивает все ранее выбранные элементы. Эта опция может быть
полезна после перерисовки. Если Вы первый раз выберите Rehighlight, выбранные
элементы восстанавливают изображение в своих цветах подсветки. Если Вы
выберите Rehighlight снова, каждый выбранный элемент отображается
дополнительным цветом. Если Вы продолжаете выбирать эту опцию, цвета
выбранных элементов продолжают переключаться между этими двумя цветами.

- Done Sel- принимает сделанный выбор, выходит меню GET SELECT и продолжает
текущий процесс.

- Quit Sel - игнорирует сделанный выбор и выходит из текущего процесса.

Использование Нескольких Меню GET SELECT

Если меню GET SELECT используется и требуется дополнительный выбор,
дополнительное меню GET SELECT получают с последовательным номером в области
заголовка меню (GET SELECT 1, GET SELECT 2).

Дополнительное меню будет появляться в следующих ситуациях:

- Если при открытом GET SELECT, Вы выбирает опцию ориентации, которая требует
выбора плоскости или кромки. Дополнительное меню GET SELECT позволяет Вам
выбрать плоскость или кромку.



- При создании элемента, например, отверстия, в сборке, система запросит Вас
выбрать плоскость размещения. Если Вы выберете меню Sel By, система запросит
Вас выбрать объект для последующего выбора из меню. Дополнительное меню
GET SELECT позволяет Вам выбрать модель.

Подобно, любой выбор в сборке, который требует, чтобы модель была выбрана перед
собственно выбором, выдает дополнительное меню GET SELECT.

- если Вы выбираете, Unsel Item, как в команде Suppress, дополнительное меню
GET SELECT даст Вам возможность выбрать элемент или элементы для снятия
выделения.

Использование Меню PICK MANY

Используйте меню PICK MANY для выбора нескольких объектов за раз. Это меню
содержит следующие опции:

- Pick Box - Выделите всё объекты в пределах rubberband (м.б. резинового
примечание переводчика) поля. Левой кнопкой мыши, укажите противоположные
углы поля. Нажмите среднюю кнопку мыши для запуска команды и левую кнопку
мыши для завершения действия.

- Pick Chain - Выделите всё объекты, которые соединены вместе, типа цепочки.

- Pick Poly - выделите всё объекты в пределах границы полилинии. Левой кнопкой
мыши, выберите точки ломаной линии, которые окружают выбираемые объекты.
Нажмите среднюю кнопку мыши для завершения выбора. Система создает
полилинию от выбранной точки до первой точки (если конечная точка не совпадает
с первой точкой). Нажмите среднюю кнопку мыши для запуска команды и левую
кнопку мыши для завершения действия.

- Inside Box - Выделите всё элементы, которые полностью находятся в пределах
поля. Эта опция доступна только, если выбрано Pick Box.

- Across Box - Выделите всё элементы, которые частично или полностью находятся
в пределах поля. Эта опция доступна только, если выбрано Pick Box.

Использование Меню CONFIRM

Используйте меню CONFIRM для проверки выбора. Это меню содержит следующие
опции:

- Accept - подтверждает текущую подсвеченную геометрию в качестве выбранной
геометрии.

- Next - переходит через следующий выбор геометрии и подсвечивает ее красным.
Если не имеется никаких других объектов в точке выбора, эта опция недоступна.

- Previous - возвращает к предыдущей подсвеченной геометрии. Если не имеется
никакого предыдущего выбора, опция недоступна.

Использование Меню SPECIFY BY

Используйте меню SPECIFY BY для выбора элементов (базовый элемент, кромка, ось,
поверхность) по имени, внутреннему ID (идентификатору примечание переводчика) или
номеру регенерации. Это меню содержит следующие опции:

- Name - Выбирает элемент по его имени. Появляется список NAMES, который
включает все имена, данные системой (типа имен базовой плоскости или системы



координат) и всех пользовательских имен, введенных при создании элемента.
Опция переключателя обозначает выбранные имена.

- ID - выбирает элемент по его внутреннему номеру базы данных. Этот номер
остается постоянным независимо от переупорядочения или подавления элемента.
Используйте эту опцию для подавленных элементов. Чтобы выяснить внутренний
ID элемента, выберите Info > Feature List.

- Number- выбирает элемент по его номеру регенерации. Этот номер может
изменяться, если элементы были добавлены, удалены, подавленный или
переупорядочены. Чтобы выяснить номер регенерации элемента, выберите Info >
Feature List.

- Last Feature - выбирает последний созданный элемент.

Обратите внимание: Когда Вы выбираете ID или Number, Вы можете продолжать
вводить внутренний ID номер элемента или номер регенерации элемента, пока не
нажмете ENTER и не выйдите из процесса.
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