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Глава 1 

Введение в Pro/ENGINEER 

В этой главе обсуждаются основные элементы и концепции Pro/ENGINEER. 

Цель 

В этой главе Вы изучите: 

• Pro/ENGINEER в качестве инструмента твердотельного моделирования. 

• Три основные концепции конструирования Pro/ENGINEER. 

Основные Концепции Pro/ENGINEER 

Pro/ENGINEER используется для создания твердотельных моделей (solid models) в процессе 
проектирования. Трехмерная рабочая среда позволяет воспользоваться преимуществами: 

• моделирования с использованием элементов (Features). 

• Ассоциативностью. 
• Параметрическими зависимостями. 

Твердотельное моделирование имеет много преимуществ перед двухмерными конструкциями: 

• твердотельное моделирование имеет объем и площади поверхностей. 

• Масс-инерционные характеристики можно вычислять на основе создаваемой геометрии. 

• При манипулировании моделью она продолжает оставаться твердотельной. 

 
Рисунок 1: Различные Виды Твердотельной Модели 
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Конструирование Моделей на Основе Элементов 
Модели в Pro/ENGINEER создаются на основе элементов (feature-based). Это означает, что 
геометрия модели детали состоит из одного или более элементов. Элемент - самый маленький 
кирпичик в модели детали. 

Pro/ENGINEER позволяет строить модель поэтапно, по одному добавляя отдельные элементы. В 
процессе создания модели, конструктор выбирает требуемые компоновочные блоки и порядок их 
выстраивания. 
Создание моделей в Pro/ENGINEER неразрывно связано с понятием «следовать назначению 
конструкции (design intent)». Назначение конструкции является причиной добавления каждого 
последующего элемента. Например, элементы отверстия добавляются к модели потому, что 
результирующая деталь должна быть собрана с другой деталью, а отверстия необходимы для винтов. 
Следующий рисунок показывает, как типичная деталь может быть спроектирована путем добавления 
одного элемента за другим к базовой модели. 

 
Рисунок 2: Построение Модели Элемент за Элементом 

Проектирование с Параметрическими Элементами 
Конструкции, создаваемые в Pro/ENGINEER, могут быть параметрическими. Это означает, что их 
размеры управляются параметрами. 

Параметрическое моделирование имеет много преимуществ: 

• геометрия модели может изменяться путем изменения параметров. 

• Созданные элементы могут зависеть друг от друга. 

• Изменения одних элементов влекут изменения других элементов. 

• Между элементами могут быть созданы зависимости Родитель/Потомок (Parent/child). 
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Рисунок 3: Выступ и Отверстие Следуют За Изменением Блока 

Использование Преимуществ Ассоциативности 
Компоненты Pro/ENGINEER обычно состоят из нескольких деталей, сборок и рисунков. Все эти 
объекты в Pro/ENGINEER полностью ассоциативны. Это означает, что изменения, сделанные на 
одном уровне передаются на все уровни. Например, при изменении размера в рисунке, такое же 
изменение произойдет и в сопутствующей детали. На следующем рисунке показана ассоциативность 
между деталью и сборкой. 

 
Рисунок 4: Ассоциативность 
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Глава 2 

Интерфейс Pro/ENGINEER 

В этой главе обсуждается использование интерфейса Pro/ENGINEER для эффективной 
работы в процессе конструирования. 

Цели 
В этой главе Вы изучите: 

• интерфейс Pro/ENGINEER. 

• Различные типы файлов. 

• Операции вызова, сохранения стирания и удаления файлов в Pro/ENGINEER. 

• Дерево Модели (Model Tree) и Менеджер Меню (Menu Manager) 

• Понятия параметрический, ассоциативный и элемент, применительно к моделям Pro/ENGINEER. 

Интерфейс Pro/ENGINEER 

 
Рисунок 1: Образец Модели в Главном Окне 

При запуске Pro/ENGINEER, на рабочем столе открывается главное окно. В этом окне выполняется 
процесс проектирования. Это окно имеет четыре главных части: 
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• Выпадающие меню 

• Меню пиктограмм 

• Графическое окно 

• Область сообщений 

Вызов Команд в Выпадающем Меню 
Можно использовать следующие выпадающие меню Pro/ENGINEER: 

• File  - команды управления файлами 

• Edit  - команды управления и обработки объектами 

• View - команды отображения модели 

• Datum - команды управления опорными элементами (datum feature) 
• Analysis - команды работы с моделями, поверхностями, кривыми, движением, 

чувствительностью (sensitivity) и оптимизацией (optimization) 

• Info  - команды обработки запросов и отчетов 

• Application - исполняемые модули Pro/ENGINEER 

• Utilities - команды настройки рабочей среды Pro/ENGINEER 

• Windows - команды управления окнами 

• Help - команды справки 

Вызов Часто Используемых Команд из Меню Пиктограмм 
Меню пиктограмм Pro/ENGINEER содержит пиктограммы часто используемых команд. Они 
используются в качестве альтернативы командам выпадающих меню. Пиктограммы в меню могут 
настраиваться. 

 
Рисунок 2: Меню Пиктограмм Pro/ENGINEER 

Управление Проектами в Графической Области 
Pro/ENGINEER отображает детали, сборки, рисунки и модели на экране в графической области. 
Отображение объектов зависит от текущих настроек среды. При выборе модели на экране, система 
различает между кромкой и поверхностью модели и подсвечивает их двумя различными цветами. 

Обратите внимание: 
Поверхности моделей в Pro/ENGINEER являются действительными вне зависимости от отображения 
модели. 

Просмотр Информации в Области Сообщений 
Область сообщений: 

• отображает вспомогательную информацию по каждой выполняемой операции. 

• Отображает запросы и подсказки для помощи при выполнении текущей задачи. 

• Запрашивает дополнительную информацию (текстовое сообщение, сопровождаемое 
опциональным звуковым сигналом). 

• Отображает пиктограммы, представляющие различную информацию, типа предупреждающих 
сообщений или запросов. 

Для просмотра старых сообщений можно использовать линейку прокрутки, расположенную справа. 

Обратите внимание: 
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Когда Pro/ENGINEER требует ввода данных, он временно блокирует все другие функции, пока 
требуемые данные не будут введены. 

Работа С Моделями 

Типы Файлов 
Каждый тип объектов Pro/ENGINEER имеет различные расширения файла. Типичные расширения 
файлов описаны ниже. 

• PRT � файлы деталей, содержащие трехмерные модели, состоящие из различных элементов. 

• ASM � файлы сборок, содержащие информацию по сборке вместе трехмерных деталей и узлов. 

• DRW - файлы рисунков, содержащие полную образмеренную двухмерную геометрию деталей и 
узлов. 

• SEC � файлы эскизов, содержащие двухмерные неассоциативные эскизы, которые могут быть 
импортированы в процессе эскизирования. В режиме эскизирования (SKETCHER) можно 
создавать параметризованные двухмерные эскизы. 

Работа с Диалоговыми Окнами 
Диалоговые окна в Pro/ENGINEER используются для манипуляции моделями, создания элементов и 
сохранения. Имеются два вида диалоговых окон: основные (general) и модели (model). 

Основное Диалоговое Окно 
Основное диалоговое окно выполняет общие функции типа сохранения, просмотра и организации 
запросов. Следующий рисунок представляет некоторые из основных элементов в стандартном 
диалоговом окне. 

 
Рисунок 3: Пример Диалогового Окна 
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Диалоговое Окно Модели 
В диалоговом окне модели создается и изменяется геометрию модели, где у пользователя 
запрашиваются требуемые и необязательные элементы. 

Требуемые элементы - модифицируемые свойства элементов Pro/ENGINEER, которые должны быть 
обязательно указаны для полного определения элементов. Необязательные элементы являются 
дополнительными операциями, которые могут быть выполнены; но которые не являются 
необходимыми для создания элемента. 

На следующем рисунке показано диалоговое окно модели, которое определяет элемент скругления 
(ROUND). 

 
Рисунок 4: Диалоговое Окно Модели 

Кнопки в диалоговом окне модели имеют следующие функции: 

• Define - определяет и/или изменяет выбранные в диалоговом окне элементы. 

• Refs - отображает внешние привязки выбранного элемента 

• Info  - генерирует список свойств создаваемого элемента 

• OK  - завершает определение элементов, создает элемент или объект модели. 

• Cancel - отменяет текущий элемент или объект модели. 

• Preview - проверяет геометрию перед завершением определения элемента. 

Вызов Моделей 
При вызове любого корректного файла в Pro/ENGINEER, в рабочей сессии также открывается окно 
Дерева Модели (Model Tree) и Менеджер Меню (Menu Manager). Эти окна позволяют создавать, 
управлять и изменять геометрию модели. 

Использование Дерева Модели 
Дерево Модели представляет поэлементную структуру модели. В Дереве Модели можно выбирать 
элементы для изменения и удаления. Пиктограммы в Дереве Модели указывают соответствующий тип 
элемента и его текущее состояние. 
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Рисунок 5: Дерево Модели с Включенными Дополнительными Параметрами 

Использование Менеджера Меню 
Менеджер Меню отображает список меню, которые можно использовать для создания, изменения и 
дублирования геометрии модели. 

При использовании Менеджера Меню, необходимо выбирать пункты меню, которые могут вызывать 
следующие подменю. Меню будут отображаться, пока все требуемые опции не будут выбраны. 

Получение Дополнительной Информации 
Если некоторое время удерживать курсор мыши на требуемой опции меню, то в нижней части 
активного окна отображается сообщение интерактивной помощи. Если требуется дополнительная 
помощь, то можно щелкнуть правой кнопкой мыши по меню и выбрать из выпадающего списка Get 
Help. 

Обратите внимание: 
Администратор системы должен установить и настроить интерактивную документацию для того, 
чтобы эта функциональная возможность работала. 

Работа с Несколькими Моделями 
В одной сессии можно иметь несколько моделей; каждое окно содержит по одной модели. Поэтому 
можно обращаться к одной модели в процессе работы над другой моделью. Однако, Pro/ENGINEER 
позволяет одновременно работать только в одном активном окне. 

Работа с Несколькими Под-Окнами 
Если главное окно в настоящий момент содержит модель, Pro/ENGINEER автоматически открывает 
новое главное окно для каждой следующей открываемой модели. Новое главное окно содержит те же 
меню пиктограмм и область сообщений, что и первое главное окно. 
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Рисунок 6: Новое Окно Поверх Главного Окна 

Сохранение Изменений 
В процессе работы над проектом, приучите себя регулярно сохранять текущую работу. Опция File > 
Save создает новую версию файла с приращением номера версии. 

Для вызова старой версии, укажите номер версии в имени вызываемого файла. Опция All Versions в 
диалоговом окне FILE OPEN отображает номера версий файла. 

 
Рисунок 7: Открытие Версии Модели 

Закрытие Окон 
Для закрытия окна используйте опцию Window > Close File > Close Window. Однако, при этом 
модель из текущей сессии Pro/ENGINEER не удаляется. Модель продолжает находиться в 
оперативной памяти компьютера. Если модель больше не требуется, можно стереть ее из 
оперативной памяти при помощи опции File > Erase > Current. Для того, чтобы стереть все модели, 
которые находятся в текущей сессии, но не отображаются в активных окнах используйте опцию Erase 
> Not Displayed. 
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Удаление Файлов 
Опция File > Delete, удаляет старые версии модели. Опция Delete > All Versions удаляет все версии 
модели из памяти и жесткого диска системы. 

Лабораторный Практикум 

Цель 
В этом практикуме показаны параметрические, ассоциативные и элементно-
ориентированные возможности твердотельного ядра Pro/ENGINEER. 

Метод 
В Упражнении 1, изучается среда Pro/ENGINEER. 

В Упражнении 2: изучаются методы управления масштабом отображения и ориентацией модели. 

В Упражнении 3, изучается Дерево модели (MODEL TREE). 

В Упражнении 4, исследуется ассоциативность между компонентом сборки и незаконченным 
рисунком. 

Инструменты 
ПИКТОГРАММА ОПИСАНИЕ 

    Вкл\Выкл отображение опорных плоскостей 

   Закрашенное отображение 

   Каркасное отображение 

    Отображение со скрытыми линиями 

    Увеличение масштаба изображения 

    Уменьшение масштаба изображения 

    Отображение в размер модели 

    Ориентирование вида 

    Список сохраненных видов 

    Сохранение файла 

УПРАЖНЕНИЕ 1: Использование Среды Pro/ENGINEER 
Задача 1. Открыть основную сборку. 

1. Щелкните по File > Set Working Directory для установки рабочего каталога. 

2. Щелкните по File > Open. 

3. В диалоговом окне FILE OPEN, выберите Assembly в выпадающем списке TYPE. Отображаются 
только файлы сборки. 
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4. выберите MASTER.ASM и щелкните Preview >>>. Эта функция отображает модель до ее открытия. 
Щелкните по пиктограмме No Hidden Line для скрытия невидимых линий сборки. 

5. Щелкните Open для открытия MASTER.ASM. 

Задача 2. Управление отображением сборки. 

1. Щелкните по Utilities > Environment. 
2. В диалоговом окне ENVIRONMENT, снимите галочки с переключателей Datum Planes и Datum 
Axes. 

3. Щелкните по Apply. Не закрывайте диалоговое окно. 

4. выберите Hidden Line из выпадающего списка DISPLAY STYLE. 

5. Щелкните по Apply. 

Задача 3. Измените ориентацию сборки. 

1. выберите Isometric из выпадающего списка DEFAULT ORIENT. 

2. Щелкните по Apply. 

3. Измените ориентацию обратно на Trimetric. 

4. Щелкните по ОК для закрытия диалогового окна. 

 
Рисунок 8: Отображение Скрытых Линий Сборки 

Задача 4. Используйте меню пиктограмм для управления моделью. 

1. Включите отображение опорных плоскостей. Щелкните по пиктограмме Datum Planes в меню. 
Опорные плоскости вновь отображаются. 
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Рисунок 9: Часть Меню, Отвечающая за Отображение Опорных Элементов 

2. Щелкните по  [Вкл\выкл] для выключения опорных плоскостей. 

3. Закрасьте модель. Щелкните по  [Закраска] в меню пиктограмм. 

 
Рисунок 10: Изменение Режимов Отображения Модели 

4. Щелкните по  [Отображение с подсветкой скрытых линий] для возврата к предыдущему способу 
отображения. 

5. Щелкните View > Shade для выполнения косметической закраски модели. 

Обратите внимание: 
Пиктограмма Hidden Line в меню пиктограмм остается выбранной, потому что модель заштрихована 
только косметически и не переключен режим закрашенного отображения. 

6. Щелкните по View > Repaint. 

УПРАЖНЕНИЕ 2: Управление Размером и Ориентацией Модели 
Задача 1. Изменить масштаб отображения и ориентацию модели с использованием меню пиктограмм. 

1. Щелкните по  [Увеличение масштаба изображения]. 

 
Рисунок 11: Опции Ориентации Модели 

2.Укажите местоположение в модели. Затем выберите второе местоположение для определения 
рамки увеличения. Указанное место модели будет увеличено. 
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3. Щелкните по  [Уменьшение масштаба изображения]. 

4. Щелкните по  [Отображение в размер модели] для отображения всей модели. 

Задача 2. Сориентируйте модель таким образом, чтобы скоба повернулась передней частью к 
конструктору. 

1. Щелкните по  [Ориентирование вида]. 

2. Открывается диалоговое окно с выбранный опцией Orient by Reference. В окне OPTIONS, зона 
Reference 1 отвечает за расположение параллельно экрану, а Reference 2 отвечает за расположение 
параллельно выбранному элементу привязки. 

3. В зоне Reference 1 оставьте Front. 
4. выберите переднюю поверхность скобы, как показано на следующем рисунке. 

 
Рисунок 12: Выбор Поверхностей для Ориентации 

5. выберите следующую поверхность (см. Рис. 12) скобки в качестве Reference 2. Модель изменяет 
свою ориентацию. 

6. В этом же диалоговом окне выберите меню SAVED VIEWS. Введите [SIDE] в текстовом поле NAME. 

7. Щелкните по Save для сохранения новой ориентации. 

8. Щелкните по ОК в диалоговом окне ORIENTATION.  
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Рисунок 13: Модель После Ориентирования 

Задача 3. Вернуть ориентацию модели в состояние по умолчанию. 

1. Щелкните по  [Список сохраненных видов]. Поочередно выберите сохраненные виды DEFAULT 
(по умолчанию) и SIDE в выпадающем списке для просмотра модели в двух различных ориентациях. 

Совет: 
Управлять ориентацией модели можно при помощи трех кнопок мыши и нажатой клавиши <CTRL>. 
Левая кнопка мыши изменяет масштаб изображения модели (зумирует), средняя вращает ее, а 
правая перемещает (панорамирует). 

УПРАЖНЕНИЕ 3: Изучение Дерева Модели 
Задача 1. Измените размеры модели, используя Дерево модели (MODEL TREE). 

1. Если Дерево модели не активно, щелкните по View > Model Tree.. 
2. Измените значение отступа вала. Щелкните правой кнопкой мыши по MASTER_SHAFT.PRT, затем 
выберите Modify в выпадающем меню. 

3. Щелкните по появляющемуся размеру 76. 

4. В области сообщения введите [90] и нажмите <ENTER>. 

5. Щелкните по Done в меню MODIFY Менеджера меню. 

6. Щелкните по Done/Return в меню ASSEM MOD. 

Задача 2. Регенерировать сборку. 

1. В меню ASSEMBLY, щелкните по Regenerate. 

2. В меню PRT TO REGEN, выберите Automatic. 

3. Вал перемещается в свое новое местоположение. Детали gear и crank следуют за валом. Это 
доказывает параметрический характер сборки. 

Задача 3. Проверить ассоциативность путем изменения длины вала. 

1. Щелкните по File > Open. Откройте MASTER_SHAFT.PRT. 

2. Щелкните по Modify в Менеджере меню. 

3. выберите вал, как показано на следующем рисунке. 
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Рисунок 14: Изменение Вала 

4. выберите размер 152. 

5. Введите [250] и нажмите <ENTER>. 

6. Щелкните по Regenerate в меню PART. 

7. Сохраните модель вала. Щелкните по  [Сохранить). 

8. Оставьте имя по умолчанию MASTER_SHAFT.PRT. 

Задача 4. Проверить ассоциативность между осью и сборкой. 

1. Закройте окно модели SHAFT. Щелкните по Window > Close. 

2. Сделайте окно ASSEMBLY активным. Щелкните по Window > Activate. 

3. Регенерируйте сборку. В Менеджере меню, щелкните по Regenerate > Automatic. 

4. Регенерированная сборка отображается с измененными размерами вала, как показано в 
следующем рисунке. 

 
Рисунок 15: Сборка после Модификации и Регенерации 

5. Изменения, сделанные в детали, автоматически изменяют всю сборку. Это доказывает 
ассоциативность Pro/ENGINEER. 

УПРАЖНЕНИЕ 4:  
Задача 1. Исследовать ассоциативность между компонентом сборки и неполным рисунком. 
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1. Откройте рисунок DRAW_CRANK2. DRW. 

2. Включите опорные плоскости, если они не включены, затем, перерисуйте экран. 

3. Щелкните по Edit > Value. 

4. выберите размер 60.50. 

5. Введите [90.5] в качестве нового размера. 

 
Рисунок 16: Рисунок Crank2 

6. Щелкните по Regenerate в меню DRAWING. 

7. Щелкните по Model в меню REGENERATE. 

8. Сохраните рисунок. Щелкните по File > Save, и нажмите <ENTER>. 

9. Щелкните File > Close Window. 

10. Активизируйте окно сборки. Заметьте, что кривошип в сборке обновлен. 

Задача 2. Проверить взаимопроникновение между твердотельными моделями сборки. 

1. Щелкните по Analysis > Model Analysis. Появляется диалоговое окно MODEL ANALYSIS, как 
показано на следующем рисунке. 

2. По умолчанию установлено Assembly Mass Properties. выберите Global Interference в 
выпадающем списке TYPE. 

3. Примите опции по умолчанию и щелкните по Compute. 
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Рисунок 17: Global Interference (Общее Взаимопроникновение) 

4. В окне RESULTS, система указывает, что две детали соударяются (interfere). Используйте стрелку 
для переключения между соударяемыми моделями. На экране также подсвечивается объем 
взаимопроникновения. 

5. Закройте диалоговое окно. 

6. Сохраните модель сборки. Щелкните по File > Save и примите имя по умолчанию. 

Задача 3. Определить результаты закрытия окна основной сборки. 

1. Щелкните по Window > Close. Обратите внимание, что основное окно Pro/ENGINEER не может 
быть закрыто. Об этом также сообщается в области сообщения. 

2. Откройте деталь CRANK2. PRT, модель который все еще находится в памяти. В диалоговом окне 

FILE OPEN, щелкните по  [В сессии]. 

 
Рисунок 18: Использование Опции IN SESSION 
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3. выберите CRANK2. PRT. Щелкните по Open. Система восстанавливает эту модель из памяти 
системы, но не с жесткого диска компьютера. 

Задача 4. Удалить модели основной сборки, не отображаемых в окне, из памяти текущей сессии. 

1. Сотрите модели, которые не отображаются. Щелкните по File > Erase > Not Displayed. 
2. Появляется диалоговое окно с подсвеченными моделями, которые находятся в сессии. Щелкните 
по ОК для завершения действия. 

Задача 5. Повторно вызвать модели "в сессию" для определения того, которые из них остались в 
сессии. 

1. Щелкните по , затем по . Обратите внимание, что в списке находится только CRANK2. PRT. 

2. Щелкните по Cancel. 
Задача 6. Стереть модель кривошипа из памяти системы для освобождения оперативной памяти. 

1. Сотрите текущий файл. Щелкните по File > Erase > Current.. Подтвердите действие. 

Резюме 

В этом модуле Вы узнали что: 

• выпадающие меню, меню пиктограмм, графическая область и область сообщений являются 
четырьмя важными элементами пользовательского интерфейса Pro/ENGINEER. 
• Существуют различные варианты ориентирования и отображения моделей на экране. 

• Модели Pro/ENGINEER типа деталей, сборок и рисунков имеют элементно-ориентированные, 
параметрические и ассоциативные характеристики. 

• Pro/ENGINEER автоматически открывает новое окно для каждой открываемой модели. Поэтому 
работа ведется в многоконной среде. 

• Стирание неиспользуемой модели освобождает дополнительную память системы. 
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Глава 3 

Элементы, Размещаемые По Щелчку 

В этой главе изучается, как воспользоваться преимуществами различных типов 
элементов, размещаемых по щелчку (pick-and place features). 

Цели 
В этой главе Вы изучите: 

• описание различных типов элементов, размещаемых по щелчку. 

• Создавать, удалять и изменять элементы, размещаемые по щелчку. 

• Принцип «назначения конструкции» на примере элемента отверстия. 

Создание Элементов, Размещаемых По Щелчку 

Элементы, размещаемые по щелчку, рассматриваемые в настоящей главе: 

• Оболочка 

• Фаска по кромке 

• Скругление по кромке 

• Отверстие 

Для создания элементов, размещаемых по щелчку, необходимо указать привязки для размещения 
(placement references) в модели и ввести требуемые размеры. Pro/ENGINEER размещает элемент 
автоматически. Элементы, размещаемые по щелчку, являются параметрическими. Если привязка для 
размещения перемещается, элемент также перемещается. 

Создание Элемента Оболочки (Shell) 
Выбор Shell удаляет поверхность (поверхности) или пустоты из твердотельной модели, оставляя 
оболочку с указанной толщиной стенки. 

 
Рисунок 1: Элемент Оболочки 

При создании оболочки в Pro/ENGINEER, пустотелыми становятся все элементы, которые были ранее 
добавлены к твердому телу. Поэтому, очень важен порядок создания элементов. 
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Создание Фаски по Кромке 
Элемент фаски по кромке удаляет плоскую часть материала с выбранной кромки. При этом создается 
скошенная поверхность между двумя исходными поверхностями, имеющими эту общую кромку. 
Схемы образмеривания фасок, доступные в Pro/ENGINEER, показаны на следующем рисунке. 

 
Рисунок 2: Схемы Образмеривания Фаски 

Обратите внимание: 
При выборе круговых кромок для фасок, Pro/ENGINEER подсвечивает только одну половину кромки. 
Так как система размещает фаску по всей длине круговой кромки, то не следует выбирать другую 
половину кромки. 

Создание Простых Скруглений 
Элемент скругления используется для создания гладкого, скругленного перехода между двумя 
смежными поверхностями. Скругление сглаживает острые кромки между смежными поверхностями. 

Pro/ENGINEER предлагает два типа скруглений: простое и сложное. Простые скругления используют 
круглые формы и переходы по умолчанию. Сложные скругления используют определенные 
пользователем круглые формы и переходы. 

Выбор Типа Кругового Радиуса 
• Constant � использует одинаковый радиус для каждой выбранной кромки. 

• Variable � использует отдельный радиус для каждой конечной точки и, при необходимости, в 
промежуточных вершинах вдоль скругляемых кромок. 
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Рисунок 3: Скругление Постоянного и Переменного Радиуса 

• Full Round � создает скругление, которое полностью удаляет поверхность модели 

 
Рисунок 4: Полное Скругление 

Обратите внимание: 
Не образмеривайте другие элементы относительно кромок или касательно к кромкам скруглений. 
Элементы скруглений имеют непостоянные родительские элементы. 

Совет: 
Элементы скруглений следует создавать в модели как можно позже в процессе проектирования.  

 
Рисунок 5: Элемент Выреза, Образмеренный Относительно Радиуса Скругления Боковой Кромки 
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Определение Значений Радиуса Скругления 
• Enter � указывает новое значение радиуса, которое не отображается в меню. Используйте 
клавишу <ESC> для выбора других опций типа радиуса. 

• Select On Surf � указывает точку на смежной поверхности, которая определяет значение 
радиуса. 

• Thru Pnt/Vtx � указывает опорную точку, вершину, конечную точку кривой или кромки, 
через которую должен пройти радиус скругления. 
• Default Values � указывает системное значение радиуса скругления по умолчанию или ранее 
веденное значение радиуса в меню SEL VALUE. 

 
Рисунок 6: Использование Опции Select On Surf 

Создание Гладких Отверстий 
В Pro/ENGINEER можно создавать любой из трех типов элементов отверстия: 

• Гладкое 

• Стандартное 

• Эскизированное 

Pro/ENGINEER создает все гладкие отверстия с постоянным диаметром. Элемент отверстия всегда 
удаляет материал из модели. 

Размещение Отверстия 
Для размещения отверстия, можно выбирать следующие опции в меню PLACEMENT. 

• Linear � размещает отверстие на плоскости. Укажите расстояние от центра отверстия до двух 
поверхностей или кромок используя линейные размеры. 

 
Рисунок 7: Линейное Отверстие 
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• Radial � размещает отверстие относительно оси, используя полярные размеры на 
плоскости, цилиндре или конусе. Радиальные отверстия, размещенные на плоскости, имеют 
диаметр, радиус и линейную схему образмеривания. 

 
Рисунок 8: Радиальные Отверстия на Плоскости 

• Coaxial � размещает отверстия с использованием существующей оси. Координирующие 
размеры не создаются. Указывается только диаметр создаваемого отверстия. 

 
Рисунок 9: Соосное Отверстие 

• On Point � размещает центр отверстия непосредственно на опорной точке поверхности (surface 
datum point). Ось отверстия перпендикулярна поверхности размещения. 

 
Рисунок 10: Отверстие в Точке 
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Установка Глубины Отверстия 
Отверстие можно создавать по одну сторону от плоскости размещения или по обе стороны, используя 
опции Depth One в Depth Two в диалоговом окне HOLE. 

 
Рисунок 11: Выбор Стороны 

Система определяет глубину создаваемого отверстия на основании указанной глубины. На 
следующем рисунке показаны различные опции глубины, находящиеся в выпадающем списке 
диалогового окна HOLE. 

 
Рисунок 12: Опции Глубины Отверстия 

 
Рисунок 13: Использование Опции Thru Pnt/Vtx  

Лабораторный Практикум 

Цель 
В этом практикуме показано, как использовать основные элементы, размещаемые по 
щелчку. 
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Метод 
В Упражнении 1, к базовой модели будет добавлен элемент оболочки и элемент простого скругления 
по цепочке, используя функцию создания автоматического скругления. 
В Упражнении 2, к модели будет добавлена фаска и скругление. 
В Упражнении 3, будет создан элемент гладкого отверстия. 
В Упражнении 4, будет создано гладкое радиальное отверстие, размещенное на планарной 
поверхности. 

Инструменты 
ПИКТОГРАММА ОПИСАНИЕ 

   Закраска 

   Отображение скрытых линий 

   Элемент повторения 

УПРАЖНЕНИЕ 1: Создание Автоматических Скруглений 

 
Рисунок 14: Исходная Модель 

Задача 1. Создать элемент оболочки. 

1. Вызовите деталь AUTOMATIC.PRT из рабочего каталога. 

2. Щелкните по Insert > Shell. 
3. выберите переднюю поверхность детали, как показано на следующем рисунке. 

 
Рисунок 15: Выбор Поверхности Привязки для Оболочки 

4. Щелкните по Done Sel > Done Refs. 
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5. Введите [0.25] в качестве толщины оболочки и нажмите <ENTER>. 

6. Щелкните по ОК в диалоговом окне SHELL для завершения элемента оболочки. 

 
Рисунок 16: Законченная Оболочка 

Задача 2. Добавить автоматический элемент скругления. 

1. выберите внешнюю дуговую кромку, как показано на следующем рисунке. 

2. Щелкните правой кнопкой мыши по выбранной кромке и выберите из выпадающего меню Round 
Edges. 

 
Рисунок 17: Выбор Скругляемых Кромок 

3. Перетащите зеленую пиктограмму на скруглении для динамического изменения размера. Щелкните 
в любом месте экрана для завершения создания скругления. 

4. Заметьте, что система автоматически выбирает кромки, касательные к дуговой кромке, при 
создании элемента простого скругления. 

 
Рисунок 18: Завершенное Скругление 

5. Щелкните по File > Save. Примите имя по умолчанию и нажмите <ENTER> для сохранения модели. 

6. Щелкните по File > Close Window, чтобы закрыть текущее рабочее окно. 
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УПРАЖНЕНИЕ 2: Создание Фасок и Скруглений 

 
Рисунок 19: Исходная Модель 

Задача 1. Добавить фаску 45 x d к цилиндру. 
1. Вызовите деталь CHAMFERS.PRT из рабочего каталога. 
2. Щелкните по Insert > Chamfer > Edge Chamfer. 
3. Щелкните по 45 x d в меню SCHEME. 
4. Введите [1.0] в качестве размера фаски. 
5. выберите две круговых грани на обоих концах цилиндра, как показано на следующем рисунке. 
Кромки подсвечиваются синим цветом. 

 
Рисунок 20: Выбор Круговых Кромок 

6. Щелкните по Done Sel > Done Refs. 
7. Щелкните по ОК для завершения фаски. 

 
Рисунок 21: Диалоговое окно EDGE CHAMFER 
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8. Завершенная фаска показана на следующем рисунке. 

 
Рисунок 22: Завершенная Фаска 

Задача 2. Добавить фаску d1 X d2 к четырем кромкам в нижней части модели. 

1. Щелкните по Insert > Chamfer > Edge Chamfer. 
2. выберите d1 x d2 в меню SCHEME. Введите [1] в качестве значения размера d1 и [2] в качестве 
значения размера d2. 

3. Переключите отображение в Hidden Line. Щелкните по  [Скрытая линия] в меню пиктограмм 
Pro/ENGINEER. 

4. выберите Query Sel, затем выберите скрытую поверхность основания в качестве поверхности 
привязки для размера d1. 

 
Рисунок 23: Выбор Нижней Поверхности 

5. выберите переднюю и правую кромки в качестве кромок привязки. 

6. Щелкните по Query Sel, затем выберите две скрытые кромки основания. 
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Рисунок 24: Выбор Скрытых Граней 

7. Щелкните по Done Sel > Done Refs. 

8. Щелкните по ОК для завершения фаски. 

9. Щелкните по  [Закраска] для отображения закрашенной модели. 

 
Рисунок 25: Завершенная Фаска 

Задача 3. Создать простое скругление с переменным радиусом. 

 
Рисунок 26: Простое Скругление с Переменным Радиусом 

1. Щелкните по Insert > Round > Simple > Done. 
2. Щелкните по Variable > Edge Chain > Done. 
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3. Включите отображение скрытых линий. Щелкните по  [Скрытые линии]. 

4. Щелкните по One By One в меню CHAIN для указания кромок привязки по одной. 

5. выберите три видимых и одну скрытую вертикальные кромки, как показано на следующем рисунке. 

 
Рисунок 27: Выбор Привязок Для Переменного Скругления 

6. Для выбора скрытой вертикальной кромки, щелкните Query Sel > Accept в диалоговом окне Query. 
Четыре вертикальные кромки подсвечиваются синим цветом. 

7. Щелкните по Done в меню CHAIN. Система подсвечивает восемь вершин. 

8. Щелкните еще раз по Done. 

Задача 4. Определить значения радиуса для переменного радиуса скругления. 

1. Поскольку система подсвечивает каждую конечную точку кромки, введите [0] в качестве значения 
для верхней части кромки, и введите [2] в качестве значения для нижней части кромки. 

2. Щелкните по ОК для завершения элемента скругления. 

3. Щелкните по  [Закраска]. 

 
Рисунок 28: Завершенное Скругление 
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4. Сохраните деталь и сотрите ее из оперативной памяти. 

УПРАЖНЕНИЕ 3: Создание Гладких Отверстий 

 
Рисунок 29: Исходная Модель 

Задача 1. Создать линейно размещенное отверстие с переменной глубиной 30 в верхней части 
базового элемента модели, показанной в предыдущем рисунке. 

1. Откройте STRAIGHT_HOLES.PRT. 

2. Щелкните по Insert > Hole. Появляется диалоговое окно HOLE. 

 
Рисунок 30: Диалоговое Окно HOLE 

3. В зоне HOLE TYPE оставьте значение по умолчанию Straight. 
4. Введите [7.5] в поле DIAMETER. Нажмите <ENTER>. 

5. В зоне DEPTH ONE оставьте значение по умолчанию Variable; вторую глубину None. 
6. Введите [30] в поле DEPTH VALUE. Нажмите <ENTER>. 
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7. Зона PRIMARY REFERENCE определяет местоположение отверстия. Щелкните по верхней 
поверхности базового элемента, которая является плоскостью размещения, как показано на 
следующем рисунке. 

 
Рисунок 31: Создание Линейно Размещенного Отверстия 

8. Для первой линейной привязки, щелкните по Query Sel и выберите скрытую боковую сторону 
базового элемента. Введите [10] в качестве расстояние для этой привязки. Нажмите <ENTER>. 

9. Для второй линейной привязки, щелкните Query Sel, и выберите видимую переднюю поверхность. 
Введите [15] для расстояния от этой привязки. Нажмите <ENTER>. 

10. Щелкните по . 

 
Рисунок 32: Первое Завершенное Отверстие 

Задача 2. Добавить линейное отверстие, проходящее через охлаждающие ребра. 

1. Щелкните по Insert > Hole. 

2. В диалоговом окне HOLE, в зоне HOLE TYPE, оставьте значение Straight. 
3. Введите диаметр отверстия [12.5]. Нажмите <ENTER>. 

4. В зоне DEPTH ONE щелкните по Thru All (насквозь), а в зоне DEPTH TWO щелкните по None. 
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5. выберите верхнюю поверхность первого охлаждающего ребра около правого заднего угла в 
качестве плоскости размещения, как показано на следующем рисунке. 

 
Рисунок 33: Создание Второго Элемента Гладкого Отверстия 

6. В качестве первой линейной привязки, щелкните по Query Sel и, затем, выберите скрытую заднюю 
поверхность базового элемента. 

7. Введите [10] в качестве расстояния для этой привязки. Затем нажмите <ENTER>. 

8. Для второй привязки, щелкните по Query Sel. выберите боковую поверхность (не кромку) верхнего 
охлаждающего ребра. Если выбрать боковую поверхность ребра затруднительно, увеличьте масштаб 
отображения модели. 

9. Введите [10] в качестве расстояния для второй привязки, затем нажмите <ENTER>. 

10. Выполните предварительный просмотр элемента отверстия, но не закрывайте диалоговое окно 
HOLE. 

Обратите внимание: 

Если требуется создать следующий элемент отверстия, можно использовать кнопку повторения  
в диалоговом окне HOLE. 

 
Рисунок 34: Второе Размещенное Отверстие 

Задача 3. Использовать опцию глубины TO REFERENCE для создания следующего линейного 
отверстия через верхние три ребра. 

1. В диалоговом окне HOLE, в зоне HOLE TYPE, оставьте значение по умолчанию Straight. Введите 
диаметр [12.5]. Нажмите <ENTER>. 
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2. Щелкните по To Reference в выпадающем списке. 

3. выберите Query Sel. Для определения того, что отверстие должно закончиться на нижней 
поверхности третьего ребра, выберите нижнюю поверхность третьего ребра. 

 
Рисунок 35: Отверстие До Привязки 

4. Для Первичной Привязки, выберите верхнюю поверхность первого ребра, как показано на 
следующем рисунке. 

 
Рисунок 36: Создание Третьего Отверстия 

5. Для первой Линейной Привязки, выберите переднюю часть базового элемента. Введите [10] в 
качестве расстояния. Нажмите <ENTER>. 

6. Для второй Линейной Привязки, выберите видимую боковую поверхность ребра охлаждения. 
Введите [10] в качестве расстояния. 

7. Завершите элемент отверстия. 

Задача 4. Создать соосное отверстие в цилиндрическом элементе. 

1. Щелкните по Insert > Hole 

2. В диалоговом окне HOLE, оставьте по умолчанию HOLE TYPE как Straight. 
3. Введите [5] в поле диаметра отверстия. 



  Pro/ENGINEER 2001 Базовый Курс 

- 45 - 

 
Рисунок 37: Создание Соосного Гладкого Отверстия 

4. выберите To Reference в зоне DEPTH ONE. Щелкните по Query Sel и выберите видимую переднюю 
поверхность базового элемента, как показано в предыдущем рисунке. 
5. выберите переднюю поверхность цилиндрического элемента в качестве первичной привязки. 
6. выберите Coaxial в выпадающем списке PLACEMENT TYPE. 
7. выберите ось A_3 цилиндрического элемента в качестве оси привязки. Если ось не отображается, 

щелкните по  [вкл\выкл опорные оси]. 

8. Щелкните по  для завершения элемента соосного отверстия. 

 
Рисунок 38: Завершенный Элемент Соосного Отверстия 

УПРАЖНЕНИЕ 4: (Необязательное) 
Задача 1. Создать гладкое радиальное отверстие, размещенное на плоской поверхности. 

 
Рисунок 39: Завершенная Модель 
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1. Установите параметры отверстия. 

• Diameter (Диаметр) = 15 мм. 

• Depth One (Глубина в первом направлении) = To Reference 

• Depth Two (Глубина во втором направлении) = None 

• Depth Reference (Привязка по Глубине) = Скрытая поверхность круглого фланца 

2. Определите размещение отверстия. 

• Primary Reference (Первичная Привязка) = Видимая передняя поверхность круглого фланца 

• Placement Type (Тип Размещения) = Radial 

• Axial Reference (Осевая Привязка) = A_3  

• Distance (Расстояние) = 25 mm 

• Angular Reference (Угловая Привязка) = Передняя поверхность фланца около выреза сектора 

• Angle (Угол) = 25 

 
Рисунок 40: Создание Радиального Крепежного Отверстия 

3. Завершите создание отверстия. 

4. Необязательно: Измените диаметр фланца с 47 на 60 и выполните регенерацию для отображения 
изменений в модели. 

5. Сохраните деталь и сотрите ее из оперативной памяти. 

РЕЗЮМЕ 
В этой главе Вы изучили, что: 
• Оболочка, Фаска, Скругление и Отверстие являются четырьмя важными элементами размещения 
по щелчку в Pro/ENGINEER. 
• Фаски можно размещать не только на плоскостях и перпендикулярных поверхностях, но и на 
круговых кромках. 
• Скругления могут быть созданы с различными параметрами радиуса: постоянный, переменный и 
полное скругление. 
• Скругления и Фаски следует создавать на заключительном этапе процесса конструирования. 
Кроме того, эти элементы могут вводить в конструкцию нежелательные отношения родитель-потомок. 
• Элемент Отверстия может быть создан с различными параметрами размещения и глубины. 
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Глава 4 

Основы Эскизирования 

В этой главе Вы научитесь создавать эскизы и определять модели одиночных и составных 
деталей. Pro/ENGINEER имеет режим Эскиза (Sketcher) и включает встроенный Менеджер 
Намерений (Intent Manager), помогающий выразить назначение конструкции. 

Цели 
В этой главе Вы изучите, как: 

• использовать в эскизе образмеривание для передачи назначения конструкции. 

• Создавать геометрию, включающую линии, осевые линии, дуги, окружности, прямоугольники и 
эскизные точки. 

• Накладывать геометрические зависимости на элементы эскиза, типа зависимостей равной длины 
или перпендикулярности. 

• Использовать инструментарий эскиза для изменения эскиза сечения. 

Интерфейс Среды Эскизирования 

Интерфейс среды эскизирования состоит из: 

• меню со стандартными выпадающими меню Pro/ENGINEER и двумя дополнительными меню 
эскизирования - EDIT и SKETCH. 

• Стандартного меню пиктограмм Pro/ENGINEER. 

• Дополнительного меню пиктограмм со специфичными командами эскизирования. 

• Области сообщений. 

• МЕНЕДЖЕРА НАМЕРЕНИЙ (INTENT MANAGER) с пиктограммами в правой части для выполнения 
часто используемых действий. 

• Дополнительной области сообщений в нижней левой части окна с описанием текущего действия 
МЕНЕДЖЕРА НАМЕРЕНИЙ. 
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Рисунок 1: Интерфейс Среды Эскизирования 

Выбор Эскизных Объектов 
Используя мышь, можно выбирать один или несколько объектов эскиза, или же все объекты, лежащие 
внутри рамки выбора. Выбранные объекты подсвечиваются красным цветом. 
Менеджер Намерений 
МЕНЕДЖЕР НАМЕРЕНИЙ с выпадающими пиктограммами автоматически появляются в правой части 
экрана при входе в среду эскизирования. Пиктограммы логически сгруппированы вместе по 
функциональному признаку. Они обеспечивают свободный доступ к часто используемым 
инструментам эскиза. 

 
Рисунок 2: Выпадающие Пиктограммы МЕНЕДЖЕРА НАМЕРЕНИЙ 
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Обратите внимание: 
Пользователи, работавшие с предыдущими версиями Pro/ENGINEER могут самостоятельно принять 
решение, использовать Менеджер Намерений перед началом эскизирования, или нет. Переключение 
в режим работы со старым Менеджером меню в процессе эскизирования может привести к 
непредсказуемым результатам. 

Использование Выпадающих Меню 
Выпадающие меню вызываются щелчком правой кнопкой мыши на экране. Они содержат часто 
используемые команды для эскизирования, изменения, образмеривания, удаления и отмены. 

 
Рисунок 3: Стандартное Выпадающее Меню Эскизирования 

Режим Эскизирования 

Использование Меню Эскизирования 
EDIT и SKETCH являются меню высшего уровня в среде Эскизирования. Они содержат все команды, 
необходимые для создания эскиза. 

 
Рисунок 4: Меню EDIT 

Кроме того, в меню SKETCH доступны команды МЕНЕДЖЕРА НАМЕРЕНИЙ и опция Text. 
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Рисунок 5: Меню SKETCH 

Определение Привязок 
В режиме эскизирования привязки для будущего эскиза определяются при: 

• создании нового элемента. 

• Переопределении элемента с потерянными или недостающими привязками. 

• Указании привязок для размещения сечения. 

Вообще � рекомендуется указывать привязки перед созданием эскиза. Это обеспечивает 
автоматическое выравнивание объектов эскиза и их образмеривание от элементов привязки. 

Обратите внимание: 
Привязки, выбранные для сечений, создают отношения Родитель/Потомок. 

Создание Геометрии 
Режим эскизирования позволяет создавать геометрические формы и объекты. Основные из них, 
линии, дуги и окружности, обсуждены ниже. 

• Линии � используя выпадающие пиктограммы Line в МЕНЕДЖЕРЕ НАМЕРЕНИЙ, можно 
создавать два типа эскизных линий: 

− прямые линии от точки до точки. 

− Осевые линии для привязки или конструктивной геометрии. 

 
Рисунок 6: Выпадающие Пиктограммы Линий 

• Дуги - используя выпадающие пиктограммы Arcs в МЕНЕДЖЕРЕ НАМЕРЕНИЙ, можно создавать 
четыре типа дуг: 
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− дуга по 3 точкам или касательная к объекту в его конечных точках. 

− Концентрическая дуга. 

− Дуга по центру и конечным точкам. 

− Коническая дуга. 

 
Рисунок 7: Выпадающие Пиктограммы Дуг 

• Окружности - используя выпадающие пиктограммы Circle в МЕНЕДЖЕРЕ НАМЕРЕНИЙ, можно 
создавать три типа окружностей: 

− окружность по центру и точке. 

− Концентрическая окружность. 

− Полный эллипс. 

 
Рисунок 8: Выпадающие Пиктограммы Окружностей 

 
Рисунок 9: Окружность, Концентричная к Кромке 

Образмеривание 
По завершении эскиза его следует образмерить. Упорядоченное расположение размеров 
способствует лучшему пониманию эскизов, особенно сложных. 
Для размещения размеров в эскизе щелкните левой кнопкой мыши для выбора объекта и щелкните 
средней кнопкой мыши для размещения размера. Размеры можно размещать в процессе 
эскизирования или после. 
Следующий рисунок иллюстрирует схему образмеривания прямоугольника. 

 
Рисунок 10: Создание Размеров для Прямоугольника 
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Рисунок 11: Захват и Перемещение Размеров 

Изменение Размеров 
Значения размеров эскиза можно изменять в диалоговом окне MODIFY DIMENSIONS. Также, в эскизе 
имеются опции Regenerate (Регенерация) и Lock Scale (Зафиксировать). 

При двойном щелчке на указанном размере в эскизе динамически изменяется значение размера. 
Бегунок SENSITIVITY позволяет регулировать чувствительность колесиков управления при 
динамическом изменении размеров. 

 
Рисунок 12: Диалоговое Окно MODIFY DIMENSIONS 

Наложение Зависимостей 
Система накладывает на объекты зависимости по умолчанию для определения исходного 
«назначения конструкции». Эти зависимости по умолчанию можно изменять при помощи диалогового 
окна CONSTRAINTS. 

 
Рисунок 13: Диалоговое Окно Зависимостей Эскиза 

Зависимости имеют следующее назначение: 

  1. Устанавливает линию или две вершины вертикальными. 
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  2. Устанавливает два объекта касательными. 

  3. Устанавливает две точки или вершины симметричными относительно осевой линии. 

  4. Устанавливает линию или две вершины горизонтальными. 

  5. Размещает точку в середине линии. 

  6. Создает зависимости равной длины, равных радиусов или равной кривизны. 

  7. Устанавливает два объекта перпендикулярными. 

  8. Создает одинаковые точки или точки на объектах. 

  9. Устанавливает две линии параллельными. 

Использование Дополнительных Инструментов Эскиза 

Кромка 
Инструмент Кромка (Edge) имеет две пиктограммы в Менеджере Намерений, представленные ниже: 

 
Рисунок 14: Выпадающие Пиктограммы Кромки 

• Use Edge � использует существующие кромки модели для создания объектов эскиза. 
Автоматически выбирает кромку в виде указанной привязки. 

 
Рисунок 15: Использование Существующей Кромки Модели Для Создания Эскизных Объектов 

• Offset Edge - использует существующие кромки модели для создания объектов эскиза со 
смещением. 

 
Рисунок 16: Создание Эскизных Объектов со Смещением 

Обратите внимание: 
Опции Use Edge и Offset Edge создают отношения Родитель/Потомок с объектами привязки. 
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Копирование 
Опция Edit > Copy копирует двухмерные рисунки (drafts) и импортирует объекты из рисунка. Сечения 
можно перемещать и масштабировать, делая наследуемые данные более легкими для управления. 

Зеркало 
Можно зеркально отображать эскизные объекты с одной стороны осевой линии на другую, используя 
опцию Edit > Mirror. 

Перемещение 
Меню MOVE ENTITY отображает следующие опции: 

• Drag Item � перемещает объект или его вершину в новое местоположение. 

• Drag Many � переносит выбранные объекты в пределах эскиза. 

• Rotate90 � поворачивает объекты эскиза вокруг выбранной точки на угол, кратный 90°. 

• Dimension � позиционирует размер в пределах эскиза. 

Обрезка 
Опция Edit > Trim обрезает или удлиняет объект тремя различными способами, в соответствии с 
тремя выпадающими пиктограммами, показанными ниже: 

 
Рисунок 17: Выпадающие Пиктограммы Обрезки 

• Первая � динамически обрезает выбранные объекты. 

• Вторая � удлиняет или обрезает объекты до точки пересечения с другими объектами или 
геометрией. 

• Третья � обрезает объекты в точке выбора, создавая вместо одного объекта � два. 

Замена 
Команда Replace заменяет эскизный объект в исходном сечении новым эскизным объектом. 

Анализ Сечения 
Опция Analysis > Section Analysis предоставляет информацию по:  

• точкам касания и пересечения. 

• Углам и расстояниям. 

• Привязкам размеров. 

• Кривизне объектов. 

Точки Эскиза 
Точки эскиза соединяют эскизные объекты и позволяют создавать наклонные размеры между 
конечными точками эскизных объектов. 
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Рисунок 18: Определение Средней Точки с Использованием Точки Эскиза 

 
Рисунок 19: Определение Теоретической Формы с Использованием Точек Эскиза 

Установки Среды Эскизирования 
Диалоговое окно SKETCHER PREFERENCES в меню UTILITIES изменяет среду эскизирования. 

 
Рисунок 20: Диалоговое Окно SKETCHER PREFERENCES 



Pro/ENGINEER 2001 Базовый Курс    

- 56 - 

Используйте Диалоговое Окно SKETCHER PREFERENCES для: 

• изменения опций отображения различных эскизных объектов. 

• Включения/выключения зависимостей, разрешенных в среде эскизирования. 

• Настройки сетки, интервала сетки и параметров точности. 

• Кнопка Default возвращает системные параметры по умолчанию. 

Эскизирование в Трехмерном Пространстве 
При выборе опции Use2D Sketcher в диалоговом окне ENVIRONMENT, Среда эскизирования 
запускается в двухмерной ориентации (то есть в плоскости эскизирования, параллельной экрану 
компьютера). 

Если эта опция не выбрана, Среда эскизирования запускается в трехмерной ориентации. Ориентацию 
вида можете изменять в любой момент и продолжать процесс эскизирования в трехмерной 
ориентации. Используя View > Sketch View можно переориентировать сечение эскиза в двухмерном 
пространстве. 

 
Рисунок 21: Диалоговое Окно Environment 
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Рекомендации по работе в среде эскизирования 

1. Создавайте простые эскизы. 

• Это делает окончательную модель более гибкой и помогает при регенерации. 

2. Используйте опцию Undo 

• Выбор опции Undo восстанавливает эскиз сечения в его предыдущее состояние. 

• Это очень полезно при последовательном создании объектов эскиза. 

3. Используйте сетку. 

• Создавайте линии равной длины параллельными или перпендикулярными. 

• Выравнивайте эскизные объекты. 

• Выравнивайте центры по горизонтали и по вертикали. 

5. Не расширяйте эскиз за деталь. 

• Нет никакой необходимости продлевать сечения эскиза за деталь, как это требуется при работе с 
некоторыми программами твердотельного моделирования. 

6. Эффективно используйте точность Среды эскизирования. 

• Диапазон точности эскиза от 1.0 10-9 до 1.0 (по умолчанию). 

• Чтобы при эскзировании не накладывались зависимости, можно увеличить точность. 

7. Используйте открытые и замкнутые сечения соответствующим образом. 

• При использовании открытых эскизных сечений, нельзя иметь более одного открытого сечения в 
элементе. 

• Если используется открытое сечение, его открытые концы должны быть точно выровнены по 
детали. 

• При сомнениях, используйте замкнутое сечение, так как оно легче регенерируется и дает меньше 
ошибок. 

 
Рисунок 22: Открытое и Замкнутые Сечения 
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Лабораторный Практикум 

Цель 
В этом практикуме будут изучены основные процедуры эскизирования типа входа в режим 
эскизирования, создание прямых линий, создание дуг, наложение зависимостей, 
образмеривание и создание твердотельных моделей. 

Метод 
В Упражнении 1, изучаются основные процедуры эскизирования. 

В Упражнении 2, создается пружинное упорное кольцо путем пошагового эскизирования. 

В Упражнении 3, создается сечение шестигранной гайки, используя объекты построений. 

Инструменты 
ПИКТОГРАММА ОПИСАНИЕ 

   Накладывает эскизные зависимости 

   Зависимость перпендикулярности 

   Касательная дуга 

   Создает окружность 

   Создает прямоугольник 

   Создает размер 

   Динамическая обрезка 

   Изменение размера 

УПРАЖНЕНИЕ 1: Основы Эскизирования 

 
Рисунок 23: Окончательный Эскиз, Полученный После Выполнения Упражнения 1 

Задача 1. Создать новый эскиз с именем ROUND_RECTANGLE. 

1. Щелкните по  [Новый файл] в меню пиктограмм. 
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2. В диалоговом окне NEW, выберите Sketch. 

3. Введите [ROUND_RECTANGLE] в качестве имени. 

4. Активизируется режим эскизирования. 

Задача 2. Нарисовать четыре линии с горизонтальной нижней линией, как показано на следующем 
рисунке. 

 
Рисунок 24: Эскиз Четырехугольника 

Задача 3. Наложить зависимости перпендикулярности на линии. 

1. Щелкните по  [Наложить зависимости в эскизе], затем щелкните по  [зависимость 
перпендикулярности], затем выберите две линии, которые должны быть перпендикулярными, как 
показано на следующем рисунке. 

 
Рисунок 25: Зависимость Перпендикулярности на Одной Стороне 

2. выберите другие две линии, чтобы сделать их перпендикулярными. 

 
Рисунок 26: Зависимость Перпендикулярности с Другой Стороны 

3. Закройте диалоговое окно CONSTRAINTS. 

Задача 4. Удалить две вертикальных линии. 
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1. Щелкните по пиктограмме Pointer, и выберите левую вертикальную линию. 

2. Нажмите и, удерживая нажатой <SHIFT>, выберите правую вертикальную линию. 

3. Щелкните правой кнопкой мыши и выберите Delete из выпадающие меню. 

Задача 5. Нарисовать дугу, касательную к левой части сечения. 

1. Щелкните по  [Касательная дуга]. 

2. Укажите левую верхнюю точку горизонтальной линии, затем левую нижнюю точку. 

3. Протащите курсор влево, образовывая левосторонний касательный квадрант окружности, как 
показано на следующем рисунке. 

 
Рисунок 27: Эскиз Дуги, Касательной в Конечных Точках 

Задача 6. Повторить процесс для правой стороны сечения. 

 
Рисунок 28 Эскиз Дуг, Касательных с Обеих Сторон 

Задача 7. Добавить соответствующие размеры. 

1. Щелкните по  [Создать размер]. 

2. выберите каждую дугу и щелкните средней кнопкой мыши для размещения размера. 

3. выберите Tangent и Horizontal для указания типа и ориентации. 
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Рисунок 29 Образмеренные Дуги 

Задача 8. Создание диаметрального размера на левой дуге. 

1. Щелкните по . 

2. Дважды щелкните по левой дуге, затем щелкните средней кнопкой мыши для размещения размера. 

 
Рисунок 30 Образмеренная Левая Дуга 

Задача 9. Изменить оба размера. 

1. выберите горизонтальный и диаметральный размеры. Нажмите и, удерживая нажатой <SHIFT>, 

щелкните по  [Изменение размера]. 

2. Измените диаметр на [2] а линейный размер на [4]. 

 
Рисунок 31: Диалоговое Окно Modify Dimensions 
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3. Сохраните и закройте диалоговое окно MODIFY DIMENSIONS. 

 
Рисунок 32: Эскиз с Измененными Размерами 

УПРАЖНЕНИЕ 2: Пошаговое Создание Эскиза 

 
Рисунок 33: Окончательное Пружинное Упорное Кольцо После Выполнения Упражнения 2 

Задача 1. Создать новый эскиз по имени SNAP_RING. 
1. Щелкните по File > New. 
2. выберите Sketch. 
3. Введите [SNAP_RING] в качестве названия эскиза. 
Задача 2. Создать две не концентричных окружности на одной вертикали. 

1. Щелкните по  [Создать окружность] и нарисуйте две окружности, как показано на следующем 
рисунке. 

 
Рисунок 34: Две Окружности на Одной Вертикали 
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Задача 3. Создать прямоугольник, верхние вершины которого принадлежат внутренней окружности. 

 
Рисунок 35: Эскиз Прямоугольника Внутри Окружностей 

1. Щелкните по  [Создать прямоугольник]. Укажите первую точку прямоугольника, затем укажите 
диагонально противоположную точку. 

2. Затем используйте динамическую обрезку. Щелкните по  [Динамическая обрезка]. Протяните 
линию, начинающуюся под нижним основанием прямоугольника и закончите ее над верхним 
основанием. 

3. Каждый из пересеченных объектов будет подсвечиваться и удаляться после того, как отпустить 
кнопку мыши. 

4. Результат показан на следующем рисунке. 

 
Рисунок 36 Использование Динамической Обрезки 
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Задача 4. Создать эскиз другого прямоугольника. 

1. Создайте новый прямоугольник, вершины которого привязаны к нижней части наружной окружности, 
как показано на следующем рисунке. Не проводите его через какую либо из вершин дуг.  

 
Рисунок 37: Эскиз Второго Прямоугольника 

Задача 5. Используйте динамическую обрезку для удаления ненужных линий и дуги. 

1. Щелкните по  для обрезки ненужных объектов. 

2. Результат показан на следующем рисунке. 

 
Рисунок 38: Реализация «Назначения Конструкции» После Динамической Обрезки 

Задача 6. Образмерить объекты. 

1. Щелкните по  для создания размеров. 

2. выберите каждый объект и щелкните средней кнопкой мыши для размещения размера. 

3. Щелкните по  для изменения значений шести размеров. 
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Рисунок 39: Изменение Размеров 

4. Сохраните и завершите работу в эскизе. 

УПРАЖНЕНИЕ 3: Эскиз Шестиугольника 
Задача 1. Создать новый эскиз по имени HEX. 

1. Щелкните по . выберите Sketch и введите [Hex] в качестве название. 

Задача 2. Создать эскизную точку 

1. Щелкните по пиктограмме точки . 

2. Поместите точку в центре экрана. 

Задача 3. Добавить вертикальные осевые линии, проходящие через точку эскиза. 

1. Щелкните по пиктограмме осевой линии . 

2. Создайте вертикальную осевую линию, которая проходит через точку. 

3. Создайте две дополнительные осевые линии, которые проходят через точку под углом. 

Задача 4. Изменить углы на 60°. 

1. Измените угол между осевыми линиями на 60°, как показано на следующем рисунке. 

 
Рисунок 40: Изменение Углов Между Осевыми Линиями 

Задача 5. Создать окружность с центром в точке. 

1. выберите окружность, чтобы она подсветилась красным цветом. 
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2. Щелкните по окружности правой кнопкой мыши и выберите Toggle Construction для 
преобразования ее в конструкционную окружность. 

 
Рисунок 41: Создание Конструкционной Окружности 

Задача 6. Создать шестиугольник, путем создания 6 линий через точки пересечения круга и осевых 
линий. 

 
Рисунок 42: Создание Эскиза Шестиугольника 

1. Добавьте диаметральный размер к конструкционной окружности и измените его значение на [1.0] 
2. Сохраните и завершите работу в эскизе. 

Резюме 

В этом модуле, Вы узнали что: 
• Интерфейс Среды эскизирования состоит из основной области эскизирования, выпадающих меню, 
меню пиктограмм, области сообщений, МЕНЕДЖЕРА НАМЕРЕНИЙ с выпадающими пиктограммами и 
выпадающих меню. 
• Эскизная геометрия должна быть образмерена и на нее должны быть наложены зависимости. 
• В МЕНЕДЖЕРЕ НАМЕРЕНИЙ можно создавать различные геометрические примитивы: линии, 
окружности, дуги, прямоугольники, сплайны и др. 
• Меню EDIT и SKETCH содержит много инструментов, которые работают только в режиме 
эскизирования, типа Copy, Mirror, Move и Trim. 
• Размеры по умолчанию могут быть изменены на любом этапе проектирования модели. 
• Система выдаст сообщение, если обнаружит конфликтующие зависимости. 
• Настройки Среды эскизирования могут быть изменены в диалоговом окне SKETCHER 
PREFERENCES.
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Глава 5 

Эскизные Элементы 

В этой главе Вы научитесь создавать эскизные элементы на эскизных плоскостях. Вы 
также изучите, как изменять эскизы в модели. 

Цели 
В этой главе изучается, как: 

• создавать эскизы вырезов и выдавливаний. 

• Создавать элементы выдавливания и вращения. 

• Устанавливать эскизные плоскости. 

• Образмеривать эскизные объекты. 

Определение Эскизных Элементов 

Эскизирование Вырезов и Выдавливаний 
• Protrusion � добавляет материал любой формы (Extrude или Revolve) к модели. 

• Cut � удаляет материал из модели в виде замкнутого или открытого сечения. 

 
Рисунок 1: Выдавливание и Вырез 

Создание Элементов Выдавливания и Вращения 
• Extrude � линейно добавляет или удаляет материал от эскизной плоскости. 

• Revolve � создает элемент путем вращения эскиза сечения вокруг эскизной оси. 
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Рисунок 2: Элементы Выдавливания и Вращения 

Выбор Эскизной Плоскости 
Для создания нового элемента в модели, начните эскиз на той поверхности, где требуется разместить 
элемент. Выбранная поверхность определяет эскизную плоскость. 

Выбор Плоскости Привязки 
После создания и образмеривания эскиза, новый элемент ориентируется относительно плоскости 
привязки (reference plane). Плоскость привязки должна быть перпендикулярна эскизной плоскости. 

Изменение Плоскости Привязки По умолчанию 
Можно изменять ориентацию по умолчанию и вручную выбирать новую плоскость привязки. 

По умолчанию эскизная плоскость ориентируется параллельно экрану и выбирается один из опорных 
элементов по умолчанию в качестве плоскости привязки. Например, можно вручную выбрать 
поверхность Тор модели в качестве ориентации, перпендикулярной привязке. 

 



  Pro/ENGINEER 2001 Базовый Курс 

- 69 - 

 

 
Рисунок 3: Два Элемента, Построенные по Одному и Тому же Эскизу Поперечного Сечения 

Использование Инструментов Эскиза 

Всякий раз при создании эскиза, Pro/ENGINEER автоматически создает схему образмеривания. Так 
как все эскизы являются параметрическими, их можно создавать в удобном масштабе и, позже, 
изменять их размеры. 

В Среде эскизирования, выпадающее меню Sketch содержит все необходимые инструменты 
эскизирования. 

Другое дополнительное меню пиктограмм, содержащее инструменты эскизирования и зависимости, 
отображается в правой части окна. 

Образмеривание Сечения 
Для замены «слабых» размеров (weak dimensions) на постоянные, необходимо выбрать объект, 
щелкнуть средней кнопкой мыши и разместить размер в требуемом месте. 
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Рисунок 4: Функции Кнопок Мыши в Среде Эскизирования 

Линейные Размеры 
Линейные размеры указывают длину линейного сегмента или расстояние между двумя объектами. 
Различные типы линейных размеров показаны на следующем рисунке. 

 
Рисунок 5: Линейные Размеры в Режиме Эскизирования 

Обратите внимание: 
Нельзя указать длину осевой линии. 

Диаметральные размеры 
Диаметральные размеры обозначают диаметры эскизных окружностей и дуг. Для создания 
диаметрального размера, дважды щелкните по дуге или окружности и нажмите среднюю кнопку мыши 
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Рисунок 6: Диаметральный Размер на Окружности 

Для создания диаметрального размера для сечения вращения (revolved), щелкните по объекту для 
образмеривания и осевую линию, используемую в качестве оси вращения. Затем повторно выберите 
объект и разместите размер. 

 
Рисунок 7: Диаметральные Размеры для Сечения Вращения в Режиме Эскизирования 

Обратите внимание: 
Диаметральные размеры для элементов вращения выходят за осевую линию, указывая, что это - 
диаметральный размер, в отличии от радиальных размеров. 

Радиальные Размеры 
Радиальные размеры измеряют радиус окружностей или дуг. Для создания радиального размера 
выберите окружность или дугу и разместите размер. 

 
Рисунок 8: Радиальный Размер в Режиме Эскизирования 
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Угловые Размеры 
Угловые размеры создаются между линиями, выбирая эти две линии. Щелкните средней кнопкой 
мыши для размещения размера. Место размещения размера, определяет то, как система измеряет 
угол. 

 
Рисунок 9: Угловые Размеры в Режиме Эскизирования 

Для создания углового размера дуги выберите одну конечную точку, затем другую конечную точку и, 
наконец, дугу. Щелкните средней кнопкой мыши для размещения размера. 

 
Рисунок 10: Угловой Размер Дуги в Режиме Эскизирования 

Лабораторный Практикум 

Цель 
В этом практикуме Вы создадите посредством эскизирования элементы путем 
выдавливания и выреза сечения на эскизной плоскости. 

Метод 
В Упражнении 1, создается элемент выреза. 

В Упражнении 2, создается элемент выдавливания. 



  Pro/ENGINEER 2001 Базовый Курс 

- 73 - 

Инструменты 
ПИКТОГРАММА ОПИСАНИЕ 

   Осевая линия эскиза 

   Вкл/Выкл Сетки 

УПРАЖНЕНИЕ 1: Создание Выреза 

 
Рисунок 11: Завершенная Модель 

Задача 1. Создать элемент выреза по замкнутому сечению. 

1. Откройте SKETCHED_FEATURES.PRT. 

2. Включите условное отображение скрытых линий Hidden Line. 

3. Щелкните по Insert > Cut > Extrude. 

4. Щелкните One Side > Done. 

 
Рисунок 12: Выбор Эскизной Плоскости 

Задача 2. Указать переднюю поверхность в качестве эскизной плоскости. 

1. Оставьте значения по умолчанию и укажите Query Sel для выбора плоской передней поверхности 
кубика в качестве плоскости для эскизирования формы выреза. 

2. Элемент выреза должен выдавливаться в деталь. Щелкните по ОК в меню DIRECTION. 

Задача 3. Сориентировать модель, выбирая привязки ориентации. 

1. Щелкните по Top в меню SKET VIEW. 

2. выберите верхнюю плоскую поверхность в качестве ориентирующей. 
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Примечание 

Вместо ручного ориентирования модели, можно щелкнуть по Default в меню SKET VIEW для выбора 
режима эскизирования по умолчанию. 

Задача 4. Задать привязки. Назначение конструкции выреза состоит в том, чтобы он проходил 
насквозь от передней до задней поверхности. 

1. Обратите внимание, что Pro/ENGINEER автоматически назначает две привязки. Для удаления этих 
двух привязок в диалоговом окне REFERENCES, подсветите их и щелкните по Delete. 

2. выберите нижнюю и правую поверхности детали в качестве привязок. 

Обратите внимание, что обе записи в диалоговом окне REFERENCES называются 
SURF:F4(Protrusion). Щелкните по Close. 

 
Рисунок 13: Определение Привязок 

Задача 5. Создать сечение для выреза. 

1. Щелкните по . Создайте линию слева направо. Щелкните левой кнопкой мыши для указания 
конечной точки линии. Щелкните средней кнопкой мыши для завершения команды. 

2. Щелкните по . Щелкните по правой конечной точке линии и протяните дугу на 180 градусов. 
Укажите конечную точку дуги. 

Обратите внимание: 
Если эскиз с первого раза не получился, можно отменить действие, выбирая Undo. 
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Рисунок 14: Создание Касательной Дуги 

3. Из конечной точки дуги нарисуйте другую горизонтальную линию. 

4. Завершите сечение созданием последнего дугового сегмента, касательного к двум горизонтальным 
линиям. 

 
Рисунок 15: Завершенный Эскиз Сечения 

Задача 6. Сделать две горизонтальных линии равными по длине. 

1. Наложите зависимость равной длины. Щелкните по  и . 

2. выберите две горизонтальных линии, которые требуется сделать одинаковыми. 

3. Если такая зависимость уже была наложена Pro/ENGINEER самостоятельно, то в эскизе 
образуются конфликтующие зависимости, для решения которых появляется диалоговое окно 
RESOLVE SKETCH. 
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Рисунок 16. Диалоговое Окно Resolve Sketch 

4. Сохраните зависимость Equal Lengths (Равная длина) и удалите любую другую зависимость. 
Задача 7. Заменить существующие «слабые» размеры и зависимости собственными размерами и 
зависимостями. 

1. Щелкните по . выберите точку, лежащую приблизительно посередине между центрами двух дуг. 
Переместите мышь по вертикали и щелкните еще раз. 
2. Проверьте наличие символа зависимости симметричности - две стрелки, обозначающие 
симметричное расположение элементов относительно осевой линии. Если МЕНЕДЖЕР НАМЕРЕНИЙ 
добавляет размер, щелкните по Undo и повторите процесс создания осевой линии. Иначе, наложите 
зависимость симметричности самостоятельно, используя меню CONSTRAINT. 

3. Щелкните по . Образмерьте сечение выреза. 
4. Для создания радиусного размера, выберите левую дугу и щелкните средней кнопкой мыши для 
размещения размера. 
5. Для создания размера между центрами дуг, выберите центр каждой дуги и щелкните средней 
кнопкой мыши для размещения размера. 
6. Для создания размера, позиционирующего осевую линию относительно правой поверхности, 
выберите осевую линию, правую поверхность и, затем, щелкните средней кнопкой мыши для 
размещения размера. 
7. Для создания размера, позиционирующего центр левой дуги относительно нижней поверхности, 
выберите центр дуги, нижнюю поверхность и, затем, щелкните средней кнопкой мыши для 
размещения размера. 
8. Завершите образмеривание и привязку сечения выреза. 

 
Рисунок 17: Указание Зависимостей и Размеров. 



  Pro/ENGINEER 2001 Базовый Курс 

- 77 - 

Задача 8. Изменить размеры выреза. 

1. Измените значения размеров. Щелкните по . выберите размер, значение которого требуется 
изменить. 

 
Рисунок 18: Диалоговое Окно MODIFY DIMENSION 

2. Введите требуемое значение и нажмите <ENTER>. 

3. Повторите этот шаг для изменения всех размеров выреза. 

 
Рисунок 19: Измененные Размеры 

Задача 9. Завершить определение выреза. 

1. Щелкните по . 

2. Щелкните по ОК, чтобы принять стрелку, указывающую внутрь детали и определяющую 
направление выреза. 

3. Для определения глубины, щелкните Thru All > Done. 

4. Щелкните по ОК. 

Обратите внимание: 
Система разместила в центре детали окружность со значком X для указания направление создания 
элемента. Эта окружность представляет собой двухмерную стрелку, перпендикулярную экрану в 
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направлении от пользователя (внутрь экрана). Окружность с точкой в центре представляет 
двухмерную стрелку, перпендикулярную экрану в направлении к пользователю (из экрана). 

5. Просмотрите новый созданный элемент выреза в различных видах. 

 
Рисунок 20: Завершенный Вырез 

УПРАЖНЕНИЕ 2: Создание Выдавливания 
Задача 1. Создать цилиндрическое выдавливание на правой стороне модели. 

 
Рисунок 21: Окончательное Выдавливание 

1. Щелкните по Insert > Protrusion > Extrude. 

2. Щелкните по One Side > Done в меню ATTRIBUTES. 

3. выберите правую часть блока в качестве эскизной плоскости. 

4. Стрелка указывает наружу от детали. Щелкните по ОК в меню DIRECTION. 

5. Щелкните по Default в меню SKET VIEW. 

Задача 2. Определить две привязки в Среде эскизирования в виде по умолчанию. 

1. Щелкните по View > Default Orientation. 

2. Щелкните по  [вкл\выкл сетки], чтобы можно было четко видеть деталь. 

3. Удалите две привязки в диалоговом окне REFERENCE. 

4. выберите верхнюю поверхность модели в качестве привязки. Щелкните правой кнопкой мыши и 
выберите Query Select из выпадающие меню для выбора задней скрытой поверхности. 
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5. Закройте диалоговое окно REFERENCE. 

 
Рисунок 22: Выбор Привязок Сечения 

6. Щелкните по View > Sketch Orientation. 

Задача 3. Создать сечение для выдавливания. 

1. Щелкните по . 

2. Нарисуйте эскиз небольшой окружности. 

Задача 4. Задайте размеры. 

1. Щелкните по . 

2. Дважды щелкните по окружности и щелкните средней кнопкой мыши для размещения размера. 

3. выберите центр окружности и левую поверхность привязки. 

Щелкните средней кнопкой мыши для размещения размера. 

4. Разместить размер между центром окружности и левой поверхностью привязки. 

Задача 5. Изменить значения размеров для отражения назначения конструкции. 

 
Рисунок 23: Измененные Размеры 
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1. Последовательно выберите каждый из этих трех размеров при нажатой клавише <SHIFT>. 

2. Щелкните по Edit > Modify. Появляется диалоговое окно MODIFY DIMENSIONS. 

3. Измените значение каждого из размеров в соответствии с предыдущим рисунком. 

4. Щелкните по  для закрытия диалогового окна MODIFY DIMENSIONS. 

5. Щелкните по  в МЕНЕДЖЕРЕ НАМЕРЕНИЙ для завершения сечения. 

Задача 6. Определить значение глубины выдавливания. 

1. Щелкните по Blind > Done в меню SPEC TO. 

2. Введите [3] в окне ENTER DEPTH и нажмите <ENTER>. 

3. Щелкните по ОК. 

4. Просмотрите вашу модель в различных видах. 

5. Щелкните по File > Save и нажмите <ENTER>. 

6. Щелкните по File > Erase > Current; затем щелкните Yes в диалоговом окне. 

 
Рисунок 24: Окончательная Модель 

Резюме 

В этом модуле было изучено, что: 

• Вырез (Cut) и Выдавливание (Protrusion) являются двумя важными элементами которые могут 
быть созданы в Среде эскизирования. 

• Оба этих эскизных элемента могут быть созданы в форме выдавливания или вращения. 

• При создании нового эскиза его можно нарисовать приблизительно и путем изменения размеров 
придать ему требуемую форму. 

• В новом эскизе на линии, дуги и окружности можно наложить различные зависимости, типа равной 
длины, концентричности, перпендикулярности, параллельности или симметрии. 

• Эскизный элемент следует не только образмерить, но и правильно сориентировать его 
относительно плоскостей привязки (обычно, боковые стороны базового элемента). 
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Глава 6 

Исходные Опорные Элементы По Умолчанию 

В этой главе Вы научитесь использовать опорные плоскости при создании детали. 

Цели 
В этой главе будет: 

• изучено назначение и использование опорных плоскостей в качестве базовых элементов. 

• Показана разница между внутренними и внешними опорными плоскостями. 

• Создана новая конструкция с опорными и смещенными опорными плоскостями в качестве базовых 
элементов. 

• Совмещены с деталью эскизные сечения. 

• Сориентированы дополнительные опорные плоскости внутри модели. 

Использование Опорных Плоскостей в Качестве Базовых 
Элементов 

Базовые Элементы 
Базовый элемент - первый элемент, создаваемый при создании новой детали. Он является основой 
для последующих элементов модели. Элементы, которые позже добавляются к модели, зависят от 
некоторых или всех привязок базового элемента. На следующем рисунке показан пример, где цилиндр 
используется в качестве базового элемента детали. 

 
Рисунок 1: Базовый Элемент 



Pro/ENGINEER 2001 Базовый Курс    

- 82 - 

Опорные Плоскости 
Опорная плоскость - мнимая плоскость, которая используется в качестве привязки для 
ориентирования деталей и сборок. Опорные плоскости бесконечны, двухмерны и абсолютно плоские. 
Они не имеют никакой массы или объема. По умолчанию, опорные плоскости имеют две стороны: 
желтую (активная сторона) и красную (пассивная сторона). По умолчанию, система отображает 
опорные плоскости желтой стороной к пользователю и название типа FRONT, TOP и RIGHT. 

Использование Опорного Элемента По Умолчанию в Качестве Базового 
Элемента 

При создании новых моделей, Pro/ENGINEER автоматически создает опорную плоскость по 
умолчанию в качестве первого элемента. Это делается потому, что опорные плоскости позволяют: 

• создавать отношения Родитель/Потомок между различными элементами. 

• Использовать планарные (плоские) поверхности в качестве привязок, необходимых при создании 
моделей, которые не имеют плоских поверхностей. 

Создание Опорных Плоскостей 
Опорный элемент можно создать в любое время. Дополнительные опорные плоскости создаются в 
качестве элементов привязки для модели, где привязки не существуют. 

При создании опорного элемента, его можно определить, используя несколько различных методов. 
Хотя методы создания отличаются, зависимости Опорной плоскости остаются теми же: 

• Through/Plane (Через/Плоскость) 

• Offset/Plane (Смещение/Плоскость) 

• Offset/Coord (Смещение/Координата) 

• Blend Section (Сечение Сопряжения) 

Создание Внутренних Опорных Плоскостей 
Если опорные плоскости не должны являться элементом модели, можно создать внутренний опорный 
элемент, по ходу построения (on the fly), при определении эскизной плоскости или плоскости 
привязки. Иногда, выгодно строить внутренние опорные плоскости, потому что они не понадобятся 
при создании следующих элементов. 

Используйте следующие правила для опорных плоскостей, создаваемых по ходу построения: 

• опорные плоскости, созданные в процессе создания элемента, являются внутренними и 
принадлежат этому элементу. 

• Опорные плоскости, созданные по ходу построения, становятся скрытыми после создания 
элемента. Все ассоциативные размеры, позиционирующие опорную плоскость, включаются в этот 
элемент. Это придает большую гибкость при создании массивов. 

• При использовании команд Copy/Mirror для копирования элементов и использовании опорных 
плоскостей, созданных по ходу построения, в качестве плоскости отображения, эта опорная плоскость 
становится видимой, так как она относится более, чем к одному элементу. 

Лабораторный Практикум 

Цель 
В этом практикуме в Pro/ENGINEER будут созданы модели новых деталей с использованием 
шаблонов по умолчанию. 
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Метод 
В Упражнении 1, создаются элементы выдавливания и вращения, используя опорные плоскости по 
умолчанию, находящиеся в шаблоне по умолчанию. 

В Упражнении 2, создается опорная плоскость по ходу построения твердотельного элемента для 
создания требуемых отношений Родитель/Потомок. 

УПРАЖНЕНИЕ 1: Создание Новой Детали 
Задача 1. Создать модель новой детали с использованием шаблона по умолчанию. 

1. Щелкните по File > New. Назовите деталь. Введите [MOTOR_SHAFT]. Примите опцию Use default 
template и щелкните по ОК. 

2. Появляются система координат по умолчанию и три ортогональных опорных плоскости по 
умолчанию FRONT, RIGHT и TOP с желтыми сторонами, обращенными к пользователю. 

3. Щелкните по . Обратите внимание на список сохраненных видов, которые были созданы с 
использованием шаблона по умолчанию. 
4. В Менеджере меню щелкните по Setup > Units > millimeter Newton Second (mmNs) > Set. 
Щелкните по ОК в диалоговом окне WARNING, затем щелкните по Close. 
5. Щелкните по Done для выхода из меню SETUP. 

 
Рисунок 1: Опорные Плоскости По Умолчанию и Система Координат 

Задача 2. Использовать опорные плоскости по умолчанию в качестве привязки эскиза для первого 
элемента. 

1. Щелкните по ярлычку опорной плоскости FRONT. Выбранная плоскость становится эскизной 
плоскостью. 

2. Щелкните по Insert > Protrusion > Extrude. 

3. Обратите внимание, что система автоматически выбирает плоскость привязки и переходит в Среду 
эскизирования. Если требуется изменить атрибуты выдавливания, можно воспользоваться опцией 
Redefine. 

4. Обратите внимание, что МЕНЕДЖЕР НАМЕРЕНИЙ автоматически размещает привязки (RIGHT и 
TOP) для назначенного выдавливания. Щелкните по Close. 
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5. Щелкните по . выберите точку пересечения опорных плоскостей. Протяните курсор на 
требуемый диаметр окружности и вторым щелчком создайте ее. МЕНЕДЖЕР НАМЕРЕНИЙ добавляет 
«слабый» диаметральный размер. Щелчком средней кнопкой мыши завершите создание окружности. 

 
Рисунок 2: Эскизная Окружность в Центре Опорных Плоскостей 

Задача 3. Изменить диаметральный размер и регенерировать сечение для отображения изменений. 

1. Измените диаметр. Дважды щелкните по диаметральному размеру. Введите [14.5]. 

2. Нажмите <ENTER>. 

3. Щелкните по . Обратите внимание, что система автоматически назначает глубину и завершает 
выдавливание. 

4. Измените вид на вид по умолчанию. Щелкните по  и Default. 
Задача 4. Изменить глубину на 240мм. 

1. Обратите внимание, что можно использовать зеленую пиктограмму в середине выдавливания для 
динамического изменения глубины. 

2. В меню PART, щелкните по Modify > Value и выберите только что созданное выдавливание. 
Щелкните по значению глубины и введите [240]. Щелкните по Regenerate в меню PART. 

Задача 5. Добавить к созданному выдавливанию элемент повернутого выреза. В качестве привязки 
сечения, используйте опорные плоскости по умолчанию. 

1. Щелкните по Insert > Cut > Revolve. 

2. Щелкните One Side > Done. 

3. При помощи опции Query Sel выберите опорную плоскость RIGHT в качестве эскизной плоскости. 
Щелкните по OKAY для подтверждения направления создания. 

4. выберите LEFT в меню SKET VIEW и, при помощи Query Sel, выберите опорную плоскость FRONT 
в качестве плоскости привязки. 

5. Теперь опорная плоскость RIGHT является эскизной поверхностью. 

Задача 6. В эскизе сечения вращения необходимо использовать осевую линию, являющуюся осью 
вращения. Создайте осевую линию и продолжайте определять сечение. 

1. Щелкните по  и увеличьте левый конец вала. 
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2. Если диалоговое окно REFERENCE случайно закроется до того, как будут определены привязки, 
щелкните по Sketch > References для его вызова. 

3. Удалить две привязки, предлагаемые МЕНЕДЖЕРОМ НАМЕРЕНИЙ. 

4. выберите опорную плоскость TOP в качестве первой привязки. Затем выберите кромку силуэта 
выдавливания и левой торцевой поверхности в качестве второй и третьей привязки. 

5. Закройте диалоговое окно REFERENCE. 

 
Рисунок 3: Выбор Привязок для Выреза 

6. Создайте эскиз осевой линии, которая совпадает с опорной плоскостью ТОР. 

7. Нарисуйте три линейных сегмента. 

 
Рисунок 4: Эскиз для Выреза Вращения 

(Размеры для ясности не показаны) 

Задача 7. Создать диаметральный размер. 

1. Щелкните по . 

2. выберите эскизную горизонтальную линию. выберите осевую линию. Снова выберите 
горизонтальную линию. Щелкните средней кнопкой мыши для размещения размера. 
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Рисунок 5: Создание Диаметрального Размера 

3. Измените размеры сечения. Щелкните по  и измените размеры. 

 
Рисунок 6: Измененные Размеры 

Задача 8. Завершить определение выреза вращения в модели. 

1. Щелкните по . 

2. Если необходимо, измените направление стрелки для удаления материала из внутренней части 
сечения. Иначе, щелкните по ОК. 

3. выберите 360 и щелкните по Done в меню REVOLVE TO. 

4. Щелкните по ОК для завершения элемента. 

5. Перейдите к виду по умолчанию. Щелкните по View > Default. 
6. Сохраните модель. 
7. Щелкните по File > Erase > Current > Yes. 

УПРАЖНЕНИЕ 2: Создание Внутренней Опорной Плоскости 
В этом упражнении, перед добавлением выдавливания к модели сначала создается внутренняя 
опорная плоскость. 
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Рисунок 7: Завершенная Модель 

Задача 1. Добавить опорную плоскость к детали для использования в качестве эскизной привязки 
создаваемого элемента цилиндрического выдавливания. 

1. Откройте модель детали INTERNAL_DTM.PRT. 

2. Щелкните по Insert > Protrusion > Extrude. 

3. Щелкните по One Side > Done в меню ATTRIBUTES. 

4. Щелкните Make Datum > Offset в меню SETUP PLANE. выберите плоскую переднюю поверхность 
блока в качестве привязки для новой плоскости. 

 
Рисунок 8: Создание Эскизной Плоскости 

5. В меню OFFSET, щелкните по Enter Value. 

6. Введите [1] в качестве величины смещения. Щелкните по Done. 

Задача 2. Закончить определение выдавливания, используя опорную плоскость в качестве эскизной 
плоскости. 

1. Измените направление выдавливания внутрь модели. 

2. Щелкните по Top и выберите верхнюю планарную поверхность блока в качестве плоскости 
привязки. 

3. Удалите две привязки по умолчанию. выберите ось A_2 первого цилиндра в качестве первой 
привязки. выберите правую вертикальную поверхность блока, на которой начинается цилиндр в 
качестве второй привязки. Закройте диалоговое окно REFERENCE. 
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4. Щелкните по . Создайте эскиз окружности с центром, совпадающим с осью A_2. 

5. Измените диаметр окружности на 0.88. 

6. Измените расстояние от левой вертикальной поверхности основания блока на 1.5. 

 
Рисунок 9: Измененные Размеры 

7. Щелкните по . 

8. Щелкните по Thru Next > Done в меню SPEC TO. 

9. Завершите работу с элементом. 

10. Закрасьте и сохраните модель. 

 
Рисунок 10: Завершенная Модель 

Резюме 

В этом модуле было изучено, что: 

• Опорные плоскости являются бесконечными, двухмерными, плоскими привязками, которые не 
имеют ни массы, ни объема. 
• Опорные плоскости выполняют роль идеальных базовых элементов при создании новых деталей 
и моделей. 
• В процессе создания модели в Pro/ENGINEER могут быть созданы дополнительные базовые 
плоскости. 
• Существуют различные типы базовых плоскостей, типа Through/Plane (Через/Плоскость), 
Offset/Plane (Смещение/Плоскость), Offset/Coord (Смещение/Координата), Blend Section (Сечение 
Сопряжения). 
• Внутренние базовые плоскости можно создавать таким образом, чтобы они не являлись 
элементами модели. 
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Глава 7 

Отношения Родитель / Потомок 

В этом модуле изучаются отношения Родитель / потомок в Pro/ENGINEER. Порядок, в 
котором элементы создаются и связываются друг с другом, создают иерархические 
отношения. Эти отношения Родитель / потомок определяют взаимодействие элементов. 
Здесь будет показано, как управлять отношениями Родитель / потомок для достижения 
требуемого поведения моделей. 

Цели 
В этой главе: 

• описываются отношения родитель / потомок в Pro/ENGINEER. 

• Описываются отношения родитель / потомок эскизных элементов. 

• Описываются отношения родитель / потомок элементов, размещаемых по щелчку. 

• Описывается изменение родителей элемента в модели с использованием опций Reroute, 
Redefine и Reorder при изменении исходного «назначения конструкции». 

Отношения Родитель / Потомок в Pro/Engineer 

Твердотельное моделирование - совокупный процесс, в котором создание некоторых элементов 
должно, при необходимости, предшествовать другим. При создании нового элемента, Pro/ENGINEER 
привязывает его к ранее созданным элементам для получения информации относительно размера, 
формы, местоположения и ориентации. При этом формируется база для отношений родитель / 
потомок. Элемент, используемый в качестве привязки (reference) становится родителем по 
отношению к новому элементу, потомку. 

Отношения родитель / потомок определяют, как элементы реагируют при изменении некоторого 
элемента в модели. 

Отношения Родитель / Потомок Элементов, Размещаемых По Щелчку 
Элементы, размещаемые по щелчку, также имеют родительские привязки, потому что они используют 
существующую геометрию для размещения и ориентации. Любой выбор на поверхности или кромке 
создает отношения родитель / потомок. 

Система имеет различные опции для выбора привязок, которые позволяют создавать различных 
родителей для элемента. 

• Tangent Chain � указывает привязку только для выбранной кромки, но применяет элемент ко 
всем кромкам, касательным к выбранной. 

• One by One � указывает привязку для каждой выбранной кромки. 

• Surf Chain � указывает привязку для выбранной поверхности и одной кромки. Также можно 
создавать привязки для выбранных кромок, если используется опция From-To. 
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Отношения Родитель / Потомок Эскизных Элементов 
При создании элементов, эскизные плоскости и плоскости привязки становятся «родителями» нового 
элемента. Если эскизная плоскость перемещается, то элемент перемещается вместе с ней. Точно так 
же, если плоскость привязки, которая определяет ориентацию, изменяется, также изменяется  
ориентация элемента. 

 
Рисунок 1: Пример Отношений Родитель / Потомок 

Изменение «Родителей» Элементов 
Родителей элемента можно изменять, перенаправляя (Reroute) или переопределяя (Redefine) его. 

Перенаправление Родительских Элементов 
При помощи опции Reroute в меню FEAT, можно изменять родителей элемента, включая эскизные 
плоскости, плоскости привязки и любые объекты, определенные в эскизе в качестве привязок. 

В процессе перенаправления элемента, Pro/ENGINEER по одному подсвечивает внешние привязки и 
определяет каждую привязку в области сообщения. Имеется два варианта. Можно щелкнуть по 
Alternate (Изменить) и выбрать новую привязку, или щелкнуть по Same Ref и сохранить текущую 
привязку. 

Обратите внимание: 
Pro/ENGINEER рассматривает привязки, используемые для выравнивания, в качестве привязок для 
образмеривания. 

 
Рисунок 2: Скобка с Опорными Элементами 
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Переопределяемые Элементы 
Опция Redefine в меню FEAT также изменяет родительские элементы. При выборе 
переопределяемого элемента появляется то же диалоговое окно, которое отображается в процессе 
начального создания элемента. 

 
Рисунок 3: Диалоговое окно Создания Элемента 

Работа с Эскизными Элементами 
При создании сечения, можно изменять плоскость эскиза или собственно эскиз. Элементы, созданные 
после сечения, временно исчезают. 

При выборе элемента Section для эскизных элементов, меню отображает следующие опции: 

Sketch Plane � запрашивает указать эскизную плоскость и привязку. Можно выбирать и 
пересматривать все элементы, перечисленные в диалоговом окне. Поэтому, дополнительно к 
возможности изменить родителей элемента, можно также изменять другие элементы типа 
направления и стороны удаления материала перед входом в Режим эскизирования. Для каждого 
варианта, можно выбирать альтернативную или сохранять ту же привязку. 

Sketch � позволяет использовать Режим эскизирования для изменения эскизных объектов, 
добавления / удаления зависимостей и создания / удаления размеров. Система предупредит при 
попытке удалить объект, на который ссылается другой элемент. 

Разрешение Проблем Регенерации 
Pro/ENGINEER основывает определение элемента на родительском элементе. Если родительские 
элементы отсутствуют, система автоматически переходит в среду RESOLVE (Разрешение 
конфликтов). 

Обратите внимание: 
Для предотвращения регенерации элемента необходимо решить, что делать с дочерними 
элементами, если они существуют. 

Регенерация Элементов Родитель / Потомок 
При регенерации модели, Pro/ENGINEER восстанавливает элементы по одному за раз, следуя 
порядку, в который они отображаются в ДЕРЕВЕ МОДЕЛИ.  

Использование Переупорядочивания Элементов и Режима Вставки 
Опции Reorder и Insert Mode в меню FEAT, изменяют порядок элементов. Иначе, можно просто 
перетащить элементы в дереве модели для изменения их положения. 

Обратите внимание: 
Родительский элемент необходимо регенерировать до регенерации его потомков. Поэтому, нельзя 
переупорядочивать родителя, чтобы он находился после своих потомков. Также, нельзя 
переупорядочивать дочерний элемент, чтобы он находился перед своим родителем. 
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Используя опцию Insert Mode, можно создавать один или более элементов в выбранном месте в 
процессе регенерации. Элементы можно вставлять в любой точке, за исключением перед первым или 
за последним элементом. После щелчка по Activate, можно выбирать элемент, после которого 
вставляется элемент. 

Система подавляет любые элементы в процессе регенерации, находящиеся после него. При щелчке 
по Cancel для прекращения вставки элемента, необходимо указать, требуется ли восстановить 
элементы, которые были подавлены в процессе активизации режима Вставки. В случае 
восстановления, система размещает их после вставленного элемента. 

 
Рисунок 4: Переупорядочивание Отверстия 

 
Рисунок 5: Вставка Выдавливания 
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Лабораторный Практикум 

Цель 
В этом практикуме в модели будут изменены существующие и созданы новые 
зависимости родитель / потомок, с целью отслеживания изменений в назначении 
конструкции. 

Метод 
В Упражнении 1, цилиндрическое выдавливание в базовом элементе перемещается на элемент 
выреза, используя функцию Reroute (Перенаправление). Эта операция включает создание новых 
зависимостей родитель / потомок для цилиндрического выдавливания. 

В Упражнении 2, удаляется второе выдавливание и изменяется форма паза, используя функцию 
Redefine (Переопределение). 

Инструменты 
ПИКТОГРАММА ОПИСАНИЕ 

   Скрытие скрытых линий 

   Закраска 

 
Рисунок 6: Исходная Модель 

 
Рисунок 7: Завершенные Модели После Упражнений 1 и 2 

УПРАЖНЕНИЕ 1: Использование Перенаправления Элементов 
Задача 1. Перенаправить половинку цилиндра выдавливания на поверхность элемента выреза. 

1. Вызовите P_C_EXERCISE.PRT. 
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2. Щелкните по  [Скрытие скрытых линий]. 

3. Щелкните по Feature > Reroute в Менеджере меню и оставьте опции по умолчанию. 

4. выберите половинку цилиндрического выдавливания. 

5. Не откатывайте модель детали (не выполняйте roll back примечание переводчика). Примите опцию 
по умолчанию No.  

6. Укажите новую привязку для эскизной плоскости. Оставьте опцию по умолчанию Alternate. 
выберите верхнюю поверхность выреза. 

 
Рисунок 8: Перенаправление Привязок для Выдавливания 

7. Оставьте DTM3 в качестве горизонтальной привязки. Щелкните по Same Ref. 
8. Оставьте заднюю поверхность в качестве привязки для образмеривания. Щелкните по Same Ref. 
9. Измените вторую привязку для образмеривания. Оставьте опцию по умолчанию Alternate. 
выберите сторону модели, как показано в предыдущем рисунке. 

Задача 2. Модель входит в среду Resolve (Разрешения Конфликтов), потому что сделанные 
изменения создают проблему. Исследуйте проблему и разрешите ее. 

1. Изучите появляющееся окно INFORMATION. Оно указывает, что элемент паза необходимо 
регенерировать, так как потеряны привязки. 

2. Щелкните по Undo Changes > Confirm. 

Задача 3. Исследовать зависимости родитель / потомок элемента паза. 

1. Щелкните по Info > Parent/Child. выберите паз на передней стороне базового элемента. 

2. В диалоговом окне REFERENCE INFORMATION WINDOW выберите Parent�s List для 
подсвечивания родителей. 

3. Щелкните по Tree > Expand > All. 
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Рисунок 9 Окно Информация по Привязкам 

4. выберите SURFACE ID 16. Передняя поверхность базового элемента подсвечивается в качестве 
эскизной плоскости. 

5. выберите SURFACE ID 64. Верхняя часть цилиндра подсвечивается в качестве горизонтальной 
плоскости привязки. Это � конфликтные зависимости. 

6. выберите EDGE ID 73. Кромка основания цилиндра подсвечивается в качестве привязки размера. 
Эта привязка привела к конфликту операции перенаправления. 

7. выберите EDGE ID 47. Правая кромка второго выдавливания подсвечивается в качестве привязки 
размера. Этот кромка использовалась в качестве привязки выравнивания. 

8. Щелкните по Close. 

Задача 4. Разорвать зависимости родитель / потомок между пазом и цилиндрическим 
выдавливанием. 

1. Щелкните правой кнопкой мыши по пазу в ДЕРЕВЕ МОДЕЛИ и выберите Reroute из выпадающего 
меню. 

 
Рисунок 10: Выпадающее Меню в Дереве Модели 

2. Не откатывайте модель детали (не выполняйте roll back). Примите опцию по умолчанию No. 

3. Щелкните по Same Ref. Изучите окно сообщения. 

4. Оставьте опцию по умолчанию Alternate. выберите верхнюю поверхность базового выдавливания в 
качестве новой горизонтальной плоскости привязки. 
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Рисунок 11: Перенаправление Паза 

5. Оставьте размерную привязку второго выдавливания. Щелкните по Same Ref. 

6. Измените кромку размерной привязки цилиндра. Оставьте опцию по умолчанию Alternate. выберите 
верхнюю поверхность большого выдавливания. 

7. Область сообщения отображает сообщение: "Feature rerouted successfully (Элемент успешно 
перенаправлен)". 

Задача 5. Перенаправить цилиндрическое выдавливание требуемым образом. 

1. Щелкните правой кнопкой мыши по PROTRUSION ID 58 в ДЕРЕВЕ МОДЕЛИ, затем выберите 
Reroute. 

2. Не откатывайте модель. 

3. выберите верхнюю поверхность выреза в качестве новой эскизной плоскости. 

4. Не изменяйте горизонтальную привязку. Щелкните по Same Ref. 
5. Не изменяйте размерную привязку. Щелкните по Same Ref. 
6. выберите боковую сторону модели в качестве второй размерной привязки. 

7. Успешно перенаправленный цилиндрический элемент отображается, как показано на следующем 
рисунке. 

 
Рисунок 12: Перенаправленный Цилиндрический Элемент 
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УПРАЖНЕНИЕ 2: Использование Переопределения Элемента 
Задача 1. Новое назначение конструкции этой модели предусматривает удаление второго 
выдавливания из модели. Удалите его. 

1. Щелкните правой кнопкой по PROTRUSION ID 29 в ДЕРЕВЕ МОДЕЛИ, затем выберите Delete. 

 
Рисунок 13: Диалоговое Окно Предупреждения 

2. Щелкните по Cancel в окне ПРЕДУПРЕЖДЕНИЯ. 

3. Подсвечивается паз, потому что он является потомком второго выдавливания. 

Задача 2. Разорвать зависимость родитель / потомок между пазом и выдавливанием. Кроме того, 
измените сечение паза. 

1. Щелкните правой кнопкой мыши по пазу в ДЕРЕВЕ МОДЕЛИ и выберите Redefine. 

2. Щелкните по Section > Define > Sketch в диалоговом окне FEATURE. 

Совет: 
Также можно дважды щелкнуть по элементу для изменения его определения. 

3. Для изменения сечения, выберите левую вертикальную эскизную линию, как показано на 
следующем рисунке. Щелкните по Edit > Delete. 

4. Создайте касательную дугу. 

 
Рисунок 14: Новое Сечение Паза 

Задача 3. Изменить схему образмеривания паза. 

1. Щелкните по  > Explain. 

2. Изучите область сообщения. 

3. выберите зависимость вертикальной линии, как показано на следующем рисунке. 

4. Изучите область сообщения. 
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Рисунок 15: Изучение Зависимости 

5. Щелкните по Sketch > References в ГЛАВНОМ МЕНЮ. 

6. выберите EDGE: F6. Щелкните по Delete > Close > Yes. 

Совет: 
Можно легко определять внешние привязки к граням и поверхностям по коричневым пунктирным 
линиям. 

7. Щелкните по View > Default. 

8. Щелкните по . Добавьте размер от левой стороны базового выдавливания до центра левой 
дуги, как показано в следующем рисунке. 

 
Рисунок 16: Образмеренный Паз 

Совет: 
Рекомендуется образмеривать вид по умолчанию во избежание нежелательных зависимостей 
родитель / потомок. 

9. Щелкните по  > OK. 
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Задача 4. Удалить второе выдавливание. 

1. Подсветите Protrusion id 29 в ДЕРЕВЕ МОДЕЛИ. Щелкните правой кнопкой мыши и выберите 
Delete. 

2. Щелкните по ОК, чтобы подтвердить удаление второго выдавливания. 

 
Рисунок 17: Второе Выдавливание Удалено 

Задача 5. Изменить конструкцию таким образом, чтобы паз прошел через всю модель. 

1. Щелкните по Feature > Redefine в менеджере меню. 

2. выберите паз. 

3. Щелкните по Depth > Define > Thru All > Done > OK. 

Задача 6. Проанализируйте модель, используя закраску. 

1. Щелкните по  [Закраска]. Повращайте модель. 

2. Щелкните по View > Saved Views >BACK > Set > Close. 
Совет: 

Также можно выбирать поименованные виды, щелкая по  [Сохраненные виды]. 

 
Рисунок 18: Паз, Переопределенный с Опцией Thru All 

Задача 7. Изменить отверстия для получения втулки. 

1. Убедитесь, что массив отверстий в ДЕРЕВЕ МОДЕЛИ (называемый PATTERN) является последним 
элементом. 

2. выберите SHELL из ДЕРЕВА МОДЕЛИ и перетащите его ниже PATTERN. 

3. Обратите внимание, что отверстия теперь имеют втулку. 
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Рисунок 19: Переупорядоченный Элемент Оболочки 

4. Закройте модель без сохранения изменений. 

5. Щелкните по File > Erase > Current > Yes. 

Резюме 

В этом модуле было изучено, что: 

• Зависимости родитель / потомок являются иерархическими зависимостями в модели, чьи 
элементы выстраиваются последовательно, начиная с базового элемента 

• В процессе регенерации модели Pro/ENGINEER точно следует тому порядку, в котором 
создавались элементы с учетом существующих между ними зависимостей родитель / потомок. 
Дочерний элемент никогда не может быть регенерирован перед своим родительским 
элементом. 

• Для сохранения принципа назначения конструкции, зависимости родитель / потомок между 
различными элементами модели должны всегда поддерживаться. Для этого используются 
опции Reroute, Redefine и Reorder. 

• При использовании опции Insert Mode, между элементами существующей модели может быть 
вставлен новый элемент. 
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Глава 8 

Элементы Протягивания и Сопряжения 

Pro/ENGINEER позволяет создавать геометрию более сложную по отношению к простым 
элементам типа выдавливания или вращения. В этой главе будут изучены  элементы 
протягивания (sweeps) и параллельного сопряжения (parallel blends). 

Цели 
В этой главе Вы изучите: 

• создание элементов протягивания. 

• Создание элементов параллельного сопряжения. 

Элементы Протягивания и Траектории 

Создание Элементов Протягивания И Траектории 
Элементы протягивания состоят из двух элементов - траектории и поперечного сечения. Траектория 
- путь, по которому протягивается поперечное сечение. Первый шаг в определении элемента 
протягивания состоит в создании траектории. Второй шаг - создание поперечного сечения. 
Поперечное сечение необходимо расположить относительно траектории. 

Элемент протягивания может добавлять материал, если он определен как добавление материала, 
или удалять материал, если он определен как вырез. 

Траектория протягивания может быть нарисована в виде открытого или замкнутого эскиза; так что 
сечение не обязательно завершается в начальной точке. Для иллюстрации этого положения на 
следующем рисунке показаны три различных комбинации траекторий и сечений. 
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Рисунок 1: Траектории Протягивания и Сечение 

Создание Параллельных Сопряжений 
Элемент сопряжения объединяет не менее двух плоских сечений, соединенных вместе в их кромках 
переходными поверхностями, формирующими непрерывный элемент. Можно использовать 
сопряжения в виде добавления материала или выреза. 

Параллельное сопряжение создается из единственного сечения, которое содержит несколько 
контуров, называемых подсечениями (subsections). На следующем рисунке, каждый сегмент 
согласуется с последующим сегментом, создавая сопряженные поверхности между 
соответствующими сегментами. Поэтому, каждое сечение или подсечения должны всегда иметь 
одинаковое количество сегментов/вершин. 

 
Рисунок 2: Параллельные Сопряжения 

При сопряжении сечений, Pro/ENGINEER соединяет начальную точку каждого сечения и продолжает 
соединять вершины сечений по часовой стрелке. 

Опция Feature Tools в выпадающем меню SKETCH изменяет начальную точку любого сечения для 
управления сопряжением или закручиванием сопрягаемых поверхностей. Иначе, можно использовать 
выпадающие меню для выбора различных начальных точек. 
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Рисунок 3: Начальные Точки и Форма Сопряжения 

При создании параллельного сопряжения, все сечения для сопряжения создаются в одном эскизе. 
Для их различения, можно переключаться между каждым сечением. Атрибутом элемента 
параллельного сопряжения является smooth (гладкое) или straight (прямое). 

• Атрибут straight � сопрягает переходные поверхности от одного сечения к другому по прямой. 

• Атрибут smooth � сопрягает сечения сплайновой поверхностью. 

Подсечения могут быть размещены относительно других подсечений посредством размеров или 
зависимостей. Если деталь создавалась на основе трех опорных плоскостей по умолчанию, все 
подсечения могут быть образмерены по ним. Как и для любого элемента, схема образмеривания 
важна, так как она передает назначение конструкции модели. 

 
Рисунок 4: Образмеривание Сечений Параллельного Сопряжения 
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Лабораторный Практикум 

Цель 
В этом практикуме будут созданы параллельные сопряжения и простые элементы 
протягивания. 

Метод 
В Упражнении 1, будет создано параллельное сопряжение путем вызова сечения, используемого для 
подсечений. Этот метод эффективен при использовании для общего типа сечений, особенно, если 
они сложные. 

В Упражнении 2, будет создано выдавливание путем протягивания. 

Инструменты 
ПИКТОГРАММА ОПИСАНИЕ 

   Отображение границ модели 

УПРАЖНЕНИЕ 1: Создание Элементов Параллельного Сопряжения 
Задача 1. Начать новую деталь без использования опорных элементов по умолчанию. 

1. Создайте новую деталь по имени PARALLEL_BLEND.PRT. 

2. Снимите галочку с опции Use default template, как показано на следующем рисунке. 

 
Рисунок 5: Создание Детали без Использования Шаблона По Умолчанию 

3. Щелкните Empty > OK в диалоговом окне NEW FILE OPTIONS. 

4. Щелкните по Insert > Datum > Plane. 

Задача 2. Создать элемент параллельного сопряжения путем выдавливания. 

1. Щелкните по Insert > Protrusion > Blend 

2. Примите все опции по умолчанию в меню BLEND OPTS и щелкните по Done. 

3. Оставьте по умолчанию Straight в меню ATTRIBUTES и щелкните по Done. 
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4. выберите DTM3 в качестве привязки эскиза и щелкните по ОК для направления. 

5. Щелкните по Top и выберите DTM2 в качестве плоскости привязки. 

6. Переключите  для отображения линий сетки. 

7. Измените масштаб изображения до 4 X 4 квадратов сетки в месте пересечения DTM1 и DTM2. 

Задача 3. Вызвать первое сечение с диска и разместить его. 

1. DTM1 и DTM2 размещены в качестве привязок сечения. Закройте диалоговое окно REFERENCE. 

2. Щелкните по Sketch > Data from File. 

3. выберите BLEND.SEC и щелкните по ОК. Появляется небольшое сечение сопряжения и диалоговое 
окно SCALE ROTATE. 

4. Для опции Scale введите [3.0]. Для опции Rotate оставьте по умолчанию значение [0.0]. Не 
закрывайте диалоговое окно. 

5. выберите центр сечения; переместите и разместите его так, чтобы вертикальные и горизонтальные 
осевые линии были привязаны к DTM1 и DTM2 соответственно. 

 
Рисунок 6: Размещение Первого Сечения 

6. Щелкните по  в диалоговом окне SCALE ROTATE. 

7. Щелкните по  [Показать границы изображения]. 

Задача 4. Добавить к эскизу второе сечение, используя тот же самый эскиз, но  с другим значением 
масштаба. 

1. Щелкните по Sketch > Feature Tools > Toggle Section. Обратите внимание, что первое подсечение 
дезактивируется и становится серым. 
2. Для повторного вызова сечения BLEND.SEC, щелкните по Sketch > Data from file. 
3. Для опции Scale введите [1.0] и нажмите <ENTER>. 

4. Для опции Rotate оставьте по умолчанию значение [0.0]. Не закрывайте диалоговое окно SCALE 
ROTATE. 

5. Разместите сечение так, чтобы осевые линии совпадали с осевыми линиями предыдущего сечения. 

6. Щелкните по  в диалоговом окне SCALE ROTATE. 

Задача 5.  Еще раз использовать тот же эскиз для третьего сечения сопряжения и назначить ему 
масштабный коэффициент 2. 
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1. Щелкните по Sketch > Feature Tools > Toggle Section. 

2. Вызовите то же сечение BLEND.SEC и назначьте масштабный коэффициент [2.0]. 

3. Эти три сечения должны выглядеть, как показано на следующем рисунке. 

4. Сделайте вид по умолчанию. 

 
Рисунок 7: Создание Третьего Сечения 

Задача 6. Определить элемент. 

1. Щелкните по  для выхода из менеджера намерений. 

2. Введите [30.0] в качестве глубины для второго сечения и нажмите <ENTER> 

3. Введите [20.0] в качестве глубины для третьего сечения и нажмите <ENTER>. 

4. Щелкните по ОК. 

5. Сопряжение должно выглядеть, как показано в нижем рисунке, за исключением того, что размеры 
будут не видны. 

 
Рисунок 8: Завершенный Элемент Сопряжения 

Обратите внимание: 
Pro/ENGINEER использует прямые линии в качестве переходных для соединения вершин подсечений. 

Задача 7. Изменить форму переходных поверхностей с прямой линии на сплайны при помощи 
Redefine. 

1. Щелкните правой кнопкой мыши на элементе сопряжения в дереве модели и выберите Redefine. 
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2. Щелкните по Attribute > Define > Smooth > Done. 

3. Завершите определение. Щелкните по ОК. 

4. Сохраните файл и закройте окно. 

 
Рисунок 9: Прямые и Гладкие Поверхности 

УПРАЖНЕНИЕ 2: Создание Простого Элемента Протягивания 
Задача 1. Создать деталь, начинающуюся с опорных плоскостей по умолчанию. Создать базовый 
элемент выдавливания в качестве протягивания. 
1. Начните новую деталь по имени SWEEP.PRT. 
2. Снимите галочку с опции Use the default template в диалоговом окне New и щелкните по Empty в 
диалоговом окне NEW FILE OPTIONS. 

3. Щелкните по  для создания опорных плоскостей по умолчанию. 

4. Включите  для отображения опорных плоскостей. 
5. Щелкните по Insert > Protrusion > Sweep. 
Обратите внимание: 
Протягивание � это эскиз, состоящий из двух частей: первая � траектория, а следующее - поперечное 
сечение. 
Задача 2. Создать эскиз траектории на DTM2, используя DTM3 в качестве привязки Bottom. 
1. Щелкните по Sketch Traj в меню SWEEP TRAJ. 
2. выберите DTM2 и щелкните по ОК для направления. 
3. Щелкните по Bottom и выберите DTM3 в качестве привязки. 
4. Установите DTM3 и DTM1 в качестве привязок по умолчанию и закройте диалоговое окно 
REFERENCE. 
5. Создайте эскиз открытого сечения траектории, состоящий из линии, касательной дуги; затем 
нарисуйте две линии, как показано на следующем рисунке. Создайте соответствующие размеры. 
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Рисунок 10: Эскиз и Размеры 

6. По завершении траектории, щелкните по  в МЕНЕДЖЕРЕ НАМЕРЕНИЙ. 

7. Система переходит в следующую сессию эскизирования. 

Задача 3. Обратите внимание что осевые линии, созданные системой, находятся в начальной точке 
траектории. Система определяет эскизную плоскость в качестве плоскости, перпендикулярной к 
траектории, расположенной в начальной точке. Создайте эскиз поперечного элемента сечения 
протягивания. 

1. Нарисуйте эскиз поперечного сечения в виде перевернутой буквы T, как показано на следующем 
рисунке. Отображение сетки можно выключить. 

 
Рисунок 11: Эскиз Перевернутой  Буквы "T" 

Вид по умолчанию отображается следующим образом. 



  Pro/ENGINEER 2001 Базовый Курс 

- 109 - 

 
Рисунок 12: Вид По Умолчанию 

2. Щелкните по  для завершения сечения. 

3. Щелкните по ОК для завершения элемента. Элемент протягивания скругляется там, где в 
траектории находится дуговой сегмент и имеет скос там, где имелся угол (некасательный сегмент) в 
траектории. 

4. Сохраните файл и сотрите его из памяти. 

 
Рисунок 13: Завершенный Элемент Протягивания 

Резюме 

В этом модуле было изучено, что: 

• при определении элемента протягивания необходимо определить его траекторию и его 
поперечное сечение. 

• Элемент протягивания может удалять или добавлять материал в зависимости от того, 
является ли он добавлением материала или вырезом. 

• Параллельное сопряжение создается из отдельного сечения, которое содержит несколько 
контуров, называемых подсечениями. 

• Параллельное сопряжение может иметь атрибут прямого или сплайнового сопряжения. 
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Глава 9 

Уравнения и Параметры 

В этом модуле изучается использование уравнений и параметров в процессе 
конструирования модели. Будет показано, как изменение уравнения приводит к изменению в 
модели. 

Цели 
В этой главе будет изучено: 

• назначение уравнений. 

• Четыре типа уравнений, относящихся к модели. 

• Свойства уравнений, которые позволяют родительским элементам управлять дочерними 
элементами. 

• Переупорядочивание уравнений. 

• Удаление и обновление некорректных уравнений. 

Уравнения И Параметры 

Параметрические Уравнения 
Уравнения - пользовательские уравнения, записанные между символическими размерами и 
параметрами. Они могут использоваться для управления отображением изменений в моделях, для 
определения значений размеров в деталях и сборках и в качестве зависимостей для условий работы 
конструкций. 
Следующий рисунок представляет простое отношение между двумя размерами прямоугольного 
элемента, где d0 - всегда вдвое превышает размер d1. 

 
Рисунок 1: Зависимость Детали: d0 = 2*d1 
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Четыре типа уравнений модели следующие: 

• Assembly relations (Зависимости сборки) � связывают параметры различных компонентов 
один с другим, используя кодовые символы для определения различных компонентов. 

• Part relations (Зависимости детали) � связывают параметры различных элементов один с 
другим в одиночной детали. 

• Feature relations (Зависимости элемента) � связывают параметры, принадлежащие 
одиночному элементу детали. 

• Pattern relations (Зависимости массива) � связывают параметры конкретного массива. 

 
Рисунок 2: Различные Типы Уравнений 

Представление Уравнений: Типы и Символы 
Таблица ниже представляет различные элементы, в которые можно включать уравнения. 
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Таблица 1: Уравнения Элементов 

 
Типы зависимостей Уравнение: d0=2* 

Зависимость: d1≥ 2.67 
if (d4>.25) 
endif 

Сравнение: 
d1 d12 = 1.5 
else 
d12=1 

  
Размерные символы d# � размеры детали  

rd# � справочные размеры 
sd# � размеры эскиза 

  
Символы допусков tm# � минусовой допуск 

tp# � плюсовой допуск 
tpm# � допуск плюс / минус 

  
Символы вхождений Целочисленный параметр для вхождения в каждом 

направлении массива: p0, p1, p2 и т.д. 
  
Пользовательские символы Численный параметр (т.е., 3.67)  

Текстовый parameter (т.е., 32-A24-67B)  
Параметр Yes или no  
Параметр примечания модели 

 

Реализация Назначения Конструкции с Использованием Уравнений 
Уравнения позволяют уловить тонкости назначения конструкции в модели. Они являются 
неотъемлемой частью любого процесса проектирования сложных частей и сборок. 
Уравнения позволяют одному элементу управлять другим. Можно воспользоваться преимуществом 
этой уникальной способности и использовать дочерние элементы для управления родительскими. В 
традиционных зависимостях родитель / потомок, присутствует родительский элемент, который всегда 
имеет приоритет (при образмеривании или регенерации). Параметрические отношения позволяют 
изменять иерархическую направленность отношений родитель / потомок в модели. 
В следующем рисунке, можно записать уравнение, которое управляет размещением отверстия так, 
чтобы оно размещалось посередине между верхом и низом: 
/*center hole top to bottom  
d5=d2/2

 
Рисунок 3: Пластина с Параметрами 

Затем можно записать другое уравнение, размещающее отверстие посередине между левой и правой 
стороной: 
/*center hole left to right

d6=d3/2
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После добавления этих уравнений, Pro/ENGINEER автоматически устанавливает отверстие в 
пластине и сохраняет его в центре, даже при изменении высоты или ширины пластины. 

Обратите внимание: 
Символическое название размеров можно изменять, используя Modify > DimCosmetics > Symbol. 

 
Рисунок 4: Уравнения, Управляющие Местоположением Отверстия 

Совет: 
Рекомендуется добавлять уравнения, помогающие осуществить назначение конструкции. Не 
ожидайте окончания процесса проектирования. Также, следует комментировать уравнения, используя 
/* для описания используемых уравнений. 

Необходимо всегда проверять введенные уравнения, чтобы убедиться в их корректном 
функционировании. 

Порядок Уравнений 
Pro/ENGINEER обрабатывает уравнения последовательно. Поэтому, важен порядок их ввода. В 
процессе регенерации модели, система обрабатывает уравнения и проверяет, все ли они являются 
действительными. Если это не так, появляется предупреждающее сообщение. 

На следующем рисунке показаны последствия некорректного ввода уравнений: 
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Рисунок 5: Переупорядочивание Отношений 

Назначение конструкции состоит в том, чтобы центрировать отверстие на пластине. Эти два 
уравнения, d5 = d4 и d4 = d2/2, добавлены в указанном порядке. После первой регенерации модели, 
уравнения не удовлетворяют требуемому назначению. 

Назначение конструкции будет выполнено в случае изменения очередности уравнений. Уравнения 
могут быть удалены или отредактированы, используя опцию Edit Rel. Окончательно 
регенерированная модель показана на следующем рисунке. 

 
Рисунок 6: Модель, Регенерированная с Переупорядоченными Уравнениями 

Изменение Конструкции 
Поскольку процесс проектирования не стоит на месте, назначение конструкции модели имеет 
тенденцию изменяться. Поэтому, существующие в модели уравнения могут терять свою актуальность. 
Всякий раз, когда Pro/ENGINEER в процессе регенерации сталкивается с недействительными 
уравнениями, он автоматически подсвечивает проблему и запрашивает разрешения на ее 
исправление. Можно изменить, либо удалить уравнение. 

Если уравнение необходимо изменить или удалить по причине изменения конструкции или ошибки, то 
его можно отредактировать в модели, используя системный текстовый редактор. 

Редактор, используемый системой, зависит от типа используемого рабочего места. 

Лабораторный Практикум 

Цель 
В этом практикуме будут созданы уравнения и показана возможность управления их 
параметрами. 

Метод 
В Упражнении 1, создаются уравнения для реализации назначения конструкции детали, уравнения 
проверяются и добавляются новые параметры. 
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В Упражнении 2, создаются параметры, которые управляют элементами с использованием уравнений. 

УПРАЖНЕНИЕ 1: Создание Уравнений 
Задача 1. Разместить гладкое отверстие в верхнем прямоугольном основании элемента. 

1. Откройте RELATIONS.PRT. 

2. Включите каркасное отображение. 

 
Рисунок 7: Символические Размеры RELATIONS.PRT 

3. Щелкните по Relations в меню PART. 

4. выберите отверстие для отображения его размеров. 

5. Размеры появляются в их символической форме (то есть, d4, d5, d6). 

6. выберите блок для отображения его символических размеров. 

Задача 2. Добавить уравнение. 

1. Щелкните по Add в меню RELATIONS. 

2. Введите комментарий, описывающий функцию уравнения. Введите [/*center hole front to back]. 
Нажмите <ENTER>. 

3. Введите [d6 = d4/2], затем нажмите <ENTER>. 
4. Для второго уравнения, введите [/* Center hole left to right], затем нажмите <ENTER>. 
5. Введите [d5 = d2/2], затем нажмите <ENTER>. 

6. Нажмите <ENTER> на пустой строке для завершения создания уравнений. 

Задача 3. Переключиться между числовыми и символическими значениями. 

1. Щелкните по Switch Dim в меню RELATIONS. 

2. Щелкните по Done в меню MODEL REL. 

3. Щелкните по Regenerate. Отверстие должно переместиться в центр блока. 
Обратите внимание: 
Если уравнение содержит ошибку, щелкните по Relations > Edit. 
Задача 4. Проверить эти два уравнения, изменяя ширину и глубину базового элемента. 

1. Щелкните по Modify в меню PART. 

2. выберите прямоугольное основание. 

3. выберите ширину блока и измените ее с [50.0] на [70.0]. 

4. Измените размер глубины. выберите глубину блока и измените ее на [90.0] с [50.0]. 
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5. Регенерируйте модель. 

Задача 5. Отобразить размеры отверстия. 

1. Щелкните по Modify в меню PART. 

2. выберите гладкое отверстие для отображения его размеров. 

3. Подтвердите, что два координирующих размера = 35 и 45. 

4. Верните размеры базового элемента к первоначальным значениям. выберите каждый размер и 
введите [50.0]. 

5. Регенерируйте модель. 

Задача 6. Добавить уравнение, которое ограничивает диаметр отверстия значением меньше или 
равным 11.25. 

1. Щелкните по RELATIONS в меню PART. 

2. выберите элемент отверстия. Укажите символическое название, принадлежащее диаметру 
отверстия, (d7). 

3. Щелкните по Add в меню RELATIONS. 

4. Введите соответствующий комментарий. 

5. Введите [d7 < = 11.25]. 

6. Нажмите <ENTER> в пустой строке. 

7. Щелкните по Done в меню MODEL REL. 

Задача 7. Проверить отношение, изменяя диаметральный размер. 

1. Щелкните по Modify > Dimension в меню PART. 

2. Щелкните по диаметральному размеру. Появляется диалоговое окно DIMENSION PROPERTIES. 

3. Введите [15] в качестве номинального значения. 

 
Рисунок 8: Диалоговое Окно DIMENSION PROPERTIES 

4. Регенерируйте модель. 

5. Обратите внимание на предупреждение в информационном окне; затем закройте его. 

6. Продолжайте регенерацию независимо от предупреждения. 
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7. Введите [Y] для продолжения регенерации. 

Задача 8. Изучить уравнения в информационном окне. 

1. Щелкните по Relations > Show Rel. 
2. Закройте окно и щелкните по Done. 

3. Верните назад меньший диаметр. Щелкните по Modify, выберите отверстие, выберите 
диаметральный размер, затем введите [10.0]. 

4. Регенерируйте модель. 

Задача 9. Восстановить отверстие и зенковку, которые были предварительно подавлены. 

1. Щелкните по Feature > Resume. 

2. Регенерируйте только последний набор элементов, которые были подавлены. Щелкните по Last Set 
> Done в меню RESUME. 

 
Рисунок 9: Восстановленное Отверстие 

УПРАЖНЕНИЕ 2: Создание Параметров для Контроля Элементов 
Задача 1. Добавить к модели параметр, затем управлять глубиной зенковкой, используя параметр. 

1. Щелкните по Relations в меню PART. 

2. Щелкните по Add Param. 
3. Введите вещественное число, чтобы глубина могла изменяться на большую величину. Щелкните по 
Real Number. 
4. Введите [depth_ratio] в области сообщения, затем нажмите <ENTER>. 

5. Введите [.10], затем нажмите <ENTER>. 

Задача 2. Добавить уравнение. 

1. Щелкните по Part Rel в меню MODEL REL. 

2. выберите поверхность зенковки. 

3. Щелкните по Add. 

4. Введите [/*control the counter bore depth], затем нажмите <ENTER> 

5. Введите уравнение, чтобы иметь глубину зенковки, равную глубине отверстия за минусом глубины 
резьбы. Введите [d23 = depth_ratio*d22], затем нажмите <ENTER> 

6. Нажмите <ENTER> в пустой строке. 

7. Щелкните по Done в меню MODEL REL. 
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8. Регенерируйте модель. 

Задача 3. Проверить уравнение. 

1. Увеличьте глубину отверстия. Щелкните по Modify и щелкните по зенковке. 

2. Щелкните по размеру глубины и введите [30]. 

3. Регенерируйте модель. 

Задача 4. Отредактировать параметр отношения для изменения отношения между зенковкой и 
отверстием. 

1. Щелкните по Set Up в меню PART, затем щелкните по Parameters в меню PART SETUP. 

2. Оставьте деталь по умолчанию и щелкните по Modify. 

3. выберите DEPTH_RATIO и введите [.5]. 

4. Щелкните по Done в меню PART SETUP. 

5. Щелкните по Regenerate. 

Задача 5. Изменить символическое название полной глубины отверстия и глубины зенковки в целях 
пояснения конструкции. 

1. Щелкните по Modify > Dim Cosmetics. 

2. Щелкните по Symbol, затем выберите зенковку. 

3. выберите размер глубины и введите [entire_depth]. 

4. выберите размер глубины зенковки, затем введите [cbore_depth]. 

5. Щелкните по Done в меню DIM COSMETIC, затем щелкните по Done в меню MODIFY. 

Задача 6. Изучить параметры модели, используя различные методы. 

1. Щелкните по Setup > Parameters > Info в меню MODEL PARAMS. 

2. Изучите окно INFORMATION; затем щелкните по Close. 

3. Щелкните по Done в меню PART SETUP. 

4. Щелкните по RELATIONS > Show Rel. 

 
Рисунок 10: Окно Relation Information 
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5. Обратите внимание, что система перечисляет созданные уравнения  вместе с параметрами. Также 
обратите внимание, что теперь отображаются новые символические названия. 

6. Щелкните по Close > Done. 

7. Сохраните модель и сотрите ее из оперативной памяти. 

Резюме 

В этом модуле было изучено, что: 

• Уравнения являются пользовательскими математическими уравнениями, состоящими из 
символьных параметров и размеров. Они реализуют назначение конструкции в детали или 
нескольких деталей в сборке. 

• Существует четыре различных типа уравнений: уравнения сборки, уравнения детали, 
уравнения элемента и уравнения массива. 

• Порядок следования уравнений критичен для сохранения назначения конструкции, так как 
Pro/ENGINEER вычисляет уравнения в порядке их следования. 

• В процессе регенерации модели недействительные или конфликтующие уравнения 
подсвечиваются и Pro/ENGINEER запрашивает разрешения на их исправление. 

• Пользователь должен всегда планировать уравнения, как неотъемлемую часть детали или 
сборки. 

• Уравнения могут «разумно» подходить к вопросу, чтобы дочерние элементы управляли 
своими родителями. 
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Глава 10 

Поведенческое Моделирование 

Системы Автоматизированного Проектирования в процессе развития прошли четыре 
стадии: двухмерное черчение, трехмерно каркасное моделирование, 3-ное твердотельное 
моделирование и 3-ное твердотельное моделирование с ассоциативными, 
параметрическими и элементно-ориентированными характеристиками. 

Последнее современное состояние, 5-е поколение САПР называется Поведенческое 
Моделирование (Behavioral Modeling). В этом модуле даются основы поведенческого 
моделирования в Pro/ENGINEER. 

Цели 
В этой главе будут: 

• изучены цели поведенческого моделирования. 

• Описаны различные компоненты Поведенческого Моделирования и принципы их 
использования. 

• Изучены масс-инерционные характеристики. 

• Изучены принципы построения зависимостей аналитических элементов модели. 

• Показано управление чувствительностью (sensitivity), технической осуществимостью 
(feasibility) и оптимизацией (optimization). 

Поведенческое Моделирование 

Требования к изделиям становятся все более и более изменчивыми, а изделия все более 
специализированными. В этой ситуации, необходимы условия для автоматизации процесса 
проектирования деталей таким образом, чтобы конструктор мог сосредоточиться на творческой 
работе. Поведенческое Моделирование является такой технологией. 
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Рисунок 1: Развитие САПР 

Элементы Поведенческого Моделирования 
Мощные возможности Поведенческого Моделирования управляются тремя факторами: 

1. «Разумными» Моделями 

2. Возможностями Объектно-Управляемых Конструкций 

3. Открытой Масштабируемой Средой 

 
Рисунок 2: Краеугольный Камень Поведенческого Моделирования 

«Интеллектуальные» модели 
• «Разумные» модели являются интеллектуальными моделями, которые адаптируются к среде. 

• Они содержат все технические требования и обрабатывают информацию, которая от них 
требуется. 
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• Поскольку «разумные» модели знают свой контекст и цели, конструктор может новаторски и 
дифференцированно разрабатывать изделия по требованию заказчиков. 

 
Рисунок 3: «Разумная» Модель, Адаптирующаяся к Изменениям 

Возможности Объектно-Управляемых Конструкций 
• Объектно-управляемый подход к конструированию позволяет автоматически оптимизировать 

конструкцию для удовлетворения любому количеству задач, реализуемых в «разумной» 
модели. 

• Возможно одновременное разрешение противоречивых требований; задача, решение которой 
зачастую невозможно при традиционных подходах. 

• Дополнительно к определению проблемы при помощи стандартных инструментов типа центра 
тяжести или длины кромки, в элементах могут быть реализованы более сложные требования. 
Например, анализ сложных поверхностей или кривых, а также комплексные уравнения. 

Например, требуется разместить отверстие, совпадающее с осью центра тяжести конструкции. 
Определение элемента центра тяжести и параметрическое увязывание его с отверстием 
обеспечивает совпадение элемента с отверстием, даже в случае проведения других изменений в 
конструкции, перемещающих центр тяжести. 

Открытая Среда 
• «Разумные» модели могут содержать элементы, связанные с информацией в других 

приложениях. 
• Такие внешние элементы обеспечивают максимальную гибкость конструктивных решений. 
• Внешние элементы находятся внутри «разумных» моделей и связаны с другими 

приложениями. 

Использование Поведенческого Моделлера 

Ниже приведен пример применения Поведенческого Моделлера: 

• Создание параметров элементов на основании размеров и анализа модели 

 
Рисунок 4: Создание Параметров 
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• Создание опорной геометрии на основании измерения и анализа модели 

 
Рисунок 5: Создание Опорных Элементов 

• Создание новых типов размеров, отвечающих специфическим потребностям 

 
Рисунок 6: Создание Новых Типов Размеров 

• Анализ поведения измеряемых параметров при измерении размеров 

 
Рисунок 7: Анализ Изменяющихся Размеров 

• Автоматическое определение значений размеров, при которых достигается требуемое 
поведение модели. 
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Рисунок 8: Определение Оптимального Расстояния и Размера 

• Обмен информацией между внешними приложениями и Pro/ENGINEER. 
• Электронные таблицы 

Математический аппарат решения различных уравнений 
Среда математических вычислений при численных расчетах и высокоуровневые языки 
программирования 
Вычислительная Гидродинамика (Computational Fluid Dynamics (CFD)) 
Свето-оптический анализ 
Анализ трубопроводов и вентиляции (HVAC) 
Математический аппарат моделирования, который оптимальным образом соответствует 
различным целям м зависимостям 

 
Рисунок 9: Решение Комплексных Проблем 

• Наложение графиков 

 
Рисунок 10: Сравнение Графиков 
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• Выполнение кинематического анализа. 

 
Рисунок 11: Анализ Движения 

Определение Компонентов Поведенческого Моделлера 
• Элементы Анализа (Analysis Features) � опорные элементы, которые измеряют или 

оценивают геометрию и генерируют результирующие параметры и геометрию. 

 
Рисунок 12: Символы Элементов Анализа 

• Пространственные Точки (Field Points) � опорные точки, которые частично ограничивают 
или освобождают перемещение в пределах своего ограничения. 

 
Рисунок 13: Пространственные Точки 

• Пользовательский Анализ (User-Defined Analysis (UDA)) � анализ, который настраивается в 
соответствии с потребностями пользователя и определяется набором элементов. 

 
Рисунок 14: Пользовательский Анализ 
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• Анализ Чувствительности (Sensitivity Analysis) � анализ, который показывает, как 
изменение конкретного параметра воздействует на результаты анализа. На следующем 
рисунке, ось Х измеряет ширину, а Ось Y - объем. 

 
Рисунок 15: Диаграмма Чувствительности 

• Анализ технической осуществимости (Feasibility Study) � исследование, которое 
определяет, может ли быть достигнута указанная зависимость или цель при изменении 
некоторых параметров модели в пределах указанных диапазонов. 

 
Рисунок 16: Диалоговое окно Feasibility 
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• Оптимизация (Optimization) � если для указанного набора зависимостей или целей 
существует несколько решений, то для определения того, которое решение обеспечивает 
минимальное или максимальное значение указанной цели используется оптимизация. 
Оптимизацию можно внедрять в модель в качестве элемента таким образом, что изменения в 
модели будут происходить автоматически. 

 
Рисунок 17: Диалоговое Окно Optimization 

Лабораторный Практикум 

Цель 
В этом практикуме Вы изучите разнообразные случаи практического применения 
функциональных возможностей Поведенческого моделирования. 

Метод 
В Упражнении 1, Вы создадите опорный элемент анализа для измерения масс-инерционных 
характеристик, разрабатывая новую лопасть винта для подводных работ. 

В Упражнении 2, Вы создадите три элемента анализа. Они покажут, что положение каждого элемента 
анализа в ДЕРЕВЕ МОДЕЛИ критично для обеспечения расчета требуемого параметра. 

В Упражнении 3, Вы создадите и используете Элементы Чувствительности, Технической 
осуществимости и Оптимизации. 
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Инструменты 
ПИКТОГРАММА ОПИСАНИЕ 

  Создает элемент 

  Создает элемент и повторяет операцию создания того же типа элемента 

  Переходит к следующей странице 

  Предварительный просмотр геометрии элемента 

    Создает элемент анализа 

УПРАЖНЕНИЕ 1: Создание Опорного Элемента Анализа. Измерение Масс-
Инерционных Характеристик 

Задача 1. Изменить рабочий каталог и открыть деталь Blade. 

1. Щелкните по File > Set Working Directory > INTRO_PROE_320. 

2. Щелкните по  > BLADE.PRT. 

3. Отключите отображение опорных плоскостей. 

4. Щелкните по Utilities > Environment для удаления центра вращения в диалоговом окне 
ENVIRONMENT. Модель отображается, как показано на следующем рисунке. 

 
Рисунок 18: Деталь Blade 

Обратите внимание: 
Проектирование модели частично завершено. Состояние модели, показанное на экране, 
представляет модель после предварительной обработки. Кроме определения массы модели 
требуется найти опорную систему координат, которая представляет центр тяжести, создаваемый в 
текущем местоположение в процессе регенерации. 

Задача 2. Создать опорный элемент анализа, измеряющий массу. 

1. Щелкните по Insert > Datum > Analysis. 

2. Введите [MASS_PROPS] в поле NAME и нажмите <ENTER>. 

3. выберите MODEL ANALYSIS как тип анализа, и щелкните по  [Следующая Страница]. 

4. Оставьте по умолчанию Model Mass Properties в поле TYPE. 

5. Щелкните по Compute. 

6. На запрос плотности в окне сообщения, введите [.75]. (Текущие единицы модели - lbs/in3) 



Pro/ENGINEER 2001 Базовый Курс    

- 130 - 

7. Закройте диалоговое окно MODEL ANALYSIS. 

Задача 3. Создать параметры VOLUME и MASS. 

1. В разделе RESULT PARAMS диалогового окна ANALYSIS, установите опцию VOLUME в YES. 
Установите название параметра Mass в Yes. Щелкните по CREATE. 

2. Щелкните по  [Следующая Страница]. 

Задача 4. Создать COORDINATE SYSTEM в центре тяжести. 

1. С подсвеченным CSYS_COG_59, щелкните по Yes. 

2. Щелкните по  [Предварительный просмотр]. На следующем рисунке показана созданная 
система координат. 

 
Рисунок 19: Созданный Элемент Анализа Координаты 

3. Щелкните по  [Создать Элемент]. 

Задача 5. Изучить значения созданных параметров в ДЕРЕВЕ МОДЕЛИ. 

1. Щелкните по View > Model Tree Setup > Column Display. 
2. выберите Feat Params в качестве TYPE. 

3. Введите [MASS] в поле NAME, затем нажмите <ENTER>. 

4. Введите [VOLUME] в поле NAME, затем нажмите <ENTER> и щелкните по OK. 
5. Обратите внимание на значения параметра в ДЕРЕВЕ МОДЕЛИ. (При необходимости, растяните 
дерево модели, или измените ширину колонки.) 

 
Рисунок 20: Значения Параметров, Отображаемые в Дереве Модели 

6. Щелкните по View > Model Tree Setup > Item Display > Suppressed Objects > OK. 

7. выберите cut (вырез) в ДЕРЕВЕ МОДЕЛИ и щелкните по  > Resume. 
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Обратите внимание, что параметры MASS и VOLUME обновились. 

 
Рисунок 21: Обновленные Значения Параметра в Дереве Модели 

Задача 6. Создать копию элемента анализа и переупорядочить его с целью обеспечения регенерации 
размера в порядке создания. 

1. Щелкните по Feature > Copy > , выберите элемент MASS PROPS и щелкните по  > . 

2. Растяните группу в ДЕРЕВЕ МОДЕЛИ для просмотра нового элемента анализа. Затем выберите 

группу и щелкните по  > Ungroup. Обратите внимание, что оба обозначают один тот же параметр 
MASS и VOLUME. 

3. выберите новый элемент анализа, затем щелкните по  > Redefine. Измените имя на 
MASS_PROPS_2, нажмите <ENTER> и щелкните по . 

 
Рисунок 22: Создание Нового Элемента Анализа 

4. Перетащите первый элемент анализа MASS_PROPS над вырезом. Обратите внимание на 
изменение значения и местоположение системы координат COG. 

 
Рисунок 23: Динамическое Изменение Значения при Вычислениях Масс-Инерционных Характеристик 



Pro/ENGINEER 2001 Базовый Курс    

- 132 - 

Обратите внимание: 
Результаты элемента Анализа зависят от его положения в дереве модели. При необходимости 
продолжать работу с этой моделью, можно создать дополнительные элементы, базирующиеся на 
результатах этих элементов анализа. 
5. Сохраните модель, закройте окно и щелкните по File > Erase > Not Displayed. 

УПРАЖНЕНИЕ 2: Анализ Объема Жидкости в Стакане 
Задача 1. Измерить объем до элемента shell (оболочка). 

1. Откройте STYROFOAM.PRT 

 
Рисунок 24: Исходная Модель 

2. В ДЕРЕВЕ МОДЕЛИ щелкните и перетащите красный маркер вставки над элементом оболочки 
(shell). 

3. Щелкните по  > Offset и выберите DTM2. Щелкните по Enter Value, введите [4.0] и щелкните 

по . 

4. Щелкните по Setup > Name, выберите последнюю созданную плоскость из ДЕРЕВА МОДЕЛИ и 
введите [FLUID_LEVEL). Щелкните по Done в меню PART SETUP для возврата на верхний уровень. 

5. Щелкните по  [Элемент Анализа] > Model Analysis. 

6. Введите [VOL_SOLID] в качестве названия и нажмите <ENTER> 

7. Щелкните по  [Следующая Страница]. 

8. выберите One-Sided Volume в выпадающем меню TYPE " диалогового окна MEASURE. 

9. выберите опорную плоскость FLUID_LEVEL в дереве модели. 

10. Щелкните по Flip (чтобы стрелка указывала вниз) и ОК. 

11. Обратите внимание на расчетный объем в разделе Results, и щелкните по Close. 

12. Установите параметр объема в Yes, измените название на [VOL] и нажмите <ENTER>. 

13. Щелкните по  [Создать Элемент]. 

14. Щелкните по View > Model Tree Setup > Column Display. 

15. выберите Feat Params в качестве Type. 

16. Введите [Vol] в поле названия, затем нажмите <ENTER> и щелкните по ОК. 
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Рисунок 25: Дерево Модели с Параметром Объема 

Задача 2. Измерить односторонний объем за элементом оболочки. 

1. Щелкните и перетащите маркер вставки ниже элемента оболочки. 

2. Щелкните по  [Элемент Анализа] > Model Analysis. 

3. Введите [VOL_SHELL] в качестве названия и нажмите <ENTER>. 

4. Щелкните по  [Следующая Страница].  

5. В TYPE , выберите One-Sided Volume. 

6. выберите опорную плоскость FLUID_LEVEL. 

7. Щелкните по Flip (чтобы стрелка указывала вниз) и ОК. Обратите внимание на расчетный объем в 
разделе RESULTS и щелкните по Close. 

8. Установите параметр объема в Yes, измените название на [VOL] и нажмите <ENTER>. 

9. Щелкните по  [Создать Элемент]. 

Задача 3. Создать элемент анализа типа уравнения. Это уравнение будет вычислять разницу между 
предыдущими односторонними объемами. 

1. Щелкните по  [Элемент Анализа] > Relation в кнопке типа. 

2. Введите [VOL_FLUID] в качестве названия и нажмите <ENTER>. 

3. Щелкните по  [Следующая Страница]. 

4. В появляющемся текстовом редакторе, введите в одной строке следующее уравнение 

[vol=vol:fid_vol_solid - vol:fid_vol_shell] 

5. Щелкните по  [Создать Элемент] и изучите, как вычисляется объем (см. нижний рисунок). 
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Рисунок 26: Вычисление Объема Пластикового Стакана 

Задача 4. Исследовать объем жидкости при изменении модели. 

1. Измените высоту плоскости Fluid_Level на [5.0] и выполните регенерацию. 

2. Выключите и снова включите отображение дерева модели для перерисовки его содержимого. 
Значение объемов должны измениться, как показано ниже. 

 
Рисунок 27: Обновленные Значения Объемов 

3. Измените высоту плоскости Fluid_Level на [2.50], выполните регенерацию и освежите Дерево 
модели. 

4. выберите в дереве модели первое выдавливание и щелкните по  > Modify. 

5. Измените размеры, как показано на следующем рисунке, выполните регенерацию и освежите 
Дерево модели. 

 
Рисунок 28: Измененная Пластиковая Модель 
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6. Новый объем жидкости с измененными размерами - 43.15in3 отображается в дереве модели. 

Задача 5. Использовать возможности поведенческого моделирования при поиске решения для 
объема жидкости в 50.0 

1. Щелкните по Analysis > Feasibility/Optimization в главном меню. 

2. См. следующий рисунок и установите Study Type в Feasibility. 

3. Установите конструктивную зависимость для поиска решения vol_fluid = [50.0] и диапазон 
конструктивных переменных плоскости Fluid_Level (d29) с [2.0] по [3.0]. 

 
Рисунок 29: Проверка Технической Осуществимости 

4. Щелкните по Options > Preferences, установите Convergence % (% Сходимости) в [0.001] как 
показано на следующем рисунке и щелкните по ОК. 

 
Рисунок 30: Установка Значения Сходимости 

5. Щелкните по Compute. 

6. После уведомления о выполненном решении, щелкните по Close > Confirm. 

7. Освежите дерево модели и обратите внимание, что vol_fluid = [50.0] при уровне жидкости [2.788]. 
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Рисунок 31: "Выполненное" Решение 

8. Сохраните модель, закройте окно и сотрите из оперативной памяти. 

УПРАЖНЕНИЕ 3: Оптимизация Коленчатого Вала 
Задача 1. Создать элемент анализа для измерения масс-инерционных характеристик детали. 
Вывести параметр MASS и опорную систему координат в центре тяжести. 

1. Откройте CRANKSHAFT.PRT. 

 
Рисунок 32: Исходная Модель 

2. Щелкните по  [Элемент Анализа] > Model Analysis. 

3. Введите [Mass_Props] в качестве названия, нажмите <ENTER> и щелкните по  
[Следующая Страница]. 

4. При необходимости, выберите Model Mass Properties в качестве Type и щелкните по Compute > 
Close. 

5. Переключите параметр Volume в NO, а параметр Mass в YES для создания только параметра 
Mass. 

6. Щелкните по  [Следующая Страница]. 

7. Переключите создание Csys в YES, измените название на [COG], нажмите <ENTER>, и щелкните по 
. 

8. Обратите внимание, что текущий COG находится значительно ниже оси вращения. Создайте другой 
элемент анализа, который измеряет расстояние между системой координат центра тяжести и осью 
вращения коленчатого вала, A_1. 
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9. Щелкните по  [Элемент Анализа] > Measure. 

10. Введите [COG_DIST] в качестве названия, нажмите <ENTER> и щелкните по  
[Следующая Страница]. 

11. выберите Distance в качестве Type и выберите A_1 и COG для выполнения измерения между 
ними, как показано. (Расстояние должно быть, приблизительно, 0.35). 

 
Рисунок 33: Измерение Расстояния 

12. Щелкните по Close, проверьте, чтобы параметр Distance был установлен в YES и щелкните по . 

Задача 2. Использовать элемент чувствительности для определения того, изменение какого размера 
(высоты или ширины) имеет большее воздействие на COG. 

1. Установите опцию конфигурации, которая использует Excel для создания диаграмм вместо 
графического окна Pro/E. Проконсультируйтесь с преподавателем, если требуется помощь. 

 
Рисунок 34: Установка Опции Конфигурации 

2. Щелкните по Analysis > Sensitivity Analysis > Dimension и выберите основной кулачок кривошипа, 
как показано ниже. Обратите внимание, что размеры d28 и d27 � основные размеры по высоте и 
ширине. 

 
Рисунок 35: Выбор Основного Кулачка Кривошипа 

3. выберите d27 и обратите внимание, что система по умолчанию установила Минимальное и 
Максимальное значения диапазона Переменный в + /- 10 %. 
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4. Щелкните по  > DISTANCE:COG_DIST > OK, чтобы установить параметр для отображения 
диаграммы. 

5. Щелкните по Compute. После некоторого времени расчетов, должна отобразиться следующая 
диаграмма: 

 
Рисунок 36: Диаграмма Чувствительности 

Обратите внимание: 
Эта диаграмма принадлежит таблице Excel, запущенному внутри Pro/E. Щелчок правой кнопкой мыши 
по диаграмме позволяет Открывать, Редактировать или Удалять диаграмму. 

6. Запишите разницу между наибольшим и наименьшим значениями вертикальной шкалы диаграммы. 
(0.404 - 0.304 = 0.1). Поэтому, изменение этого размера +/- 10% переместит COG на [0.1]. 

7. выберите диаграмму и  > Delete. Затем, щелкните по Dimension, выберите d28 и щелкните по 
Compute. 

 
Рисунок 37: Измененная Диаграмма Чувствительности 

8. Снова, запишите разницу между наибольшим и наименьшим значениями вертикальной шкалы 
диаграммы. (0.529 - 0.229 = 0.3) Поэтому, изменение этого размера +/- 10% переместит COG на [0.3]. 

9. В заключение, Элемент Чувствительности показывает, что размер высоты (d28) имеет большее 
воздействие на COG, чем размер ширины (d27). 

10. Щелкните по Close. 

Задача 3. Создать Элемент Технического Осуществления (Feasibility Study) для получения центра 
тяжести и оси вращения равными нулю. Имеются некоторые размеры, которые можно изменять. 

1. Щелкните по Analysis > Feasibility/Optimization > Feasibility. 
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2. Щелкните по Add, выберите параметр Distance:Cog_measure, установите значение в [0] и 
щелкните по OK > Cancel. 

3. Щелкните по Add Dimension и выберите размеры d27, d28 и d31. Затем щелкните по . 

4. Введите Минимальные и Максимальные значения, как показано. 

 
Рисунок 38: Минимальные и Максимальные Значения 

5. Щелкните по Options > Preferences, включите только Graph constraints и щелкните по ОК. 
Щелкните по Compute для получения результатов. 

 
Рисунок 39: Граф Сходимости Предела Оптимизации 

6. Обратите внимание, что расстояние COG быстро снижается с 3.5 до значения, близкого к нулю 
всего за две итерации. 

7. Сравните размеры до и после, как показано ниже. Обратите внимание, что значение радиуса, 
изменяется незначительно и, поэтому, может быть исключено из последующих вычислений. 

 
Рисунок 40: Сравнение Значений Размеров 

8. Щелкните по  > Side и обратите внимание на то, что при сохранении этих новых значений, 
COG Csys совпадет с осью вращения. Вывод: балансировка этой модели возможна. 

9. Отмените изменения и закройте диалоговое окно пока. Щелкните по Undo, затем по Close в 
диалоговом окне OPTIMIZATION/FEASIBILITY. 

Задача 4. Создайте третий элемент анализа таким образом, чтобы материал между основным валом 
и балансировочным телом оставался выше некоторого значения. 
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1. Щелкните по  [Элемент Анализа] > Measure. 

2. Введите [MATL_DIST] в качестве названия, нажмите <ENTER> и щелкните по  
[Следующая Страница]. 

3. выберите Distance в качестве Type и укажите две показанные грани. 

 
Рисунок 41: Выбираемые Грани 

4. Щелкните по Close, проверьте, чтобы параметр Distance был установлен в YES и щелкните по . 

Задача 5.  Повторно выполнить элемент Технического Осуществления, чтобы увидеть, может ли быть 
найдено Техническое Осуществление, когда этот новый параметр расстояния добавляется в качестве 
другой конструктивной зависимости. 

1. Щелкните по Analysis > Feasibility/Optimization. Обратите внимание, что предыдущие значения 
сохранились. 

2. Щелкните по Add > DISTANCE:MATL_DIST. Установите значение параметра в �>=� для значения 
[0.25]. Затем, щелкните по OK > Cancel. 
3. Щелкните по Options > Preferences и выключите все опции диаграммы. 

4. Вычислите результаты (Compute). (Должно быть найдено технически осуществимое решение) 

Задача 6. Для окончательных результатов проверьте, чтобы масса детали была минимизирована, а 
также все другие зависимости, путем запуска Элемента Оптимизации. 

1. Щелкните по Optimization в верхнем диалоговом окне. 

2. Оставьте Minimize и Mass:Mass_Props в качестве цели. 

3. Вычислите результаты. Обратите внимание на сокращение массы на диаграмме и, что размеры 
теперь изменены по-другому. 

 
Рисунок 42: Обзор Диаграммы и Модели 
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Задача 7. Далее, включите Оптимизацию в модель в качестве элемента, чтобы изменения в модели 
проводились автоматически. Измените модель для подтверждения. 

1. В диалоговом окне Optimization/Feasibility, щелкните по File > Make Feature > . Затем, щелкните 
по Close и перерисуйте экран. Обратите внимание, что в дереве модели появился элемент 
Оптимизации. 

2. выберите элемент Оптимизации в дереве модели и щелкните по  > Suppress > OK. 
3. Отобразите подавленные элементы в дереве модели. 

4. Измените диаметральный размер, показанный ниже с [1.25] на [0.75] и выполните регенерацию. 

 
Рисунок 43: Измененный Диаметральный Размер 

5. Добавьте колонку параметра расстояния к дереву модели и переключите отображение модели на 
вид сбоку. Обратите внимание, что теперь COG располагается немного ниже центра (0.077). 

 
Рисунок 44: Вид Сбоку Модели 

6. выберите элемент Оптимизации в дереве модели и щелкните по  > Resume. Обратите 
внимание, что модель снова сбалансирована. 

 
Рисунок 45: Оптимизированная Модель 
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7. Сохраните модель, закройте окно и сотрите модель из сессии. 

Резюме 

В этом модуле, Вы узнали что: 

• модуль Поведенческого моделирования является инструментом, необходимым для 
проектирования моделей, которые управляются в соответствии с потребностями конструктора 
и техническими требованиями к работе всего изделия.  

• В традиционных системах конструирования необходимо вручную выполнять вариантные 
расчеты. С модулем Поведенческого моделирования можно находить оптимальное решение 
при ясном понимании эффективности и поведения исследуемой конструкции. 

• Элементы Анализа позволяют измерять геометрические характеристики модели в указанных 
точках в списке элементов или компонентов модели. Эти измерения генерируют параметры и 
логические опорные элементы таким образом, что их можно использовать для определения 
геометрических свойств типа массы, объема, кривизны, центра тяжести и многого другого. 
Можно даже создавать собственные параметры, являющиеся результатом решения уравнения 
или пользовательские элементы Анализа. 

• Элемент Технического осуществления (Feasibility Study) ищет решение в диапазоне заданных 
размеров для соответствия набору зависимостей. Конструктор определяет ограничения 
посредством одного или более параметров элемента Анализа. 

• Элемент оптимизации (Optimization Study ) разрешает проблему технической осуществимости 
при помощи дополнительных условий, цели. Цель состоит в том, чтобы минимизировать или 
максимизировать некоторые параметры элемента Анализа 
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Глава 12 

Рисунки и Шаблоны Рисунка 

Используя режим Рисунка в Pro/ENGINEER, можно создавать рисунки по любой модели 
Pro/ENGINEER или по импортированному из другой системы файлу. 

Pro/ENGINEER связывает рисунки с их родительскими моделями. Модель автоматически 
отображает любые изменения, сделанные в рисунке. Точно так же, рисунки отражают 
любые изменения, сделанные в модели в режимах Детали, Sheetmetal, Сборки или 
Обработки. 

Цели 
В этой главе Вы изучите: 

• описание различные типы видов чертежей в Pro/ENGINEER. 

• Создадите рабочий чертеж по существующей модели детали. 

• Исследуете ассоциативность между моделью и ее рисунком. 

• Создадите зависимости между некоторыми видами рисунка. 

• Создадите простой рабочий чертеж с подробными размерами и аннотациями. 

Основные Принципы Создания Рисунка 

Создание Рисунка 
После выбора Drawing в диалоговом окне NEW и назначения ему имени, открывается диалоговое 
окно NEW DRAWING. Это диалоговое окно содержит различные опции, при помощи которых можно 
назначать ассоциированную модель, выбирать размер листа и определять ориентацию: 

• при ориентации portrait система использует большую сторону листа в качестве высоты, а 
меньшую � в качестве ширины. 

• при ориентации landscape (установка по умолчанию) система использует меньшую сторону 
листа в качестве высоты, а большую � в качестве ширины. 

• при ориентации variable система использует в качестве высоты и ширины листа рисунка 
значения, указанные пользователем. 

Также есть возможность назначить собственный формат компании. Выбранный формат, 
автоматически определяет размер листа и ориентацию. 

Добавление, Видов Рисунка 
После выбора формата или определения размера листа, можно добавлять виды в рисунке, используя 
опцию Views. Первый вид должен быть видом general (основным). При первом размещении он 
отображается с ориентацией по умолчанию. Используя диалоговое окно ORIENTATION, можно 
переориентировать его в процессе размещения. 
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Обратите внимание: 
Необходимо всегда использовать опорные плоскости по умолчанию для размещения основного вида. 

Типы Видов 
Пять исходных типов видов, доступных в меню VIEW TYPE: 

• Projection � ортогональная проекция объекта спереди, сверху, справа или слева. 

• Auxiliary � вид, спроецированный под углом 90° по отношению к поверхности, опорной 
плоскости или вдоль оси. 

• General � вид, который ориентируется отдельно и который не зависит от ориентации 
остальных видов. 

• Detailed � вид, который содержит часть существующего вида. Он масштабируется и 
образмеривается в целях пояснения. Границей вида detailed может быть окружность, эллипс 
(с или без вертикальной или горизонтальной главной осью) или сплайн. 

• Revolved � плоское поперечное сечение, повернутое на 90° относительно линии, 
принадлежащей плоскости сечения и смещенное вдоль этой линии. 

 
Рисунок 1: Пять основных Типов Видов 

Использование Меню View Type 
Используя другие опции в меню VIEW TYPE, можно определить какая часть модели в виде будет 
видна, как показано на следующем рисунке. 

• Full View � отображается вся модель. 

• Half View � отображается только часть модели по одну сторону от опорной плоскости. 

• Broken View � удаляет часть длинной модели между двумя точками и смещает оставшиеся 
части ближе друг к другу. 

• Partial View � отображает только часть вида, ограниченного контуром. 
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Рисунок 2: Примеры Отображения Частей Модели 

Добавление Поперечного Сечения 
Для определения, содержит ли вид единственную поверхность или поперечное сечение, 
используются опции меню VIEW TYPE: 

• Section � отображает поперечное сечение указанного вида. 

• No Xsec � не отображает поперечное сечение. 
• Of Surface � отображает только выбранную поверхность в направлении указанного 
вида. 

На следующем рисунке показаны различные типы видов с поперечными сечениями, которые можно 
создавать с использованием меню XSEC TYPE. 

 
Рисунок 3: Поперечные сечения 

Управление Видами 
Используя опцию Move View, можно перемещать основной и выносные виды в любое место листа. 
Однако, проекционный, вспомогательный и повернутый виды можно перемещать только вдоль их 
линии проекции. 

При использовании опции Delete View, виды PARENT (родительские) � виды, используемые для 
создания проекций, не могут быть удалены. Однако, они могут быть стерты опцией Erase View. 
Стертые виды восстанавливаются с использованием опции Resume View. 
Используя опцию Disp Mode, виды отображаются независимо от установок диалогового окна 
ENVIRONMENT Wireframe, Hidden line и No Hidden. Например, можно отображать некоторые виды 
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со скрытыми линиями, а другие без скрытых линий. Любые виды, установленные с этой опцией, 
остаются этими установками, независимо от любых изменений, проводимых в диалоговом окне 
ENVIRONMENT. 
Некоторые виды можно размещать с использованием опции Scale. Эти виды имеют свои собственные 
параметры масштабирования, которые можно изменять с использованием опции Modify. При 
изменении, изменяются только эти виды и их дочерние виды; изменения не затрагивают другие виды 
в рисунке. 

Определение Шаблонов Рисунка 

Шаблоны рисунка предоставляются системой для автоматического создания рисунков моделей. 

Шаблоны рисунка: 

• автоматически создают виды. 

• Устанавливают требуемое отображение вида. 

• Создают линии привязки. 

• Отображают размеры модели на основании шаблона. 

Шаблоны рисунка содержат три типа информации для создания новых рисунков. 

• Базовая информация � создает рисунок, но не зависит от модели рисунка. Эта информация 
копируется из шаблона в новый рисунок. 

• Команды � используется для настройки видов рисунка и действий, которые выполняются над 
этим видом. Также используется для создания нового рисунка с новыми объектами рисунка 
(модель). 

• Параметрические примечания � обновляются в соответствии с новыми параметрами модели 
рисунка и значениями размеров. Примечания перерассчитываются  при конкретизации 
шаблона. 

Шаблоны рисунка используются для: 

• определения компоновки видов. 

• Установки отображения видов 

• Размещения примечаний 

• Размещения символов 

• Определения таблиц 

• Создания линий привязки 

• Отображения размеров 

Настройка Шаблонов Рисунка 
Можно создавать пользовательские шаблоны рисунка для различных типов создаваемых рисунков. 
Преимущество таких шаблонов в том, что они позволяют создавать элементы рисунков 
автоматически. 

Например, можно создать шаблон для детали с механической обработкой и для отливки. Шаблон 
рисунка детали с механической обработкой может содержать виды, которые являются типичными для 
такого типа деталей. Можно: 

• Устанавливать настройки отображения для каждого вида. 

• Размещать стандартные для отрасли или компании записи. 

• Автоматически создавать линии привязки для размещения размеров. 
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Аннотирование Рисунка 

Аннотирование (detailing) важно, как метод связи между назначением конструкции и рабочим станка, 
изготовителем литейной оснастки и другим производственным персоналом. 

Как только на рисунке будут созданы виды, отображение размеров производится одним щелчком 
кнопки. Поэтому избыточность размеров, которая бывает у конструктора и чертежника, исключена. 

В производстве, дополнительные размеры в рисунке бывают необходимы для передачи 
дополнительной информации. 

Как только управляемые размеры в рисунке будут размещены, они могут изменяться и эти изменения 
немедленно отображаются в модели. Такая ассоциативность позволяет быстро и эффективно 
проектировать конструкцию. 

Создание Размеров Элементов 
Размеры элементов создаются в фактической модели детали или сборки. В рисунке они появляются 
только в отдельном виде для предотвращения двойного образмеривания. 

Размеры элементов имеют много опций: 

• Show All �  отображает все размеры в модели. 

• View � отображает все размеры в выбранном виде. 

• Feature � отображает размеры выбранного элемента. 

• Feature & View � отображает все размеры выбранного элемента в выбранном виде. 

• Part � отображает размеры выбранной детали. 

• Part & View � отображает размеры выбранной детали в выбранном виде. 

Создание Управляемых Размеров 
Размеры, которые создаются в режиме Рисунка, называются управляемыми размерами (Driven 
dimensions). Для их создания, щелкните по Create в меню DETAIL и Dimension в меню DETAIL ITEM; 
затем выберите требуемую геометрию. 

Изменение и Удаление Управляемых Размеров 
В отличие от размеров элементов, изменять управляемые размеры в рабочем чертеже нельзя, 
потому что их значения основаны на модели детали. Однако, их можно удалять из рисунка. 

Управление Размерами 
После отображения размеров в рисунке, ими можно управлять при помощи опций в меню DETAIL: 

• Move Text � перемещает размерный текст вдоль линии размера или выноски. 

• Mod Attach � размещает размеры скруглений или фасок на другой привязке этого же 
элемента. 

• Switch View � перемещает размер на другой вид. 

• Flip Arrowsи � отображает стрелки внутрь или за выносные линии. 

• Clip � обрезает выносные линии по указанной точке. 

• Break � разрывает выносные линии. 

• Align � выравнивает размеры. 
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Создание Примечаний рисунка 
Используйте опцию Note в меню DETAIL ITEM для создания примечаний рисунка путем их ввода или 
импорта из текстового файла. 

Меню DETAIL ITEM позволяет определять выноски, выравнивание и стили текста. 

Параметрические Примечания 
При включении в примечание размера или параметра, они становятся Параметрическими 
Примечаниями (Parametric Note). 

Для изменения значения размера в Параметрическом Примечании, выберите Modify в меню 
DRAWING и укажите значение. Для указания информации параметра, используйте следующий 
формат: 

• Dimensions � &d#, где # - ID размера. 

• Instance number � &p#, где # - ID параметра (например, &p0). 

• User-defined parameters � &xxxxx, где xxxxx символьное имя параметра. 

Лабораторный Практикум 

Цель 
В этом практикуме Вы создадите рисунки твердотельных деталей, поэкспериментируете 
с меню VIEWS и DETAIL и исследуете ассоциативность между рисунками и моделями 
деталей. 

Метод 
В Упражнении 1, будет создан рисунок детали шестерни по шаблону. При этом будут исследованы 
различные доступные опции и созданы дополнительные виды. 

В Упражнении 2, различными способами будут изменены виды в рисунке и будет выполнена его 
регенерация с целью исследования его ассоциативности с твердотельной шестерней. 

В Упражнении 3, будет вызван рисунок шестерни, созданный ранее, будут обработаны его размеры и 
созданы примечания. 

Инструменты 
ПИКТОГРАММА ОПИСАНИЕ 

    Пиктограмма выбора 

   Каркасное отображение 

  Размер 
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УПРАЖНЕНИЕ 1: Создание Рисунка 

 
Рисунок 4: Завершенный Рисунок Шестерни 

Задача 1. Создать рисунок с именем gear на основании шаблона по умолчанию ptc_std. 

1. Щелкните по , чтобы начать новый файл. 

2. В диалоговом окне NEW, щелкните по Drawing, введите [gear], и щелкните по ОК. 

3. В диалоговом окне NEW DRAWING, щелкните по Browse в зоне Default Model и найдите GEAR.PRT 
в рабочем каталоге. 

4. Щелкните по Browse в зоне TEMPLATE и выберите PTC_STD, как показано на следующем рисунке. 

 
Рисунок 5: Диалоговое Окно New Drawing 
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5. Щелкните по ОК. 

6. Рисунок создается с автоматически генерируемым трехмерным видом. 

Задача 2. Создать и сориентировать первый вид модели шестерни, используя основной вид. 

1. Щелкните по Views в меню DRAWING. 

2. Щелкните по General > Done, чтобы принять опции по умолчанию в Менеджере меню. 

3. Щелкните в окне рисунка слева от основного вида. Не акцентируйтесь на положении вида; его 
можно переместить в любое время. 

4. выберите DTM3 для FRONT REFERENCE и DTM2 для TOP REFERENCE в диалоговом окне 
ORIENTATION. 

5. Щелкните по ОК для завершения создания вида. 

Задача 3. Переместите только что созданный общий вид. 

1. Щелкните по  в INTENT MANAGER. 

2. Щелкните по виду для его активизации и переместите его в новое местоположение. 

3. Поэкспериментируйте с перемещением вида. В конце, разместите его в левой части листа. 

Задача 4. Добавить второй вид в качестве проекции, используя основной вид как родительский. 

1. Щелкните по Add View в меню VIEWS. 

2. Оставьте опции по умолчанию Projection > Full View > No Xsec > No Scale. 

3. Щелкните по Done. 

4. Разместите проекционный вид, выбирая точку выше первого вида в верхней части листа. 

Задача 5. Добавить вспомогательный вид с поперечным сечением. 
1. Щелкните по Add View > Auxiliary > Full View > Section > No Scale > Done. 
2. Задайте поперечное сечение на всем виде. Щелкните по Full > Total Xsec > Done. 
3. выберите точку внизу справа от первого вида для размещения вида с поперечным сечением. 

4. Прочтите область сообщения и выберите DTM4 как показано на следующем рисунке. 

 
Рисунок 6: Ориентирование Вспомогательных Привязок 

5. Вспомогательный вид отображается снизу справа от основного вида. 

Обратите внимание: 
Эта деталь имеет заранее созданное поперечное сечение с названием "C". Система позволяет 
использовать поперечные сечения, созданные в режиме детали. 

6. выберите C из меню XSEC NAMES. 

7. Прочтите область сообщения. 

8. Еще раз щелкните по созданному основному виду. На нем отображается стрелка сечения. 

9. Щелкните по Done/Return в меню VIEWS. 
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Обратите внимание: 
В рисунке можно создавать поперечные сечения, если имеется лицензия для опционального модуля 
Pro/DETAIL. 

Задача 6. Изменить штриховку для улучшения ее отображения в рисунке. 

1. Щелкните по  в INTENT MANAGER. 

2. выберите штриховку, как показано на следующем рисунке. 

 
Рисунок 7: Выбор Штриховки 

3. Щелкните по Edit > Properties. 

4. Щелкните по Spacing > Half. 
5. Щелкните еще раз по Spacing > Half. 
6. Щелкните Angle > 0 > Done. Результат измененной штриховки показан на следующем рисунке. 

 
Рисунок 8: Измененная Штриховка 

Задача 7. Добавить изометрическое изображение. 

1. Щелкните по Views > Add View > General > Scale > Done. 
2. выберите местоположение в верхней правой части рисунка для размещения вида. 

3. Измените масштаб вида на [.75]. 

4. выберите DTM3 в качестве FRONT REFERENCE и DTM2 в качестве TOP REFERENCE в диалоговом 
окне ORIENTATION. Не закрывайте диалоговое окно. 

5. Если была допущена ошибка, щелкните по Undo. 

6. Щелкните по Angles в выпадающем меню TYPE. 

7. Щелкните по Horizontal в выпадающем списке REFERENCE. 

8. Введите [45] в качестве угла, затем нажмите Apply. 

9. Щелкните поEdge/Axis в выпадающем списке REFERENCE. 

10. выберите вертикальную левую кромку шестерни. 

11. Введите [30] в качестве угла, затем нажмите Apply. 

12. Завершите ориентацию. Щелкните по ОК в диалоговом окне ORIENTATION. 
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УПРАЖНЕНИЕ 2: Изменение Созданных Видов и Проверка Ассоциативности 

 
Рисунок 9: Завершенный Рисунок Шестерни 

Задача 1. Изменить отображение скрытых и касательных кромок. 
1. Щелкните по Views > Disp Mode > View Disp в MENU MANAGER. 
2. Измените отображение проекционного и AUXILIARY (вспомогательного) вида выбором Второго и 
Третьего видов, показанных на предыдущем рисунке. Щелкните по Done Sel. 
3. Щелкните по No Hidden > Tan Solid > Done в меню VIEW DISP. 

4. Измените отображение основного и изометрического видов (Первый и Четвертый виды). Щелкните 
по двум видам с последующим Done Sel. 
5. Щелкните по Hidden Line > Tan Solid > Done. 

6. Щелкните  [Скрытая линия]. Обратите внимание, что отображение видов не изменилось. 

7. Щелкните по  для возврата отображения обратно к скрытым линиям. 

Задача 2. Проецируемые и вспомогательные виды � дочерние элементы по отношению ко своим 
родительским видам. Поэкспериментируйте с перемещением этих типов видов. 

1. Щелкните по  в INTENT MANAGER.. 

2. выберите Проецируемый (или Второй вид) и переместите его в новое местоположение. 

3. Разместите вид. 

4. Щелкните по Done/Return для возврата в меню верхнего уровня. 

5. Затем, выберите Основной или Первый вид и переместите в новое положение. Обратите внимание, 
как Проецируемый вид и Сечение перемещаются относительно Основного вида. 

Задача 3. Изменить значение масштаба листа. 

1. Щелкните по Edit > Value и выберите значение масштаба листа 0.500 в нижнем левом углу экрана, 
как показано на следующем рисунке. 
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Рисунок 10: Изменение Масштаба Рисунка 

2. Введите [.625]. 
3. Сохраните файл рисунка. Не стирайте его. 
Задача 4. Создать элемент на шестерне для подтверждения ассоциативности между моделью детали 
и рисунком. 

1. Щелкните по  и откройте GEAR.PRT. 
2. Создайте гладкое отверстие на плоской поверхности элемента паза. 
Обратите внимание: 
Можно выбрать размер и атрибуты отверстия, так как позже они будут удалены. 
3. Активизируйте окно DRAWING и выберите GEAR.DRW. Обратите внимание на то, что отверстие 
появляется во всех видах. 
4. Возвратитесь к шестерне. Щелкните по Window и выберите GEAR.PRT. 
5. Удалите элемент отверстия. 
Задача 5. Стереть рисунок и деталь без сохранения элемента отверстия. 
1. Закройте окно ШЕСТЕРНИ. Щелкните по File > Close Window. 
2. Снова активизируйте окно GEAR DRAWING. Щелкните по Window и выберите GEAR.DRW. 
3. Сохраните оба файла перед стиранием. GEAR.DRW будет использоваться в следующем 
упражнении. 

4. Щелкните Erase > Current > Select All > OK. Система стирает рисунок шестерни. 
Обратите внимание: 
Pro/ENGINEER не сохраняет автоматически все изменения, которые были сделаны в модели. Простой 
путь вернуться назад к последней сохраненной версии, состоит в стирании модели без сохранения. 

УПРАЖНЕНИЕ 3: Аннотирование Рисунка Шестерни 

 
Рисунок 11: Аннотированный Рисунок Шестерни с Размерами 
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Задача 1. Для начала процесса аннотирования, отобразите размеры модели. 

1. Регенерируйте рисунок шестерни GEAR.DRW. 

2. Щелкните по View > Show/Erase. 

3. В диалоговом окне SHOW/ERASE, щелкните по  и выберите View в опции SHOW BY. 

4. Теперь выберите на экране нижний левый основной вид (Первый вид). Щелкните по Done Sel. 
5. Закройте диалоговое окно SHOW/ERASE. 

Задача 2. Отключить отображение размеров. 

1. Щелкните по Tools > Clean Dims в меню DETAIL. 

2. Снова выберите первый вид; затем щелкните по Done Sel. 
3. Выключите переключатель Create Snap Lines. 

4. Щелкните по Apply > Close. 

5. Щелкните по Done/Return в меню TOOLS. 

6. выберите размер курсором 76.66, и переместите его в другое местоположение. 

7. выберите другие размеры и настройте их аналогично. 

8. Щелкните по  для перерисовки экрана. 

Задача 3. Стереть дополнительные размеры в рисунке 

1. Щелкните по Show/Erase > Erase в меню DETAIL. 

2. Щелкните по . 

3. выберите два дополнительных размера 6.3мм, показанных на следующем рисунке, и щелкните по 
Done Sel в меню GET SELECT. 

 
Рисунок 12: Стирание Размеров 

4. Щелкните по Close. 

5. Щелкните по  для отображения результатов. 

Задача 4. Включить отображение размеров в сечении и снова выключить их. 

1. Выполните ту же процедуру, что и для Первого вида. 

Задача 5. Создать параметрическое примечание, которое отображает значение диаметра отверстия. 
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Обратите внимание: 
Система позволяет отображать примечания с параметрическим размером в тексте. Это позволяет 
автоматически обновлять примечание при изменении размеров. 

 
Рисунок 13: Создание Параметрического Примечания 

1. Щелкните по Insert > Note. 

2. Щелкните по Leader > Normal Ldr > Make Note, оставляя все остальные опции в меню NOTE 
TYPES по умолчанию. 

3. В сечении, выберите кромку маленького отверстия, к которому система должна присоединить 
примечание. Используйте Query Sel, при необходимости. 

4. выберите местоположение для примечания. Все размеры и параметры изменяются на 
символическое отображение. 

5. В нижнем правом углу или в поперечном сечении найдите и укажите символический размер, 
представляющий диаметр маленького отверстия (например: symbol:d26). 

6. выберите символ ∅  из окна SYMBOL PALETTE. 

7. Введите [&d26 drill thru] в области сообщения. 

8. Один раз нажмите <ENTER>; затем введите [one place]. 
9. Еще раз нажмите <ENTER> для завершения. 

10. Сохраните и сотрите рисунок механизма и деталь шестерни из памяти. 

Резюме 

В этом модуле, Вы узнали что: 

• существуют пять основных Типов рисунка � Проекционный (Projection), Вспомогательный 
(Auxiliary), Основной (General), Выносной элемент (Detailed) и Повернутый (Revolved). 

• Основные виды не зависят от других видов. 

• Основные виды могут иметь собственный масштаб. 

• Основные виды могут иметь любую ориентацию и содержать вид по умолчанию и любые 
сохраненные в режиме модели виды. 

• Для ориентирования первого основного вида должны всегда использоваться опорные 
плоскости по умолчанию. 

• Типы видов имеют 4 под-типа: Полный вид (Full View), Половина вида (Half View), Вид с 
разрывом (Broken View) и Частичный вид (Partial View). 

• Виды можно перемещать и удалять, а также можно изменять режимы их отображения и 
величины масштабов. 

• Между твердотельной моделью и ее рисунками существует ассоциативная связь. 
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• Поперечные сечения могут быть созданы в режиме Модели или режиме Модели при 
размещении вида. 

• Основные размеры, включаемые в рисунок, берутся из режима Модели. 

• Существует два типа размеров: Размеры элемента и Управляемые размеры. 

• Размерами можно управлять. 

• В рисунке можно создавать примечания для документирования и других целей. 
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Приложение С 

Использование Справочной Службы PTC 

Справочная Служба PTC - инструмент, удобно и легко построенный по двум принципам. Он может 
использоваться для сиюминутных рекомендаций и для подробной информации по выбранным темам. 

Цели 
В этой главе Вы изучите: 

• запуск справочной службы РТС. 

• Поиск требуемой информации. 

• Получение контекстно-зависимой подсказки в процессе выполнения задачи. 

Краткий Обзор Справочной Службы РТС 

Справочная Служба PTC - полнофункциональная система помощи, интегрированная с программным 
обеспечением Pro/ENGINEER. Она может быть установлено вместе с Pro/ENGINEER на компьютере. 

Элементы Справочной Службы PTC 
Справочная Служба PTC предлагает: 

• новую систему помощи с содержанием, индексированием и мощными возможностями поиска. 

• Контекстно-зависимую помощь с доступом к справочной службе РТС по щелчку мыши. 

• Оперативные Руководства, сфокусированные на обучении различным аспектам программного 
обеспечения. 

• Расширенные темы помощи, находящиеся в диалоговых окнах. 

Пожалуйста посетите Оперативную Базу Данных Знаний Технической Поддержки PTC (PTC 
Technical Support Online Knowledge Database), которая содержит тысячи Предлагаемых Методик.  

Использование Справочной Службы Pro/Engineer 

Запуск Справочной Службы: Четыре Метода 
Имеются четыре процедуры запуска Справочной Службы. 

1. Из Главного Меню 
Это - стандартный путь вызова наиболее полной системы Справочной Службы с содержанием, 
индексом и возможностями поиска. В зависимости от скорости работы Вашей системы, может 
потребоваться несколько секунд для запуска полной системы Справочной Службы. 

Щелкните по Help > Contents and Index в главном меню, как показано на следующем рисунке. 
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Рисунок 1: Запуск Справочной Службы PTC 

Домашняя страничка Диалоговой Справочной Службы Pro/ENGINEER отображается в окне Вашего 
броузера. 

 
Рисунок 2: Содержание и Индекс в Справочной Службе PTC 

В левой части окна, отображается список тем в виде древовидной структуры. Щелкая на каждой теме 
верхнего уровня, можно получить доступ к под-темам, а, щелкая по под-темам можно получить доступ 
к подробным пояснениям, инструкциям и советам. 

2. Посредством Контекстно-Независимой Справочной Службы 

1. Щелкните по  в правой части главного меню пиктограмм. 

2. Щелкните по любой пиктограмме или любой части главного окна Pro/ENGINEER, по которой 
требуется получить пояснение. 

3. Открывается окно броузера с пояснением темы. 

4. В следующем примере, щелчок по пиктограмме в дереве модели запускает окно броузера с 
пояснением функциональных возможностей пиктограмм. 
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Рисунок 3: Контекстно-Зависимая Справочная Служба 

5. Кроме того, в нижнем левом углу можно заметить ссылку �See Also�, которая по щелчку переходит к 
списку тем, связанных с текущей, и которые могут иметь непосредственный интерес. 
6. Можно щелкать по любой теме, которую требуется изучить дополнительно. 

 
Рисунок 4: Список Тем �See Also� 
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3. Посредством Менеджера Меню Pro/ENGINEER 
1. Щелкните в правой части основного меню пиктограмм Pro/ENGINEER. 

2. Щелкните по любой команде в Менеджере меню. 

3. Открывается окно броузера TOPIC ROUTER со списком ссылок, поясняющих команду меню. 

4. Щелкните по требуемой теме. 

5. В следующем примере, щелчок по X-Section в Менеджере меню запускает окно броузера TOPIC 
ROUTER со списком двух полезных тем. 

 
Рисунок 5: Запуск Справочной Службы через Менеджера Меню 

4. Щелчком в Правой Части Вертикального Меню Команд 
1. Щелкните и удерживайте правую кнопку мыши в меню до появления окна GETHELP. 

 
Рисунок 6: Щелчок в Правой Части Менеджера Меню 
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Перечень Модулей Справочной Службы PTC 

Имеется четыре главных раздела в оглавлении Справочной Службы PTC: Welcome, Основы 
Pro/ENGINEER, Использование Базовых Модулей и Использование Дополнительных Модулей. 

 
Рисунок 7: Четыре Главных Раздела в Справочной Службе 

Изучите следующий список для поиска требуемого модуля в содержании: 

 
Рисунок 8: Основные и Дополнительные Модули Справочной Службы 
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